Jump to content

Really weird FPS-Fix


Recommended Posts

Hi there everyone,


first off all, i really enjoy the game, for hundreds of hours since five years, great game!

I never had any bigger performance issues, rarely fps drop but i was fine with that, but since alpha 18, maybe 18.2 oder 18.3, i dont know exaktly, i got rarely high fps, constantly arround 20 fps, unplayable.

While playing singleplayer the fps are a little bit higher and but hosting an multiplayergame, was terrible.

There where only a few seconds every two or three minutes, the game runs smooth on 60 FPS.


So i opened Afterburner to take a look what the Problem exaktly was and i was suprised.

While playing the game everything seems fine, but my GPU was only at 20% usage and very uneven history?!?

But AFTER! is switched on the Afterburner and 7DTD runs behind the usage went up to 90-100% and 7DTD shows up to 60FPS and even more without V-Sync.

I repeat switching between 7Days and MSI Afterburner with the same result

7DTD in front = 20fps and around 20% usage

Afterburner in Front, but 7Days visible in the background = 60fps and 100% usage.


It seems that 7dtd was not able to use my GPU without help, i tried a lot to fix that, reinstall, change drivers, overclocking and more, but nothing helps.

Then i tried the same with the Windows Task-Manager and it worked fine, so i set a mark at „allways in front“ put the Task-Manager as far as possible on the bottom of the screen under the toolbelt, switch on 7DTD and since then i can play the game with constantly 60fps (without v-Sync up to 90) again, not a small single Drop in the last 10 hours of play.


I hope i could explain understandable and it helps other players and the Devs to find out what the problem is? Maybe a rare issue with the Hardware?

I have no idea whats going on, maybe someone can explain that to me?


I play on a Windows 10 System

Intel Core i5 4690k

16GB Memory

MSI Geforce GTX 970 4G Gaming


Some may say, that this is far away from a fix and they are right, but it works for me and i have no problems with the small white stripe under the toolbelt/Water and Food bar.


best regards!


Link to comment
Share on other sites

Hm really sad, that it didn't worked.

Have you tried to change the Power-Options on your computer to performance?


I tried this to and it raises the fps up to 50/60 without v-Sync, but with an opened task-manager i got up to 130 fps, so it isnt a fix for the issue i have....

Link to comment
Share on other sites

Did you check your driver settings? Reinstalling a driver afaik doesn't remove them.

And NVidia Controlpanel can hold different settings for different games, so it still may occur only to 7d2d too. Maybe something got messed up there?

Do you have the Nvidia Experience software installed? This one messes arround with graphic settings for specific games and already messed up some of my game settings. That's why i removed that @%$*#! and never installed it again.


If a framelimiter or similar is set i could imagine it only works for the foreground application. That'll explain why it runs faster when in background.

Link to comment
Share on other sites

@op hmm it seems to be related to the GPU not handeling desktop and exclusive mode very well. I got once a similiar issue in 7 dtd, related to an HDMI TV connected to the pc along with an 1440p (displayport) and an 1080p(displayport) screen, resulting in always trying to force V-sync, wether it was set to on or not.

As soon as I removed the screen in the nvidia systempreferences, 7DTD went way up beyond 60fps at the 1440p main screen. (the issue even persists while the HDMI 1080p TV was connected to the PC but turned off and 7DTD is played at the 1440p screen)

So if you use a multi monitor setup, try to remove the other screens from your desktop setup using nvidias or amds control panel. This is not a real solution but it might help to isolate the "real" issue.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...