Jump to content

Game stuck at loading user: null reference exception object reference not set to an instance of an object


Recommended Posts



I have an alpha 18 game running on a server from gameservers, my friends can login to the game fine but I am now having the error below, I tried everything

1- Delete the entire game, save files, registry ect as per some forums

2- Load the game, choosing another profile and playing a new *local* game (which works fine) but then when I join my server it still gives the same error.


Looks like my save files somewhere are corrupt, this is really bad because i had some good progress on my character..




Link to comment
Share on other sites

The setting for MaxUncoveredMapChunksPerPlayer is extreme. That's probably going to contribute to the issue.


The NullRef error indicates corruption in the player data file. Which would be possible if you've exceeded the file size cap by having the stored map data be too large. I've doubled it without any issue, but multiplying it by a factor of 4 is pretty extreme.


Wipe your player profile on the server, and delete your local server cache. Fix that setting to something more reasonable, and try again.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...