Jump to content

AI on Dedicated MP Server Seems Broken


monty13

Recommended Posts

***NOTE: I tried posting this earlier today and it didn't ever show up as far as I could see.***

 

Hello,

 

I'm having some issues with the AI on my server (MP - dedicated, GTXGaming 'gtxcp.uk' as the host). I'm fairly certain I'm doing something wrong, but I can't figure it out.

 

I did some Google searching, and searched the forums, and all I found was a similar issue from A 17.X where deleting the profile apparently fixed it.

 

 

 

Issue:

--------------------------------

Since a full server restart after b155 went stable, no AI in the game actively pursues / attacks / runs away (IE: deer).

If you get within melee range of an aggressive AI, it will attack.

 

 

Scenario:

--------------------------------

When running EXP 18 b155, everything was fine. When b155 went stable, I wiped my server, and re-loaded it to stable again just to be sure.

 

I always delete the "steamapps" folder off the server (I've had issues starting new servers before unless I delete it),

and then do a Steam update to get to the latest version.

 

I also wipe out the "\..\Data\Worlds" folder to delete any remnants of the prior server / player info.

 

The map is PREGEN03. Since I've never played that one before, I flew / teleported around in admin mode to

scope the map out. NOTE: wondering if moving around the map so much caused z's to spawn and maybe over-loaded the AI after the new spawning changes with 18?

 

Despite a server wipe, I noted that the map is revealed from my previous exploration, even though I deleted the "\..\Data\Worlds" folder and everything under it.

I tried renaming the "GameName" also, but still seeing map revealed.

 

Anyways, I also tried updating to EXP 18.1 b4, wiped, etc. Same issue with the AI.

I also deleted my local player profile and made a new one with a different name, same issue with the AI.

I have several friends who play on the server too, I had each of them create new player profiles. They experienced the same issue with the AI.

 

 

MODS (worked in EXP 18 b155)

--------------------------------

Allocs

BCManager

HH_Starter_Items_Quest

HH_Custom_Materials

ItemIconTest

KHA18-60BBM

RussianDoodGC

RussianDoodSS

S420_SimpleUI-4DigitCraft

S420_SimpleUI-LeftHUD

S420_SimpleUI-Toolbelt

VPlus-Quest

 

 

Profit!

--------------------------------

I can't figure out what's going on, and it makes no sense to me that the map is still showing revealed even after deleting my individual steam ID player files (.map / .ttp).

 

I've verified in the "serverconfig.xml" that enemies are set to spawn. They obviously are b/c they show up but don't do anything.

I've also spawned in enemies using admin commands, and they still just stand there.

 

Looking for the "output_log__<DATETIME>.txt" to add to the post.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

Guest
This topic is now closed to further replies.
×
×
  • Create New...