Jump to content
  • Game hangs or crashes during RWG due to "Out of Memory" exception

    • Version: A21 b313
    Summary: Game hangs or crashes during RWG due to "Out of Memory" exception (despite having plenty of system memory)
    Game Version: A21 b313
    OS/Version: Windows
    CPU Model: AMD Ryzen 5 3600 6-Core Processor  (cores: 12)
    System Memory: 16 GB
    GPU Model and VRAM: NVIDIA GeForce RTX 2060 (5980 MB)
    Screen Resolution: 2560x1440
    Video Settings: Medium / Custom (Turned off motion blur, all else Medium)
    Game mode: SP
    Did you wipe old saves? Yes
    Did you start a new game? N/A (not able to start a game)
    Did you validate your files? Yes
    Are you using any mods? No
    EAC on or off? On
    Status: NEW
    Bug Description: Game hanging/crashing when generating new world
    Detailed steps to reproduce the bug:
    1) Go to "Advanced Generation" for RWG
    2) Choose 8K random world
    3) Enter "A21b308" for game name
    4) Enter "A21b308" for seed
    5) Hit "Generate"
    Actual result: 
    Game either hangs or crashes with an "Out of Memory" exception. This happened twice. Thee first time it hung, and I had to ctrl-alt-delete to kill. The second time there was a bug popup that closed the game when I hit "OK". The second time I was using Performance Monitor to monitor my system memory, and there was still plenty of memory that was either free (~2G) or on standby (~5G).
    Expected result:
    RWG world will generate without crashing.
    This happened twice. I am uploading Pastebin links to the logs of both episodes. After both episodes, the folder for the generated world ("Boseja Territory") was completely empty.
    Logs for first episode (no popup, had to ctrl-alt-delete): https://pastebin.com/DTxgkBnw
    Logs for second episode (popup, game closed when clicking "OK"): https://pastebin.com/5bCpyKXd
    (Note: this says to look in /AppData/Local/Temp/The Fun Pimps/7 Days To Die/Crashes but there was nothing there)

    User Feedback

    Recommended Comments

    Also, quick update. I tried again, this time making sure I was watching Performance Monitor the whole time.


    It looks like I was wrong about the memory usage. What is happening is that there is plenty of standby memory, but it wasn't being allocated as free memory fast enough.


    During RWG the free memory is rapidly used up, sometimes dipping to below 1M before more of the standby memory was moved to the free memory. Eventually Windows couldn't keep up, and the free memory was essentially zero. It's at this point that the crash occurred - even though there was still about 4G still left in standby memory.


    Note - during this trial, unlike the previous two, I did not have any other programs open. (Previously I had Chrome open.) I don't know if that makes much difference.

    Link to comment
    Share on other sites

    Update 2.


    I noticed that simply launching the game, and sitting there on the menu screen, doing nothing, will rapidly make Windows put all the system memory into standby. After a few minutes, none of it is free.


    So, I'm guessing that this "RWG" issue is really a symptom of a severe, systematic memory leak.


    I am able to play on pre-generated worlds with zero free memory and all (~8G) standby memory. So I was at least able to start a Navezgane map, and finally play the game.


    All the same I would still consider this a game-breaking bug.

    Link to comment
    Share on other sites

    I've put a stress test on this.


    • Generated A21b308, A21b313, 8k 10k with different settings on my main machine and 2 test machines, one of them on Linux
    • Generated test1, test2, test3 on three different game launches all at the same time on one machine, test4 on my linux test box, test5 on my other windows 11 machine
    • Repeated all 3 game launches generating maps at the same time again without restarting any of them (I also launched into Unity and generated a map there too, my ram was pegged max at 32gb)

    Unable to reproduce so far, do a very good cleaning and reinstalling and make sure you're not missing any driver/bios/windows updates and try again.

    Also, make sure you don't have a manually-set page file. Set it to automatic, Unity doesn't play well with a manually-set one.

    Link to comment
    Share on other sites

    It turns out I needed to do a total re-install of the game.


    I already had deleted everything in %appdata%/7DaysToDie, and verified my local files in Steam after updating to the latest experimental. Apparently that wasn't enough, I had to un-install it in Steam and re-download the entire game.


    But once I did that, RWG worked, so far I have had no out of memory errors.



    Link to comment
    Share on other sites

    Well, I fixed my issue.  Seems I had a VERY slight instability in my memory.  I backed off the clock speed on my memory and now it generates with ZERO issues.  I wasn't having any instability that I knew about but I have had a couple other games freeze randomly lately.


    So, if anyone else has this issue and fresh installs don't work maybe this comment could be helpful.

    Link to comment
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now

  • Create New...