Jump to content
  • The infamous clear quest bug

    • Version: A21 b317

    Summary: If you wake up a bunch of zombies, lose their aggro, and let them wander off into the distance, they will eventually despawn. Because of this, you will not be able to complete your clear quest even though you've been through the entire area, killed the rest of the zombies, and no red/orange dots are shown

    Game Version: A21 b317
    OS/Version: Windows 11
    CPU Model: Intel Core i5-12500 3 GHz 6-Core Processor
    System Memory: 32GB
    GPU Model and VRAM: Radeon RX 6700 XT 12 GB
    Screen Resolution: 1920x1080
    Video Settings: Custom: https://imgur.com/a/mP1vSrT
    Game mode: SP

    Did you wipe old saves? Wiped 6/12 on A21 b313
    Did you start a new game? Created 6/22 on A21 b317
    Did you validate your files? Validated files 6/22 on A21 b317
    Are you using any mods? No
    EAC on or off? On

    Status: NEW

    Bug Description:

    Detailed steps to reproduce the bug:

    1. Go to prison_02
    2. Start a clear quest at night (max from the shadows and military armor with advanced muffled connectors)
    3. Kill the zombies outside the building
    4. Kill the zombies inside the building but dont go near the bathroom area until they're all dead
    5. Walk near the bathroom area to trigger the zombies to spawn
    6. Run outside and make a lap around the building (gives time for zombies to lose aggro)
    7. When you get near the entrance of the building again, throw a bunch of rocks to lure the zombies outside (this is where having good stealth makes it easier to lure them without them aggroing you)
    8. Keep throwing rocks until the zombies are far away from the POI, notice the red dots disappear from the compass
    9. Kill any straggler zombies that didn't get far away enough and still showing red dots. Be careful not to lure the existing groups back towards the POI
    10. Go inside and clear the rest of the zombies

    Actual result: Clear quest will not complete
    Too long for imgur :( here's a youtube video:

    Expected result: I should be able to clear the quest. I've done this POI a couple times now experimenting things so I'm pretty sure I've been through every area. I even restarted quest and went through same areas again but killing the trigger volume this time and finished it successfully.

    Log files: https://pastebin.com/bPuWWjvM


    Some additional thoughts for QA:

    • I tested specifically with trigger volume, not sure if sleeper volume will still despawn?
    • Not sure if the issue is caused by the red dots disappearing when the zombies walk away from POI, or the fact that they simply despawned (not sure what causes them to despawn either)

    User Feedback

    Recommended Comments

    Got exactly the same problem right now. Never even seen this POI before, started a tier5 "Infested Clear" from joel, made it in and got super overwhelmed so I ran around the building trying to take them out one by one. Got through the whole thing after I don't know 700 9mm and 600 .44 in 12-14 ingame hours to find out the quest wouldn't finish and no yellow dot would appear. So I searched the whole building a couple of times and destroyed many walls to find the last zombie but with no luck.

    I really hope this gets fixed, was not the first time this happened to me in a21 (with other jobs, it was some gasstation POI with a laundry, a kitchen and a restaurant i think).


    Best regards :)



    Link to comment
    Share on other sites

    Thank you for reporting.

    Yes,  we are aware of the issue,  and are working on a fix for it.  Hopefully it will be fixed soon.

    I will add your report the internal ticket for it.

    Edited by chikorina (see edit history)
    Link to comment
    Share on other sites

    I've got a similar one in A21 B324. "Pass-N-Gas Plaza".  The dot is showing the last spawn of the zombie is on top of the trailers but I've been up there twice.  Cleared the place once, exited without leaving the POI bounds to restart the quest, cleared it a second time and both times dot shows the last zombies are on top of the blue trailer even after they had already run off of it when I started the quest and aggro-ed them.  Killed them but the dot is still there, and there is no dot or way to get into the back entrance up a flight of stairs to a locked door. The POI is also not showing up as a tier 3 for me, but as simply "Pine Forest" in the top right corner.  I did a clean build before I started this world, I run these mods: "CraftFromContianers", "JaWoodleUI-A21", and "KHA21-LockableInvSlots".

    PNG bug.PNG

    PNG bug2.PNG

    Link to comment
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now

  • Create New...