Jump to content
  • Game runs sloww on windowed mode


    Summary: Game runs sloww on windowed mode


    Game Version: A20

    Platform: PC

    OS/Version: (Windows)

    CPU Model: AMD Ryzen 5, Vega 8 APU (laptop processor)

    System Memory: 12GB

    GPU Model and VRAM: Radeon Vega 8 APU 2 GB dedicated memory

    Screen Resolution: 1280x720

    Video Settings: Lowest

    Game mode: SP


    Did you wipe old saves? NO

    Did you start a new game? (Yes)

    Did you validate your files? (No)

    Are you using any mods? (No)

    EAC: not sure


    Status: NEW


    Bug Description: On Alpha 19 I played the game in windowed mode and it worked fine. On upgrading to alpha 20 when in windowed mode the game looks like everything is happening in slow motion. When I switched to full screen the  game works fine


    Detailed steps to reproduce the bug:


    1) Go to video options and switch to windowed mode



    Actual result: (description of what is occurring)

    Game moves runs really slow


    Expected result: (what you expect to occur)

    The game should operate at normal speed

    User Feedback

    Recommended Comments

    In a while after other things I will run it on my Vega 8


    Top of my head, if you have something else in focus you will lose FPS due to it being treated as a background process

    Link to comment
    Share on other sites

    Can't confirm. Using my Vega8 (APU on Ryzen 3 3200G) limiting my ram in my system to 12GB I actually increased FPS by about 2 - 4 FPS in windowed mode.  You may want to alter your power plan to give it more performance, and tell Windows to prioritize programs


    You may also want to use the game launcher cleaning tool to clean your game settings, which will wipe the registry containing old settings.

    Edited by Jugginator (see edit history)
    Link to comment
    Share on other sites

    not getting any serious issues here but i do have ryzan 7 2700x, rtx 2080 ti 3 27" led monitors and 64G ram.


    remember you see all those other windows thus they are being rendered by your GPU so when at full screen your video card does not render them (until you leave game).


    in game turn down or off shadows and reflections.. lower setting to medium if you havent tried it yet.


    i am thinking vram at 2g is slightly pushing it. could be your card needs more ventilation too.

    Link to comment
    Share on other sites

    Going to "close" this ticket, since this is an isolated issue.


    You may respond here of course, but likely will see a boarder audience in general support. What Joe said is likely the culprit, although with the way Windows 11 handles games currently that may also be causing overhead. There have been some updates, but I currently don't have a Windows 11 setup for testing.


    Side note, also did this on a Win 8.1 laptop with 8gb of ram and an igpu which has like 512mb dedicated ram and shares up to about 2gb and it performed slightly better in windowed mode with the desktop icons disabled.


    You MIGHT also get a performance increase by shutting down explorer through the task manager and running the game in windowed mode (if you need to enable the desktop again just click File, Run New Task, enter explorer or explorer.exe)

    Edited by Jugginator (see edit history)
    Link to comment
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now

  • Create New...