Jump to content
Sign in to follow this  
millare69

War3zuk Demolisher not doing damage

Recommended Posts

Hello, i recently downloaded the War3zuk mod package. I realized that demolishers aren't doing any explosive damage when they detonate. I was wondering if anyone else experienced the same thing? Before I added the mods, they were able to blow holes into my base.

Share this post


Link to post
Share on other sites

I dont run the latest version, but they do not deal any block damage as far as i noticed, it still kills me if i'm closer than 4 meters when it goes boom though. i just assume the block damage property is set to very low or it's non existent, so you may wanna just turn that up a bit if you wish.

under the mod config folder, you'll find the entityclasses.xml, open that, and search for demolisher, then look into the code for the following property:

<property name="Explosion.BlockDamage" value="0"/>

set that value anything above 0, let's say..

<property name="Explosion.BlockDamage" value="250"/>

so that will be enough to break any wood blocks or block with durabillity under 250 in a 1 meter radius. same goes for radius, can be increased as much as you want.

  • Like 1

Share this post


Link to post
Share on other sites
I dont run the latest version, but they do not deal any block damage as far as i noticed, it still kills me if i'm closer than 4 meters when it goes boom though. i just assume the block damage property is set to very low or it's non existent, so you may wanna just turn that up a bit if you wish.

under the mod config folder, you'll find the entityclasses.xml, open that, and search for demolisher, then look into the code for the following property:

<property name="Explosion.BlockDamage" value="0"/>

set that value anything above 0, let's say..

<property name="Explosion.BlockDamage" value="250"/>

so that will be enough to break any wood blocks or block with durabillity under 250 in a 1 meter radius. same goes for radius, can be increased as much as you want.

 

Thanks man, I was actually searching through the XML files and couldn't find those lines.

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...