Jump to content
  • Can log into friends server

    • Version: Alpha 21 (b324) now thats the old log but same error




    Game Version: (A21 b3xx)

    OS/Version: (Windows / Linux / Mac)

    CPU Model: (Intel i5 9600K / AMD Ryzen 7 1800x / etc)

    System Memory: (4 GB / 8 GB / 16 GB / etc)

    GPU Model and VRAM: (nVidia GTX 1060 4 GB / AMD RX 580 8 GB / etc)

    Screen Resolution: (Width and Height such as 1920x1080)

    Video Settings: (Low / Medium / High / Ultra / Custom(Custom has many combinations, so just list the settings you think are relevant to the bug if any))

    Game mode: (MP host / MP client / SP / Client on Dedi, RWG or NAV)

    2023-06-28T23:46:44 0.026 INF Version: Alpha 21 (b323) Compatibility Version: Alpha 21, Build: WindowsPlayer 64 Bit
    2023-06-28T23:46:44 0.027 INF System information:
    2023-06-28T23:46:44 0.027 INF    OS: Windows 10  (10.0.19045) 64bit
    2023-06-28T23:46:44 0.028 INF    CPU: AMD Ryzen 7 5800H with Radeon Graphics  (cores: 16)
    2023-06-28T23:46:44 0.028 INF    RAM: 15714 MB
    2023-06-28T23:46:44 0.028 INF    GPU: NVIDIA GeForce RTX 3070 Laptop GPU (8033 MB)
    2023-06-28T23:46:44 0.035 INF    Graphics API: Direct3D 11.0 [level 11.1] (shader level 5.0)
    2023-06-28T23:46:44 0.060 INF Last played version: Alpha 21

    I think its a Dedicated server, friends server.  game works in NAV or other Dedicated servers no problem


    Did you wipe old saves? (Yes/No)


    Did you start a new game? (Yes/No)


    Did you validate your files? (Yes/No)


    Are you using any mods? (Yes/No)


    EAC on or off?

    no idea, default

    Status: NEW


    Bug Description:

    Was playing fine and then patch happened and now get this strange error.


    Have uninstalled game multiple times and even reinstalled steam.  Removed all local files in appdata; roaming and locallow.  


    Friend wiped my account from the server but still unable to log in without this error everytime.


    Able to play on nazarene and other servers.



    NullReferenceException: Object reference not set to an instance of an object
      at GameManager.PlayerId (System.Int32 _playerId, System.Int32 _teamNumber, PlayerDataFile _playerDataFile, System.Int32 _chunkViewDim) [0x0005d] in <476fa46948834b5fae97419a606b9b4f>:0 
      at NetPackagePlayerId.ProcessPackage (World _world, GameManager _callbacks) [0x00000] in <476fa46948834b5fae97419a606b9b4f>:0 
      at ConnectionManager.ProcessPackages (INetConnection _connection, NetPackageDirection _disallowedDirection, ClientInfo _clientInfo) [0x000c8] in <476fa46948834b5fae97419a606b9b4f>:0 
      at ConnectionManager.Update () [0x0016a] in <476fa46948834b5fae97419a606b9b4f>:0 

    2023-06-28T23:52:01 317.432 INF Dymesh: Warming dynamic mesh
    2023-06-28T23:52:01 317.432 INF Dymesh: Creating dynamic mesh manager
    2023-06-28T23:52:01 317.439 INF Dymesh: Awake
    2023-06-28T23:52:01 317.439 INF Dymesh: Mesh location: C:\Users\backd\AppData\Roaming/7DaysToDie/SavesLocal/995B73D2B0D62943B5820C5D31C82EF9/DynamicMeshes/
    2023-06-28T23:52:01 317.440 INF Dymesh: Loading Items: C:\Users\backd\AppData\Roaming/7DaysToDie/SavesLocal/995B73D2B0D62943B5820C5D31C82EF9/DynamicMeshes/
    2023-06-28T23:52:01 317.442 INF Dymesh: Loaded Items: 0
    2023-06-28T23:52:01 317.442 INF Client package items: 0
    2023-06-28T23:52:01 317.442 INF Dymesh: Sending client arrive message. Items: 0
    2023-06-28T23:52:01 317.443 INF Dymesh: Loading all items took: 0.0040006 seconds.
    2023-06-28T23:52:01 317.451 INF Clearing queues.
    2023-06-28T23:52:01 317.451 INF Cleared queues.
    2023-06-28T23:52:01 317.454 INF Dynamic thread starting
    2023-06-28T23:52:01 317.456 INF Dymesh door replacement: imposterBlock
    2023-06-28T23:52:09 325.533 INF Discarding NetPackagePlayerStats for entity Id=5352
    2023-06-28T23:52:10 325.949 INF Discarding NetPackagePlayerStats for entity Id=5352


    The last line just keeps repeating as it says creating character.. with different time stamps


    Detailed steps to reproduce the bug:

    1) try and run game




    Actual result: game basically locks up in the creating player screen




    User Feedback

    Recommended Comments

    I had the same problem and I solved it as follows:


    You will open %appdata%>Roaming and save the folder "7 Days To Die". This will serve as your backup.

    Now, you will navigate to the location where the game is saved and open the game launcher. Proceed to the "Tools" section and select "Clean Game Data." Activate all the available options. After completing this step, launch the game and create a new save in the same world as your previous one.

    Once the new world you create finishes loading, log out, and open %appdata%>Roaming>7 Days To Die>Saves. Here, you will replace the <Navezgane> folder (which represents the map you play on) with the <Navezgane> folder from the backup you previously made.


    And the best part is, you won't lose anything at all.


    I resolved my issue by replacing only that folder, so I'm not aware if there's any other way to solve it.

    Good luck dude

    Link to comment
    Share on other sites

    Did this work on Multiplayer Dedicated Server? I have having this issue when trying to login to our server, but not on singleplayer.

    Link to comment
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now

  • Create New...