Jump to content
  • E key no longer works with memory cannot be expanded error


    verified files and folders, happened twice (last 2 games)  first on my own dedicated server and second on a public dedicated server  both RWG maps.. it seems it is not map related   there is a file that hits its max.. and then your done.. yo8u can still play.. the game.. you can shoot things..  but your E key no longer works.. remapping E key does not help.  verifying files and folders does not help.  this never used to happen so i suspect it is the latest version (i use experimental). on rejoin the server  the error is gone (and your backed up  a bit in game time) .. till you do something.. a few seconds.. then u get the same memorry cannot be expanded error.  As before u can do anything in game.. except interact with e key.  which makes the game unplayable..   so this happened to me 2x  every7d2dbug.jpg.b3e5d8b9c367b1e5714a5f55166e194e.jpg7d2dbug.jpg.b3e5d8b9c367b1e5714a5f55166e194e.jpgtime so far i have played with this latest version.. and it only happens after many many hours and having built a massive fortress so much time and effort invested!


    what a frigging messhow do i undo this image insertion?   i have 48G memory.. why issnt my memory stream expandable?


    also the game works fine.. if i  join a new game..  or create a new game (till it gets too big and errors out)  but if i try to join this latest game or the prior game, any game that has previously errored out.. i get the same error..  so everything works.. till something gets too big.. then my e key quits working with this memory stream is not expandable error..  so what you can play 100  hours then your game e key becomes non functional cus a file got too big?  this is worst time to find out  you cant play the game ..


    i opened 7daystodie.gc.log  (cus i cant paste it here) and all that was in the log was "

    Unexpected mark stack overflow


    User Feedback

    Recommended Comments

    Summary: E key (or its binding) stops working after hundreds of hours of game play with exc memory stream is not expandable error and unexpected mark stack overflow error in log.


    Game Version: a20.4 b42

    Platform: (PC


    OS/Version: (Windows

    CPU Model: (Intel i5 9600K / AMD Ryzen 7 1800x / etc)


    System Memory: (4 GB / 8 GB / 16 GB / etc)

    GPU Model and VRAM: (nVidia GTX 1060 4 GB

    Screen Resolution: (width and height)



    Video Settings: (Low / Medium / High / Ultra / Custom (Custom has many combinations, so just list the settings you think are relevant to the bug if any))



    Game mode: (MP host / MP client / SP / Client on dedi, RWG or NAV)

     mp client on dedi rwg  (two different servers, different games same error after EXTENSIVE play)

    Did you wipe old saves? (Yes/No)  yes

    Did you start a new game? (Yes/No) yes

    Did you validate your files? (Yes/No) yes

    Are you using any mods? (Yes/No) no none ever

    EAC on or off? on


    Status: NEW


    Bug Description:


    Detailed steps to reproduce the bug:


    1) play the game.. build a 10,000 - 100,000 block fortress with hundreds of hours invested

    2) just play the game when suddenly.. the consol opens with this error



    3)  now everyting works in game once you close consol.. excep the E key..  which will never work again in this game  you can join new games.. create new games everying works fine.. till you invest another hundred hours


    Actual result: (description of what is occurring) E key (or any of its its binding for that function) quits working after that error


    Expected result: (what you expect to occur) i expect to interact with items using the E key.

    if  you reload the game it works for about 2 seconds.. then u get the error again.. and the E key becomes non functional  everything else works.. you can shoot you can move.. game is normal except never again can you interact with the e key or any other key you bind that function to.

    Link to comment
    Share on other sites

    I'm sorry you are experiencing this.  Thank you for reporting,  but this issue has been reported and dealt with already,  and there will be a fix for it in a future update.


    Link to comment
    Share on other sites

    thank god.. thank you too chikorina for your response. 9,500 hours in this game and counting  and i'm suffering withdrawal symptoms.  this is one of the best games ever made and the best in it's class by far.. and i want to restore my good review of it on steam.  I can rest assured i will be able to play the game in the future at some point..   one thing i am currious about is what was the cause of this error?  can my game(s) be saved?  what was the previous report and findings?  i hope all that is not "classified"  if it is in the public forums how would i search for it?

    Link to comment
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now

  • Create New...