Jump to content

Error in blockmappings.nim


Recommended Posts

My issue involves a mod, but I doubt the mod itself is to blame.

I'm playing Vanilla A20.5, the mod is KHA20-ChickenCoops.

The symptom is console spams this message:

ERR Block on position 2324, 33, 1680 with name 'DFChickenCoopFull' should be parent but it is not! (1)

At that location was a chicken coop that got destroyed. In the game, that location is unusable, as the game thinks something is there.

Using Notepadd++ I found a string containing DFChickenCoopFull in blockmappings.nim.

(I removed everything related to that mod in-game, so there is only the one reference in blockmappings)

I'm guessing that is a compiled file so I can't edit it directly.

Is there any way to console-edit something like this in game? Or does anyone have any other solution?


Link to comment
Share on other sites

I think I fixed the issue. I'll post how, but the reader MUST understand I don't have deep knowledge of this, I just bumbled around till I got something that worked. You might break your game doing this.
First thing I had to do was enable something that is available when creating a POI (map? whatever), anyway it is  the Level Editor.
Make a BACKUP of this file before editing. Exit game First! Search
C:\Program Files (x86)\Steam\steamapps\common\7 Days To Die\Data\Config\XUi\windows.xml
for the entry that looks like:

<button style="press, hover" name="levelTools" tooltip_key="xuiLevelTools" sprite="ui_game_symbol_resource" visible="{is_editmode}" sound="[paging_click]" width="32" height="32" hoverscale="1.25" pivot="left"  collider_scale="1.5"/>

Remove the:


Now in the game F1 to open console, type dm and press Enter to enable debug mode. Press Esc to close the console window.
With crosshairs on problem area press Z key to create a blue selection box. I was not able to directly put box on the area, but pressing Z again expands it. Pressing Backspace removes the blue box. Took me a few times to get an area that included the problem spot.
Equip some block, I used a wood frame.
Then press Esc and on the right should be a window with some editing tools. The edit I made to the windows.xml file enables an icon in the top area called "Level Tools". Click that and at the bottom of the new window is a button "Rnd decorate Sel."
Basically clicking it randomly fills the area with whatever block you are holding. It took a lot of clicks but eventually the problem spot was replaced with frames that I could then pick up.
You will also see a button "Fill Area" that sounds like it would be perfect for this, but it is disabled for whatever reason. What I described above worked for me so I left well enough alone.
Again, I just figured this out bungling around. Do your own research before you do this.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...