Jump to content

Opulent bladetrap-setup causing strange bugs/freezing?


Recommended Posts

tldr: solar-powered bladetraps causing periodically freezings and/or memory leaks


I have a 9x9 tower and I just installed a defensive system around the towerbase with 16 rotating blades powered by two solar banks for running them round the clock. And that's the strange thing at the story: When I activated it the first time, everything runs fine for hours and there was no sign of problems with this setup. I logged out with running blades to see the next day how the power consumption over time is.


When I logged in the next day I wondered first why 4 batteries in each bank were empty although I noticed the day before that the night eats up only the charge of 2 batteries. And I noticed a periodically short freeze every second, which was gone after switching off the blades. Blades on: periodically freezes. Blades off: ok.

After some testing it got really worse so that the chunk didn't loaded correct, half of my tower wasn't loaded. Moving away from the chunk and coming back ended up in the game having a memory leak with unplayable framerate. I switched off the blades and restarted. Now it's ok again.


So my assumption is, that there's a bug in the power usage/loading current calculation which can cause strange bugs/freezes.


I will watch the thing further and write here how it goes. Have other players made similar observations with such setups?

Link to comment
Share on other sites

Possible solution for lag with Solar Panels


I had lag back in A16 when using blade traps with solar panels as a power source. After some testing I discovered that it was NOT the blade traps or the solar panels: It was the wire relays causing all the problems (probably just bugged/bad code). So I took them all out of my base & replaced them with "switches." Problem solved, no more lag! Switches act just like a wire relay, but are actually better because they don't use any electricity (wire relays use 1 watt per relay, which adds up fast in a larger base and with the limited power that is generated from solar panels). Switches also show a green light when they're on and working properly, and have an ON/OFF switch—which is another bonus.


Hope this helps you out... Otherwise, it could be a new bug in A17. If you have time, drop me a message & let me know how it turns out. I'd like to know the outcome.

Link to comment
Share on other sites

New bughunter stories, seems like You're right @Bodybagger, thanks for the tip.


So I replaced all relays with switches (not easy with 6 circuits in a 90 block tower). It was short before sunrise when I decided to use at least one timer relay for the lights-circuit. Like in the first try, everything ran fine. Then came sunrise and it began.

Really bad periodically freezing, worse than in the first try. Then it was a freeze tenth of a second every second, this time it was like quarter second freezed, quarter second running, and so on.

I switched of the lights circuit with the only (timer-)relay, freezes were gone. Switched on again, after a few seconds the freezes came back (blades were running all the time, so they were not the problem).

I removed the relay, but after a while again freezes. I tried to restart the game but then it hanged at the login 3 times. Was probably me who wrecked the server with this, have to wait now until the next server restart.


Yeah, it's really the relays which must be the cause, timer relay even worse than the normal relay.


I will testing further completely without relays and will write here what happens next in the adventures of bughunter.

Link to comment
Share on other sites

Final report: I give it up, that thing goes deeper and I can't find a single reason. It happens even in a simple circuit with 6 lights and only switches.


I couldn't log in for hours and the reason was that the electricity setup blocked the last step of the login (Generating distant terrain), but the porting commands worked, so I ported out of the non-loading home chunk to an area where the client finished the loading. The nearer I came to my base the worse the lag. After a while it was enough loaded so that I could reach the switches and switch all off.


More testing only with the light circuit resulted in strange behaviour. If only 5 lamps were on, it was ok. If 6 were on I got periodically freezes after ~20 secs, and that all was also dependant from my standing position. I don't know if this is same for all others or only me, but for me it means I can't run complex electricity setups atm. Only single lights at a time.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...