Jump to content
  • Vehicle stopped on invisible wall, player no longer can jump or interact

    • Version: A21 (b324)

    Summary: While playing Singleplayer I ran into an issue while driving the 4x4 truck. I was driving down a road I've used literally hundreds of times because it is between my base and a trader. At some point on the road, where there was nothing on it, my truck suddenly bounced backwards like it hit something but it didn't take any damage. After that the truck was no longer able to go forward anymore and the entire truck was leaning to the right with both right side tires stuck half way into the ground. I tried reversing and the truck could not move at all though it made the sound and animation like it was trying too. I thought it was stuck in the ground so I exited the vehicle to try and dig it out. However the ground underneath it would not take any sort of block damage, and the truck itself no longer would react to tools or weapons hitting it.


    I also noticed shortly after this that my player character could no longer jump no matter how many times I pressed space, I was not encumbered, not in sneak mode, there was no reason I shouldn't be able to jump. My character also could not interact with the world anymore. I could walk around but I could not open doors or mailboxes, etc. I also could not dig into the ground, swinging would show the animation but nothing would happen. I tried turning on God Mode and was able to fly around as well, but turning it off would say God Mode was turned off but I could still fly and seemed to be in God Mode still. Toggling it a few times would eventually change it back to normal but my character would seem to teleport to a random location I happened to pass while flying around, not where I had enabled or disabled God Mode. 


    I tried exiting and restarting the program. Sometimes I would be able to enter into the truck and interact with blocks again, but the truck wouldn't seem to be able to drive very far. It was stuck in a seemingly invisible 20x20 block kinda square. It could drive a little distance in any direction before bouncing back again like the original incident. The right side of the truck also was sunk into the ground still.


    I checked if it was just the truck and picked it up and tried placing it again. It had a very hard time finding a way to place it, like the game couldn't detect where the ground was unless it was right under my feet. I spawn a new, different truck and had the same issue. Eventually getting to place both trucks on the ground they both still acted the same way, partially sunk into the ground and unable to move much further from where they started. I even picked them up and tried different areas of the map but they always act the same way. In God mode I noticed I could bump them and they would fly into the air and out of the ground, but then after landing they would sink back into the ground again.


    This is the first time I've seen the issue and I'm not sure what could of caused it. There hasn't been a new update between when I was able to drive down that road and this occurring. I heard some people mention it may be the chunk loading, but this was in a relatively small area close to where  my base was and I hadn't gone very far. I also tried walking ahead on foot to ensure the area loaded and it seemed fine, but the truck was still stuck. My player also randomly loses the ability to jump and interact with anything or do block damage as well.


    Sorry for the long post but a lot of different things all broke at once.

    Game Version: (A21 b324)

    OS/Version: (Windows)

    CPU Model: ( AMD Ryzen 9 5900hx /)

    System Memory: (16 GB)

    GPU Model and VRAM: (RTX 3080 laptop GPU)

    Screen Resolution: (1920x1080)

    Video Settings: ( High )

    Game mode: ( SP )


    Did you wipe old saves? (Yes/No)

    No, only one save.


    Did you start a new game? (Yes/No)



    Did you validate your files? (Yes/No)



    Are you using any mods? (Yes/No)



    EAC on or off?



    Status: NEW


    Bug Description: Vehicle gets stuck in ground, player will lose the ability to jump and interact with objects or re-enter the vehicle after exiting.


    Detailed steps to reproduce the bug:

    1) Load game world and enter vehicle.

    2) Try to drive around, exit vehicle.

    3)Try to jump or interact with other entities in the world, or re-enter the vehicle and drive again.


    Actual result: Vehicle is stuck, no methods are able to make it unstuck. New vehicles spawned in also get stuck in the same way. Player is unable to jump and interact randomly.


    Expected result: Vehicle drives normally, player able to jump and interact with everything normally.

    Link to Pastebin Output Log:https://pastebin.com/RDPds2Pp

    User Feedback

    Recommended Comments

    1. Thank you for reporting.

      I see this in your log.  Your drone's position is very strange.


    2. 2023-07-23T17:58:33 9224.962 INF 606704 Drone PostInit [type=EntityDrone, name=entityJunkDrone, id=22687], (-386880000000000000.00, -1759826000000000000.00, 44269810000000000000.00) (chunk -134217728, -134217728), rbPos (-386880000000000000.00, -1759826000000000000.00, 44269810000000000000.00)

      Have you lost track of a drone recently?

      If you have lost a drone,  this issue is most likely caused by the drone being stuck somewhere. 


      When the drone gets stuck,  it creates an endless spam of logs in the console,  which results in many issues like the ones you described.  


      You would need to delete the drone from your save game.  The sure way to do this is to delete the "drones.dat" and the "drones.dat.bak" files in your save game folder.  Deleting these files will delete the drone you had,  so your drone and everything you had in its inventory will be lost.


      You can find your savegame folder by,

      - Select the "Tools" tab in your launcher.

      - Select the "Open savegame folder".

      - Open the "Saves" folder.

      - Open the folder with the name of the map that you are having the issue with.

      - Open the folder with the name of the save game that your are having the issue with.

      - Delete both the "drones.dat" and the "drones.dat.bak" files.


      After deleting the drone files,  do the following in game.  This will allow you to place new drones.

      - Open console by pressing F1

      - Type in "dm" in the console and press enter.

      - Type in "jd clear" in the console and press enter.

      - Try deploying the drone again.

    Link to comment
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now

  • Create New...