Jump to content
  • Specific Items do not Display on Vending Machines

    • Version: 21 b317

    Summary: On multiplayer server depositing weapons, tools, weapon mods into the vending machine deposits them into the machine, but does not display them in anyway. You still get them back when you "take all" but cannot adjust price and buyers cannot see them to buy.

    Game Version: (A21 b3xx) A21 b317

    OS/Version: (Windows / Linux / Mac) Windows

    CPU Model: (Intel i5 9600K / AMD Ryzen 7 1800x / etc) i5-9600K

    System Memory: (4 GB / 8 GB / 16 GB / etc) 32gb

    GPU Model and VRAM: (nVidia GTX 1060 4 GB / AMD RX 580 8 GB / etc) 3070TI

    Screen Resolution: (Width and Height such as 1920x1080) 1920x1080

    Video Settings: (Low / Medium / High / Ultra / Custom(Custom has many combinations, so just list the settings you think are relevant to the bug if any)) Ultra with bloom/motionblur/dynamic mesh turned off

    Game mode: (MP host / MP client / SP / Client on Dedi, RWG or NAV) MP Client on RWG map


    Did you wipe old saves? (Yes/No) Yes


    Did you start a new game? (Yes/No) Yes


    Did you validate your files? (Yes/No) Yes


    Are you using any mods? (Yes/No) No


    EAC on or off? On


    Status: NEW


    Bug Description: Depositing any weapon, tool or related mod into vending machine places it in the machine, but you can not see it or adjust it or buy it.

    My Outputlog: https://pastebin.com/6Nt1jhD5


    Detailed steps to reproduce the bug:

    1) Place Player Vending Machine

    2) Interact with Machine

    3) Deposit Brass Knuckles or any weapon or tool into the store.


    Actual result: The item will leave your inventory and not display on the machine


    Expected result: For the item to show up in the list and allow the price to be adjusted. Or for the item to show up to a seller to buy.

    User Feedback

    Recommended Comments

    Extra info: What items do not display seems to be all over the place. The majority of items I deposit do not display within the category of "weapon/Tool/related mods.," but some of them do.  Iron Crossbow rank 5, Metal Chain Mod and Foregrip mod worked for some reason, while sledge turret, rank 5 pistol, rank 5 stone shovel, rank 3 wrench, rank 4 hunting knife, rank 5 rachet, did NOT display when put into the machine.

    Link to comment
    Share on other sites

    Thank you for reporting.

    This issue is known,  and there is already an internal ticket written for it.  

    We've found the cause,  so please wait for a fix in a future update.

    Link to comment
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now

  • Create New...