Jump to content
  • POI trigger system bugged

    • Version: A21.1 Stable

    Summary: Trigger system failing to keep track of what triggers have been triggered and not yet triggered (or untriggered)

    Game Version: (A21. b16)

    OS/Version: Windows

    CPU Model: AMD Ryzen 7 3700X 8-Core Processor   3.60 GHz

    System Memory: 16 GB

    GPU Model and VRAM: 

    Screen Resolution: 1920x1080

    Video Settings: Ultra / Custom

    Game mode: SP / Prefeb Editor


    Did you wipe old saves? Fresh test world


    Did you start a new game? Yes


    Did you validate your files? Yes


    Are you using any mods? Yes, my own mod that doesn't touch the trigger system


    EAC on or off? Off


    Status: NEW


    Bug Description: A single block setup to be triggered by multiple triggers, doesn't trigger when all triggers assigned to that block are "turned on"
    Sometimes the block will trigger anyway when some triggers have been deactivated

    See photo/video for a VERY simplified version


    Detailed steps to reproduce the bug:

    1) Set up multiple switches, lights and a single door

    2) link each switch to their own light and the door using the trigger system

    3) press all switches to light up all lights and what the door stay closed


    Actual result: Door is NOT opening when ALL lights are triggered on


    Expected result: Door SHOULD open once all lights are turned on, even in more complicated setups when lights can also be turned off in the process via multiple triggers per switch

    Screenshot 2023-08-20 045137.png

    User Feedback

    Recommended Comments

    3 hours ago, 3ternalDamned said:

    Confirmed, Thank You for the report!

    Here is a more complex puzzle I tried doing for my "escape room" mod. image.thumb.png.f1c22f60c82164495637329485c0e720.png

    Link to comment
    Share on other sites

    I've played around a bit with the A21.2 update. It appears that some fixes have occurred, still not working 100% though.

    I reworked this puzzle slightly in A21.2. The goal is to turn OFF all of the lights, to open the door (24,25,26,27,28). However, the door opens when the green light is on (the rest are off)

    Link to comment
    Share on other sites


    A21.2 b30 has completely broken the trigger system


    Example above:
    So, the idea is, the door shouldn't open until ALL switches are pressed. This worked before b30 update.
    But now, pressing ANY switch will open and close the door

    Why was this change made?
    It has completely destroyed by puzzles in my mod

    Link to comment
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now

  • Create New...