Jump to content
  • Crashing/freezing on PC (Windows 10)


    Summary: I load into a game and anywhere from a few seconds to a few minutes in the game will freeze and become unplayable. I've tried it on random generated worlds, on navezgane, and on worlds hosted by other players and it always ends up crashing. When I turn the settings and resolution all the way down to lowest possible it no longer crashes (or at least I haven't seen it crash so far) but my computer should really be able to handle more than that, especially when I ran Alpha19 at medium/high settings at 1440p without issue.


    Game Version: A20b218

    Platform: PC

    OS/Version: Windows 10

    CPU Model: AMD Ryzen 5900HX

    System Memory: 32GB

    GPU Model and VRAM: NVidia RTX 3070 Laptop w/ 8GB vRAM

    Screen Resolution: 2560 x 1440 (have also had the issue with several other resolutions I tried out) (game didn't crash when running at 640 x 480 and settings at lowest)

    Video Settings: Tried a bunch of variations but none made any difference

    Game mode: MP, SP, RWG & Navezgane


    Did you wipe old saves? Yes

    Did you start a new game? Yes

    Did you validate your files? Yes

    Are you using any mods? No

    EAC on or off? Off


    Status: NEW


    Bug Description: When I load into worlds after a variable amount of time (usually between a few seconds to a few minutes) the game will freeze and become unplayable.


    Detailed steps to reproduce the bug:


    1) Start game

    2) Load into world

    3) Freeze


    Actual result: The game freezes and becomes unplayable


    Expected result: I want it to not freeze

    Log: https://pastebin.com/6Nuana4L


    Additional notes: I tried looking up some of the error codes in the logs. I didn't see anything related to 7 days to die specifically, but found similar posts for other games, and they usually related to the graphics card/driver failing. Additionally, in event viewer there are recorded errors during the freeze that say:

    "The description for Event ID 14 from source nvlddmkm cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

    If the event originated on another computer, the display information had to be saved with the event.

    The following information was included with the event: 

    0000(0000) 00000000 00000000

    The message resource is present but the message was not found in the message table"

    I did try clean installing the graphics drivers and even installing an older one to see if it made any difference, but it didn't. All of my drivers are up to date. I also haven't been having any problems in any other demanding games, and ran a benchmark to see if I had any issues or freezes during that and I didn't.

    User Feedback

    Recommended Comments

    I would use DDU to uninstall your driver and install a fresh driver, that crash is specific to that. May want to update your other drivers/Windows as well


    Note that you should disable networking when booting into safe mode for DDU or at least prevent automatic updates, sometimes you can't get a clean driver without going into safemode and all of that.

    Moving to not a bug, but feel free to respond back if you need further help with this.

    Edited by Jugginator (see edit history)
    Link to comment
    Share on other sites

    Hello, and thanks for the response! I booted into safe mode and used DDU to uninstall my drivers and then installed them again. Unfortunately this did not fix the issue. The game still freezes after loading into a world.

    Link to comment
    Share on other sites

    Hmm. Something isn't playing correctly with your GPU driver.


    Open up a command prompt with admin rights, then run this (spaces and caps included), let me know if it finds any errors


    DISM /Online /Cleanup-Image /CheckHealth

    Link to comment
    Share on other sites

    You may want to try to just update/download DX11 from microsoft (here)


    Going for quick and easy ones here, you MAY want to rollback to an earlier driver, perhaps there is a bug on this version.


    FOr debugging you can try using GLcore and/or Vulkan, go to the launcher for that. Just as well, verify your game files twice

    Edited by Jugginator (see edit history)
    Link to comment
    Share on other sites

    Okay, so I tried updating DX11 and it didn't seem to make a difference. I have also tried several older drivers (including the OEM recommended driver - I use the latest NVidia driver normally), and they didn't seem to make a difference either. 

    I verified the game files twice and then I booted up using GLcore and it crashed as soon as I loaded into the world as well. The log ends abruptly after "PlayerSpawnedInWorld" and there's no crash report. When I tried Vulkan it also crashed, but it did provide a crash report. The log stated "Vulkan - Out of memory!" and the error log stated something similar to the DX11 crash: "UnityPlayer.dll caused an Access Violation (0xc0000005) in module UnityPlayer.dll at 0033:3a6e3c52."

    Here are the Vulkan logs if you want to look at them:

    output: https://pastebin.com/2aYv6van


    error: https://pastebin.com/016uYapD

    Link to comment
    Share on other sites

    Hello, I wanted to give you an update. At the time I was first having this problem I tried playing other games (and even ran a benchmark) to see if it was a problem with my hardware, but didn’t have any issues. Unfortunately I recently discovered that I’m starting to have problems with other games too, and now it seems more like it might be an issue with my actual GPU, as any game I try to play is now crashing. I appreciate the help up to this point, and I’m going to contact support for my PC and see if the GPU might need to be replaced. I’ll let you know if anything changes and it doesn’t end up being a hardware issue, but for now it does seem to be a problem on my end. Thanks for the help!

    Link to comment
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now

  • Create New...