Jump to content
  • Game Freezing when using wire tool to connect light fixtures to generator


    Summary: Whenever I right click the appliance I am trying to hook up to a generator bank or battery bank the game Freezes and crashes


    Game Version: A20.3 (b3)

    Platform: PC

    OS/Version: Windows 7 Professional

    CPU Model: Intel(R) Core(TM) i5-4690K CPU @ 3.50GHz 3.50GHz

    System Memory: 16 GB

    GPU Model and VRAM: NVIDIA GeForce GTX 970

    Screen Resolution: 1920 x 1080 (16:9)

    Video Settings: Custom (Dynamic Res: Off. FoV: 65. AA: Medium. Sharpening: 0%. View Distance: Low. Motion Blur: Off. Dynamic Mesh: Off)

    Game mode: MP Host (Note it is basically a Single Player server but as that does not seem to be an option in A20 that I have seen it was created as a MP server that is password protected and only visible to friends. No other players are present on this server.)


    Did you wipe old saves? No

    Did you start a new game? No

    Did you validate your files? No

    Are you using any mods? No

    EAC Was initially on when server was created. Has been turned off yet the problem has not been resolved.


    Status: NEW


    Bug Description: I am currently trying to hook up electricity via a battery bank, (Generator bank has also caused this issue). I am able to right click the banks with a wire tool and no issue. As soon as I right click the appliance, (in this example a basic lightbulb) the game immediately freezing and must be closed to continue. No other crashes or game breaking bugs have been detected.


    Detailed steps to reproduce the bug:


    1) Several attempts with battery bank to light fixtures (first noticed occurrence of crash)

    2) Attempted with generator bank to same result

    3) No additional attempts


    Actual result: As stated above and in title the game will freeze and require closing as soon as light fixtures are right clicked with the wire tool to connect them to a power source. 


    Expected result: Expect Electrical system to connect and function as intended and how it has functioned in previous patches.

    Here is a link to the pastebin for the most recent output log:

    User Feedback

    Recommended Comments

    We would need a bit more information in order to attempt to reproduce the problem you are having.

    1 - Are you using solar power as well?

    2 - What quality,  how many,  and how degraded were the batteries in your battery bank.

    3 - If you are using solar power, please give the same information for the solar cells.

    4 - In what order did you connect all your electrical components.  Example : Solar bank - battery bank - light bulb.


    It would help even more if you could provide a screenshot of the wiring and the Max output and power stat screen when you open your battery bank.

    Link to comment
    Share on other sites

    I will get a screenshot as soon as I reopen the game.


    As far as your other questions go. 

    1. No solar power is used at this moment

    2. 1 quality 6, 3 quality 5, 1 quality 3, and 1 quality 2 batteries are installed. All are at max durability. Max output for the battery bank is currently 255w. 

    3. N/a

    4. Battery Bank - Light bulb. The game freezes as soon as I click the light bulb with the wire tool to connect it. When reloading my character is back a few feet in game and nothing is connected.

    for the screenshots should I post them here directly or have a link to them?

    Link to comment
    Share on other sites

    I just uploaded the screenshots to imgur and here are the links. There are 4 in total. The battery banks setup.
    A quick look at what I am testing. The game still working when the bank is connected. And the resulting freeze/crash when the light is connected.



    2 https://imgur.com/2qk8yhy

    3 https://imgur.com/7xSygTj



    I hope that this is all helpful to identifying the problem

    Link to comment
    Share on other sites

    Thank you for the additional information.

    I attempted to reproduce the issue by making the same type of room,  setting the generator and light in the same spots,  placing the same quality batteries in the bank,  and was able to connect the wires without any issue.


    Sometimes oddities can happen when you don't validate your files.

    Please try validating your files in your steam 7 days to die property's local files tab.

    Link to comment
    Share on other sites

    I just validated the files and everything there claims to be fine. In the save I am having issues it is still freezing as soon as I try to connect to the light source. 

    I did create a new world in the base map and was able to connect a similar setup just fine after spawning in the parts needed. I am not sure why it is working there and not in the save that I have been playing. There have been no other issues in that game prior to this. Could it have to do with random generated maps?

    Ok so quick update. I attempted to place different light fixtures in a few other places and those are connecting fine with no issue to the game. Hoping the issue was solved I again tried in the original placement and that one alone caused a crash to desktop immediately. 

    Link to comment
    Share on other sites

    I suppose the solution is just to place lights and other electronics in a different location? I won't lie that is a very strange and specific crash that I have never encountered before. But I guess if it works everywhere else then that's cool. Thank you very much for responding as quickly as you have. I do wish I could figure out the reason that one particular location is causing the game to crash. But I am familiar enough with that sort of thing to begin trying to figure it out.

    Link to comment
    Share on other sites

    Thank you for the update.  It probably has to do with the save being carried over versions.  Even if it seems safe to continue playing on the same save game after an update,  there may be unexpected issues.

    I'm glad that you seem to have found a workaround for it,  and hope nothing else pops up.

    I wasn't able to reproduce it,  so I will move this over to the can not reproduce category.

    Link to comment
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now

  • Create New...