Jump to content

New Zombies Not working in Mod system?


Recommended Posts

Has anyone successfully added new zombies via the new Mod System?


I get this error when I try WRN XML patch for "entityclasses.xml" from mod "FastBurst Mod" did not apply: <append xpath="/entityclasses"


But if I add them directly into the entityclasses.xml vanilla game file I can get them in no problem which kinda defeats the entire purpose of the new Mods system right??? And I am NOT talking about new prefab ones. Using the old UMA style zombies.

Link to comment
Share on other sites

Yeah I've got them to work. It appears there is a problem with your xpath code. Would you mind sharing it? Maybe I can see what is wrong.



I tried doing the below code just to see if I could add a new zombie using one of the current ones and changing the name. It's one already in the vanilla file which doesn't make any sense to me.

Example I tried to add this just to see:

<append xpath="entityclasses">
<entity_class name="zombieStripperRadiated" extends="zombieStripper">
	<property name="Tags" value="zombie,walker,feral"/>
	<property name="Mesh" value="Zombies/zombieStandardStripperRagdoll"/>
	<property name="ReplaceMaterial1" value="entities/zombies/materials/feral_eye"/>

	<!-- Gameplay -->
	<property name="MoveSpeedAggro" value=".5, 1.35"/>

	<property name="HandItem" value="meleeHandZombieStripperFeral"/>

	<property name="ExperienceGain" value="700"/> <!-- XP grunt feral -->
	<property name="LootDropProb" value=".03"/> <!-- Feral -->
	<effect_group name="Base Effects">
		<passive_effect name="HealthMax" operation="base_set" value="237"/>
		<passive_effect name="HealthMax" operation="perc_set" value="1"/> <!-- Zombie HP scale -->
		<passive_effect name="EntityDamage" operation="perc_add" value="0"/> <!-- Feral damage -->


and I get that error immediately. I can do other appends that change values no problem. BUT, if I try and add any new entity_class it gives that error and doesn't apply them? Anyone know why or a work around for this or is this just not possible with the new Mod System?

Link to comment
Share on other sites

I see the problem. You are missing a "/" and entityclasses should be "entity_classes". like this "<append xpath="/entity_classes">text</append>"


Edit: I was a lil too slow. glad you got it working :D


Bruh you have no idea how many hours I been testing and looking at the code wondering WTF "why isn't it working!!!" was ready to throw my keyboard LOL

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...