Jump to content
manux

A17 Custom Vehicles Modlet

Recommended Posts

Servers only push xml files currently. The server and all clients have to install any mod that contains anything other than xml files.

Share this post


Link to post
Share on other sites

17.2 B<watever> NOT working; was working before the B<whatever> addon, but now the helicopter I used last night is bjorked and non interactable

Share this post


Link to post
Share on other sites

The modlet works in version 17.2. Great job i love your mod.

 

I saw that you provided weapon addons for the vehicles and the helicopter optimizer.

Is it possible to activate the weapons for the helicopter in the modlet?

 

If you turn off the comments in the XML, the game crashed.

Share this post


Link to post
Share on other sites

The guns are a16 code, which doesn't work in a17 (hence it's commented out); unsure if Manu will ever update the code part to a17.

Share this post


Link to post
Share on other sites
The modlet works in version 17.2. Great job i love your mod.

 

I saw that you provided weapon addons for the vehicles and the helicopter optimizer.

Is it possible to activate the weapons for the helicopter in the modlet?

 

If you turn off the comments in the XML, the game crashed.

 

This mod WAS working for me (we built the helicopter), then STOPPED working (couldn't interact with helicopter) post 17.2 launch ... so, in my books, that's "not working" ...

Share this post


Link to post
Share on other sites

Did you rebuild it in 17.2? A lot of items have to be remade when you update to a new version. Darkness falls mod had the same issue with the advanced forge. People needed to place a new one for it to work properly.

Share this post


Link to post
Share on other sites
Did you rebuild it in 17.2? A lot of items have to be remade when you update to a new version. Darkness falls mod had the same issue with the advanced forge. People needed to place a new one for it to work properly.

 

I'll try that and will report back!

Share this post


Link to post
Share on other sites

Motorcycle with horns just a rocket. Now jerk through the entire map, like two fingers ... :D

Share this post


Link to post
Share on other sites

HI

Is there Something i kan do to stop the 4X4 from damaging / destroying Bridges ?

I really Love that Vehicle... but i dont want it to damage or even destroy all the Bridges when i had to drive over them :( Even when i try slow or backward.

 

Also it woud be cool if others coult enter the Sotrage too.

Edited by Xellulina (see edit history)

Share this post


Link to post
Share on other sites

Has anyone found a work-around for the helicopter suddenly not being accessible? I logged off my server then came right back and i can't enter it.

 

Heck, i can't even get any text acknowledging that i've trying to access it like when you point at vehicles.

Share this post


Link to post
Share on other sites
Did you rebuild it in 17.2? A lot of items have to be remade when you update to a new version. Darkness falls mod had the same issue with the advanced forge. People needed to place a new one for it to work properly.

 

I did. Built a fresh one in 17.2x and the next time i logged on i couldn't access it. I had to have a fellow player try and access it before it would come back to me. Now it's back to doing it, once again. And , when i landed next to it with my jet pack, it sorta just sucked the jetpack in (once i jumped out of it) and now there are two in one space.

 

I can see both icons as if they are sitting side by side but i, literally, saw it engulf my jetpack as i jumped off.

 

 

I would call that a pretty major glitch.

 

 

Update - After several logons, and doing strange things, it allowed me access for one play but it does it every time i logon now.

 

I've followed the directions to the letter. Does anyone know how to get around this issue?

Edited by Kilroy5150 (see edit history)

Share this post


Link to post
Share on other sites
HI

Is there Something i kan do to stop the 4X4 from damaging / destroying Bridges ?

I really Love that Vehicle... but i dont want it to damage or even destroy all the Bridges when i had to drive over them :( Even when i try slow or backward.

 

Use the mod willy jeep. The best SUV at the moment.

Share this post


Link to post
Share on other sites
This mod WAS working for me (we built the helicopter), then STOPPED working (couldn't interact with helicopter) post 17.2 launch ... so, in my books, that's "not working" ...

 

It's a problem.

 

I parked my helicopter outside one of the corporate building. Later, i was inside (working on stairs) and suddenly, without warning, the text to access the chopper appears "inside" the building. So, i back up, click on it and it actually "pulls" me outside and into the chopper.

 

It's not you, it's the mod. I've never even fooled with A16 and everything i did was from scratch from a the A17 newest version and it started acting nutty the moment i got back on my dedicated server. I had to have a buddy on and, by goofing around, we finally got the jetpack and the helicopter to work but it only lasted for that one logon. I was also getting this error off my server when trying to get close to, or access, the manux vehicles and i think it might be related to the problem considering the only vehicles i was trying to access were the manux vehicles.

 

We are just going to have to wait until someone, who has a little better access to Manux, can contact him and let him know this is going on.

 

 

 

2019-04-15T17:28:52 428.600 INF VehicleManager Save

2019-04-15T17:28:53 429.864 INF Time: 4.76m FPS: 33.73 Heap: 1703.5MB Max: 1782.8MB Chunks: 306 CGO: 53 Ply: 1 Zom: 3 Ent: 9 (10) Items: 0 CO: 1 RSS: 5553.9MB

The referenced script (PSMeshRendererUpdater) on this Behaviour is missing!

 

(Filename: Line: 1575)

 

The referenced script (ME_MeshMaterialEffect) on this Behaviour is missing!

 

(Filename: Line: 1575)

 

The referenced script on this Behaviour (Game Object 'Effect5') is missing!

 

(Filename: Line: 1775)

 

The referenced script on this Behaviour (Game Object 'MeshEffect') is missing!

 

(Filename: Line: 1775)2114330471_Screenshot(42).jpg.bf9c26767cf89776badda921f5c1f7ff.jpg

 

I dunno if you can tell, by this photos, but i'm too far from it to be getting the text to access it.

 

616221686_Screenshot(43).jpg.c9c843d134b087a5bdb60ffde9a50ac2.jpg

 

This photo shows the chopper flying with 0% fuel.

 

Oh and, just 2 minutes ago, i landed and the chopper COMPLETELY vanishes off my screen.

 

Yeah, i would say there are a lot of issues that need to be looked at.

Edited by Kilroy5150 (see edit history)

Share this post


Link to post
Share on other sites

Hi, I'm getting a lot of questions about my vehicles that have some of these same issues, and I build mine in an entirely different way than Manux and Dust, so I think it's safe to say that either:

 

1 - Vanilla be bugged

2 - Mod support for custom vehicles has bugs

 

...not a lot to be done from us on either front, I'm afraid.

 

I'd be interested in the FULL log you see those errors in though, so I can stand a better chance of finding out, thanks!

Share this post


Link to post
Share on other sites
Hi, I'm getting a lot of questions about my vehicles that have some of these same issues, and I build mine in an entirely different way than Manux and Dust, so I think it's safe to say that either:

 

1 - Vanilla be bugged

2 - Mod support for custom vehicles has bugs

 

...not a lot to be done from us on either front, I'm afraid.

 

I'd be interested in the FULL log you see those errors in though, so I can stand a better chance of finding out, thanks!

 

 

The only issue i can seem to remember, with your shopping kart, was that it required a table i couldn't ever see on my inventory.

 

I had considered putting your vehicles back on my server and, if i do, i would drop in a log (as i did in the one above). But, every time i have to make a change all my players have to do the same so i only make changes every now and then with mods.

Edited by Kilroy5150 (see edit history)

Share this post


Link to post
Share on other sites
This mod WAS working for me (we built the helicopter), then STOPPED working (couldn't interact with helicopter) post 17.2 launch ... so, in my books, that's "not working" ...

 

By the way, if you read my post (to you) the ONLY way to ensure that the helicopter ALWAYS works (when you log back in) is to put it in your inventory every time before you logoff. I've fresh-installed my server "every" time a coder said it might be on my end and i eventually stopped doing that because i realized most of the errors were bugs that just haven't been worked out yet.

 

So, pocket your vehicle. Otherwise you're in for grief. I mean, you saw all the craziness that i had to deal with.

Share this post


Link to post
Share on other sites
Hi, I'm getting a lot of questions about my vehicles that have some of these same issues, and I build mine in an entirely different way than Manux and Dust, so I think it's safe to say that either:

 

1 - Vanilla be bugged

2 - Mod support for custom vehicles has bugs

 

...not a lot to be done from us on either front, I'm afraid.

 

I'd be interested in the FULL log you see those errors in though, so I can stand a better chance of finding out, thanks!

 

 

 

 

Getting to your master modlet list, i did some searching. You've got a vehicles mod and a lone shoppingcart mod. In the single mod shopingcart's "block" area, there's no guppyautoworkbench. In the vehicles mod, you included it. So, you might wanna just remove the single cart mod because i think it might confuse people. That's why i could never make the cart work was because the workbench wasn't included in that single mod.

 

I also got all this off your github account listing. Let me ask you, is it your most up-to-date stuff? I'm asking because your LightSystem mod was throwing out a lot of red error-code on my server.

Edited by Kilroy5150 (see edit history)

Share this post


Link to post
Share on other sites

The gitlab is updated, the github is not. If the light mod is throwing errors, I'd be happy to look at a log.

 

Yeh the lack of accessory files on the cart single modlet (and non sdx version) is intentional, as I dropped support for it a while back; like everything that's NOT the SDX overhaul mod, they're only still there because I was asked to leave them for other modders or server admins or end users to use and implement how they want, since I only consider the overhaul mod "complete" so to speak (even though I'm not finished yet), and have focused all updates and whatnot on it. Ragsy took the time to update the modlet version to include the accessory files, but from my PoV, they're just "there" for people to implement how /they/ want. The damn vanilla spawner sucks too much for my taste. =)

 

The auto workbench in particular is aggressively high in vertices, so I'd be surprised if anyone used it except me. =)

Share this post


Link to post
Share on other sites

i wonder if this uninteractable Bug may have something todo with DX11 and Unity?

This starts happen after 7 Days update as far as i know.

 

My friend have random Crashes since then (i read a lot of other people too, and only solution is change from DX11 to OpenGL)

Also he have that problem with the Heli, me not.

Share this post


Link to post
Share on other sites
i wonder if this uninteractable Bug may have something todo with DX11 and Unity?

This starts happen after 7 Days update as far as i know.

 

My friend have random Crashes since then (i read a lot of other people too, and only solution is change from DX11 to OpenGL)

Also he have that problem with the Heli, me not.

 

 

Well, i did provide logs directly from my server that showed the issues/errors/warnings had something to do with "mesh" and i figured he could read the logs and provide a fix from there.

 

It's just a matter of him reading them and making the adjustments at this point.

 

- - - Updated - - -

 

The gitlab is updated, the github is not. If the light mod is throwing errors, I'd be happy to look at a log.

 

Yeh the lack of accessory files on the cart single modlet (and non sdx version) is intentional, as I dropped support for it a while back; like everything that's NOT the SDX overhaul mod, they're only still there because I was asked to leave them for other modders or server admins or end users to use and implement how they want, since I only consider the overhaul mod "complete" so to speak (even though I'm not finished yet), and have focused all updates and whatnot on it. Ragsy took the time to update the modlet version to include the accessory files, but from my PoV, they're just "there" for people to implement how /they/ want. The damn vanilla spawner sucks too much for my taste. =)

 

The auto workbench in particular is aggressively high in vertices, so I'd be surprised if anyone used it except me. =)

 

 

 

I'm glad you said that because i put that older, non-SDX vehicle mod in and....WOW. My building EXPLODED with vehicles...I left a pic below if anyone can see it.

 

1612653901_Screenshot(47).jpg.fea9e458990493b051f15a92481a7c64.jpg

 

So, question: Are ALL of your mods SDX now? I'm asking because the old modpack had a mixed bag so to speak.

Edited by Kilroy5150 (see edit history)

Share this post


Link to post
Share on other sites

So far just this one; I only resort to Sdx when vanilla can't deliver exactly what I want.

 

In this case, I wanted vehicles out in the world. Gas was totally reworked and a lot harder to maintain, AND you can't make it.

 

Although I respect how others want to play, I feel vehicles are not balanced without the sdx version.

Share this post


Link to post
Share on other sites
So far just this one; I only resort to Sdx when vanilla can't deliver exactly what I want.

 

In this case, I wanted vehicles out in the world. Gas was totally reworked and a lot harder to maintain, AND you can't make it.

 

Although I respect how others want to play, I feel vehicles are not balanced without the sdx version.

 

 

 

I think there are some car respawn mods out there i'm sure a gas barrel respawn mod could be made too...

Share this post


Link to post
Share on other sites

Yeh I want to avoid camping waiting for the respawn. One shot or no shot, my momma used to say...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...