Jump to content
stedman420

A17 Simple UI Modlets

Recommended Posts

Any way to get it to show actual %. With it reporting 130% while its actually at 65% (130/200) is confusing :p

 

I'm actually just gonna remove the % sign in the next update. Might be later today or tomorrow.

Share this post


Link to post
Share on other sites

Left HUD modlets were updated.

 

I removed the outdated percent sign from food and water. Just use the same download link in the OP for the new version.

Share this post


Link to post
Share on other sites

I love your modlets. They're a godsend. I still don't get why TFP removed that vital information from the UI so many alpha's ago.

 

With the overeating and overdrinking mechanic, would it be possible for your modlets to show the overeating and overdrinking amount? (with or without brackets behind the base value)

 

For example: let's say i've got 1 point in agility so my food max is 110 and I'm overeating to my cap at 160.

Could this be shown as "110(50)" or just as "160"?

(I prefer the first once if that's possible so I don't have to check what my agility/food cap is on each character when playing different worlds)

Share this post


Link to post
Share on other sites
I love your modlets. They're a godsend. I still don't get why TFP removed that vital information from the UI so many alpha's ago.

 

With the overeating and overdrinking mechanic, would it be possible for your modlets to show the overeating and overdrinking amount? (with or without brackets behind the base value)

 

For example: let's say i've got 1 point in agility so my food max is 110 and I'm overeating to my cap at 160.

Could this be shown as "110(50)" or just as "160"?

(I prefer the first once if that's possible so I don't have to check what my agility/food cap is on each character when playing different worlds)

 

A fix for not displaying overfill amounts is already done just needs a little testing then should be out later today or tomorrow. It will be like the second one just one number.

 

@All also I will be releasing 4 new versions of the left hud as well that don't have the food bar since stamina is food.

Share this post


Link to post
Share on other sites
A fix for not displaying overfill amounts is already done just needs a little testing then should be out later today or tomorrow. It will be like the second one just one number.

 

@All also I will be releasing 4 new versions of the left hud as well that don't have the food bar since stamina is food.

 

Are these ready to go for 17.1 stable?

Share this post


Link to post
Share on other sites

Left HUD Modlets have been updated.

 

Food and water now display overfill. Just use original download link in the OP for the new version.

 

4 New left HUD modlets have been added

  • Simple UI Left HUD No Food
  • Simple UI Left HUD No Food Buff Timers
  • Simple UI Left HUD No Food No Temp
  • Simple UI Left HUD No Food No Temp Buff Timers

 

 

Big thanks to Red Eagle LXIX for an example of how to get the CharacterFrameWindow controller working for the hud

Edited by stedman420 (see edit history)

Share this post


Link to post
Share on other sites

Left HUD Modlets have been updated.

 

Fixed food and water not updating.

Added a toggle to the right of the water bar to toggle the food and water display

 

The following modlets were removed due to longer being needed

  • Simple UI Left HUD No Food
  • Simple UI Left HUD No Food Buff Timers
  • Simple UI Left HUD No Food No Temp
  • Simple UI Left HUD No Food No Temp Buff Timers

 

 

Big thanks to Red Eagle LXIX for an example of how to get a toggle working on the hud

Share this post


Link to post
Share on other sites

Unless I'm understanding this wrong since I updated the UI from your last update the numbers for food and water do not change from the 97 and 83 shown, even though the character stats show 110 and 105. I have eaten and drank, to watch the character stats numbers increase, but not those on the UI.

 

For some reason inserting an image is not working......

 

https://imgur.com/a/WhX8CLT

Edited by Dibbler
Can't insert image (see edit history)

Share this post


Link to post
Share on other sites
Unless I'm understanding this wrong since I updated the UI from your last update the numbers for food and water do not change from the 97 and 83 shown, even though the character stats show 110 and 105. I have eaten and drank, to watch the character stats numbers increase, but not those on the UI.

 

For some reason inserting an image is not working......

 

https://imgur.com/a/WhX8CLT

 

I think latest versions all have a toggle. Dont see one on your screenshot. You on 1.6?

 

Cheers

Share this post


Link to post
Share on other sites
I think latest versions all have a toggle. Dont see one on your screenshot. You on 1.6?

 

Cheers

 

...ah thanks for that, I was on ver 1.5 :)

Share this post


Link to post
Share on other sites

Thanks so very much for your work on this mod. I've been needing larger storage boxes and now I have them. You are a god among men :tickled_pink:

Share this post


Link to post
Share on other sites

Just a minor request... On your first page near the links to the mods could you add the newest mod version so it's easier to tell if I've got the latest update of the mod? Thanks for your awesome work and time!!!

Share this post


Link to post
Share on other sites
Just a minor request... On your first page near the links to the mods could you add the newest mod version so it's easier to tell if I've got the latest update of the mod? Thanks for your awesome work and time!!!

 

Version numbers were added next to the download links ;)

Share this post


Link to post
Share on other sites

First of all, thank you for your fantastic work. :smile-new:

In the MOD "S420_SimpleUI-Toolbelt" is it possible to insert the value "playerxptonextlevel" instead of "playerdeaths"?

I did some tests, but how do I insert the "EquipmentStackGrid" controller.

Share this post


Link to post
Share on other sites

Hi.

 

Is it posibly to make the detailed food/water in the Simple UI Left HUD Buff Timers as default so i don't have to switch it ??

Share this post


Link to post
Share on other sites
Hi.

 

Is it posibly to make the detailed food/water in the Simple UI Left HUD Buff Timers as default so i don't have to switch it ??

Unfortunately that is not possible due to the way the CharacterFrameWindow controller works currently. It would require either a DLL mod or SDX patch script.

It only updates once on first load, or every .25 seconds after clicking the button to turn on stats. There is no way to tell it to start in Stats mode and as the below code demonstrates if it is in Character tab mode, it doesn't update (must be stats mode):

        if ((this.currentTab != Tabs.Character) && (Time.time > this.updateTime))
       {
           this.updateTime = Time.time + 0.25f;
           base.RefreshBindings(this.isDirty);
       }

I posted about this in dev discussions and even asked on the side if maybe someone would remove this portion '(this.currentTab != Tabs.Character) && ' which would then allow it to always update. As such the compromise is to start less detailed, and require a button press.

 

Thanks for asking though, I should put this information in my thread as well.

Edited by Red Eagle LXIX (see edit history)

Share this post


Link to post
Share on other sites
Unfortunately that is not possible due to the way the CharacterFrameWindow controller works currently. It would require either a DLL mod or SDX patch script.

It only updates once on first load, or every .25 seconds after clicking the button to turn on stats. There is no way to tell it to start in Stats mode and as the below code demonstrates if it is in Character tab mode, it doesn't update (must be stats mode):

        if ((this.currentTab != Tabs.Character) && (Time.time > this.updateTime))
       {
           this.updateTime = Time.time + 0.25f;
           base.RefreshBindings(this.isDirty);
       }

I posted about this in dev discussions and even asked on the side if maybe someone would remove this portion '(this.currentTab != Tabs.Character) && ' which would then allow it to always update. As such the compromise is to start less detailed, and require a button press.

 

Thanks for asking though, I should put this information in my thread as well.

 

 

That saddens me, but thank for the explanation. DLL modding is a bit out of my scope at the moment

Share this post


Link to post
Share on other sites

Hi, I have a problem since the last update of the game. If I install any mod, be it the HUD or anything else, the screen stays in loading UI and I do not load the game, I have tried everything and there is no way to fix it. Does anyone know how to solve this problem?

Share this post


Link to post
Share on other sites
Hi, I have a problem since the last update of the game. If I install any mod, be it the HUD or anything else, the screen stays in loading UI and I do not load the game, I have tried everything and there is no way to fix it. Does anyone know how to solve this problem?

 

I found that the left hud no buff works fine but something about the buff bugs it out as you stated. I had this issue yesterday when trying to update left side hud no buff to the one with the buff.

Share this post


Link to post
Share on other sites
I found that the left hud no buff works fine but something about the buff bugs it out as you stated. I had this issue yesterday when trying to update left side hud no buff to the one with the buff.

 

thanks for the answer, but still giving me the same problem

Share this post


Link to post
Share on other sites
Hi, I have a problem since the last update of the game. If I install any mod, be it the HUD or anything else, the screen stays in loading UI and I do not load the game, I have tried everything and there is no way to fix it. Does anyone know how to solve this problem?

 

What's your install path or where did you install them to? Any chance you could provide your output log?

 

 

I found that the left hud no buff works fine but something about the buff bugs it out as you stated. I had this issue yesterday when trying to update left side hud no buff to the one with the buff.

 

All is still working fine here any chance you had more than one left hud installed?

Share this post


Link to post
Share on other sites
What's your install path or where did you install them to? Any chance you could provide your output log?

 

 

 

 

All is still working fine here any chance you had more than one left hud installed?

 

I double checked and nope. Maybe there was another conflict I was not aware but the game DID load after I switched out the hud mods. But I could have missed something, which LOL with me being software illiterate for the most is highly likely. ;P

Share this post


Link to post
Share on other sites
I double checked and nope. Maybe there was another conflict I was not aware but the game DID load after I switched out the hud mods. But I could have missed something, which LOL with me being software illiterate for the most is highly likely. ;P

 

Sweet glad to here all is working for you now :thumb:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...