Jump to content
Red Eagle LXIX

Red Eagle LXIX's A17 Modlet Collection (UI, Blocks, Quests)

Recommended Posts

Nice, I'm enjoying some of these. These additional options couldn't be done in A16, could they?

The UIMenu options? For A16 the only way to do them would be as full DLL releases, or SDX Patch Scripts. A17 is when these menus were converted to use XUi.

Share this post


Link to post
Share on other sites

Note: I have removed the ShortBasicQuestChain from the large collection zip. It must be separately downloaded. I have also added additional warnings that this modlet is intended for new games only while I investigate a potential issue to determine if it was caused by this modlet or a bug.

Share this post


Link to post
Share on other sites
You think it could have been the shorten quest chain mod?

 

Yes, the issue with player data has been traced to installing the ShortBasicQuestChain on an existing save. I have removed it from the main collection based on your report and the report from Bias (on discord) and my own testing.

I will investigate if I can create a version that is compatible with existing saves. For now I have tagged that modlet as for New Saves Only. It is also no longer included in the collection zip and must be a separate download.

Edited by Red Eagle LXIX (see edit history)

Share this post


Link to post
Share on other sites

Quest chains get saved to the player save file, changing quests has long been known to not play well with older saves; same with progression, fyi.

Share this post


Link to post
Share on other sites

Thanks for these modlets Red. The ones I've installed so far work great and are wonderful QOL additions to my game.

Edited by Aesir (see edit history)

Share this post


Link to post
Share on other sites

2018-12-11 - All modlets updated to v1.0.3 - Added a purposeful WRN event to log when files load -- This is a non-critical, logging only update. By creating a bogus remove attempt I can confirm each file has been read successfully.

 

This was done as an effort to aid in debugging if issues or conflicts occur to see order of events.

 

As an example here are some log entries from a working install of the UI Menu Mods. The below are intentional warnings I created through a false remove event:

2018-12-11T17:55:59 7.372 WRN XML patch for "XUi_Menu/windows.xml" from mod "RELXIX_UIMENU_DropOnDeathNothing" did not apply: <remove xpath="/Successfully_Loaded[@modname='RELXIX_UIMENU_DropOnDeathNothing'][@version='1.0.3'][@filename='\Config\XUi_Menu\windows.xml']" 
2018-12-11T17:55:59 7.375 WRN XML patch for "XUi_Menu/windows.xml" from mod "RELXIX_UIMENU_More24HourLengthOptions" did not apply: <remove xpath="/Successfully_Loaded[@modname='RELXIX_UIMENU_More24HourLengthOptions'][@version='1.0.3'][@filename='\Config\XUi_Menu\windows.xml']" 
2018-12-11T17:55:59 7.376 WRN XML patch for "XUi_Menu/windows.xml" from mod "RELXIX_UIMENU_MoreBlockDurabilityOptions" did not apply: <remove xpath="/Successfully_Loaded[@modname='RELXIX_UIMENU_MoreBlockDurabilityOptions'][@version='1.0.3'][@filename='\Config\XUi_Menu\windows.xml']" 
2018-12-11T17:55:59 7.377 WRN XML patch for "XUi_Menu/windows.xml" from mod "RELXIX_UIMENU_MoreDayLightLengthOptions" did not apply: <remove xpath="/Successfully_Loaded[@modname='RELXIX_UIMENU_MoreDayLightLengthOptions'][@version='1.0.3'][@filename='\Config\XUi_Menu\windows.xml']" 
2018-12-11T17:55:59 7.378 WRN XML patch for "XUi_Menu/windows.xml" from mod "RELXIX_UIMENU_MoreLootAbundanceOptions" did not apply: <remove xpath="/Successfully_Loaded[@modname='RELXIX_UIMENU_MoreLootAbundanceOptions'][@version='1.0.3'][@filename='\Config\XUi_Menu\windows.xml']" 

Edited by Red Eagle LXIX (see edit history)

Share this post


Link to post
Share on other sites
nevermind i just downloaded the wrong mod everything its working great.

Not the first time to happen with so many choices. I'm going to get a better set of screenshots to give a clearer indication which modlet makes which changes.

Share this post


Link to post
Share on other sites

  • New
    • RELXIX_UIMENU_MoreLandClaimSizeOptions
      • This adds the options '91, 101, 125, 151, 175, 201' as Land Claim Size options in addition to the default '21, 31, 41, 51, 71' options. These options are also added as available filter choices in the server browser.

       

      [*]RELXIX_Quests_TraderAdvertisements

      • This adds a new item as loot in the places one would find paper (mailboxes, junk), 'Trader_Advertisement'. The 'Trader_Advertisement' item adds a quest to locate the nearest trader. There is no reward for this quest. The purpose is to simulate Traders trying to get the word out about their survival and business.

 

 

2018-12-15 - Added RELXIX_Quests_TraderAdvertisements

2018-12-12 - Added RELXIX_UIMENU_MoreLandClaimSizeOptions

2018-12-11 - All modlets updated to v1.0.3 - Added a purposeful WRN event to log when files load -- This is a non-critical, logging only update. By creating a bogus remove attempt I can confirm each file has been read successfully.

Edited by Red Eagle LXIX (see edit history)

Share this post


Link to post
Share on other sites

Last Tested: A17-Experimental(b231) compatibility confirmed, no updates required, 1 recommended.

RELXIX_Quests_ShortBasicQuestChain v1.0.4 - 2018-12-18 - Changed values to match updated chain (4 Skillpoints, 700xp for Basic survival)

Edited by Red Eagle LXIX (see edit history)

Share this post


Link to post
Share on other sites

Hi. First I'd like to say I love your mods. Sadly this latest update from TFP has caused a game breaking null reference with your Loot Abundance mod. Not sure what the plan is, but I hope you can fix it. I'll keep seeing to make sure it is that mod but so far after a while of playing with out it the null reference has stopped.

 

Edit: After a bit more playing I finally got the same game breaking null reference error. And since I have to alt + f4 to close 7d2d I have no log that I can see to see what the error is. Not sure how to get the log exported in console before I force close 7d2d.

Edited by Zyamaia (see edit history)

Share this post


Link to post
Share on other sites
Hi. First I'd like to say I love your mods. Sadly this latest update from TFP has caused a game breaking null reference with your Loot Abundance mod. Not sure what the plan is, but I hope you can fix it. I'll keep seeing to make sure it is that mod but so far after a while of playing with out it the null reference has stopped.

 

Edit: After a bit more playing I finally got the same game breaking null reference error. And since I have to alt + f4 to close 7d2d I have no log that I can see to see what the error is. Not sure how to get the log exported in console before I force close 7d2d.

 

I am unable to replicate any issue.

Can you provide more details?

 

Logs are produced any time the game is started in your game folder.

Quickest way to get to the logs:

Steam Client > Games Library > Right-Click 7 Days To Die > Click Properties > Click Local Files Tab > Click Browse Local Files Button > Navigate to subfolder '7DaysToDie_Data' > output_log__<DATE>__<TIME>.txt

 

As can be seen here, the expected WRN messages showing the files for multiple mods were successfully loaded (as per the 1.0.3 release notes for my mods).

In the background one can see I've even selected a loot abundance of 500%.

https://steamuserimages-a.akamaihd.net/ugc/946217933038109560/DF6C37EBA2204EDC7125BD182FD4EB4C4C2E1E6F/

 

I see you also got the error after removing the mod.

Hopefully the instructions on obtaining the logs will help narrow the cause since it also occurred without the mod. It might be related to a random null ref I've seen mentioned in the bug report threads.

Edited by Red Eagle LXIX (see edit history)

Share this post


Link to post
Share on other sites
I am unable to replicate any issue.

Can you provide more details?

 

Logs are produced any time the game is started in your game folder.

Quickest way to get to the logs:

Steam Client > Games Library > Right-Click 7 Days To Die > Click Properties > Click Local Files Tab > Click Browse Local Files Button > Navigate to subfolder '7DaysToDie_Data' > output_log__<DATE>__<TIME>.txt

 

As can be seen here, the expected WRN messages showing the files for multiple mods were successfully loaded (as per the 1.0.3 release notes for my mods).

In the background one can see I've even selected a loot abundance of 500%.

https://steamuserimages-a.akamaihd.net/ugc/946217933038109560/DF6C37EBA2204EDC7125BD182FD4EB4C4C2E1E6F/

 

I see you also got the error after removing the mod.

Hopefully the instructions on obtaining the logs will help narrow the cause since it also occurred without the mod. It might be related to a random null ref I've seen mentioned in the bug report threads.

 

I "think" I figured out the issue, some how my save got corrupted I played for a good while after starting a new world and no null reference errors.

As for the log I could never find any for yesterday. I wonder if it is because instead of closing the game properly I had to Alt + f4. No clue.

Share this post


Link to post
Share on other sites

  • New
    • RELXIX_RWG_MoreTraders
      • Ups the number of traders in the world by re-adding the traderGroup to the wilderness mix.

This change increases the default min/max of 5 possible traders on a RWG to 5-10 possible (based on current traderGroup percentages).

 

---

 

This can be tested this by generating a World without the mod installed, count number of traders (b240 only 5) found in prefabs.xml. Exit game, delete World, install mod, start game, use same seed and generate world. You should get between 5 and 10 traders.

 

As an example:

Stock b240:

  • Seed: Back from the dead
  • Size 8192
  • Generated Name: South Moduso County
  • Trader Count: 5

 

Mod b240:

  • Seed: Back from the dead
  • Size 8192
  • Generated Name: South Moduso County
  • Trader Count: 10

Edited by Red Eagle LXIX (see edit history)

Share this post


Link to post
Share on other sites

Sorry if this has come up already. Is there any chance for a modlet that increases the number of allowable _active_ Land Claim Blocks?

 

I don't mind editing the xmls myself, but I can't find anything that looks like ~activeAllowed=X~ anywhere.

 

I found/know about this in blocks.xml; <block name="keystoneBlock"> <!-- landclaim -->

 

Would be really helpful to me in SP to not be limited to one active LCB

---

There's a request by another here;

https://7daystodie.com/forums/showthread.php?101158-LCB-modlet

Share this post


Link to post
Share on other sites
Sorry if this has come up already. Is there any chance for a modlet that increases the number of allowable _active_ Land Claim Blocks?

 

I don't mind editing the xmls myself, but I can't find anything that looks like ~activeAllowed=X~ anywhere.

 

I found/know about this in blocks.xml; <block name="keystoneBlock"> <!-- landclaim -->

 

Would be really helpful to me in SP to not be limited to one active LCB

---

There's a request by another here;

https://7daystodie.com/forums/showthread.php?101158-LCB-modlet

That cannot be done via XML only. It would require and SDX Patch Script or full DLL replacement.

Share this post


Link to post
Share on other sites

<remove xpath="/Expected_WRN_means_Successfully_Loaded[@modname=RELXIX_UIMENU_MoreRWGSizeOptions][@version=1.0][@filename=\Config\XUi_Menu\windows.xml]" />

 

May I ask what is the use of this? Your mod has this item, and it displays yellow characters in F1 console. Is this wrong?

Share this post


Link to post
Share on other sites

WRN XML patch for "blocks.xml" from mod "RELXIX_Blocks_PickThisUp" did not apply: <remove xpath="/blocks/block[@name=miniblindTopSheet]/property[@name=CanPickup]"

WRN XML patch for "items.xml" from mod "RELXIX_Quests_TraderAdvertisements" did not apply: <remove xpath="/Successfully_Loaded[@modname=RELXIX_Quests_TraderAdvertisements][@version=1.0.3][@filename=\Config\items.xml]"

2018-12-23T22:39:54 16.772 INF Item IDs with mapping

WRN XML patch for "rwgmixer.xml" from mod "RELXIX_RWG_MoreTraders" did not apply: <remove xpath="/Successfully_Loaded[@modname=RELXIX_RWG_MoreTraders][@version=1.0][@filename=\Config\rwgmixer.xml]"

WRN XML patch for "XUi/windows.xml" from mod "RELXIX_UI_PlayerStats" did not apply: <remove xpath="/Successfully_Loaded[@modname=RELXIX_UI_PlayerStats][@version=1.0.3][@filename=\Config\XUi\windows.xml]"

WRN XML patch for "XUi/xui.xml" from mod "RELXIX_UI_PlayerStats" did not apply: <remove xpath="/Successfully_Loaded[@modname=RELXIX_UI_PlayerStats][@version=1.0.3][@filename=\Config\XUi\xui.xml]"

WRN XML patch for "XUi/xui.xml" from mod "RELXIX - UI - ZDP - Zombie Kills, Deaths, and Player Kills" did not apply: <remove xpath="/xui/ruleset[@name=default]/window_group[@name=toolbelt]/window[@name=window_RELXIXUI_ZKIcoChng]"

 

Got this bunch of errors, with actual files on my dedi linux server.

Most of your Mods work fine for me. But these ones won't work correct!

Any help would be fine :) Thank you a lot

Share this post


Link to post
Share on other sites
<remove xpath="/Expected_WRN_means_Successfully_Loaded[@modname=RELXIX_UIMENU_MoreRWGSizeOptions][@version=1.0][@filename=\Config\XUi_Menu\windows.xml]" />

 

May I ask what is the use of this? Your mod has this item, and it displays yellow characters in F1 console. Is this wrong?

 

WRN XML patch for "blocks.xml" from mod "RELXIX_Blocks_PickThisUp" did not apply: <remove xpath="/blocks/block[@name=miniblindTopSheet]/property[@name=CanPickup]"

WRN XML patch for "items.xml" from mod "RELXIX_Quests_TraderAdvertisements" did not apply: <remove xpath="/Successfully_Loaded[@modname=RELXIX_Quests_TraderAdvertisements][@version=1.0.3][@filename=\Config\items.xml]"

2018-12-23T22:39:54 16.772 INF Item IDs with mapping

WRN XML patch for "rwgmixer.xml" from mod "RELXIX_RWG_MoreTraders" did not apply: <remove xpath="/Successfully_Loaded[@modname=RELXIX_RWG_MoreTraders][@version=1.0][@filename=\Config\rwgmixer.xml]"

WRN XML patch for "XUi/windows.xml" from mod "RELXIX_UI_PlayerStats" did not apply: <remove xpath="/Successfully_Loaded[@modname=RELXIX_UI_PlayerStats][@version=1.0.3][@filename=\Config\XUi\windows.xml]"

WRN XML patch for "XUi/xui.xml" from mod "RELXIX_UI_PlayerStats" did not apply: <remove xpath="/Successfully_Loaded[@modname=RELXIX_UI_PlayerStats][@version=1.0.3][@filename=\Config\XUi\xui.xml]"

WRN XML patch for "XUi/xui.xml" from mod "RELXIX - UI - ZDP - Zombie Kills, Deaths, and Player Kills" did not apply: <remove xpath="/xui/ruleset[@name=default]/window_group[@name=toolbelt]/window[@name=window_RELXIXUI_ZKIcoChng]"

 

Got this bunch of errors, with actual files on my dedi linux server.

Most of your Mods work fine for me. But these ones won't work correct!

Any help would be fine :) Thank you a lot

 

Those with text 'Successfully_Loaded' are purpose WRN events that allow me to see in the logs that 7 Days To Die successfully read and attempted processing of that file.

They are expected.

There are even comments in the files mentioning those are expected and done on purpose.

 

In addition, as noted in RELXIX_Blocks_PickThisUp there are 3 additional WRN events as I attempt to remove the CanPickup property in case another mod has added it and set it. Since by default that property does not exist it correctly give a WRN. It was actually these precautionary removes that gave the idea on how to log and be able to view when mod files were loaded and processed.

 

I'm going to add a bit more to the first post to make such clear. Thanks.

 

EDIT:

I have added the following to the first post:

  • These modlets all contain additional debugging in the form of a purposefully generated WRN event that will show Yellow in the console similar to the below entry. This allows me to know the file was successfully read and process by 7D2D, what mod the file was from, and which particular file in that mod:
    • WRN XML patch for "XUi_Menu/windows.xml" from mod "RELXIX_UIMENU_DropOnDeathNothing" did not apply: <remove xpath="/Successfully_Loaded[@modname=RELXIX_UIMENU_DropOnDeathNothing][@version=1.0.3][@filename=\Config\XUi_Menu\windows.xml]"

Edited by Red Eagle LXIX (see edit history)

Share this post


Link to post
Share on other sites
That cannot be done via XML only. It would require and SDX Patch Script or full DLL replacement.

 

Damn. :( Ok, thanks for the info Red Eagle :)

Share this post


Link to post
Share on other sites

https://7daystodie.com/forums/showthread.php?74084-Developer-Discussions-Alpha-17&p=914022&viewfull=1#post914022

Can you point me in the right direction on where to find this? And can this be installed into a server without having to use the mod launcher? If so, would I have to wipe the server to get it to work?

Yes, my modlets can be installed without restarting the server (except for the Short Basic Quests Chain modlet, and More RWG Traders).

Yes they can be installed to a server without mod launcher.

As to where: check my Latest Thread Starts. :)

 

--

https://7daystodie.com/forums/showthread.php?74084-Developer-Discussions-Alpha-17&p=914043&viewfull=1#post914043

Speaking of which..can the new trader quest advert thing be added after rolling a world? I think I asked on steam, but forget. Thats an issue right now.. if there are only 5 traders in a 8k world, its hard to find any other than the starting quest one.

Yes, this can be added at any time, but once added it is not recommended to remove it without a restart.

 

Maybe in the future higher tier quests can include a quest with the trader getting goods from another trader? That would allow the player to discover them naturally, and imply the traders actually working together.

I thought about making Trader Coupons as well. Same as Trader Advertisements but having Random Buffs to the trader related skills. If you also meant one trader directing to a different trader. I am not sure if that would be possible.

 

RED EAGLE: Would it be possible in the modlets to just display a 100% guesstimate line over about where 100% is, and anything to the right would be the overage? That way we could visually "see" where 100% should be, an be able to see the implied overage. The actual percent number wouldn't be corrected, but the visual indicator would at least help.

The same system that generates the % number generates the fill bar. As such not without a code change to the DLL.

 

 

 

-

Figured this would be the better place to reply to this.

Edited by Red Eagle LXIX (see edit history)

Share this post


Link to post
Share on other sites

I am having some trouble getting the modlet:RELXIX_UI_MenuStats to work on my dedicated server. I have created the mod folder and then uploaded the folders and XML documents to it and it's not working. I have disabled EAC (not sure if was needed) and couldn't find anything to show me how to do it on a bluefang server. I have attached a pic to show you where I put it and was wondering if you could possibly help?

 

Thanks in advance if you have time to help and sorry for being a noob at modlets lol.

 

Capture1.jpg.61e289f16689dd4e70bd3293badcd799.jpg

 

Capture2.jpg.f3db8d5cf630a22b4ed6e9d10ecb023e.jpg

Share this post


Link to post
Share on other sites
I am having some trouble getting the modlet:RELXIX_UI_MenuStats to work on my dedicated server. I have created the mod folder and then uploaded the folders and XML documents to it and it's not working. I have disabled EAC (not sure if was needed) and couldn't find anything to show me how to do it on a bluefang server. I have attached a pic to show you where I put it and was wondering if you could possibly help?

 

Thanks in advance if you have time to help and sorry for being a noob at modlets lol.

 

[ATTACH=CONFIG]26626[/ATTACH]

 

[ATTACH=CONFIG]26627[/ATTACH]

 

Big M on the Mods folder name.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...