Jump to content

Darkness Falls: They mostly come out at night...


KhaineGB

Recommended Posts

From what I've been told...

 

Put them in the Data/Worlds folder on the server, then open up serverconfig.xml

 

Then find this.

 

<property name="GameWorld"						value="Navezgane"/>			<!-- RWG (see WorldGenSeed and WorldGenSize options below) or any already existing world name in the Worlds folder (currently shipping with Navezgane) -->

 

As per the note, you just put the name of the folder in Worlds where Navezgane should be. So DFalls-Small, DFalls-Small2 or DFalls-Medium. :)

Link to comment
Share on other sites

A17.2 can't create any new map... gets stuck after bunch of errors pops up. I assume A17.2 messed everything up? Any way to revert to 17.1 Darkness falls?[ATTACH=CONFIG]27836[/ATTACH]

 

Steam library > 7 Days To Die > Properties(with right mouse button) > Betas > Choose Alpha17.1 Stable

 

Edit: Oh you asked about DF older version... maybe somebody else will answer on that..

Edited by PrivateHudson (see edit history)
Link to comment
Share on other sites

I'm guessing that batteries lack "juice", 'cause I don't see the durability bar (kinda messes up my night electric fence defences now).

 

Edit: Yes, the current carBattery in items.xml is lacking "effect group" at the end. When you return that, it brings back degradation and levels and it works fine in a battery bank... Don't know, though, if that messes with anything else :)

 

<item name="carBattery">

<property name="HoldType" value="45"/>

<property name="Meshfile" value="Items/Misc/sackPrefab"/>

<property name="DropMeshfile" value="Items/Misc/sack_droppedPrefab"/>

<property name="VehicleSlotType" value="battery"/>

<property name="Material" value="MresourceScrapLeadLarge"/>

<property name="RepairTools" value="resourceRepairKit"/>

<property name="Stacknumber" value="1"/>

<property name="Weight" value="160"/>

<property name="EconomicValue" value="500"/>

<property name="Group" value="Resources"/>

<property name="DegradationBreaksAfter" value="false"/>

<property class="Attributes">

<property name="DegradationMax" value="1000,6000"/> <!-- needed for electrical calculations -->

<property name="BatteryMaxLoadInVolts" value="24, 36"/>

<property name="BatteryDischargeTimeInMinutes" value="30,90"/>

</property>

<effect_group>

<passive_effect name="ModSlots" operation="base_set" value="0"/>

<passive_effect name="DegradationMax" operation="base_set" value="5000,10000" tier="1,6"/>

</effect_group>

</item>

Edited by eXSe (see edit history)
Link to comment
Share on other sites

A17.2 can't create any new map... gets stuck after bunch of errors pops up. I assume A17.2 messed everything up? Any way to revert to 17.1 Darkness falls?[ATTACH=CONFIG]27836[/ATTACH]

 

That error looks like the rock01 error.

 

Which means you're running a 17.2 mod on 17.1 or your 17.1 didn't update properly.

 

2.03C is on nexus. That's the only way to use an earlier version.

 

I'm guessing that batteries lack "juice", 'cause I don't see the durability bar (kinda messes up my night electric fence defences now).

 

Edit: Yes, the current carBattery in items.xml is lacking "effect group" at the end. When you return that, it brings back degradation and levels and it works fine in a battery bank... Don't know, though, if that messes with anything else :)

 

<item name="carBattery">

<property name="HoldType" value="45"/>

<property name="Meshfile" value="Items/Misc/sackPrefab"/>

<property name="DropMeshfile" value="Items/Misc/sack_droppedPrefab"/>

<property name="VehicleSlotType" value="battery"/>

<property name="Material" value="MresourceScrapLeadLarge"/>

<property name="RepairTools" value="resourceRepairKit"/>

<property name="Stacknumber" value="1"/>

<property name="Weight" value="160"/>

<property name="EconomicValue" value="500"/>

<property name="Group" value="Resources"/>

<property name="DegradationBreaksAfter" value="false"/>

<property class="Attributes">

<property name="DegradationMax" value="1000,6000"/> <!-- needed for electrical calculations -->

<property name="BatteryMaxLoadInVolts" value="24, 36"/>

<property name="BatteryDischargeTimeInMinutes" value="30,90"/>

</property>

<effect_group>

<passive_effect name="ModSlots" operation="base_set" value="0"/>

<passive_effect name="DegradationMax" operation="base_set" value="5000,10000" tier="1,6"/>

</effect_group>

</item>

 

Problem is that may also mean vehicles will return to their durability being affected by the battery, which I didn't want... so needs some testing. :)

 

When I use the server link from the first post I get the experimental files, that's correct?

 

I have never used SDX so far...not sure what it does or if I need it ?

 

Fixed it.

 

SDX is included in the mod builds, and yes, you need it.

Link to comment
Share on other sites

Have a question, and great mod by the way. In the last version ( 2.03c? ) Parkour was blended with the Agility base stat. Noticed in this now with 17.2 installed, and 2.04 Darkness Falls, it seems to be either gone, or the text is missing.

 

Any heads up if it was just taken out? That's fine, just curious. Asking for me, and someone else.

Link to comment
Share on other sites

Just a localization issue.

 

It's still there. Initial upload of the mod had a localization derp that I fixed about... 15-ish minutes later.

 

EDIT: Ok, did a small hotfix.

 

- added durability back to the battery since the bank is apparently a pain.

- made bacon and eggs always unlocked.

- re-pushed the localization file, just in case.

Edited by KhaineGB (see edit history)
  • Like 1
Link to comment
Share on other sites

Ok guys, i decided to update darkness falls to 2.0.4 and works fine, but then when i try to go to my old 17.1 save, I can't start it because the start button is greyed out and when i look at the console it says "savegame contains unknown option 'BlockDurabilityModifier'. Probably an outdated savegame- ignoring this option!" so if any of you guys can help me that would be pretty nice, thank you.

 

Might need to make sure the save is in the correct folder. Not sure where that would be for the mod launcher.

 

I have the exact same issue.

I made a new Game with the same Map to see if there's a new Path for the new Save file, but it's still the same.

The A17.1 and A17.2 Save are in the same Directory > "D:\7D2D\Saves\Darkness Falls\Darkness Falls\North Jeyebe Mountains".

 

Guess the changes in the Serverconfig file are the problem? Funny thing, because my A17.1 Test World loaded without any problems in A17.2. In compare to my normal save which is greyed out, it's just an other Map Seed and a bigger Base.

 

:noidea:

Link to comment
Share on other sites

Huh. That's kind of annoying. I shall have to go poke at that and see if I can fix it up. Thanks for letting me know, :)

 

 

 

Only thing I can suggest is delete and redownload the game, then delete and download the non-experimental version of the mod. Launcher wasn't fully downloading files last night and that's what some folks in the discord had to do to make it work.

 

 

 

Thank you :) Glad you're enjoying it.

 

Just stay away from wasteland, even small 2-block patches of it. God I hope RWG gets fixed soon.

 

 

 

Yep. Made in the camp fire or working oven. :)

 

I actually like the Wasteland, it reminds me of the old hub days. You did NOT want to go there because it was seriously dangerous. So started my players in Forest and desert and now we are slowly moving into the wastelands. I do think the RWG makes too much of it but RWG has been fu**ed up since forever.

Link to comment
Share on other sites

Just a note of interest. The RWG with the mod is changing the trader locations vs. vanilla. Maybe it was like that previously and intended, but I didn't think so. Using b27 vanilla, the seed "gimme good map" has a trader along the main road to the east (there are probably others). But generating it while running the modpack, there are no traders on the map at all. When I finish the hammer quest, the null reference errors start popping up, because it can't find a trader.

Link to comment
Share on other sites

Just a localization issue.

 

It's still there. Initial upload of the mod had a localization derp that I fixed about... 15-ish minutes later.

 

EDIT: Ok, did a small hotfix.

 

- added durability back to the battery since the bank is apparently a pain.

- made bacon and eggs always unlocked.

- re-pushed the localization file, just in case.

 

Thanks for the speedy response and hotfix.

Link to comment
Share on other sites

Just started playing this mod and I am enjoying it but ran into an issue with the forge. Looked up forged iron and it calls for clay but digging gives me clay soil which doesnt work for that recipe. I cant find a conversion recipe to go from clay soil to clay. Is this a separate resource that I can get in another way?

Link to comment
Share on other sites

It's random. Keep looking. I found one. This is not the place to whine about not finding loot

 

Actually its part of the mod so I'd say this is the right place. I think that looting those things like sewing kit and welding torch is affected buy your level.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...