Jump to content

Darkness Falls: They mostly come out at night...


Recommended Posts

Hi all,

 

Is the Behemoth and Night Stalker supposed to be working?

 

I´ve recently updated to v2.03 through Mod Launcher and I´m getting the following:

 

2019-02-14T03:08:43 86.449 ERR Could not instantiate classEntityZombieNew, Mods' for entity_class 'DFzombieBehemoth'

2019-02-14T03:08:43 86.471 ERR Could not instantiate classEntityZombieNew, Mods' for entity_class 'DFzombieBehemothRadiated'

2019-02-14T03:08:43 86.487 ERR Could not instantiate classEntityMutant, Mods' for entity_class 'DFNightStalker'

 

If I try to manually spawn them using F6 menu I get this:

 

2019-02-14T03:11:08 231.718 ERR Unknown entity 707655414

NullReferenceException: Object reference not set to an instance of an object

at XUiC_SpawnMenu.BtnSpawns_OnPress (Int32 _key) [0x00000] in <filename unknown>:0

at XUiC_SpawnMenu.EntitiesList_SelectionChanged (.XUiC_ListEntry`1 _previousEntry, .XUiC_ListEntry`1 _newEntry) [0x00000] in <filename unknown>:0

at XUiC_List`1[T].OnSelectionChanged (.XUiC_ListEntry`1 _previousEntry, .XUiC_ListEntry`1 _newEntry) [0x00000] in <filename unknown>:0

at XUiC_List`1[T].set_SelectedEntry (.XUiC_ListEntry`1 value) [0x00000] in <filename unknown>:0

at XUiC_ListEntry`1[XUiC_SpawnEntitiesList+SpawnEntityEntry].set_Selected (Boolean value) [0x00000] in <filename unknown>:0

at XUiC_ListEntry`1[XUiC_SpawnEntitiesList+SpawnEntityEntry].XUiC_ListEntry_OnPress (.XUiController _sender, .OnPressEventArgs _e) [0x00000] in <filename unknown>:0

at XUiController.OnPressed (.OnPressEventArgs _e) [0x00000] in <filename unknown>:0

at XUiController.Pressed (Int32 mouseButton) [0x00000] in <filename unknown>:0

at XUiView.OnClick (UnityEngine.GameObject _go) [0x00000] in <filename unknown>:0

at UIEventListener.OnClick () [0x00000] in <filename unknown>:0

UnityEngine.GameObject:SendMessage(String, Object, SendMessageOptions)

UICamera:Notify(GameObject, String, Object)

UICamera:ProcessTouch(Boolean, Boolean, Boolean)

UICamera:ProcessMouse()

UICamera:ProcessTouches()

UICamera:Update()

 

(Filename: Line: -1)

 

Is there a way I can fix this?

Edited by harussame (see edit history)
Link to post
Share on other sites

Installed this Fresh to my server & all were getting is Server Desyncing were the use button doesnt work, Tried deleting the entire server & still get the same even after the update..... I have NO idea if this is ALpha 17 or the mod as I uninstalled the game once I tried their update & thought ermm NO lmao.....

Link to post
Share on other sites
I tried google, youtube, steam forum search...and failed miserably! I would've posted this question on steam, but figured I'd post it here since it's directly related to this post.

 

I've made it game with "Darkness Falls" as the "Game Name", I've made a game with "Darkness Falls" as the "World Generation Seed" name, and I've made a game with "Darkness Falls" as both...yet, I still don't seem to have the same map. Can someone please explain what I'm doing wrong? My game is A17.1, which I'm guessing is the same as this post.

 

Thanks for any help!

Most often, the size of the map is responsible for such a problem, mine was 8k.

As for the name, only the name of the seed determines the map, the name of the game has no effect on anything.

Link to post
Share on other sites

Love the Mod, been playing quite a bit.

 

Just have a couple of questions which I couldn't find in the Forum:

 

1. I think bandits are turned off, is that still the case?

2. Is FutureTech still an option with the underground base, or has that been disabled?

3. Is the gyrocopter not available?

4. Is the armored car not available?

 

Thanks,

Link to post
Share on other sites
Hi all,

 

Is the Behemoth and Night Stalker supposed to be working?

 

I´ve recently updated to v2.03 through Mod Launcher and I´m getting the following:

 

 

 

If I try to manually spawn them using F6 menu I get this:

 

 

 

Is there a way I can fix this?

 

Try redownloading the mod. Just rebuilt the DLL's AGAIN and pushed to github on the off chance it didn't build correctly... which I have had before.

 

Installed this Fresh to my server & all were getting is Server Desyncing were the use button doesnt work, Tried deleting the entire server & still get the same even after the update..... I have NO idea if this is ALpha 17 or the mod as I uninstalled the game once I tried their update & thought ermm NO lmao.....

 

Huh. Never seen that one outside of A16, and that was only when I used to play via steam with the wife.

 

Love the Mod, been playing quite a bit.

 

Just have a couple of questions which I couldn't find in the Forum:

 

1. I think bandits are turned off, is that still the case?

2. Is FutureTech still an option with the underground base, or has that been disabled?

3. Is the gyrocopter not available?

4. Is the armored car not available?

 

Thanks,

 

1) Bandits are still off right now.

2) Not yet. The bases/bunkers did not convert well to A17 so I need to rebuild them.

3) No. It was removed.

4) The A16 car is not available as I'm pretty sure I need to re-do the rigging. Motorbike and 4x4 are mechanic mastery though.

Link to post
Share on other sites
Yup :)

 

What would be a ideal farm layout with them you think?

 

- - - Updated - - -

 

How exactly does the looting work? Is it still linked to a skill? The only one I thought would fit was scavenging but that doesn't level by looting. I looted a whole city and am still at 0. My brother is leveling it fast by using the wrench.

 

That sounds like a bug, it should be going up from opening unopened containers (By any player if someone used it before you'll prob get 0 skill exp I bet) or using the wrench on things.

Link to post
Share on other sites
How exactly does the looting work? Is it still linked to a skill? The only one I thought would fit was scavenging but that doesn't level by looting. I looted a whole city and am still at 0. My brother is leveling it fast by using the wrench.

 

Sometimes it gets stuck. Borrow his wrench and go take something apart and it should get it to start moving.

 

Yes it's an issue. No I don't know why it randomly does it for no reason when it uses basically the same method as every other action skill and they work.

 

What would be a ideal farm layout with them you think?

 

I'd do it as a + formation and put one in the middle... so maybe like this...

 

D D D T D D D

D D D R D D D

D D D T D D D

T R T T T R T

D D D T D D D

D D D R D D D

D D D T D D D

 

T for trench, R for rain catcher, D for dirt.

Link to post
Share on other sites

Small update to fix some niggling issues.

 

Pushed V2.03B to github. Changes as follows.

 

- Rebuilt DLL files... AGAIN.

- Nerdy Glasses now give +1 intellect instead of a flat crafting tier bonus/crafting speed reduction.

- Treasure Radius effect moved OFF scavenging and onto PERCEPTION since it didn't like decimal numbers and thus wasn't working properly.

Link to post
Share on other sites

Sorry in advance for the long post.

 

Ooooh, that one. I remember Game Edged finding that and thinking "Holy crap, that's a bit good."

 

Wouldn't be so bad if there were less boxes and the workbenches weren't guaranteed to work.

 

Yeah.. i agree. Too much loot and crafting stations for a POI that doesn't have any sleeper spawns (or at least didn't for me).

 

I still haven't found the casino you had mentioned, but did go to the amusement park.... and while i thought that parking garage or whatever it is was bad,(to quote Kickz) HOLY BALLS!!

 

I went into one of the minions at the front gate.. and there were 6 working forges, a bunch (didn't count) of working workbenches and chem stations, 2 working mixers, and a working generator. That is a base and a half right there. Now.. not sure if what happened next was a triggered event for the POI.. or something that happens randomly with your mod... but after exiting the minion and heading for the park entrance.. i heard some explosions behind me and when i turned to look, there were 3 or 4 orange smoke plumes (like with airdrop crates) and some zombies spawned. I didn't really get to see what zombies spawned because from the pack a VERY tall zombie came charging at me. It was only day 5 and all i had was a crappy pistol i bought from a trader. I unloaded as many shots as i could into it before i turned to run... but it caught up to me very quickly and with just one hit..... i was dead.

 

I went back to get my pack hoping it would be gone.. but nope.. still there. I ran as soon as it noticed me, but there was no outrunning it.. and again.. one hit... death. I tried again.. hoping i had lured it far enough away from my original pack but nope.. dead again. I kinda got PO'd at this point, turned on cheat mode and grabbed the dev pistol from the creative menu. I got all my stuff back :) lol

 

Now that story time is done.. I have a couple of questions...

 

1) Has anyone reported issues with the amusement park (i know it's compo pack and not your mod) having blocks go all weird? After dealing with the giant zombie i wanted to finally get in the park, but would have a bunch of blocks just randomly show up all over the place. They were there visually, but not physically as i could walk right through them. If i moved away from the area i was in when they showed up.. they would disappear... but would reappear if i went back to the same area. Happened in a few different spots so i decided to just leave the park.

 

2) Has anyone reported any issues with opening loot containers and not getting loot? I was going through a town selectively looting and things were normal. Then, as if a switch was flipped.. all loot containers i opened were empty. Boxes, crates, shopping carts, garbage bags, birds nests... everything. The first few i thought it was just a small run of bad luck.. but then went and found/looted about 20 bird nests and not a single feather or egg... so i knew it was some sort of bug/glitch. I exited out and came back.. and everything was fine again.

Link to post
Share on other sites
Just as an FYI, be careful of the rain catchers. They drowned half my crops and I still can't pick them up. :(

 

You dug it two blocks deep?

 

- - - Updated - - -

 

So I found 1 welding torch after maaaany boxes but still no sewing kit or tanning rack, where are those?

Link to post
Share on other sites
Sorry in advance for the long post.

 

 

 

Yeah.. i agree. Too much loot and crafting stations for a POI that doesn't have any sleeper spawns (or at least didn't for me).

 

I still haven't found the casino you had mentioned, but did go to the amusement park.... and while i thought that parking garage or whatever it is was bad,(to quote Kickz) HOLY BALLS!!

 

I went into one of the minions at the front gate.. and there were 6 working forges, a bunch (didn't count) of working workbenches and chem stations, 2 working mixers, and a working generator. That is a base and a half right there. Now.. not sure if what happened next was a triggered event for the POI.. or something that happens randomly with your mod... but after exiting the minion and heading for the park entrance.. i heard some explosions behind me and when i turned to look, there were 3 or 4 orange smoke plumes (like with airdrop crates) and some zombies spawned. I didn't really get to see what zombies spawned because from the pack a VERY tall zombie came charging at me. It was only day 5 and all i had was a crappy pistol i bought from a trader. I unloaded as many shots as i could into it before i turned to run... but it caught up to me very quickly and with just one hit..... i was dead.

 

I went back to get my pack hoping it would be gone.. but nope.. still there. I ran as soon as it noticed me, but there was no outrunning it.. and again.. one hit... death. I tried again.. hoping i had lured it far enough away from my original pack but nope.. dead again. I kinda got PO'd at this point, turned on cheat mode and grabbed the dev pistol from the creative menu. I got all my stuff back :) lol

 

Now that story time is done.. I have a couple of questions...

 

1) Has anyone reported issues with the amusement park (i know it's compo pack and not your mod) having blocks go all weird? After dealing with the giant zombie i wanted to finally get in the park, but would have a bunch of blocks just randomly show up all over the place. They were there visually, but not physically as i could walk right through them. If i moved away from the area i was in when they showed up.. they would disappear... but would reappear if i went back to the same area. Happened in a few different spots so i decided to just leave the park.

 

2) Has anyone reported any issues with opening loot containers and not getting loot? I was going through a town selectively looting and things were normal. Then, as if a switch was flipped.. all loot containers i opened were empty. Boxes, crates, shopping carts, garbage bags, birds nests... everything. The first few i thought it was just a small run of bad luck.. but then went and found/looted about 20 bird nests and not a single feather or egg... so i knew it was some sort of bug/glitch. I exited out and came back.. and everything was fine again.

 

1) That amusement park is gonna get removed because it's INSANE.

 

2) That does happen. I was pretty sure it was fixed in a later release as I think it's due to loot gamestage not liking decimal numbers. Will look into it some more later.

 

Just as an FYI, be careful of the rain catchers. They drowned half my crops and I still can't pick them up. :(

 

With great power comes great responsibility?

 

You dug it two blocks deep?

 

- - - Updated - - -

 

So I found 1 welding torch after maaaany boxes but still no sewing kit or tanning rack, where are those?

 

Same places. Sewing kit and tanning rack ALSO have a chance of being in night stands and suitcases.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...