Jump to content

Darkness Falls: They mostly come out at night...


KhaineGB

Recommended Posts

For those that had the creating character issue, we had that on our server too. I had completely deleted all mods from my local client, and installed the 3.2 mod. Another player did not clear everything out, and neither one of us could get in again after initial connection. We resolved it by having everyone clear out all mods first from all clients, reinstall the server completely, and then install the current mod on the server and each client. No issues since then.

Link to comment
Share on other sites

On 9/25/2020 at 9:03 AM, rommel64 said:

I have no input slots on any of my forges I'm on 3.1 has anyone had this issue?

i did yesterday when i went to forge some iron. finally saw it was referencing my inventory for available input items and then got it working. had me wondering, thought it had slots but????? lol.  

Link to comment
Share on other sites

19 hours ago, Steck183 said:

For those that had the creating character issue, we had that on our server too. I had completely deleted all mods from my local client, and installed the 3.2 mod. Another player did not clear everything out, and neither one of us could get in again after initial connection. We resolved it by having everyone clear out all mods first from all clients, reinstall the server completely, and then install the current mod on the server and each client. No issues since then.

Are you running your own server or a hosted server.  I am on a hosted server and my options are fairly limited.  If you are on a hosted, which hosting company? 

Link to comment
Share on other sites

On 9/25/2020 at 1:29 PM, KhaineGB said:

Ok, the server issue is officially on my "Cannot reproduce" list. This is what I just did.

Grabbed clean 7DTD client AND server from steam.
Patched with my git repo files.
Edited my server config to password it, pick a DF map, etc.
Booted the server.
Booted the game, logged in.
Ran around, grabbed loads of fruit and veg, threw them into slots 11-15 on my toolbelt.
Logged out, closed the game.
Rebooted the game, logged back into the server. Ran to the trader, finished my quest.
Logged out of the game and shut down the server.
Rebooted the server, rebooted the game and logged back in.

Absolutely no Creating Player issues. So I would get your clients to check they don't have the bad DLL file.

So we encountered a few issues with our server, however we discovered that at least one person was able to get in the server just fine.  So ill share with you what we discovered. First, ill start with what the person did to successfully get on.

 

They deleted the mods folder on their darkness falls install. Unzipped the latest version of darkness falls to their destop, and copied over the folders one by one, overwriting as necessary, rather than extracting directly to the directory like the rest of us had.

 

Those of us that were getting an error found it best to completely uninstall 7 days, delete the entire directory, then reinstall, and then reinstall the 19.1 7days. However, we discovered that if someone connected with the config that caused them to error out in any way, it was somehow corrupting their entry on the server too. i had the players in question send me their steam64id, then i deleted their files (resets progress of course) and cleared their entry in player.xml. When i did THAT step, and the step with the complete clean install, we were able to resolve the error messages everyone was getting.

 

Just for emphasis. IF YOU CONNECT TO A SERVER AND GET THIS ERROR YOUR PLAYER DATA WILL BE CORRUPT AND YOU WONT BE ABLE TO GET BACK IN UNLESS AN ADMIN HAS YOUR STEAM64 ID AND CLEARS IT FROM THE SERVER

 

I hope that helps, i help run a relatively small server and everyone loves this mod so we took the time to troubleshoot this for everyone til we figured out the right series of steps to get this working for all our guys.

Link to comment
Share on other sites

I know what it is.

Your server or your players still have the 10 slot toolbelt.dll that i've mention SEVERAL times over the past 2-3 pages in their Mods/1-DarknessFalls/Harmony folder.

That's why it's corrupting. The server is saying they have 15 slots. The player says they have 10 slots. So they use the 11-15 slots with no problem but it's saving the "10 slot" data to their profile.

I want to make this very clear that i'm not saying this to have a go at you, just to make things VERY clear.

DELETE Harmony-10 Slot Toolbelt.dll FROM YOUR Mods/1-DarknessFalls/Harmony FOLDER ON ALL CLIENTS AND THE SERVER!!!!!!

 

Folks in discord have CONFIRMED this resolves the issue.

Link to comment
Share on other sites

On 9/25/2020 at 10:56 AM, calbo2020 said:

Update to my recent post.... I tried some testing on our server with the navezgane map and determined that if you use the toolbelt but move your items out of slots 11-15 before you exit then you will be able to come back into the game without problem.  If you leave stuff in those slots then your player will not load and you are stuck at the creating player screen.  Alternatively if you load the game locally and use those same slots  you will have no problems loading your character if anything is in them.  So it is a server side problem but I have no clue where.  Is that 15 slot dll file loaded any where else in a server install? 

Issue you're having is client side and it corrupts your player data on the server too. Do this:

 

Find your steam64 ID

delete the files in ./saves/mapname/servername/player/ that have your 64id (should be 3) 

edit the player.xml in ./saves/mapname/servername/ and delete your steam 64id entry there

 

now that the server is prepped, back to things client side. At this point, completely delete your 7 days directory, and then reinstall alpha 19.1.

 

Install darkness falls by extracting to your desktop and move over one folder at a time.

 

i have found most of these errors people are reporting are client side, not server side. i was working with about 5 people getting various similar errors and these steps solved that issue.

Link to comment
Share on other sites

1 hour ago, KhaineGB said:

 that i've mention SEVERAL times over the past 2-3 pages

Yeah, people are lazy. If I were you I wouldn't answer the same question more than once. Waste of your time.  People need to learn to use the SEARCH function.  If they can't or won't, that's their problem.

  • Like 2
Link to comment
Share on other sites

Intended. I lowered the amount repair kits repair.

16 minutes ago, scubahalo said:

Yeah, people are lazy. If I were you I wouldn't answer the same question more than once. Waste of your time.  People need to learn to use the SEARCH function.  If they can't or won't, that's their problem.

Normally I would agree, but it's sadly in my nature to try and be helpful.

I blame the 8 years of customer service jobs. ;)

  • Like 2
Link to comment
Share on other sites

Does anyone know which xml needs to be edited to edit the amount of loot in say loot chests for example? I dont mean loot abundance which gives you say 20 rounds of ammo instead of 10. I mean the xml that would say put 3 pistols in a loot box instead of 1. Thanks in advance!

Link to comment
Share on other sites

8 hours ago, calbo2020 said:

Are you running your own server or a hosted server.  I am on a hosted server and my options are fairly limited.  If you are on a hosted, which hosting company? 

I am running a hosted server on ServerBlend. Highly recommend them as their customer service is stellar.

Link to comment
Share on other sites

Hello, i have found a bug in two buildings, outside it looks normal, but inside parts come out like another building. I did not give importance to the first one i found, since it was a small house, but after finding the same problem in a larger building, i take pictures. The parts of the other building are not solid.

(sorry i use google traslator)

Map: DFalls-Large2, single player

 

 

 

 

A19.1_2020-09-27_17-32-57.jpg

A19.1_2020-09-27_17-31-21.jpg

A19.1_2020-09-27_17-31-26.jpg

A19.1_2020-09-27_17-32-11.jpg

Edited by LemonDemon
edit pictures (see edit history)
Link to comment
Share on other sites

13 minutes ago, LemonDemon said:

Hello, i have found a bug in two buildings, outside it looks normal, but inside parts come out like another building. I did not give importance to the first one i found, since it was a small house, but after finding the same problem in a larger building, i take pictures. The parts of the other building are not solid.

(sorry i use google traslator)

Map: DFalls-Large2, single player

 

 

 

 

 

 

 

 

This is a known visual bug with 7days to die. You need to exit and relaunch your game client and the weird visual glitchs should resolve. This is not caused by teh mod

Link to comment
Share on other sites

So quick question is anyone having problems with using a class book after creating one. The group i'm playing with is having an issue. We have our 2 base starting classes and those books worked just fine. However when they turned their newly created blank books (made from the table) into class books (Scavanger and Hunter in particular) and use them and hit 'Yes' to the quest it gives them this error. NullReferenceException: Object reference not set to an instance of an object.

 

I don't know if this is a common problem I don't know if it's a problem with the game. We recently updated to 19.1 having to fully uninstall the mod and reinstall it. We are using the ModLauncher to play the game and pre-sync before starting every game. I've tried searching google and mostly just find things talking about how to use the skill books but nothing mentions errors.

Link to comment
Share on other sites

5 hours ago, KhaineGB said:

Class books are quest items.

Use them either from your backpack, or ONLY in slots 1-10 on your toolbelt. 11-15 seem to error with quest items. Not sure why that's happening (need to look into it) but it ONLY happens with quest items.

On 9/22/2020 at 11:31 AM, KhaineGB said:

o

I only quoted you in hopes you would read this. I have been playing 7d2d since 2014 (wow I joined here in 2015!!). Your mod makes the game about 80% better!!! No knock on the Pimps, you are just REALLY making it awesome!! Thanks for all you do, and for putting up with morons who ask the same questions over and over. ;)

 

That's all. Just a sincere thanks!

Edited by ejlarson (see edit history)
  • Like 1
Link to comment
Share on other sites

1 hour ago, potatoxic said:

hello, mr mod author! i think this V3.1 on Alpha19.1 is bugged. All type of furnace don't have input, there're no slots to put clay/stone/irons in. Love your mod so much. Hope you fix it soon. Thank you. 

The way forges work has been changed. You don't need to smelt materials now - materials needed will just be directly taken from your inventory. So, for instance, you need some clay and iron in your backpack in order to make some nails in the forge.

Link to comment
Share on other sites

28 minutes ago, Swist75 said:

The way forges work has been changed. You don't need to smelt materials now - materials needed will just be directly taken from your inventory. So, for instance, you need some clay and iron in your backpack in order to make some nails in the forge.

oh, so that's how it work now? damn, me and my friends though it was a bugged. thank for early reply, that helps alot. 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...