Jump to content

Low FPS in game


Psikhotyj

Recommended Posts

all you did was to say you have a computer and you want more fps (yeah.... ok.... but...)

 

be nice to show whats running in background and with windows 10, there WILL be crap running in background.

 

anti-virus/ anit-malware/ windows defender and so on....

nvidia 3rd party junk installed and running

steam junk allowed (over lays, chats and such...)

other types of game optimizers

game video settings (screen shot of the video options screen) place image in imgur.com and provide link here

mods installed (yes they make a difference too)

 

if you want some help you got to tell what your life history is just like going to a doctor and sitting thru 10 pages of history of your life and your family. :)

 

and be prepared for some strange suggestions!

Link to comment
Share on other sites

Almost every single post I've followed up on like this where a user has all the specs required for a decent framerate, and isn't getting one....

Is because they are trying to play the game at 2k or 4k resolutions. Going back to 1080p resolves their issue.

 

Also, don't forget to turn off Shadows and all Reflections. Neither of these features are optimized enough to be used right now.

Link to comment
Share on other sites

Also, don't forget to turn off Shadows and all Reflections. Neither of these features are optimized enough to be used right now.

Interesting. I've always had my reflections settings set to high and never noticed any fps issues with it set that way. Shadows, I agree with though as I resorted to having it set to "near".

 

Maybe I'll play around with it some more to see just how much it boosts my fps by disabling it and whether or not it's worth it.

Link to comment
Share on other sites

Almost every single post I've followed up on like this where a user has all the specs required for a decent framerate, and isn't getting one....

Is because they are trying to play the game at 2k or 4k resolutions. Going back to 1080p resolves their issue.

 

Also, don't forget to turn off Shadows and all Reflections. Neither of these features are optimized enough to be used right now.

 

good advice there too. i might be wrong but i dont think our texture graphics is even scaled to allow resolution that high. i have all settings maxed with my set up at 2660 x 1440 .

 

ok so Sylen I tested it and here is my findings. tested on navezgane sp map

 

2660 x 1440 spawned and tp 0 0 faced sw and let fps settle because of tp all settings maxed gave me 39.41 FPS

2660 x 1080 spawned and tp 0 0 faced sw and let fps settle (same as above reason) gave me 68.74 FPS

using 2nd test settings i go into video to turn off reflections and shadows (everything else stays as i normally play) no changes to reflections and shadows affected my FPS.

 

so for me... you suggesting to lower resolution has a great deal of benefits. :) nice catch. curious to see how Fox makes out.

Link to comment
Share on other sites

Ok, I did some tests... all on 1080p. Random Gen. And I of course re-loaded the world for each test and allowed the fps to settle.

 

Reflections set to high next to large body of water with sun reflecting off of it: 105fps

Reflections set to off next to large body of water in the same position: 115fps

 

Reflections set to high inside a house looking at a reflective stove among other kitchen stuff: 56fps

Reflections set to off inside the house in the same position: 60fps

 

"Reflected shadows" setting didn't seem to make any difference with shadow distance set to near, maybe 1 or 2fps difference?

 

Shadow distance set to Far next to large body of water (same position), with trees / foliage covering half the screen: 99fps

Shadow distance set to off next to large body of water and trees / foliage: 107fps

 

Shadow distance set to Far inside the house in the kitchen: 57fps

Shadow distance set to off inside the house in the same position: 68fps

Shadow distance set to Near inside the house in the same position: 60fps

 

Conclusion, I think reflections don't impact performance enough to stand out from any other graphics settings. The only reason there was a 10fps difference with the water was because the the sun reflects a lot off of the water, so when it's disabled, the water just becomes a flat color. So of course reflections would have a pretty big impact on that. Also, the world looks kind of bad without reflections, so I think it's worth turning down other settings just to have it on.

 

I wanted to do more tests, but the time of day seems to impact the fps results by over 20fps difference. So I did what I could within daytime.

Link to comment
Share on other sites

never had any issues with nvidia because i ONLY install the video drivers.. i uncheck all the other crap and i will not let steam modify things like they and microsoft feel is best for my experience. but essentially and people sometimes take it wrong, but all that improve your gaming experience BS, is just that.... BS and hogs down your resources.

 

so for improved experience... hopefully enough has been covered here to help OP with his/her fps issue. :)

 

i just noticed you have a little modification in your ui (that can help cut fps too), try cutting the brightness down a bit.

 

here is my game video settings https://i.imgur.com/W1Vrl2x.jpg

 

my system is only a ryzen 5 1400 (and i have been replacing low grade stuff with better as i go) it will be a ryzen 7 with 32 or 64gs of ram currently as an r5 with only single stick 16g ram its a bottlenecking my video card, but you can see from below i am upgrading.

 

250g nvme for Os

1tb SSD for all other installs

1tb for videos (i save my tester videos that are submitted with my bug reports)

16G ram

gtx 1080 Amp Extreme

ASUS crosshair VI motherboard

Link to comment
Share on other sites

never had any issues with nvidia because i ONLY install the video drivers.. i uncheck all the other crap and i will not let steam modify things like they and microsoft feel is best for my experience. but essentially and people sometimes take it wrong, but all that improve your gaming experience BS, is just that.... BS and hogs down your resources.

Same here.

Link to comment
Share on other sites

did you use a gsync monitor? If yes, turn gsync in the driver off + restart your game. I had the same problem but just with win10.

As someone who has a g-sync monitor, I can safely say g-sync has zero effect on fps for any game in the world. G-sync is a monitor feature with it's own built in hardware to make it all work. If anything, g-sync promotes higher fps because you don't need the crappy v-sync enabled and instead just use frame rate limiter.

Link to comment
Share on other sites

https://forums.geforce.com/default/topic/957952/gsync-full-and-windowed-borderless-low-fps/

 

 

tons of it and i had the same problem with win10 (was working without problems in win7).

 

 

8700k, 16gb ram and gtx1070.

im stuck with gsync (Predator XB271HUAbmiprz) at ~20 fps. JUST in 7 days.

 

a temp. fix for me is... put gsync off, start the game, put it on and fastswitch to the game.

Link to comment
Share on other sites

https://forums.geforce.com/default/topic/957952/gsync-full-and-windowed-borderless-low-fps/

 

 

tons of it and i had the same problem with win10 (was working without problems in win7).

 

 

8700k, 16gb ram and gtx1070.

im stuck with gsync (Predator XB271HUAbmiprz) at ~20 fps. JUST in 7 days.

 

a temp. fix for me is... put gsync off, start the game, put it on and fastswitch to the game.

That sounds more like an OS issue, not a hardware issue. Just one more reason not to downgrade to Windows 10.

Link to comment
Share on other sites

  • 1 year later...
https://forums.geforce.com/default/topic/957952/gsync-full-and-windowed-borderless-low-fps/

 

 

tons of it and i had the same problem with win10 (was working without problems in win7).

 

 

8700k, 16gb ram and gtx1070.

im stuck with gsync (Predator XB271HUAbmiprz) at ~20 fps. JUST in 7 days.

 

a temp. fix for me is... put gsync off, start the game, put it on and fastswitch to the game.

 

 

I was also having this problem in Windows 10, GTX 1080 graphics card, and LG 2k monitor 165Hz with GSync.

The game would look like it is lagging but it was actually skipping every 2nd frame and locked at 60 fps.

When I realized this I did some testing and could replicate the problem.

 

I could replicate the problem and the solution, GSYNC not working as intended when the 7 Days to Die window is active in Windows 10.

Here is the my fix:

*Disclaimer, it helps to have the Steam FPS counter turned on while troubleshooting.


  • [1] Start the 7 Days to Die game and nVidia Control Panel
    [2] In the nVidia Control Panel --> Select Manage 3D Settings --> then select Program Settings
    [3] Choose the program 7 Days to Die 7daystodie.exe
    [4] Change the following settings:

[A] Monitor Technology = set to Fixed Refresh

Preferred Refresh Rate --> set to Application-Controlled


[5] Alt-Tab back to the 7 Days to Die window, making it the active window again, and confirm the setting change has resolved the FPS "lag"

 

From what we've observed between my friends this only seems to be a problem with Windows 10 and nVidia's GSync technology.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

Guest
This topic is now closed to further replies.
×
×
  • Create New...