Jump to content
JaxTeller718

Ravenhearst Mod

Recommended Posts

Unfortunately I'm having trouble with the ravenhearst mod. I play side by side with my bf and every time I switch to my blunderbuss he gets a text box at the top of the screen. This really is gamebreaking, I get the text box come up randomly too... I thought this was the most stable ravenhearst yet... We are absolutely gutted this is happening. We both have well over 1000 hours on 7dtd... we dont believe this to be because of us... :(

Share this post


Link to post
Share on other sites
Unfortunately I'm having trouble with the ravenhearst mod. I play side by side with my bf and every time I switch to my blunderbuss he gets a text box at the top of the screen. This really is gamebreaking, I get the text box come up randomly too... I thought this was the most stable ravenhearst yet... We are absolutely gutted this is happening. We both have well over 1000 hours on 7dtd... we dont believe this to be because of us... :(

 

look my post:

https://forums.7daystodie.com/forum/-7-days-to-die-pc/game-modification/mods/78314-ravenhearst-mod?p=1725130#post1725130

 

you and your friend need to find the same file in your game client (with mod) \ Mods \ 0-SphereIICore \ Config \ blocks.xml

edit line 54. false -> true

<property name="NoExceptionHijack" value="false" /> <!-- Disables the console drop down on red exception -->

 

and you will no longer have a console open on any errors.

 

This error occurs every time when a weapon or tool that reaches durability 0 and breaks (disappears) in the hands.

An interesting feature makes you keep track of equipment and do not forget to fix it on time. the red frame on objects close to breakage is also not bad, but if there are several such objects, the white frame of the currently selected slot is not visible and control is lost.

 

Great mod, the best of all that I played, and this is a huge list :)

But in an imaginary competition of the most glitchy games, 7dtd will definitely take a prize. Fans of this game have long come to terms with this. :)

 

ps. sorry for my english. google translator.

 

 

Share this post


Link to post
Share on other sites

Hey there,

 

first of all ... damn nice mod. I don't know, why i never noticed it ...

 

But i have a little problem and google said NOPE to me ...

 

I'm from germany ... i installed it and played in german language. Now i have ravenhearst installed with a clean installation. Its english like excepted. BUT some parts are spanish?! Even with generating the prefab worlds, i get "Cargando datos del juego" as onscreen message ... and later ingame, some things are spanish too.

 

How can i swap this to english? Maybe i did something stupid?

Share this post


Link to post
Share on other sites

 

look my post:

https://forums.7daystodie.com/forum/-7-days-to-die-pc/game-modification/mods/78314-ravenhearst-mod?p=1725130#post1725130

 

you and your friend need to find the same file in your game client (with mod) \ Mods \ 0-SphereIICore \ Config \ blocks.xml

edit line 54. false -> true

<property name="NoExceptionHijack" value="false" /> <!-- Disables the console drop down on red exception -->

 

and you will no longer have a console open on any errors.

 

This error occurs every time when a weapon or tool that reaches durability 0 and breaks (disappears) in the hands.

An interesting feature makes you keep track of equipment and do not forget to fix it on time. the red frame on objects close to breakage is also not bad, but if there are several such objects, the white frame of the currently selected slot is not visible and control is lost.

 

Great mod, the best of all that I played, and this is a huge list :)

But in an imaginary competition of the most glitchy games, 7dtd will definitely take a prize. Fans of this game have long come to terms with this. :)

 

ps. sorry for my english. google translator.

 

 

 

Thanks for you advice. This has helped the issue, we no longer have the console open up randomly while we're trying to fight zombies! However the blunderbuss in question was fresh level 34, not in a bad working order. The error wasn't due to needing repairs.

We started a new game as the other one we just felt cheated by due to the errors... however now we have errors where we cannot open cupboards, nests, boxes... it seems we will be waiting much longer before we can enjoy Ravenhearst again... it makes us very sad. The vanilla game is just so boring... we will hope A19 comes out this month so we can get our semi-fix :(

 

 

Share this post


Link to post
Share on other sites

 

 

Thanks for you advice. This has helped the issue, we no longer have the console open up randomly while we're trying to fight zombies! However the blunderbuss in question was fresh level 34, not in a bad working order. The error wasn't due to needing repairs.

We started a new game as the other one we just felt cheated by due to the errors... however now we have errors where we cannot open cupboards, nests, boxes... it seems we will be waiting much longer before we can enjoy Ravenhearst again... it makes us very sad. The vanilla game is just so boring... we will hope A19 comes out this month so we can get our semi-fix :(

 

 

If you are both using the mod launcher, be sure to un-check the "refresh mods automatically", then go into each of your installs and delete the RH_ReturnModsOnBreak from the folder under the mods folder. (C:\7D2D\Alpha18\Ravenhearst\Ravenhearst_6_4_Edition\Mods\RH_ReturnModsOnBreak or something similar).

 

My friend and I had a similar issue and the consoles popping up was HORRIBLE. He had a spear break and it caused errors on my screen and he experienced very little to none of them.

 

Anyway, we didn't edit the SphereIICore mod at all, but was instructed from the Curly in the Discord channel to do the above and we have not had a console error since. Hope it helps/works!

  • Like 2

Share this post


Link to post
Share on other sites

 

If you are both using the mod launcher, be sure to un-check the "refresh mods automatically", then go into each of your installs and delete the RH_ReturnModsOnBreak from the folder under the mods folder. (C:\7D2D\Alpha18\Ravenhearst\Ravenhearst_6_4_Edition\Mods\RH_ReturnModsOnBreak or something similar).

 

My friend and I had a similar issue and the consoles popping up was HORRIBLE. He had a spear break and it caused errors on my screen and he experienced very little to none of them.

 

Anyway, we didn't edit the SphereIICore mod at all, but was instructed from the Curly in the Discord channel to do the above and we have not had a console error since. Hope it helps/works!

 

 

Okay that sounds like another option. I'd be a little worried about not getting my red dot sight back from my pistol tho lol... we are going to try this again tonight. I hope that I can open birds nests and cupboards tho... that was the reason we quit again yesterday... the error log wasn't coming up, I was just tapping 'E' to open these things with no avail :dispirited:

Share this post


Link to post
Share on other sites

 

 

I think it depends on a specific skill, the higher you have it the less levels you lose when combining them.

 

I'd think combining should IMPROVE the item, not degrade it. Otherwise why not just repair the item?

Share this post


Link to post
Share on other sites
Hey there,

 

first of all ... damn nice mod. I don't know, why i never noticed it ...

 

But i have a little problem and google said NOPE to me ...

 

I'm from germany ... i installed it and played in german language. Now i have ravenhearst installed with a clean installation. Its english like excepted. BUT some parts are spanish?! Even with generating the prefab worlds, i get "Cargando datos del juego" as onscreen message ... and later ingame, some things are spanish too.

 

How can i swap this to english? Maybe i did something stupid?

 

Is there any support-topic, where i can get help? :)

Share this post


Link to post
Share on other sites

 

I'd think combining should IMPROVE the item, not degrade it. Otherwise why not just repair the item?

 

When you repair a item is the same, lost quality.

Share this post


Link to post
Share on other sites

Following on from my posts previously.... I am giving up on this Ravenhearst entirely... it's not stable... shit is still going wrong. 1000's of hours in this game, not a noob... ... devastated to of wasted so many hours and time.... Roll on A19

Share this post


Link to post
Share on other sites
Following on from my posts previously.... I am giving up on this Ravenhearst entirely... it's not stable... ♥♥♥♥ is still going wrong. 1000's of hours in this game, not a noob... ... devastated to of wasted so many hours and time.... Roll on A19

 

:grumpy: Sorry to hear it. The losing of your mod is exactly what we have to worry about now on our play through. My only suggestion now is to jump over to the Discord channel. There are a lot of awesome folks over there ready to help. Most of the time if you provide a summary of the problem and your log, they can help. Just note though, if you are using the mod launcher, you log will be something like C:\7D2D\Alpha18\Ravenhearst\Ravenhearst_6_4_Edition\7DaysToDie_Data\output_log.txt

 

https://ravenhearst.enjin.com/ - The link is on the left hand side, as well as along the top. Good luck!

Share this post


Link to post
Share on other sites

 

When you repair a item is the same, lost quality.

 

Yes, that is what I was pointing out. No need to bother with combine when you can just repair the item.

Share this post


Link to post
Share on other sites

So it seems zombies stopped spawning in the world no matter what my settings are. Anyone have any idea how to fix this? I dont want to start another new game.

 

 

Share this post


Link to post
Share on other sites
Hey there,

 

first of all ... damn nice mod. I don't know, why i never noticed it ...

 

But i have a little problem and google said NOPE to me ...

 

I'm from germany ... i installed it and played in german language. Now i have ravenhearst installed with a clean installation. Its english like excepted. BUT some parts are spanish?! Even with generating the prefab worlds, i get "Cargando datos del juego" as onscreen message ... and later ingame, some things are spanish too.

 

How can i swap this to english? Maybe i did something stupid?

 

Got it on my own. Thanks ... not.

Share this post


Link to post
Share on other sites
So it seems zombies stopped spawning in the world no matter what my settings are. Anyone have any idea how to fix this? I dont want to start another new game.

 

 

 

Before entering your game in game options in the Ravenhearts section, the number of zombies you want appears in the first, by default it is 0 and you have to change it, I have it set to 30 but you can put it in more ( I do not recommend it, it is very much the number of zombies that appear).

Share this post


Link to post
Share on other sites

 

 

Okay that sounds like another option. I'd be a little worried about not getting my red dot sight back from my pistol tho lol... we are going to try this again tonight. I hope that I can open birds nests and cupboards tho... that was the reason we quit again yesterday... the error log wasn't coming up, I was just tapping 'E' to open these things with no avail :dispirited:

 

 

Thank you, good advice but Ill wait now, its all been a bit much :( Gonna play Rimworld now lol

Share this post


Link to post
Share on other sites

Still looking for a little assistance in figuring out why our Zeds are not attacking. Everything else seems to be working just fine with the new update 18.4 b4 except the Zeds will not attack, even when we attack them. It;s like they can not target us. They will however run right up to us during outings, attack our base to get to us but once face to face, they just stand there like a mindless noob....My log says this ----> [TABLE]

[TR]

[TD]Exception[/TD]

[TD]MissingMethodException: bool EntityUtilities.CheckAIRange(int,int)[/TD]

[/TR]

[/TABLE]

I have searched the server files for EntityUtilities to no avail...

Any help would be appreciated.

Share this post


Link to post
Share on other sites

My friends and 1 took over a poi for a base but from time to time sleepers respawn in our base as well as 1 zombie bear and 3 of those 1500 hp zombies. i see that we can craft some Safe terrain but no idea how to get the schematic for it.

Share this post


Link to post
Share on other sites

Strange thing started to happen on my dedi server: my game kinda crack, I can't open boxes (can menus and backpack), I can see friend walking around and he sees me standing in one place. Quick leaving server and returning solves this but when we doing quest I loose quest progress, of course. Started to happen every half an hour...

Is Hunter perk designed to be so minimal to none improvement when chopping animals for meat?

Share this post


Link to post
Share on other sites

is this error normal to get cause i always keep getting it and cant boot server up:

 

GameStat.ZombieSuperRage = 0

2020-04-13T22:54:59 17.616 INF StartAsServer

WARNING: Shader Unsupported: 'Autodesk Interactive' - Pass 'FORWARD' has no vertex shader

WARNING: Shader Unsupported: 'Autodesk Interactive' - Pass 'FORWARD_DELTA' has no vertex shader

WARNING: Shader Unsupported: 'Autodesk Interactive' - Pass 'ShadowCaster' has no vertex shader

WARNING: Shader Unsupported: 'Autodesk Interactive' - All passes removed

WARNING: Shader Unsupported: 'Autodesk Interactive' - Pass 'FORWARD' has no vertex shader

WARNING: Shader Unsupported: 'Autodesk Interactive' - Pass 'FORWARD_DELTA' has no vertex shader

WARNING: Shader Unsupported: 'Autodesk Interactive' - Pass 'ShadowCaster' has no vertex shader

WARNING: Shader Unsupported: 'Autodesk Interactive' - All passes removed

WARNING: Shader Unsupported: 'Autodesk Interactive' - Pass 'FORWARD' has no vertex shader

WARNING: Shader Unsupported: 'Autodesk Interactive' - Pass 'FORWARD_DELTA' has no vertex shader

WARNING: Shader Unsupported: 'Autodesk Interactive' - Pass 'ShadowCaster' has no vertex shader

WARNING: Shader Unsupported: 'Autodesk Interactive' - All passes removed

WARNING: Shader Unsupported: 'Autodesk Interactive' - Pass 'FORWARD' has no vertex shader

WARNING: Shader Unsupported: 'Autodesk Interactive' - Pass 'FORWARD_DELTA' has no vertex shader

WARNING: Shader Unsupported: 'Autodesk Interactive' - Pass 'ShadowCaster' has no vertex shader

WARNING: Shader Unsupported: 'Autodesk Interactive' - All passes removed

WARNING: Shader Unsupported: 'Autodesk Interactive' - Pass 'FORWARD' has no vertex shader

WARNING: Shader Unsupported: 'Autodesk Interactive' - Pass 'FORWARD_DELTA' has no vertex shader

WARNING: Shader Unsupported: 'Autodesk Interactive' - Pass 'ShadowCaster' has no vertex shader

WARNING: Shader Unsupported: 'Autodesk Interactive' - All passes removed

WARNING: Shader Unsupported: 'Autodesk Interactive' - Pass 'FORWARD' has no vertex shader

WARNING: Shader Unsupported: 'Autodesk Interactive' - Pass 'FORWARD_DELTA' has no vertex shader

WARNING: Shader Unsupported: 'Autodesk Interactive' - Pass 'ShadowCaster' has no vertex shader

WARNING: Shader Unsupported: 'Autodesk Interactive' - All passes removed

WARNING: Shader Unsupported: 'Autodesk Interactive' - Pass 'FORWARD' has no vertex shader

WARNING: Shader Unsupported: 'Autodesk Interactive' - Pass 'FORWARD_DELTA' has no vertex shader

WARNING: Shader Unsupported: 'Autodesk Interactive' - Pass 'ShadowCaster' has no vertex shader

WARNING: Shader Unsupported: 'Autodesk Interactive' - All passes removed

WARNING: Shader Unsupported: 'Autodesk Interactive' - Pass 'FORWARD' has no vertex shader

WARNING: Shader Unsupported: 'Autodesk Interactive' - Pass 'FORWARD_DELTA' has no vertex shader

WARNING: Shader Unsupported: 'Autodesk Interactive' - Pass 'ShadowCaster' has no vertex shader

WARNING: Shader Unsupported: 'Autodesk Interactive' - All passes removed

WARNING: Shader Unsupported: 'Standard (Roughness setup)' - Pass 'FORWARD' has no vertex shader

WARNING: Shader Unsupported: 'Standard (Roughness setup)' - Pass 'FORWARD_DELTA' has no vertex shader

WARNING: Shader Unsupported: 'Standard (Roughness setup)' - Pass 'ShadowCaster' has no vertex shader

WARNING: Shader Unsupported: 'Autodesk Interactive' - Pass 'FORWARD' has no vertex shader

WARNING: Shader Unsupported: 'Autodesk Interactive' - Pass 'FORWARD_DELTA' has no vertex shader

WARNING: Shader Unsupported: 'Autodesk Interactive' - Pass 'ShadowCaster' has no vertex shader

WARNING: Shader Unsupported: 'Autodesk Interactive' - All passes removed

2020-04-13T22:57:58 195.776 INF Block IDs with mapping

2020-04-13T22:57:58 195.776 INF BlockIDs from Mapping

WARNING: Shader Unsupported: 'Autodesk Interactive' - Pass 'FORWARD' has no vertex shader

WARNING: Shader Unsupported: 'Autodesk Interactive' - Pass 'FORWARD_DELTA' has no vertex shader

WARNING: Shader Unsupported: 'Autodesk Interactive' - Pass 'ShadowCaster' has no vertex shader

WARNING: Shader Unsupported: 'Autodesk Interactive' - All passes removed

2020-04-13T22:58:49 246.764 INF Unable to find class: MinEventActionAnimatorSetTrigger

2020-04-13T22:58:49 246.764 INF Unable to find class: MinEventActionAnimatorSetTrigger

2020-04-13T22:58:50 247.682 INF Item IDs with mapping

2020-04-13T22:58:50 247.682 INF ItemIDs from Mapping

WARNING: Shader Unsupported: 'Hidden/Dof/DX11Dof' - Pass '' has no vertex shader

WARNING: Shader Unsupported: 'Hidden/Dof/DX11Dof' - Setting to default shader.

HDR Render Texture not supported, disabling HDR on reflection probe.

 

(Filename: C:\buildslave\unity\build\Runtime/Camera/ReflectionProbes.cpp Line: 269)

Share this post


Link to post
Share on other sites

After for a long time, we decided to come back.

But there are too much errors!

 

While we were playing in multiplayer, it says: "EndOfStreamException: Failed to read past end of stream"

 

How can we fix this?

 

 

Share this post


Link to post
Share on other sites

In this mod I see there is a wood spike and a wood spike trap. The "wood spikes" cost 10 more wood. Are they more durable or do the do more damage?

 

Thanks!

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)

Heya, I have a question.

I installed this mod with mod launcher on clean copy. The game opens and seems fine. But after 2-5minutes the game just crashes to desktop. Anyone knows a fix for it?

Sometimes it even crash to desktop right after the loading player character.

 

Edit: Also now game crashes with flicking my monitor on and off few times and 7DTD crash. With that also most of my PC apps crash: Discord, Firefox, Steam, Sharex and so on.

Edited by Bulki (see edit history)

Share this post


Link to post
Share on other sites

with the release of 6.4.3 sometime today it is important that you know this patch WILL wipe your player save data.

 

I did my best to avoid this but there were quite a few QoL changes made including some recipe and progression unlock shifts, quest fixes and player level unlock reductions. This combined with all the fixes for spawning, hive houses, gamestage calculations and performance enhancements has me STRONGLY suggesting that if you are going to update to this patch you should start a new save and a new world. Otherwise you will not fully see the benefits of the work we have done.

 

You will also need a brand new install as we have modified and removed some dll modules that were causing server crashes. I am submitting to Bluefang now and hope this can curb price increases. I am also strongly advising Bluefang to wipe any game requesting an update to this new patch. I know this probably sucks but with development ending on 18 the band aid should be ripped now and a fresh start can bring to you guys a much more stable and long term world in the long run.

 

Look for the update sometime this afternoon. Once this releases we will not be taking any bug reports on version pre 6.4.3 so please keep that in mind.

 

I understand that this may be enraging to some but please understand our position and also realize that this is a difficult time for all of us and we did our best. 19 will be a new start for all of us. That said i feel like 6.4.3 is stable as hell and runs 100 times better than 6.4.2.

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...