Jump to content

Ravenhearst Mod


Recommended Posts

Just a quick question, don't know if it's right or wrong to ask but is there any way to merge the UI from Undead Legacy with this mod, gotta admit i'm in love with that UI if anyone could help me figure it out i can't say anything but you got my heartfelt thanks P.S. I'm scratching my head right now trying to merge this mod and i don't know much about modding just a basic here :D

Edited by Suhail75 (see edit history)
Link to post
Share on other sites

Hey,

 

I Thought I'd give this mod a try (since alpha (21)17 is gonna take a little while longer ;) ).

 

I'm having issues getting it to run though.

 

I installed 7d2d mod launcher as advised (v 1.0.5.2)

I deleted 7 days to die from steam (to start clean - I ran valmod before).

I renamed (for savekeeping) my old 7 days to die C:whatever folder

I reinstalled 7d2d beta 16.4

I checked the correct making of a new c:whatever 7daystodie directory.

I used 7d2d mod launcher to install ravenhearst 4.3 normal 7 day edition.

I ran the pre-sync (damn that takes long)

 

Starting the game

It recognised my screens wrong (middle screen which is main display gets recognised as 2 - left instead of 1 middle) - but that I figured out.

 

Starting the game takes a LONG time. It crashed a couple of times.

Full clean boot, minimal programs running got me to the start menu with the mouse highlighting the mouse-over menu option.

I tried to go into options (as physcial ram was MAXED out - running on 8gb here - 7 days to die was taking about 6.5)

Crash again.

 

output error log says:

========= OUTPUTING STACK TRACE ==================

 

RtlLookupFunctionEntry returned NULL function. Aborting stack walk.<Missing stacktrace information>

 

========== END OF STACKTRACE ===========

 

**** Crash! ****

 

I got the crash files available if thats of use to anyone trying to figure it out.

 

B

Link to post
Share on other sites

mmm

 

I seem to be making some progress.

 

Even though EAC is off in the mod launcher it was checked in the launcher menu for 7d2d itself. So I turned it off there.

Also started 7 days to die 'regular', which went fast and smoothly, to lower the automatically detected 'high' video settings a bit.

 

I'm getting to an active start menu now.

Gonna check if I can actually start a game now.

 

Updates as I muddle along.

Link to post
Share on other sites

Seems to run 'fine' now. Most likely was the EAC problem.

 

For others that might visit (if it's duplicate please remove)

 

Problem:

7d2d ravenhearst mod 4.3 (fully updated) get stuck loading or at the menu screen. It (eventually) results in a crash.

 

Analysis:

Even though EAC is OFF in 7d2d Mod launcher it appears the EAC ON from the 7d2d launcher (orig) gets priority.

 

Solve:

Start 7d2d regular with it's launcher and turn EAC off there. Then use 7d2d mod launcher to start ravenhearst mod.

 

On a plus note: I managed to survive my first day first at first play at this :) (warrior diff, 150% loot, no loot respawn, no airdrops)

Link to post
Share on other sites
you need to loot a blender, coffee machine, and microwave in order to craft the kitchen equipment table. Once built, it acts as a workstation and allows you to use those appliances. Though it may also be possible to place and use the appliances individually as well. Finding those appliances is non trivial. They seem to appear in wooden crates or cardboard boxes.

 

Yes, you find all 3 and you can craft the Appliance Table. You can also use them individually. You can break them with a pickaxe to pick them up.

Link to post
Share on other sites

Hi There, hoping someone can help. Probably a very obvious answer but I cant work out fishing. I have a rod, click on water, get fish, then click on ground and a bucket appears. But no fish? I destroy the buckets with tools, but still no fish. Am I missing something?

 

Thanks.

Link to post
Share on other sites
Hi There, hoping someone can help. Probably a very obvious answer but I cant work out fishing. I have a rod, click on water, get fish, then click on ground and a bucket appears. But no fish? I destroy the buckets with tools, but still no fish. Am I missing something?

 

Thanks.

 

fish is not 100% loot rate. I only got a fish every 3-5 buckets

Link to post
Share on other sites

MAJOR UPDATE

 

I am working on a new patch that WILL REQUIRE A WIPE

 

Since 17 is taking longer than we thought, work has begun on a new patch that will be v4.4. It will see the removal and modification of some systems that aren't working quite well (fishing for example has a new system) and also the addition of several new mods that have been created since 4.3 had released.

 

It will most definitely be worth it for you guys and hopefully give those of you who are bored something to tide you over until 17. More info as it becomes available. No estimate for a release date yet, but work began today and I will keep everyone informed.

 

With SO much changing n 17 I thought I owed it to everyone to give you a full "kitchen sink" finale that you guys will love.

 

Shortly after will see the release of my Proof of Concept for the Romero style mod. This one will have a very different feel from RH and is basically being released because lots of work went into it, and also some systems i created for it just won't be doable in 17 so rather than let it collect dust and never be seen I thought I would share it with everyone.

Link to post
Share on other sites

6. That was an addition to keep players on their toes and also to add real danger to the world from being hit by zombies. I went to day 2 without getting any kind of dirty because I was very careful not to get hit by a zombie. There are so many POIs with water in them, not to mention the caves you find in the world that have water in them. If you are quite careful as you play you can avoid filling your dirty meter until you find a water POI. We made sure every town and city had some water pois in some form or fashion.

 

Love the mod, but I'm still a bit confused by the cleanliness debuff system. How does the "red on ya" debuff actually proc? I went through day 1 without getting hit at all by anything, but I still ended up with this debuff -- and I'm 99% certain I didn't even see the "dirty" debuff beforehand. I thought avoiding injury would prevent this from happening, no? Is it just a peril of fighting in melee combat?

Link to post
Share on other sites
Love the mod, but I'm still a bit confused by the cleanliness debuff system. How does the "red on ya" debuff actually proc? I went through day 1 without getting hit at all by anything, but I still ended up with this debuff -- and I'm 99% certain I didn't even see the "dirty" debuff beforehand. I thought avoiding injury would prevent this from happening, no? Is it just a peril of fighting in melee combat?

 

its from either blood splash or walking over corpses, wet towel should fix it.

Link to post
Share on other sites

Trader Spawn Issue

The thing is i can only find a single trader and some destroyed settlements with no traders in every seed i've tested so far. I concluded this after hours of exploration in my mini bike and using cheats to make sure i didn't miss any traders, i would be grateful if someone could help me with this issue.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...