Jump to content

A16 - STARVATION Mod for A16


Mortelentus
 Share

Recommended Posts

Hello. I have network game and the latest version mod. I am the server. Week of playing time at me fog. Visibility is very low. At the same time at the second player everything is normal. Visibility good is also not present fog. In bloody night visibility was restored. But in the morning again fog.

It seems a well known bug that only affects the player that is the server. Cant remember that anyone could explain why. The most times shutdown and restart the server was helpful.

Edited by PadreNostrum (see edit history)
Link to comment
Share on other sites

It seems a well known bug that only affects the player that is the server. Cant remember that anyone could explain why. The most times shutdown and restart the server was helpfull.

 

I have not a dedicated server. Just my computer. Already several times continued a game, but fog doesn't pass. It can eat still what way to correct?

Link to comment
Share on other sites

Hello. I have network game and the latest version mod. I am the server. Week of playing time at me fog. Visibility is very low. At the same time at the second player everything is normal. Visibility good is also not present fog. In bloody night visibility was restored. But in the morning again fog.

 

This is a Vanilla issue. It's not caused by the mod. My husband and I experienced this problem as well when we play private games together. Whomever was hosting the game, would get heavy fog, as well as lightning during storms. But the non-host player would see no fog, and no lightning during storms.

 

It did not matter if we restarted the game, it was the same every game we played. We just got used to it. you might be able to turn the weather off in the xml files maybe, or through a console command. But I'm not completely sure.

 

I am not sure how to fix this, and I know many people have reported it on the bugs page for the actual game.

 

in the console command you can try:

 

weather (Control weather settings. Type "help weather" for more info. )

weathersurvival <on / off> (Toggles weather survival.)

Edited by PurgatoryWolf (see edit history)
Link to comment
Share on other sites

Doctor quest:

I found a few survivors underground in a bunker and I got given a hazmat suit and a quest to go into the rad zone to kill the doctor. Who exactly is the doctor? Is he a doc zed (the guy in blue) that drops the x-rad syringes, or is he a specific one? Reason I ask is because I killed about 3 doc zeds but it didn't register that I had killed them, so I'm not sure if this is a survivor thing or not. I also killed mortelentus in the red mesa but that didn't register either, so it can't be him... is there a specific POI I need to find?

 

I have the same question. Nobody did this quest?

Link to comment
Share on other sites

I have the same question. Nobody did this quest?

 

No, I never finished this quest. I only ever gotten it once. I can not tell you, which doc is meant (though I'd vote for the blue one as well), but I can tell you that I had kills not count for some quests and figured it might be tied to my weapon choice, because switching to some vanilla gun solved it for me.

Link to comment
Share on other sites

Hey guys.

 

Sorry if this has been fixed, but I didn't want to wade through 160 pages to find the answer...

 

I'm experiencing quite a bit of stuttering and lag when trying to play Starvation, even though my system is very good. I have the i7 7000 quad core, 16gb RAM, etc etc, can run GTA V on ultra, Kingdom Come on ultra, and obviously regular 7dtd on ultra...

 

Yet, I cannot run starvation even on medium settings...

 

 

Anyone know any way to fix this? installed through the mod manager, using the pre-sync and then tried running both from the mod manager and then through the created clone file, with no luck. Any help would be much appreciated, as this mod is fantastic.

Link to comment
Share on other sites

Hey guys.

 

Sorry if this has been fixed, but I didn't want to wade through 160 pages to find the answer...

 

I'm experiencing quite a bit of stuttering and lag when trying to play Starvation, even though my system is very good. I have the i7 7000 quad core, 16gb RAM, etc etc, can run GTA V on ultra, Kingdom Come on ultra, and obviously regular 7dtd on ultra...

 

Yet, I cannot run starvation even on medium settings...

 

 

Anyone know any way to fix this? installed through the mod manager, using the pre-sync and then tried running both from the mod manager and then through the created clone file, with no luck. Any help would be much appreciated, as this mod is fantastic.

 

Update: I tried running on the most basic settings, and then again on ultra;

 

The stuttering is exactly the same on both settings... So I can only assume somethings up with the installation...?

Link to comment
Share on other sites

No, I never finished this quest. I only ever gotten it once. I can not tell you, which doc is meant (though I'd vote for the blue one as well), but I can tell you that I had kills not count for some quests and figured it might be tied to my weapon choice, because switching to some vanilla gun solved it for me.

 

I don't remember when this finished for me, but i know i finished it. I just remember killing a bunch of Drs out in the red zone, and one day the quest was done. :/ I dont remember killing anything special either. they all looked the same.

Link to comment
Share on other sites

Hey guys.

 

Sorry if this has been fixed, but I didn't want to wade through 160 pages to find the answer...

 

I'm experiencing quite a bit of stuttering and lag when trying to play Starvation, even though my system is very good. I have the i7 7000 quad core, 16gb RAM, etc etc, can run GTA V on ultra, Kingdom Come on ultra, and obviously regular 7dtd on ultra...

 

Yet, I cannot run starvation even on medium settings...

 

 

Anyone know any way to fix this? installed through the mod manager, using the pre-sync and then tried running both from the mod manager and then through the created clone file, with no luck. Any help would be much appreciated, as this mod is fantastic.

 

That's because of the Vanilla game. The FunPimps just do not optimize it.

Link to comment
Share on other sites

Update: I tried running on the most basic settings, and then again on ultra;

 

The stuttering is exactly the same on both settings... So I can only assume somethings up with the installation...?

 

Try adding an explicit exception for 7Day2Die folder and executable in your AntiVirus. That has solved it for others.

Link to comment
Share on other sites

I have the same question. Nobody did this quest?

 

No, I never finished this quest. I only ever gotten it once. I can not tell you, which doc is meant (though I'd vote for the blue one as well), but I can tell you that I had kills not count for some quests and figured it might be tied to my weapon choice, because switching to some vanilla gun solved it for me.

 

I did this Quest one week ago. You find the "doctor" in any town in the nuclear zone you enter. Kill him and loot him. You will get a reciepe for antiradiation.

Link to comment
Share on other sites

This is a Vanilla issue. It's not caused by the mod. My husband and I experienced this problem as well when we play private games together. Whomever was hosting the game, would get heavy fog, as well as lightning during storms. But the non-host player would see no fog, and no lightning during storms.

 

It did not matter if we restarted the game, it was the same every game we played. We just got used to it. you might be able to turn the weather off in the xml files maybe, or through a console command. But I'm not completely sure.

 

I am not sure how to fix this, and I know many people have reported it on the bugs page for the actual game.

 

in the console command you can try:

 

weather (Control weather settings. Type "help weather" for more info.  )

weathersurvival <on / off> (Toggles weather survival.)

 

I have no server, im a single player, offline, but some times when my session is very long ( > 5h ) i have the same issue. First times i ended the game complete, that means not only drop back to the main and reload the save, drop back to desktop and restart. Most times i had a new weather.

 

Simultaneously i had some Gamecrashes "out of memory", i have 16GB ram ... but ive seen that the file was blowing up with runtime. So i experimented with the "mem" command.

 

My experience after weeks is, if i start the game, load the savegame, start debugmode, execute "mem", i never have this "weather-Problem" and i never have this "out-of-memory" Problem. The game didnt blow up to crash the game. Sometimes i have fog and bad weather too, but it is temporally terminated. Why? Cant say.

Link to comment
Share on other sites

I have no server, im a single player, offline, but some times when my session is very long ( > 5h ) i have the same issue. First times i ended the game complete, that means not only drop back to the main and reload the save, drop back to desktop and restart. Most times i had a new weather.

 

Simultaneously i had some Gamecrashes "out of memory", i have 16GB ram ... but ive seen that the file was blowing up with runtime. So i experimented with the "mem" command.

 

My experience after weeks is, if i start the game, load the savegame, start debugmode, execute "mem", i never have this "weather-Problem" and i never have this "out-of-memory" Problem. The game didnt blow up to crash the game. Sometimes i have fog and bad weather too, but it is temporally terminated. Why? Cant say.

 

TFP told me one, when I reported the fog issue, was that the fog was part of the game, they wanted to make it harder to see. They didnt understand I was telling them only one of us was seeing it.

 

The out of memory thing is a memory leak, this is also a vanilla issue. TFP know about it, and haven't fixed it yet, or are waiting to roll it out with a17, i don't know. Most of the time my game is fine, but then if I notice im starting to stutter or lag, then i've got a leak, and shutting the game down completely and relaunching it fixes it. Often when the game is leaking, it also takes forever to close it down. This is a huge issue, and I wish they would have fixed it and run a patch for people. Most of the time they chalk it up to "well you play MP so we're not optimized for more then 8 people" but, it's happening to SP people too.

 

--

 

Incase anyone wants to know what mem does..

 

mem Prints memory information and calls garbage collector.

memcl Prints memory information on client and calls garbage collector.

 

--

 

Don;t know if these will help, but

 

http://steamcommunity.com/app/251570/discussions/0/558749825193321550/?l=romanian

 

https://steamcommunity.com/app/251570/discussions/0/135510669595536450/

Edited by PurgatoryWolf (see edit history)
Link to comment
Share on other sites

Try adding an explicit exception for 7Day2Die folder and executable in your AntiVirus. That has solved it for others.

 

Seems I have been running into this more recently as well, stuttering every now and then. However I do have my base in the nuclear power plant, so there is that as well could possibly be the size of the POI causing it to lag out like crazy every now and then.

 

Are there any blocks in particular I can remove from the power plant to reduce the lag there? I already removed the 2 big chimneys that are there which helped a little, and destroyed the truck and spider nest.

 

(Also not using any antivirus, so nothing I can do on the exe and folder to try helping it)

 

Specs:

Samsung EVO SSD

Intel i7 4790K @ 4.6 GHz

16GB Kingston HyperX Fury DDR3

EVGA GTX 970

 

Also a quick question about the severed zombie head... is it purely a decoration item? Seems that's about all it is, though it gives me the Hunted status when I go near it. Does it summon anything or trigger some sort of event?

Edited by mdf25 (see edit history)
Link to comment
Share on other sites

Also a quick question about the severed zombie head... is it purely a decoration item? Seems that's about all it is, though it gives me the Hunted status when I go near it. Does it summon anything or trigger some sort of event?

 

I never had.. wait... you can PLACE it? Oh my!

 

The nuclear power plant is one of the poi that is surprisingly LOW on lag for me despite its size. For me things like the middle levels of the skyscrapers are bad for example. Your lag might or might not be caused by the poi itself and instead by something self-placed or surrounding it, in which case you could modify to help with it. Did you put a layer of your own blocks on all the floor and roof blocks? Plant tons of fruit trees, big farm plots, many forges and candles? If that's the case, that might cause lag too. If not, it's possible there's a lot going on in the surrounding area. If you find another power plant, you could check if it's the same there.

 

I recently started playing a completely different 7dtd mod and though the amount of lag is overall lower (I'm pretty much at the start too, so that's when I get a lot less lag in starvation as well) I have the same kind of micro-freezes A16 starvation is giving me. Is it possibly something A16 Vanilla related?

Link to comment
Share on other sites

About : Farmer

 

Bug fixes submitted for next patch, hopefully drops next weekend: 1. fix of IcyFarmerstorage, should last about 2 realtime hours before needing more ice (may replace this with another method later), ...
Any news about the patch? Some of us are waiting very hard, cause a farmer that needs your interaction each 3h ingame, is useless. 2nd Question: The Farmer seems to have another heavy bug. Sometimes you switch the plants that she have to grow. Maybe from Sunflower (tear Low) to Onion (tear Medium). At this time a big part of the bed is planted with Sunflowers that will grow up. But the Farmer is now set to "medium" and plants/harvest onions. The Sunflowers from "Low" that reach maturity, cant be harvested by the farmer, because the Farmer is set to medium-plants and they are wasting the acre. If i must harvest these plants by myself, each time i change the level, i would ask myself, for what is the farmer needet? Is it possible to edit the farmer, that he will harvest "all" plants in range that reached maturity, but only build seed and plant what he is told? Sorry for unformated text, but today im not able to format and no WYSIWYG is possible for me. Edited by PadreNostrum (see edit history)
Link to comment
Share on other sites

Any news about the patch? Some of us are waiting very hard, cause a farmer that needs your interaction each 3h ingame, is useless.

 

Look at that, one by one they come being annoyed by the farm storage. When I complained right after the patch rolled out and Mortelentus called the farmer an unpopular feature you made me look like I was the only one bothered by it ^^.

 

 

2nd Question: The Farmer seems to have another heavy bug...

 

I don't think that's a bug at all, it's the way that mechanic works. Well, if you suggest harvesting all of the plants in range as a quality of life feature, I'm all for it, as long as it doesn't cost tons of more resources. As in: doesn't cause more lag because the farmgirl now looking for 20 mature plant types instead of 6. In that case I rather manually punch out the seeds. Not that bad of an inconvenience anyway.

Link to comment
Share on other sites

I never had.. wait... you can PLACE it? Oh my!

 

The nuclear power plant is one of the poi that is surprisingly LOW on lag for me despite its size. For me things like the middle levels of the skyscrapers are bad for example. Your lag might or might not be caused by the poi itself and instead by something self-placed or surrounding it, in which case you could modify to help with it. Did you put a layer of your own blocks on all the floor and roof blocks? Plant tons of fruit trees, big farm plots, many forges and candles? If that's the case, that might cause lag too. If not, it's possible there's a lot going on in the surrounding area. If you find another power plant, you could check if it's the same there.

 

I recently started playing a completely different 7dtd mod and though the amount of lag is overall lower (I'm pretty much at the start too, so that's when I get a lot less lag in starvation as well) I have the same kind of micro-freezes A16 starvation is giving me. Is it possibly something A16 Vanilla related?

 

Yup you can place down the zombie head and when you get near it, it yells "They're coming for you!" and your status becomes hunted.

 

In terms of my setup at the nuclear plant POI I have to say not much is going on in or around the area. The only lights I have on at the power plant is 7x bug lights, 6 over my farm area (3 rows of 18x3 plots) and 1 near to the bees to allow them to have flowers around. I have 6 forges, 2 big forges, a gun bench and one of every other workstation. I have a smith, mechanic and cook, but no farmer (she's useless now that cold storage degrades and she can't interact with regular farm storage - huh...?) Anyways - around the power plant there is a forest biome with a town either side but not in a rendered chunk, one is over a mountain and the other is a 2 minute drive on the minibike away. Most trees in the area are gone. It seems like very little should be causing lag for me but even with all power off, it goes mental sometimes. In my other world I found the power plant as well, same thing. Tons of lag there but luckily my base isn't there in the other world :)

Link to comment
Share on other sites

My base wasn't laggy until my partner placed a bunch of spikes around the top. Now it lags like a mofo, especially when horde night rolls in.

 

one of my friends placed his talking head by his entrance and the head disappeared after a few min.. does weather "kill" the head like it does animals??

Link to comment
Share on other sites

Yup you can place down the zombie head and when you get near it, it yells "They're coming for you!" and your status becomes hunted.

Awesome. I need to give it a closer examination.

 

So, you seem to have placed only a modest amount of workbenches and stuff. Maybe it's best to just move to a new location and just leave the NPC at the nuclear power plant. At the beginning I had a very lag producing base because I stacked everything inside a few chunks (I believe that's the reason) in an abandoned building inside a town (probably a second reason). Then when I had to restart, I dug out underground rooms 1 above bedrock in a mostly empty place close to a trader. I placed the rooms' centers at the intersection of four chunks and had some blocks between the rooms, so I ended up mostly with 5 square rooms and a square plaza (to turn around minibike) all spread over 24 chunks. You can "see" chunk borders underground if you set the texture size and quality to low, because then you can easily see the seam where you dig into the wall separating two chunks. What can I say, I never had a base with this much stuff and this low lag before, so I guess I'm in team mountain dwarf now.

 

My base wasn't laggy until my partner placed a bunch of spikes around the top. Now it lags like a mofo, especially when horde night rolls in.

A "bunch" more like in 50-100 or a carpet of spikes as far as the render distance can see? ^^ Maybe if you established a separate horde night defense structure, you could get rid of most spikes again.

Link to comment
Share on other sites

I play on a MP server, and setting in chunks like that would block all for of those chunks from getting their weekly repaint. (when we do a clean and refresh areas with no LCBS back to default)

 

more like 300-500 spikes, lolol. ill be replacing them with something else soon as i figure out what i want to make.

Link to comment
Share on other sites

Hanging at "loading main menu"

 

First time modding 7 Days. Installed 7D2D Launcher, located StarvationMod16, copied game from an existing copy and performed the Pre-Sync Mod. It kept failing to download files from Github saying "error downloading cleaning corrupted data". I saw a fix posted about the new TLS standard which I applied since I am using Windows 7, rebooted and still having problems. So I checked the "Direct Download" which downloads the .zip, extracts and then when I click Play Mod is copies over the content and loads the game. But it hangs at "loading main menu" and never goes any further. Only items that are checked at "refresh mods automatically", "update registry" and I have "direct download" checked only when I need to directly download the entire .zip for updates but I have that unchecked after the initial download. I've tried toggling EAC and UNET and nothing seems to help me get past the hang. I've verified my 7 Day game via steam, uninstalled an reinstalled. I made sure I have Alpha 16.4. My friend did everything the same and he was able to download the mod without direct download just fine and it loads fine. However, he is using Windows 10. I have disabled Avast during all this.

 

Any suggestions?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...