Jump to content

How to remove smoke particle effects from burnt forest?


Recommended Posts

I asked this on the Steam forums quite a while back but never got an answer. Does anyone know how to go about removing (Or better yet, just massively reducing) the smoke particle effect from the burnt forest biome?


May just be a quirk of my computer setup, but I'm basically entirely blind any time I go into the burnt forest, to the point that it's unplayable. I don't mind that I can't see the zombies, but I can't even see buildings until I'm on top of them, so it's basically impossible to explore the burnt forest areas.


I tried commenting out this line in biomes.xml, but it had no effect:

<ParticleEffect prefab="ParticleEffects/p_smokestorm" ChunkMargin="7"/>


Anyone have any idea?

Link to comment
Share on other sites

It doesn't seem to be a cloud thickness issue. I've already set the clout thickness to be the same as I've set it in most other biomes:

                       <CloudThickness min="0" max="0" prob=".7"/>
		<CloudThickness min="10" max="70" prob=".2"/>
		<CloudThickness min="100" max="100" prob=".1"/>


So it should be at zero 70% of the time. But I'm still as blind as ever in the burnt forest. Even removing the latter two lines and having only one CloudThickness line like so:

<CloudThickness min="0" max="0" prob="1"/>


...doesn't eliminate the problem.

Link to comment
Share on other sites

Pretty sure you weren't looking at the burnt_forest section, as there should only be one line there. I already changed mine but iirc it originally read <CloudThickness min="80" max="100" prob="1"/>


As was recently posted as a reply in bug reports, open the console (F1 for me) and enter "weather clouds 0" to test if clouds are the right setting. If so, go into your biomes.xml and press Ctrl+F, then type in burnt_ and search for the right section to edit. The second code you posted should fix it. You may also want to find out which section you changed and change it back to what it was.

Link to comment
Share on other sites

There are a couple settings to change and I am not 100% sure which ones have the most impact:


In <biome name="burnt_forest" biomemapcolor="#ba00ff" >


thy using this





<Temperature min="0" max="20" prob="1"/>

<Fog min="0" max="0" prob="1"/>

<CloudThickness min="81" max="100" prob="1"/>

<Wind min="10" max="20" prob="0.9"/>

<Wind min="20" max="100" prob="0.1"/>

<Precipitation min="0" max="0" prob="0.0"/>

<Precipitation min="50" max="100" prob="0.25"/>

<ParticleEffect prefab="ParticleEffects/p_sandstorm" ChunkMargin="14"/>

<ParticleEffect prefab="ParticleEffects/p_snowstorm1" ChunkMargin="9"/>

<ParticleEffect prefab="ParticleEffects/p_smokestorm" ChunkMargin="3"/>

<ParticleEffect prefab="ParticleEffects/p_hotembers" ChunkMargin="1"/>









<spectrum name="pine_forest" />

<terrain class="Water" />


Link to comment
Share on other sites

  • 1 year later...

Ambient Lighting



<Temperature min="20" max="40" prob="1"/> <!--This is my personal setting-->

<Fog min="0" max="0" prob="1"/>

<CloudThickness min="0" max="39" prob="1"/>

<Precipitation min="0" max="0" prob="1"/>

<Wind min="0" max="100" prob="1"/> <!--Suggestion Change the 100 t0 40 or less -->

<ParticleEffect prefab="ParticleEffects/p_smokestorm" ChunkMargin="7"/>



Always first step is make a copy of your original file for just in case.


Copy and paste this weather section in place of yours.


copy and paste all particle storm emitters you don't want to Radiated biome

then comment or delete them from the other biomes.



Keep one line for each of the environmental settings

Key point is in each one set prob to 1 that means 100%.


Clouds 0 to 39 does not mess with ambient lighting so much 39 is cutoff; 40

and it gets noticably darker and thicker.


Fog set as above


precipitation set as above, 70 and it fogs up and rains all the time.


wind need some it move the particles around like a curtain, no wind they stay condensed

100 and it plays entire lp sound, sample ends wtih "wave crashing on rocks" max at 50


After edits this will help clear up area visually. If not enough refer to my

tut on ambiet lighting, Should help take control of it to next level.


Notes: Gamma affects this ara, mine is set at 51,

*******You can copy <spectrum name="wasteland" />

or any of the other spectrums to the burnt_forest to adjust light color scheme.

Pine is brighter sun, desert is softer orange,

forest is similar to pine but darker greens, wasteland and radiated have the fog

shield incorporated, with reddish sunlight and green ambient.********

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...