Jump to content
Sign in to follow this  
Xtrakicking

Zombie Texture Replacement

Recommended Posts

Update! A18.1 Stable version, now avaliable!

 

Is there a new, non-experimental build?

 

My latest STABLE is 18 b155.

 

Also, my folder structure is not the same as the readme file.

 

Mod:

C:\Program Files (x86)\Steam\SteamApps\common\7 Days To Die\Data\7DaysToDie_Data

 

Mine:

C:\Program Files (x86)\Steam\SteamApps\common\7 Days To Die\7DaysToDie_Data

 

When I replace the resources.assets file, the game crashes on startup.

 

 

edit: Nevermind, realizing that the author was incorrect on the version of the game. 18.1 is the latest experimental, NOT STABLE.

 

As far as that folder structure; it seems to be wrong as well?

 

Might wanna adjust that in the OP.

Edited by optyk (see edit history)

Share this post


Link to post
Share on other sites
SNIP

 

Mhh, that's interesting. Could've swore the A18.1 had already jumped to stable. Guess I was wrong, indeed.

 

Fixed that in the OP!

 

Edit: I also fixed the error of the folder structure in the readme file. Not sure why that was wrong (can't tell if they've changed it), but considering the sheer complexity of the instructions, it's quite the facepalm to have that wrong. My bad :p

Edited by Xtrakicking (see edit history)

Share this post


Link to post
Share on other sites

All good man!

 

I'll keep my eye on this for when you do a stable release! Keeping up on experimental mods is a giant PITA =P

Share this post


Link to post
Share on other sites

FYI Since the experimental has been updated I found that the resources.assets file got replaced. I'm not sure if they replaced it with the same one from the previous Experimental build or if they made changes to that file for the new Experimental...?

 

Do you reckon that it is ok to replace it with this mods resources.assets larger 380mb file....?

Just concerned in case they made changes to it with the latest build.

Share this post


Link to post
Share on other sites

Is there a way to do a DEDI version of this so both files match ? So you can add this to a client & still keep EAC on, Currently if you apply this it errors saying they dont match which means disabling EAC which id rather not do, Thanks

Share this post


Link to post
Share on other sites
FYI Since the experimental has been updated I found that the resources.assets file got replaced. I'm not sure if they replaced it with the same one from the previous Experimental build or if they made changes to that file for the new Experimental...?

 

Do you reckon that it is ok to replace it with this mods resources.assets larger 380mb file....?

Just concerned in case they made changes to it with the latest build.

 

Hi! Yeah, I just noticed they released a new Exp build. There's usually incompatibility issues with the resources.assets files if they're not from the same build, which is why I have to update the mod with every update until I find time to automate it.

 

I'll update the mod for 18.1 b4 as soon as possible.

 

Edit: Actually, I think since stable has released, I'm going to do stable versions only for the time being. A18, coming right up.

Edited by Xtrakicking (see edit history)

Share this post


Link to post
Share on other sites
Is there a way to do a DEDI version of this so both files match ? So you can add this to a client & still keep EAC on, Currently if you apply this it errors saying they dont match which means disabling EAC which id rather not do, Thanks

 

EAC, as far as I'm concerned, isn't compatible with client-side modding, nor with any modding that has to do with the assets files. This means it needs to be disabled, unfortunately.

Edited by Xtrakicking (see edit history)

Share this post


Link to post
Share on other sites
Updated for A18 Stable version!

 

Ooo very cool! Thanks!

 

As much as I like running the latest changes to this game, keeping mods going on EXP versions is almost impossible.

Share this post


Link to post
Share on other sites
Ooo very cool! Thanks!

 

As much as I like running the latest changes to this game, keeping mods going on EXP versions is almost impossible.

 

Agreed. I mainly do them only when the stable version isn't out yet. After that, stable is always the priority.

 

Anyways, hope you like it!

Share this post


Link to post
Share on other sites

I tried installing this mod in Alpha 18 Stable but when it starts loading I get a square saying "UNITY" on top, the 7daystodie icon with a red exclamation point and then the game crashes.

Any ideas?

Share this post


Link to post
Share on other sites
I tried installing this mod in Alpha 18 Stable but when it starts loading I get a square saying "UNITY" on top, the 7daystodie icon with a red exclamation point and then the game crashes.

Any ideas?

 

Might be that you are not running the same version for which it was made (18.0b155), I also received this message but I expect (my assumption) it's because I am on 18.1b8.

Share this post


Link to post
Share on other sites

These are so good! Any chance of a modlet version so they would add on and not replace the zombies outright?

Share this post


Link to post
Share on other sites
These are so good! Any chance of a modlet version so they would add on and not replace the zombies outright?

 

I'm planning on upgrading the mod to make it use xpath in the future. This, I heard, will allow me to make it an add on instead of a replacement. It'll also give me the benefit of not having to pop a new file with every new alpha.

 

I have also other ideas in mind to add more awesome things; it's just that sadly I don't have much time right now to get to all of it. But I definitely will as soon as I can.

Share this post


Link to post
Share on other sites

Hi. Thx for the Mod.

 

But it doesnt work in 18.1 on my dedicated Server.

I become red errors and the the Srever closes.

 

Client and Server on the same build 18.1 b8

 

I copied the assets in the gamefolder.

What did i wrong?

 

thx

Share this post


Link to post
Share on other sites
Hi. Thx for the Mod.

 

But it doesnt work in 18.1 on my dedicated Server.

I become red errors and the the Srever closes.

 

Client and Server on the same build 18.1 b8

 

I copied the assets in the gamefolder.

What did i wrong?

 

thx

 

Do you have any other mods installed?

 

Try creating a singleplayer game and see if it works. If it does, then the problem most likely originates from the server. If it doesn't, try validating the game files on Steam, and install the mod again (note that this will remove any modifications you may have in the XML/asset files).

Share this post


Link to post
Share on other sites

@Xtrakicking, thanks for the 18.1b8 version.

 

It's a shame though it overwrite the resources.asssets file as now I have the hard task of choosing between these awesome zombies and the cool biome and time specific lighting from DUST2DEATH's HDHQ pack.

I'm assuming this is some kind of special Unity file with assets inside?

As his is doing biome lighting and yours is zombie textures they must be referencing or including different assets / textures?

Is there any way you and he can collaborate or patch this so both mods work as it will be hard to choose, they are both great visual improvments.

His mod is over here: https://7daystodie.com/forums/showthread.php?86145-HDHQ-Textures-Lighting-Environment&highlight=hdhq

It's also here: https://www.nexusmods.com/7daystodie/mods/133?tab=files (the first 152mb file for 18.1b8)

 

Hi. Thx for the Mod.

 

But it doesnt work in 18.1 on my dedicated Server.

I become red errors and the the Srever closes.

 

Client and Server on the same build 18.1 b8

 

I copied the assets in the gamefolder.

What did i wrong?

 

thx

 

Try simply not using this on the server and only your client, if my memory serves me right I thought I read somewhere you don't need this on a server because it's basically just telling the client what textures to render the zombies in therefore it has nothing to do server side nor does the server care what you make the zombies look like.

 

In summary: Try it out and see if you can run your client / server setup with the mod installed client side only.

Edited by Reytag (see edit history)

Share this post


Link to post
Share on other sites

i know its a big PITA but you really should make this the other way since i think all the issues and requests people is having will get sorted with the other method, and they love this pack so you have to fix it every alpha. at the end the other way is less work.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...