Jump to content

Zombie Texture Replacement


Recommended Posts

My anecdotal experience is running out of texture memory, but I don't think that's your issue... Try 1/8th textures in video settings just in case though.

 

I had the same thought, and I tried all the lowest settings. The pinkness remains.

 

But as someone who's recently delved into what that mod does, all it does is replace the existing texture in the atlas with an edited one, which should leave the normal map, diffuse map, occlusion map, and specular map alone. So, it /shouldn't/ be affected by video settings any more than vanilla.

 

Thanks, I appreciate your experience in this. I relate the pink problem to shaders because Google suggested it. Here's one I followed to the Unity docs: https://support.unity3d.com/hc/en-us/articles/208380753-Shaders-are-pink-when-loaded-from-an-AssetBundle

 

If you have any spare time, perhaps that might interest you.

 

I assume you have re downloaded and are using the launcher? Something may have gone wrong.

I am on Linux, so the launcher is not a thing. I have manually installed True Survival. It suggests the use of the "Z Texture pack" (ZTP). I actually cannot download the ZTP because that mega.nz website doesn't like Firefox — I dunno why!

 

A nice member on this forum (Prisma501) actually fetched it and put it on another URL for me. That's how I got it.

 

Even without the ZTP installed, I have a similar problem in True Survival. (It's the only mod I've ever tried, so that's all I can describe.)

 

In TS there are several new assets. Two of them (palm trees and spiders) are pure pink. Maybe more stuff is, but I've not played long. I am assuming that their asset files must have been made in a similar way to the ZTP of this thread.

 

That's my best attempt to describe the pink problem! I hope you have an idea. :)

Link to post
Share on other sites

The new assets would be pretextured so it seems to point to something other than the asset files, which just use a texture atlas xtra edits (or individual image files).

 

Hm, I wish I had more nix experience for you, and could just say "use this version of drivers", but I don't.

 

At any rate, I'm still inclined to believe it's Linux specific and not the mod, but that perhaps the mod exacerbates the problem.

 

Hit up um, spectral force, he uses Linux and plays with mods.

 

- - - Updated - - -

 

Hell, I guess it could be true survival; try this... Play vanilla with ONLY xtras asset files.

Link to post
Share on other sites
Hm, I wish I had more nix experience for you, and could just say "use this version of drivers", but I don't.

 

No problem. Thanks for your input.

 

At any rate, I'm still inclined to believe it's Linux specific and not the mod, but that perhaps the mod exacerbates the problem.

 

Yeah. It's either Linux and/or OpenGL and/or my small Nvidia card.

 

Hit up um, spectral force, he uses Linux and plays with mods.

 

Cool, thanks. I will look him up.

 

- - - Updated - - -

 

Hell, I guess it could be true survival; try this... Play vanilla with ONLY xtras asset files.

 

 

Oh ho! Good plan. I shall try it asafp! :D

Link to post
Share on other sites

So, Guppycur, your idea was great. Here's what happened:

 

Vanilla 16.2

+ the ZTP

+ 7 Days built-in launcher (*) -> where I chose the "GL Core" setting. (* not the mod launcher, to clarify.)

+ Maxed my Nvidia settings

= Worked fine. I see all the new Z textures (creepy!)

 

True Survival 16.2

+ the ZTP

+ "GL Core"

+ Maxed Nvidia

= Also fine, for the ZTP, but I still have pink palm trees and potatoes.

 

(When I do not choose "GL Core", the pink comes back in all permutations of the trials I did.)

 

So, a mixed result. The ZTP seem to be fine. True Survival's textures have pink problems. (I don't know if this is unique to TS or if assets it shares with other mods have the same problem.)

 

Maybe if I started a new True Survival game with the settings above, it would be different. I can't imagine starting TS over from scratch. I think I'd rather chop a leg off and beat myself senseless with it. TS is tense man! :D

 

Thanks for your help. Very cool.

 

Hope this helps the odd Linux gamer out there!

Link to post
Share on other sites
  • 3 weeks later...
Can we install this into our public server, is it compatible?

 

Cheers,

 

They are loaded clientside. They will not push to clients from a server. Server doesnt even need to have them installed.

 

One thing the server needs is EAC off though as the clients that use this mod will have to turn it off.

 

Cheers

Link to post
Share on other sites
They are loaded clientside. They will not push to clients from a server. Server doesnt even need to have them installed.

 

One thing the server needs is EAC off though as the clients that use this mod will have to turn it off.

 

Cheers

 

So that's the reason why the server crash everything we try to implement the mod into it?

 

It's only meant for the client, not server side.

 

Cheers,

Link to post
Share on other sites
  • 8 months later...
Guest Nyteshade12134

Thanks for updating. Hope you are saving, and will continue to improve, the A16.4 version as well. As far as I know, you are the ONLY modder who does skins.

Link to post
Share on other sites
Thanks for updating. Hope you are saving, and will continue to improve, the A16.4 version as well. As far as I know, you are the ONLY modder who does skins.

 

No worries, I've got all the versions still with me. Whenever I got the time to add new zombies, I'll be glad to make versions for previous alphas as well.

Link to post
Share on other sites
  • 2 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...