Jump to content
Pille

Prefab Editor (Alpha)

Recommended Posts

Can't. Once it's seen, it cannot be unseen.

Just pretend there's nothing there.

Share this post


Link to post
Share on other sites
Ignore this post.

 

Huh what post? *Looks Around*

 

I will brave the a18 convertor with the prison tonight..wish me luck....😎👍

Share this post


Link to post
Share on other sites

Hi. My suggestion: Make an air prefab (consisting of only air block) that has the same size as your POI and add the corresponding entry above the entry for the prison in the prefabs.xml. I think Guppy had the same problem with my ship. There was water in it that belonged to the custom world. Unfortunately, the air prefab trick didn't work but but perhaps you can use it to remove those trees. Not sure.

Share this post


Link to post
Share on other sites
Hi. My suggestion: Make an air prefab (consisting of only air block) that has the same size as your POI and add the corresponding entry above the entry for the prison in the prefabs.xml. I think Guppy had the same problem with my ship. There was water in it that belonged to the custom world. Unfortunately, the air prefab trick didn't work but but perhaps you can use it to remove those trees. Not sure.

 

Thanks for the idea, I will give that a shot. Side note, after the conversion to a18 inget slot of texture white text messages in the console. Are those anything to be worried about?

Share this post


Link to post
Share on other sites

Pille,

 

Can you advise how to get the 7daystodie tab to work so I can view the prefab as it will look in game? When I click on the tab, all I am getting is a white screen.

 

War and Peace,

UnknownSoldier

 

P.S. Thanks a million for this tool. Now I can review all of the compo packs and make sure no one is being overly enthusiastic about loot boxes, or secret rooms to not-cheat finding. And get rid of the horribly designed ones.

Share this post


Link to post
Share on other sites
*Steps to convert prefab*

 

Unfortunately this didn't work for me.

I was meticulous about the steps, but the prefab still refuses to load into a new RWG world :(

No warnings, and the prefab loads fine in the prefab editor, just not into a world.

Share this post


Link to post
Share on other sites

Hallo Pille!

You can tell me briefly what the files contain."ins"?

And, for what now need <property class= "Stats"> in prefab-xml?

Share this post


Link to post
Share on other sites

Pille mate

 

I am trying to fix some textures missing on blocks in my prefab. Yeh every time I do it it doesn't work :'( are you able to take a look for me at all please

Share this post


Link to post
Share on other sites
Pille,

 

Can you advise how to get the 7daystodie tab to work so I can view the prefab as it will look in game? When I click on the tab, all I am getting is a white screen.

 

War and Peace,

UnknownSoldier

 

P.S. Thanks a million for this tool. Now I can review all of the compo packs and make sure no one is being overly enthusiastic about loot boxes, or secret rooms to not-cheat finding. And get rid of the horribly designed ones.

That's not implemented yet, sorry. I am waiting for a more stable base game, where stable means that no drastic changes are to be expected.

 

 

Unfortunately this didn't work for me.

I was meticulous about the steps, but the prefab still refuses to load into a new RWG world :(

No warnings, and the prefab loads fine in the prefab editor, just not into a world.

Probably a bug related to the random world generator. How big is the prefab? No warnings in the ingame prefab editor usually means the problem is connected to the rwg.

 

 

Hallo Pille!

You can tell me briefly what the files contain."ins"?

And, for what now need <property class= "Stats"> in prefab-xml?

.Ins - No clue. But it must be something optional. "the stats are not used by the game so far, informational only" - Alloc. Stats can be somehow used to optimize the performance of a prefab. That's my theory deduced from the patch notes and Alloc confirmed it more or less.^^

 

 

Pille mate

 

I am trying to fix some textures missing on blocks in my prefab. Yeh every time I do it it doesn't work :'( are you able to take a look for me at all please

He's already been helped. :)

Edited by Pille (see edit history)

Share this post


Link to post
Share on other sites
No, I don't have informed them but others might have. I dunno. Since they will ignore A17 bugreports, it makes sense to wait for A18... I don't want to update the editor atm. since A18 could make my attempts to fix the problem obsolete.

 

(post #1118)

 

You were absolutely right about that. In A18 all the sleeper volumes shifting problems have disappeared! :smile-new:

Share this post


Link to post
Share on other sites
(post #1118)

 

You were absolutely right about that. In A18 all the sleeper volumes shifting problems have disappeared! :smile-new:

 

Oh nice, really? Or is this a ironic smile? ^^

Share this post


Link to post
Share on other sites

Hello, thanks very much for you soft! But why zombie don't build a .mesh too? I need it for many modded prefab!

 

Modder's convert their prefab very well to a18 but the .mesh still be a old version untouched for a16/a17 & in game, this cause a weird graphic bug with a18! Sudently, texture of block change in another something wrong texture or all container become a block with weird texture, destroy them they still be here visibility...

 

Or there is a way to build prefab .mesh files, please? Thanks for any answer.

Share this post


Link to post
Share on other sites

Or there is a way to build prefab .mesh files, please? Thanks for any answer.

 

Why not using the ingame editor to build the mesh after converting the prefab?:

 

* load the converted POI into the ingame editor

* press escape and click the button update imposter

 

Alternatively to the second step, you could use the following 3 console commands to generate or update the mesh file:

 

prefab simplify

prefab combine

prefab export

 

Do not save the prefab after using the commands but reload its original version.

Share this post


Link to post
Share on other sites
Why not using the ingame editor to build the mesh after converting the prefab?:

 

* load the converted POI into the ingame editor

* press escape and click the button update imposter

 

Alternatively to the second step, you could use the following 3 console commands to generate or update the mesh file:

 

prefab simplify

prefab combine

prefab export

 

Do not save the prefab after using the commands but reload its original version.

 

Ah oky, so we can build it & it's not automatic but manual... Thanks you very much!

I try with one prefab quickly & seem be no problem anymore in game...

There's many some other prefab, I will take my time to do all this week-end & see if all is oky...

  • Like 1

Share this post


Link to post
Share on other sites

Changelog 0.84©

 

* added option to disable static entity spawning xml entries

* added about 17 new class symbols

* added option to disable new class symbols (to avoid possible performance impact)

* added console command: randomize id, randomize rotation, randomize density (type help in system tab for more information)

* added console command (nitrogen) and button (extras->generate nitrogen parameters) to print the nitrogen parameter list and to copy it to the clipboard (after clicking the button, open a text editor and press CTRL + V to get the nitrogen line)

* fixed: old .pille files may causes crashes of the editor

* preliminary end of 32-bit support

 

* known issues: sometimes allowedTownship wilderness is not saved in the xml file

Edited by Pille (see edit history)
  • Like 1

Share this post


Link to post
Share on other sites

Hallo!

 

* added option to disable static entity spawning xml entries

what static entity spawning?...did I miss something?

 

************************************************** ************************************************** *************

I was doing painting in the built-in editor and I often had to hide blocks that belong to the decor type.

You know which parameter in the code indicates that the block belongs to the decor ?

(What would the checkmark in the built-in editor disable their display. I have a feeling that this is not in the block.xml...)

Edited by n2n1 (see edit history)

Share this post


Link to post
Share on other sites
Posted (edited)

Sorry for the late reply. Pille was busy finishing the spring cleaning. lol

Hallo!

what static entity spawning?...did I miss something?

Not sure but it's very old deprecated stuff. Magoli requested an option to turn it off to keep the xml clean.^^

 

************************************************** ************************************************** *************

I was doing painting in the built-in editor and I often had to hide blocks that belong to the decor type.

You know which parameter in the code indicates that the block belongs to the decor ?

(What would the checkmark in the built-in editor disable their display. I have a feeling that this is not in the block.xml...)

 

Must be related to the filter tags:

<property name="FilterTags" value="fdecor"/>

 

The 'show decor' checkbox in the ingame editor doesn't work for me for some reason.

Edited by Pille (see edit history)

Share this post


Link to post
Share on other sites
Posted (edited)
Sorry for the late reply...

I've been here a long time - I already know all the timings :)

 

Yes, think i went through all the settings in the block.xml, tried the classes... I didn't get anywhere there.

It would be strange to see this hard-coded...

Edited by n2n1 (see edit history)

Share this post


Link to post
Share on other sites

I've been here a long time - I already know all the timings :)

 

Yes, think i went through all the settings in the block.xml, tried the classes... I didn't get anywhere there.

It would be strange to see this hard-coded...

 

So um ... problem solved?

Share this post


Link to post
Share on other sites

No, i just confirm that I didn't find a way either.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...