Jump to content

Prefab Editor (Alpha)


Pille
 Share

Recommended Posts

lol, = _)

 

- - - Updated - - -

 

 

 

You still need testers? If its EAC compliant Ill do it on a live MP server if not, I'll pass to one of my admins to bugger one of his SP games hah = ) nice work either way.

 

Lol it works with neither lol.....

 

Use either Hals bbb commands (sp & mp) or stompynzs api mod (mp only) in game. export then use pilles editor externally to do the rest.

Edited by stallionsden (see edit history)
Link to comment
Share on other sites

Hey guys,

 

I need your help. Please, can anyone explain the trader parameters in the prefab xml files? I am talking about 'area protect', 'teleport size' and 'teleport center'.

 

 

Thanks in advance (even if you don't intend to help me^^).

 

 

@Aribo

Ohh sorry, I hadn't seen your question. Fortunately stallionsden was here.:)

Edited by Pille (see edit history)
Link to comment
Share on other sites

Hmm, I've downloaded the file and tried to start zombie.exe, but windows 10 won't let me, not even as administrator. SmartScreen Defender is blocking execution of this probably Malicious software. there is no option to override. I have downloaded the 64bit version. What's up with that?

 

a'ight, one can right click the exe, and allow it there. for some reason the option didn't show in the original window. fixed!

 

Now to find out how to make a light actually work ^^

Edited by ecv
found out myself (see edit history)
Link to comment
Share on other sites

that was what threw me, the button was not there :) i really had to right click the exe and tick a box in the settings.

 

so i have managed to switch on four lights, but they all rotated to the same angle and also the light was directed in weird directions ^^ seems like it's not so trivial to just switch on a ligh source :)

 

i've located it in the matrix, entered the blockid on the righ and put meta to 2. lights ON! but do i really have to enter each and every value for all fields? they dont seem to get filled in on select

Link to comment
Share on other sites

Mhh not sure what you mean but I think you should use the 'meta' button (next to the meta edit field) instead of the 'set all' button. Or use the middle mouse button (see below).

 

7RWo3FR.png

 

 

i've located it in the matrix, entered the blockid on the righ and put meta to 2. lights ON! but do i really have to enter each and every value for all fields?

 

No, just click the middle mouse button to copy all properties of the block below the cursor to the matrix.

Edited by Pille (see edit history)
Link to comment
Share on other sites

Hey guys,

 

I need your help. Please, can anyone explain the trader parameters in the prefab xml files? I am talking about 'area protect', 'teleport size' and 'teleport center'.

 

 

Thanks in advance (even if you don't intend to help me^^).

 

 

I don't think the y does anything, but here is my take:

 

TraderAreaTeleportCenter tells the other two where Center is. in say, trader_03 it's 1 to the right of what the center of the prefab is, and then that leads to:

 

TraderAreaProtect is likely an idea they had but does nothing in reality, because they tied it to traderAreaTeleportSize

 

traderAreaTeleportSize goes out from center. So in trader_03 x is 41 from center in either direction, y is 24 up and down from center , and z is 40 in either direction.

 

I have done ZERO tests to confirm this.

Link to comment
Share on other sites

Hi n2n1,

 

just a few questions:

 

What kind of error do you get?

How often (always or just sometimes)? Sounds like a sporadically occurring issue?

 

 

Anyway, I am going to make some tests on my old windows 7 machine. :)

 

 

@Guppycur

Where is the vid? :p It's hard to fix because the xray works perfectly fine on my computer.

Edited by Pille (see edit history)
Link to comment
Share on other sites

Ah, sorry, of course - i get a crash, not an error.

 

This is manifested often (50-70%).

 

There is some sort of regularity for this:

If I load the prefab and start to adding columns/rows and i get the crash - then at the next attempt to do the same myself in the same way - 95% Editor crash. I can repeat it ten times. If I change my sequence of mouse clicks (do some other action on this prefab) and only after this i manage to adding columns/rows.

 

In relation to other functions (which i use) - the Editor never gave failures.

 

EDIT: oopps....i did it again, sorry :D

Edited by n2n1 (see edit history)
Link to comment
Share on other sites

Mhh being confused now.^^

 

adding rows/columns.

 

If I load the prefab and start to remove columns/rows, and i get the crash

 

I assume you're talking about removing columns/rows. Can you send me the prefab files (would be extremely helpful)?

 

I think I should add a log file (at least for the remove columns/rows function). This should help me to find the error/reason for the crash very easily. There will be an update next week...

 

 

Edit:

Well that's strange. Adding columns/rows shouldn't cause crashes.^^ But as I said, I going to provide an update in a few days.

 

@all

Does anyone else encounter n2n1's issue?

Edited by Pille (see edit history)
Link to comment
Share on other sites

I wanted to say "adding", removing - works well.

It seems no matter what prefab is. But next time I'll pay attention to it and if I will be able to artificially repeat the crash then I'll send this prefab.....

.....hmmmmm.....but my block.xml is completely incompatible with vanilla.....

Edited by n2n1 (see edit history)
Link to comment
Share on other sites

Just for notice, maybe this will help.

- after installing version 0.3 z© - crash due to "removing rows/columns" - began to appear almost always and i had to revert back to version 0.3z. - and the errors almost stopped again.

 

....OOOO!!!! fff***Shhhhh***** !!!!

 

... Before I also wrote it wrong...:frusty:

Edited by n2n1 (see edit history)
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...