Jump to content

Prefab Editor (Alpha)


Pille
 Share

Recommended Posts

Just an idea for custom mines:

 

 

7Wuejz0.jpg

 

side view (the blue line represent the sleeper volume):

 

LqLSpVM.jpg

 

We think alike. I came up with the same idea but slightly different. My variation involved a sleeper fully enclosed by barrels. Waking the sleeper would cause it to claw away and BOOM.

 

Was saving the idea for a new prefab i had planned.

 

I like the idea of throwing the mine in there. Ensures detonation as long as the sleeper spawns in.

Edited by Laz Man (see edit history)
Link to comment
Share on other sites

Hey Pille!

 

I haven't figured out how to do it or if it's been implemented yet, but does your editor support wiring electrical blocks together? Like a Solar Bank to a Battery Bank to a Relay To a Turret or anything like that?

 

No, that's why I'm about to run out of letters.^^ The main feature of version 0.4 will be electricity (0.2 was painting, 0.3 was about sleeper volumes). I've been quite busy the last few weeks and haven't really worked on the editor ... but I think 0.4 will be released this month.

 

 

Was saving the idea for a new prefab i had planned.

 

Mhrrr I want to have it now. ;)

Edited by Pille (see edit history)
Link to comment
Share on other sites

PILLE!

 

Feature request! lol. I know you're busy with real life. So just spew'n this stuff out there in case you'd like the same features.

 

Some new hot keys.

 

CTRL+S Switch to the Select Tool.

CTRL+E Switch to the Edit Tool.

CTRL+uh... CTRL+Q (left hand minimal reach)? Switch to the Block Picker Tool.

 

I'm finding that these are the absolute most common tools I switch around on. Being able to switch between these 3 especially and quickly would be amazing.

 

Thanks again for the awesome editor!

Link to comment
Share on other sites

PILLE!

 

Feature request! lol. I know you're busy with real life. So just spew'n this stuff out there in case you'd like the same features.

 

Some new hot keys.

 

CTRL+S Switch to the Select Tool.

CTRL+E Switch to the Edit Tool.

CTRL+uh... CTRL+Q (left hand minimal reach)? Switch to the Block Picker Tool.

 

I'm finding that these are the absolute most common tools I switch around on. Being able to switch between these 3 especially and quickly would be amazing.

 

Thanks again for the awesome editor!

 

Did you check the OP for the list of existing shortcuts? :p

Link to comment
Share on other sites

Hey Jackelmyer,

 

there is a (incomplete) list of available shortcuts in the opening post.

 

Mhh Ctrl + S (save prefab) is already implemented as well as a shortcut for the block picker tool (middle mouse button, I have to provide an additional shortcut though because the middle mouse button doesn't work with certain mouses. Don't know why). Hint: The block picker shortcut doesn't change the current mode and can be used in all modes.

 

There's also hotkeys for some of the other tools. However they're incomplete as you can see. What do you think about the shortcut shift + key for the tools (I already have plans with Ctrl + E and Ctrl + Q and most of the combinations containing the control key are assigned anyway)?

Edited by Pille (see edit history)
Link to comment
Share on other sites

For android users, u cant open the spoiler tag unless viewing in desktop view.

I don't like android users, so I don't care. ;-)

 

 

Random note: last time i saved via ctrl+s, it forces your view to side/front. Kinda annoying but not the end of the world. :p

 

Lol, this shouldn't happen, really strange. I'm going to change the shortcuts for the views. That will fix the issue.

Link to comment
Share on other sites

hey Pille

the block-coloring-function works perfect - i love it - thx for adding that

Now its so easy to find specific blocks :)

 

Request/Question:

 

Case: Tools/advanced - Texture-Replacing

 

Is it possible to fill in --KEEP OLD-- and --ANY-- to the advanced-Replacing-Tool (category: textures) ???

Link to comment
Share on other sites

Hi Magoli.

 

Yes, of course. It works already, however you have to enter it manually (since these two special entries aren't in the texture list).

 

 

Edit:

Looks a bit tricky though. Enter the new textures first... Maybe it's better the wait for the next release (probab. tuesday).

Edited by Pille (see edit history)
Link to comment
Share on other sites

Eh Pille,

 

Not sure if I'm doing something wrong or what, but in version 0.3W, I'm trying to load The Village Prefab. It's a pretty darn large prefab, which is one of the reasons I'm trying to open it up. Making a large prefab myself and looking for current large prefabs to see where the limits of "prefab size" may come into play.

 

But when I try to open The Village, the editor just stops responding and crashes. Turns into a "Not Responding" process after about 3-4 seconds and memory usage never goes higher than 375mb.

 

Environment:

AMD A10-7800 3.5GHz

16GB RAM (total memory usage never climbs over 3.3GB 20%)

NVIDIA GeForce GTX 750 Ti

7500RPM 1TB drive with 400gb+ free disk space remaining.

 

 

Editor Version: 0.3w

Prefab Link in description above.

 

Per Windows Event Viewer under Windows Logs/Applications

 

Faulting application name: Zombie.exe, version: 0.0.0.0, time stamp: 0x59a81c06

Faulting module name: Qt5Core.dll, version: 5.9.0.0, time stamp: 0x592827ae

Exception code: 0xc0000005

Fault offset: 0x00000000000b55ee

Faulting process id: 0x1b08

Faulting application start time: 0x01d324f6907a0882

Faulting application path: C:\Users\<editedout>\Desktop\Zombie (64 bit)\Zombie.exe

Faulting module path: C:\Users\<editedout>\Desktop\Zombie (64 bit)\Qt5Core.dll

Report Id: ee57bc71-3083-4397-abce-55052739be7c

Faulting package full name:

Faulting package-relative application ID:

Link to comment
Share on other sites

Eh Pille,

 

Not sure if I'm doing something wrong or what, but in version 0.3W, I'm trying to load The Village Prefab. It's a pretty darn large prefab, which is one of the reasons I'm trying to open it up. Making a large prefab myself and looking for current large prefabs to see where the limits of "prefab size" may come into play.

 

But when I try to open The Village, the editor just stops responding and crashes. Turns into a "Not Responding" process after about 3-4 seconds and memory usage never goes higher than 375mb.

 

Environment:

AMD A10-7800 3.5GHz

16GB RAM (total memory usage never climbs over 3.3GB 20%)

NVIDIA GeForce GTX 750 Ti

7500RPM 1TB drive with 400gb+ free disk space remaining.

 

 

Editor Version: 0.3w

Prefab Link in description above.

 

Per Windows Event Viewer under Windows Logs/Applications

 

Faulting application name: Zombie.exe, version: 0.0.0.0, time stamp: 0x59a81c06

Faulting module name: Qt5Core.dll, version: 5.9.0.0, time stamp: 0x592827ae

Exception code: 0xc0000005

Fault offset: 0x00000000000b55ee

Faulting process id: 0x1b08

Faulting application start time: 0x01d324f6907a0882

Faulting application path: C:\Users\<editedout>\Desktop\Zombie (64 bit)\Zombie.exe

Faulting module path: C:\Users\<editedout>\Desktop\Zombie (64 bit)\Qt5Core.dll

Report Id: ee57bc71-3083-4397-abce-55052739be7c

Faulting package full name:

Faulting package-relative application ID:

 

yep I confirm this also as I cant load the village now into the editor as it crashes on me where as previous version it worked fine. tried multiple times to

Link to comment
Share on other sites

my suggestion:

 

- add a checkbox or option - for that would not showing "sleeper volume".

sometimes it is a hindrance when working (can accidentally move it and not notice).

- i would like to be able to add any entity in prefab (as in HALL's Ed)

- some interface elements look like buttons (because of the extrusion effect), although they are not. For example: block color. I think it ruins immersion for the interface :D

 

I noticed that a new created "sleeper volume" (and moving existing) not saved in prefab.xml... i missed something or this has already been said?

 

by the way - the copy function of the block (the middle button) are very frequent for me. If it were possible - i would put it on the right button...

 

Of course - it's the little trifle - the Editor is Very good! :)

Edited by n2n1 (see edit history)
Link to comment
Share on other sites

And I'm glad that you didn't ask for a 3d view. ;)

 

my opinion about 3D-view.

of course, now possible building in realtime 3D already in the integrated editor from the game - but that's another activity.

in 2D-editor only need to have an idea about the overall geometry of the buildings in 3D vision.

Perhaps it would be enough just basic block shapes (cube, half-cube, ramp, pillar, plate .etc.)

Edited by n2n1 (see edit history)
Link to comment
Share on other sites

hey Pille

the block-coloring-function works perfect - i love it - thx for adding that

Now its so easy to find specific blocks :)

 

Request/Question:

 

Case: Tools/advanced - Texture-Replacing

 

Is it possible to fill in --KEEP OLD-- and --ANY-- to the advanced-Replacing-Tool (category: textures) ???

 

Does this feature work already? There are a lot of concrete poles in TWD prison with incorrect textures. It would be great if I could clear all these blocks back to their default texture. :)

Link to comment
Share on other sites

Micro update time!

 

 

 

 

Changelog v0.3w(2) (September 4, 2017):

- changed: replace function ignores painting of air of blocks (e.g. if you replace --any -- texture with adobe white, the replace function will not paint the air blocks)

- fixed: corrupted *.pille files may cause crashes

- fixed: replace texture function in advanced replace dialog doesn't work properly / is inconvenient to use

 

 

 

 

@Jackelmyer, stallionsden

Hey Guys,

 

the 'TheVillage.pille' looks corrupted. Don't know why the crash didn't occure in the previous version. I added a check the prevent further crashes.

 

 

@Jackelmyer

Wow that's what I call a bug report. :)

 

 

- add a checkbox or option - for that would not showing "sleeper volume".

sometimes it is a hindrance when working (can accidentally move it and not notice).

- i would like to be able to add any entity in prefab (as in HALL's Ed)

Good suggestions. The first one is easy to implement and the second one is something I need for my own project.^^

 

- some interface elements look like buttons (because of the extrusion effect), although they are not. For example: block color. I think it ruins immersion for the interface :D

I don't see it. Would like to have a screenshot...

 

I noticed that a new created "sleeper volume" (and moving existing) not saved in prefab.xml... i missed something or this has already been said?

I wasn't able to reproduce the problem (I created a new volume, moved an old one and saved the prefab). Is 'write prefab xml' enabled and 'A15 xml compatibility' disabled in the option menu?

 

by the way - the copy function of the block (the middle button) are very frequent for me. If it were possible - i would put it on the right button...

To be honest it's annoying to change this because multi block selection is already assigned to right click (and can't be easily reassigned). I hope I can add dynamic shortcuts/hotkeys some day...

 

in 2D-editor only need to have an idea about the overall geometry of the buildings in 3D vision.

Perhaps it would be enough just basic block shapes (cube, half-cube, ramp, pillar, plate .etc.)

Perhaps. It's just a matter of priorities. ;)

 

Of course - it's the little trifle - the Editor is Very good! :)

Thanks n2n1. Interesting name btw.^^

Edited by Pille (see edit history)
Link to comment
Share on other sites

Hey Pille?

 

Did you accidently push an update? v0.3w(2)? I was just prompted to update and just... well... updated... and that's the version showing.

 

Hey Jackelmyer,

 

yes, I guess you've overlooked the changelog. lol. It's just a minor update btw.:

 

 

 

Micro update time!

 

Changelog v0.3w(2) (September 4, 2017):

- changed: replace function ignores painting of air of blocks (e.g. if you replace --any -- texture with adobe white, the replace function will not paint the air blocks)

- fixed: corrupted *.pille files may cause crashes

- fixed: replace texture function in advanced replace dialog doesn't work properly / is inconvenient to use

Link to comment
Share on other sites

lol. sorry. I'm a horrible user. X-D

 

The version format is what caught my eye. the (2) seemed like maybe an internal versioning for development. So just thought I'd reach out. But yeah... I'll TRY to be better about reading change logs and such. lol. Sorry again!

 

BTW... The replace function ignores painting of air blocks? So, the replace function only replaced the block ID right? We're not talking about an advanced replace right? I rather liked being able to go "Ya know what? that shouldn't be wood. It should be concrete" but leaving the painted texture in place.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...