Jump to content

Bad Company Manager (ApiMod for Servers)


Recommended Posts

i'm workign with a16.4 now.

 

how do i get export to work?

 

I imported a prefab to give it finishing touches and now want to export it to add the water. when i tried export is said it was creating a bounding box, then it said there was no save for that box

Link to post
Share on other sites
Stompy, a wish...

 

 

can you add something like this?

"dj-regen - Regenerates a chunk or custom area based on the world seed"

 

It was a small area, 16x16 blocks and i miss that stuff so much, cause of all the gamebugs (like endless tree spawning, in the current version). So we can reset that small zones, without resetting the whole chunk.

 

 

 

topic from dj-rose and his a16 mod:

https://7daystodie.com/forums/showthread.php?69772-djkrose-s-Scripting-Mod

 

I did have a regen command at one stage but it was unstable. I'll have another look at it soon

 

- - - Updated - - -

 

i'm workign with a16.4 now.

 

how do i get export to work?

 

I imported a prefab to give it finishing touches and now want to export it to add the water. when i tried export is said it was creating a bounding box, then it said there was no save for that box

 

Im not sure what you mean. That doesnt sound like the bcm export command as I have nothing that gives that message or error.

Link to post
Share on other sites

 

 

 

Im not sure what you mean. That doesnt sound like the bcm export command as I have nothing that gives that message or error.

 

i'm not sure what it is either, i cant upload pictures or look at them. i've been blocked on the forums and those features give me an error that ways i dont have permissions, oddly. I have ZERO idea why i've been blocked from posting pictures or looking at pictures.. it worked 6 months ago and when i came back from a hiatus, i couldnt anymore.

 

but yea, i was getting a weird error Or it would just pull up a help menu.. i finally got it to work, took 3 hours of trying. I bet its something on the dedicated server side as I've been having issues with corrupted files there.

Link to post
Share on other sites

Pulling up a help menu?

 

would you mind outlining your exact steps? I don't even have an idea on what you are doing now, never seen any mod whatsoever with a help menu :) We all might be talking about different things here.

Link to post
Share on other sites
Pulling up a help menu?

 

would you mind outlining your exact steps? I don't even have an idea on what you are doing now, never seen any mod whatsoever with a help menu :) We all might be talking about different things here.

 

it pulls up a list of bc commands aka the "help" menu

Link to post
Share on other sites

Hello StompyNZ,

 

I don't know if this has been reported or seen on other servers. When I use BC-Import to import a stock prefab trader (like "settlement_trader_01") , the trader POI imports fine enough, but it is not protected and does not close at night and open in the morning as usual. I can then use the BC-Protect command to protect it and that works fine, but the trader still doesn't close at night and open in the morning. Is there something I am missing with Trader POI's?

Link to post
Share on other sites

Hey stompy any ideas on this error

 

I'm running a17 b240 with bcmanager 3.4.0

 

12-29T10:02:42 0.246 ERR [MODS] Failed loading DLL C:/TCAFiles/Users/28345/7DaysToDieServer_Data/../Mods\BCManager\BCManager.dll

2018-12-29T10:02:42 0.246 EXC Could not load file or assembly 'C:/TCAFiles/Users/28345/7DaysToDieServer_Data/../Mods\BCManager\BCManager.dll' or one of its dependencies. An attempt was made to load a program with an incorrect format.

BadImageFormatException: Could not load file or assembly 'C:/TCAFiles/Users/28345/7DaysToDieServer_Data/../Mods\BCManager\BCManager.dll' or one of its dependencies. An attempt was made to load a program with an incorrect format.

at (wrapper managed-to-native) System.Reflection.Assembly:LoadFrom (string,bool)

at System.Reflection.Assembly.LoadFrom (System.String assemblyFile) [0x00000] in <filename unknown>:0

at Mod.InitModCode () [0x00000] in <filename unknown>:0

UnityEngine.DebugLogHandler:Internal_LogException(Exception, Object)

UnityEngine.DebugLogHandler:LogException(Exception, Object)

UnityEngine.Logger:LogException(Exception, Object)

UnityEngine.Debug:LogException(Exception)

Logger:masterLogException(Exception)

Logger:Exception(Exception)

Log:Exception(Exception)

Mod:InitModCode()

Mod:LoadFromFolder(String)

ModManager:LoadMods()

GameManager:Awake()

Link to post
Share on other sites
Hello StompyNZ,

 

I don't know if this has been reported or seen on other servers. When I use BC-Import to import a stock prefab trader (like "settlement_trader_01") , the trader POI imports fine enough, but it is not protected and does not close at night and open in the morning as usual. I can then use the BC-Protect command to protect it and that works fine, but the trader still doesn't close at night and open in the morning. Is there something I am missing with Trader POI's?

 

open the trader up in pilles editor and select these in the menu, resave with a new name, then spawn using bc commands.

Link to post
Share on other sites
I did have a regen command at one stage but it was unstable. I'll have another look at it soon

 

 

Unstable means? No problem, if it produced some problems, if a player is in the near (without a reset/completly zone clear). Just release x3

 

The old dj-regen was bugged too. Clear a few zones and restart the server, NP.

 

 

But please add it with the minimum chunk-size (16x16)? =)

 

 

AND happy new year!

Edited by Slawa (see edit history)
Link to post
Share on other sites
  • 2 weeks later...
unstable as in crash the chunk generator ;)

 

REQUEST - Hey StompyNZ not sure if this is doable or not. Do you think you can something to get rid of the 1-hit Trees that will sometimes happen? Seems to be a bug with some floating trees every now and then. Especially after placing or importing a prefab.

 

I know the Patrons have something that does that wasn't sure if you planned on adding something to take care of those issues. It would be awesome as I don't want to use the Patrons after having some issues with Botman and other issues they are having. Rather just stick to using BC :smile-new:

Link to post
Share on other sites

Hey StompyNZ are you update BCM for 17.1 experimental or do we need to waitfor it to go stable?

I am seeing an error using latest with 17.1 b8.

2019-01-12 18:19:42 238.897 ERR NCSimple_Serializer (cl=76561198010759396, ch=0):

Link to post
Share on other sites
Hey StompyNZ are you update BCM for 17.1 experimental or do we need to waitfor it to go stable?

I am seeing an error using latest with 17.1 b8.

2019-01-12 18:19:42 238.897 ERR NCSimple_Serializer (cl=76561198010759396, ch=0):

 

I dont have an update for the 17.1e branch atm sorry. I have been working on my config and events system (mostly done) so will do an update when 17.1 goes to stable (assuming that is happening this week)

 

- - - Updated - - -

 

REQUEST - Hey StompyNZ not sure if this is doable or not. Do you think you can something to get rid of the 1-hit Trees that will sometimes happen? Seems to be a bug with some floating trees every now and then. Especially after placing or importing a prefab.

 

I know the Patrons have something that does that wasn't sure if you planned on adding something to take care of those issues. It would be awesome as I don't want to use the Patrons after having some issues with Botman and other issues they are having. Rather just stick to using BC :smile-new:

 

I'll see if I can find out what can be done there. I had been putting off my configs update but finally got to sorting that, next on the list is the world editing commands for a full review and some big changes.

Link to post
Share on other sites
OK. I will give it a shot. Thnks!

 

Curios did this work? what about traderarea True / False as determined by the list output from tl or traderlist - works with any or all bugged traders ingame not sure about imports though it would be good to know, thanks

Link to post
Share on other sites
I dont have an update for the 17.1e branch atm sorry. I have been working on my config and events system (mostly done) so will do an update when 17.1 goes to stable (assuming that is happening this week)

 

- - - Updated - - -

 

I'll see if I can find out what can be done there. I had been putting off my configs update but finally got to sorting that, next on the list is the world editing commands for a full review and some big changes.

 

Hey stompy any function to turn off cmds if not working or causing issues via console for when situations a like this arise.

 

Am not lazy = )

Link to post
Share on other sites
Hi Stompy,

 

This problem with A17 b211 was also an issue last release, i have used the same type of command to either fill in an air block or a terrain block and it works most of the time.

 

The time where it does not work is when the game mechanics have the terrain continuously collapsing underneath you and the hole getting wide and wider as terrain falls to bedrock. This seems to happen when a mine collapses or a base underground caves in, sometimes the terrain keeps falling in and just getting wider and wider and the only way to fix it, even after a server restart is to reset that region or restore from last backup before the change that affected the terrain.

 

In an emergency, to prevent it growing into a large hole i would attempt to fill this in with your command and make it fill a section larger than the hole was before it grew to big, and unfortunately it just flashes, but does not actually apply the blocks to prevent the further collapse.

 

 

1. LOC would be used to get location

2. bc-block fill terrGround

 

Running latest BC Mod as well.

 

This may not be an issue related to your mod at all, but i thought you should know in case you can bandaid the problem.

 

Cheers

Shaun

 

I am having this issue as well. I enter 'loc' then 'bc-block fill desertGround' and get this reply:

"Loading 25 chunks too 0 seconds

Inserting block 'air' @ [location] to [location]

Use bc-undo to revert the changes"

 

It fills the space with terrain blocks and then fills the space with air. Not sure if I'm doing something wrong or what.

Link to post
Share on other sites
Hey stompy any function to turn off cmds if not working or causing issues via console for when situations a like this arise.

 

Am not lazy = )

 

Not sure what you mean by turn off. If mean mean disable a command then the only way I can thing of is set all enabled commands to permission level 1, and disabled to 0, and set the admins to level 1

 

- - - Updated - - -

 

I am having this issue as well. I enter 'loc' then 'bc-block fill desertGround' and get this reply:

"Loading 25 chunks too 0 seconds

Inserting block 'air' @ [location] to [location]

Use bc-undo to revert the changes"

 

It fills the space with terrain blocks and then fills the space with air. Not sure if I'm doing something wrong or what.

 

terrDesertGround is the block name you need. They changed them all in a17

 

use bc-go blocks /filter=name to get a list

 

I'll update the command to fail on incorrect block names instead of using air

Link to post
Share on other sites
Is there a way to remove certain blocks with the BC-block command? I tried everything but it keeps telling me"invalid command"

 

check that the mod is installed (versions command) and that you are typing the command name correctly, it should be bc-block or just block. For it to say invalid command means it can't find the command.

 

use 'help' or bc-help to get the list of all commands or just bc commands as well

 

To remove just certain blocks you would need to use block swap. can only have one target block at a time though, so if you have a few you might want to make a text file with the list in them and paste it in as needed

Link to post
Share on other sites

If there's no stable update out by the weekend I will look at doing an update for stable and experimental.

 

The next version will reset the bcm data so I wanted to wait for stable. I've split the config into server and save specific so that a new save will keep settings such as chat colors etc.

 

I have my new config system mostly working and have started rebuilding the AI events to use the new config.

 

Events will be a separate dll mod to allow admins to decide what events if any they want to have on the server. They will all be configured through bc-config. This will also allow for some experimental and custom events to be done and added without having to update all of the bcm mod.

Link to post
Share on other sites

Sorry all, have been super busy lately and havent had a chance to do much coding.

 

The next two days are looking a bit better so I will aim to get the next update out before wednesday night. There's just a few bits left to tidy up and then I can start working on new feature requests again.

Link to post
Share on other sites
  • xyth locked this topic
Guest
This topic is now closed to further replies.
×
×
  • Create New...