Jump to content
dwallorde

War of the Walkers Mod (Overhaul)

Recommended Posts

love the work you are doing Dwalle, I was the ringleader for the Dark-iCE WoW private server project back in the day so i know how rough it is to coordinate updates (especially if you do not have a team which i was fortunate enough to have) you are doing great with this modpack keep up the good work and don't let anyone's bug reports seem like complaints or rush-orders, take your time and keep it steady; as i said you are doing awesome man

Share this post


Link to post
Share on other sites
It was in during A15 but hasn't been updated yet as I have put it on the shelf atm until I have time to revisit it. It may come back in v5.2

1. Are you using a wrench? If so use a hammer or nailgun.

2. Interesting. I will look into this. I plan on redoing fishing anyway.

3. Steel smithing class? Was mainly done for progression sake. But I can revisit it.

4. Unfortunate effect with lots of recipes. Use favorites to fix this.

1) Yes, using HD nailgun. Adding one gas can worked. But upgrading from fully empty trap doesn't. Looked in the XML files and can't find anything obvious.

3) "SteelSmithingClass" is what it's called in the XML. Not a big deal, since it seems total number of points should be enough to unlock all the perks. Just didn't want to spend 15 points on something I already had.

4) Interesting, will try favorites. Also the search in all crafting menus seems to require 3 characters minimum now. I've struggled with it for a while. And seem some streamers having the issue with it as well. Ex, if I type "9" in the perks search in vanilla it would find Miner 69er. Not so in the mod.

 

Still with as much of changes this mod adds it's a darn good job that only so few errors popped up! Keep up the good work.

Share this post


Link to post
Share on other sites

Question about the protection class. I am at lvl 100 , armor crafting at lvl 9 I still can't make kevlar armor. It is greyed out in the station.

I'm pretty sure I have met all the requirements.

Any guidance would be appreciated.

Share this post


Link to post
Share on other sites

"Only way right now is either finding the berries in loot or the seeds in loot. V5.2 will add them to certain biomes"

 

Thank you :)

Share this post


Link to post
Share on other sites

forge

 

Hello, so im new here, and to modding. Been playing around with this mod, I like it so far but a big turn off for me at the moment is the massive lag I get when accessing the forge or campfire, Its so bad that it takes several tries to drag my wood over to fuel it. Is there a fix for this, something I did wrong or?

Any help would be appreciate it, thank you.

Share this post


Link to post
Share on other sites
OK just installed this mod and must have missed something as getting strange images on the screen

 

https://www.dropbox.com/s/mbdgpvsb6upvpdo/Screenshot%202017-10-19%2018.40.55.png?dl=0

 

Any ideas ?

 

Basically Mod not installed correctly ... Haven't seen that image in several years. Get the 7D2D Mod launcher .. will make it easier:

 

https://7daystodie.com/forums/showthread.php?48537-The-7D2D-Mod-Launcher-A-Mod-Launcher-for-7-Days-to-Die

Share this post


Link to post
Share on other sites
Question about the protection class. I am at lvl 100 , armor crafting at lvl 9 I still can't make kevlar armor. It is greyed out in the station.

I'm pretty sure I have met all the requirements.

Any guidance would be appreciated.

 

A player on my server ran into this same problem. The "Kevlar Armor" and the "Iron Armor" have the same issue.

 

in the progression.xml file, It looks like they both have a skill_point_cost_multiplier of 0.2 and 0.1667 which is causing them to have a sub 1pt cost at some difficulties making their cost NA and a message stating that the skill is not purchasable.

 

The solution looks to be to change this multiplier to "0" to give it the point cost back and allow it to be purchased. Should be an easy fix.

Share this post


Link to post
Share on other sites

O.k. First, I love the Mod. I just put it on my server and have been playing sp for a while now with no issues with extended Backpack. On Server though the backpack works fine unless you log out then back in, then you see the 72 slots, but can only use the basic 32? as you play after a while the game excepts the 72 and you can use all of the slots until you log out again. also if you have items in slots 33-72, you loose them when you log out. any suggestions as to what i did wrong? I guess i should say that the way i use the expanded backpack is to alter the windows.xml file as suggested in the file.

Share this post


Link to post
Share on other sites
O.k. First, I love the Mod. I just put it on my server and have been playing sp for a while now with no issues with extended Backpack. On Server though the backpack works fine unless you log out then back in, then you see the 72 slots, but can only use the basic 32? as you play after a while the game excepts the 72 and you can use all of the slots until you log out again. also if you have items in slots 33-72, you loose them when you log out. any suggestions as to what i did wrong? I guess i should say that the way i use the expanded backpack is to alter the windows.xml file as suggested in the file.

 

There is a separate server side DLL file that needs to be downloaded and placed on the server in the \7DaysToDieServer_Data\Managed folder. Note that this is a different location than a local install.

Share this post


Link to post
Share on other sites
A player on my server ran into this same problem. The "Kevlar Armor" and the "Iron Armor" have the same issue.

 

in the progression.xml file, It looks like they both have a skill_point_cost_multiplier of 0.2 and 0.1667 which is causing them to have a sub 1pt cost at some difficulties making their cost NA and a message stating that the skill is not purchasable.

 

The solution looks to be to change this multiplier to "0" to give it the point cost back and allow it to be purchased. Should be an easy fix.

 

Thanks Dracos. I'll give it a shot. Fingers crossed haven't tried to edit an xml yet. About time I started :)

Share this post


Link to post
Share on other sites
If i have this on my Dedi server do all Clients Need to download this MOD as well ?

 

Clients need custom icons and localization files for sure.

Share this post


Link to post
Share on other sites
1) Yes, using HD nailgun. Adding one gas can worked. But upgrading from fully empty trap doesn't. Looked in the XML files and can't find anything obvious.

 

Found an answer to 1): items.xml entry for HDNailGun action0 doesn't contain gasCan:

<property name="Allowed_upgrade_items" value="wood,clayLump,dirtFragment,snowBall,scrapIron,forgedIron,forgedSteel,steelPolish,concreteMix,cobblestones,yuccaFibers,nail,ForgedTungsten,corn" />

 

While same entry for regular nailgun does:

<property name="Allowed_upgrade_items" value="wood,clayLump,dirtFragment,snowBall,scrapIron,forgedIron,forgedSteel,steelPolish,concreteMix,cobblestones,yuccaFibers,nail,gasCan,corn"/>

Share this post


Link to post
Share on other sites

Any chance HD and Eco batteries may be allowed to use in Battery banks?

 

If we look at the mod items code:

 

<item id="1432" name="carBattery">
<property name="Meshfile" value="Items/Misc/car_battery"/>
<property name="Material" value="lead"/>
<property name="RepairTools" value="repairKit"/>
<property name="HoldType" value="21"/>
<property name="Stacknumber" value="1"/>
<property name="Weight" value="160"/>
<property name="EconomicValue" value="500"/>
<property name="Group" value="Resources"/>
<property name="VehicleSlotType" value="battery"/>
<property name="DegradationBreaksAfter" value="false"/>
<property class="Attributes">
	<property name="DegradationMax" value="1000,6000"/>
	[color="#00FF00"]<property name="BatteryMaxLoadInVolts" value="24, 36"/>[/color]
	[color="#FFFF00"]<property name="BatteryDischargeTimeInMinutes" value="30,90"/>[/color]
</property>
</item>

 

<item id="1845" name="HDBattery">
<property name="Extends" value="carBattery" />
<property name="CustomIcon" value="HDBattery" />
<property name="Weight" value="180" />
<property class="Attributes">
	<property name="DegradationMax" value="1500,4500" />
	[color="#00FF00"]<property name="BatteryMaxLoadInVolts" value="32, 50" />[/color]
	[color="#FFFF00"]<property name="BatteryDischargeTimeInMinutes" value="50,120" />[/color]
</property>
<property name="CraftingSkillGroup" value="Mechanic"/>
<property name="EconomicValue" value="1250" />
</item>

 

<item id="1846" name="ECOBattery">
<property name="Extends" value="carBattery" />
<property name="CustomIcon" value="ECOBattery" />
<property name="Weight" value="145" />
<property class="Attributes">
	<property name="DegradationMax" value="800,3000" />
	[color="#00FF00"]<property name="BatteryMaxLoadInVolts" value="24, 36" />[/color]
	[color="#FFFF00"]<property name="BatteryDischargeTimeInMinutes" value="50,120" />[/color]
</property>
<property name="CraftingSkillGroup" value="Mechanic"/>
<property name="EconomicValue" value="850" />
</item>

 

We can see that there are benefits over regular battery. Both in Volts and Discharge time.

Thats +33% in discharge time and +33% more volts for HD battery. That goes a long way in base defense don't you think?

 

So far i have found these batteries can only be used in minibike or am I missing something?! :indecisiveness:

Share this post


Link to post
Share on other sites

Using a Mac

 

How do you add this mod on a Mac? I've tried searching, but failed at finding something that works.

 

Thanks in advance!

Share this post


Link to post
Share on other sites
Any chance HD and Eco batteries may be allowed to use in Battery banks?

 

Sure you can.

In blocks.Xml search for

 

<block id="2005" name="batterybank">

and in there, you will find a line that says:

<property name="SlotItem" value="carBattery"/>

Then just change it to say:

<property name="SlotItem" value="carBattery,HDBattery,ECOBattery"/>

 

That should do it.

Share this post


Link to post
Share on other sites
Sure you can.

In blocks.Xml search for

 

<block id="2005" name="batterybank">

and in there, you will find a line that says:

<property name="SlotItem" value="carBattery"/>

Then just change it to say:

<property name="SlotItem" value="carBattery,HDBattery,ECOBattery"/>

 

That should do it.

 

Thanks for this. I haven't had the chance to look into this yet. Will have this is in next patch

Share this post


Link to post
Share on other sites
Thanks for this. I haven't had the chance to look into this yet. Will have this is in next patch

 

No worries!

Thanks for the great work you're doing with the mod :)

Share this post


Link to post
Share on other sites

Is there any reasons why my game simply stop rendering when I search anything in the crafting menu or the skill page? It stops for like a second or 2 then return to normal. Was not having this issue on vanilla

Share this post


Link to post
Share on other sites
Is there any reasons why my game simply stop rendering when I search anything in the crafting menu or the skill page? It stops for like a second or 2 then return to normal. Was not having this issue on vanilla

 

It's just craft lag when there is a lot of recipes. Using favorites really will help with this.

Share this post


Link to post
Share on other sites
Sure you can.

In blocks.Xml search for

 

<block id="2005" name="batterybank">

and in there, you will find a line that says:

<property name="SlotItem" value="carBattery"/>

Then just change it to say:

<property name="SlotItem" value="carBattery,HDBattery,ECOBattery"/>

 

That should do it.

 

Tried it and it works but several things happen that should not. 1. You can not long shift click the batteries into the slot. You can place other items in like a gascan and it actually increases the power. So for now I will have to not allow the ECO HD Versions. Same thing happens with Generator.

Share this post


Link to post
Share on other sites

V5.1.6 B62 Update out!

 

Change Log:

 

-Changed Reduced XP Gain from Diamond Tipped and Tungsten Tools

-Changed Multiplier for Kevlar and Iron Armor Recipe Perks

-Fixed HD Nailgun can't repair with Gas can

-Changed Increased Repair amount when using a wrench

-Fixed Marksman Class not Rewarding Crate upon completion

-Changed Hand Weeder has a chance to harvest Strawberries and Blackberries from Azalea Bushes.

-Fixed Food Requirements for Vegetable Stew Chef Quest

-Fixed Explosive Speed Trap Missing Icon

-Changed Blood Moon Horde Zombie Count (More Balancing)

-Changed Increased Wood Bonus Damage from Iron Fire Axe

 

-End of Change Log -

Share this post


Link to post
Share on other sites
O.k. First, I love the Mod. I just put it on my server and have been playing sp for a while now with no issues with extended Backpack. On Server though the backpack works fine unless you log out then back in, then you see the 72 slots, but can only use the basic 32? as you play after a while the game excepts the 72 and you can use all of the slots until you log out again. also if you have items in slots 33-72, you loose them when you log out. any suggestions as to what i did wrong? I guess i should say that the way i use the expanded backpack is to alter the windows.xml file as suggested in the file.

 

I am having same issue server has the big back pack mod but I have twice now lost anything above the 32 mark if I log out. love most of the mod so far tho.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...