Jump to content

Subquake's Undead Legacy


Subquake

Recommended Posts

Hi, I'm a long time 7 Days player, been at it on UL since a YouTuber started playing it several months ago (JW).  I'm really enjoying the mod, but I just had one suggestion that I think could be a benefit though I don't know if it would be easy or any sort of priority:

 

There are stations you can build that help you gather some base resources, water collectors, chicken coups, bee hives etc.  My suggestion would be for a "farm pen" type block (like the chicken coup) that you could put corn and potatoes in (or something similar) that would yield animal fat, meat, and leather (or maybe different pens for each resource?).  I think it might help balance the food making to upgrade ratio (in terms of lower upgrade paths that use animal fat).  Just something to think on.  Regardless I am really enjoying the mod and also wanted to say thank you Subquake for doing such an excellent job!!

Link to comment
Share on other sites

So does 100% poison not actually kill you? I thought it would but instead it just brought me down to 2 hp and the poison debuff reset back to 0% and started climbing again and I was able to bandage myself back to full hp. 

Link to comment
Share on other sites

54 minutes ago, Yopo said:

So does 100% poison not actually kill you? I thought it would but instead it just brought me down to 2 hp and the poison debuff reset back to 0% and started climbing again and I was able to bandage myself back to full hp. 

It should, I'll take a look, thanks for reporting this

Link to comment
Share on other sites

1 hour ago, Subquake said:

It should, I'll take a look, thanks for reporting this

I had a hunch that it might of bugged. And thank you for verifying that. 
Btw also recently noticed that using the forgetting elixir dose not pull your points  out of the mithridatism perk (the poison resistance perk) as well. 

Link to comment
Share on other sites

Добрый день, сегодня обнаружил что при перепрыгивании через левиафана я получил эффект яда на 75%, при этом удара или плевка с его стороны не было, задумано ли так игрой?

Link to comment
Share on other sites

I'm using Nitrado as a dedicated server, using Filezilla client.  Where do I copy undead legacystable_main to?

 

There is a folder in filezilla call /7daystodie/7daystodiserver_data.  Do I copy the files here?

 

 

Link to comment
Share on other sites

  • 2 weeks later...

Hi there guys,

i got a little problem, maybe u can help me.

I tried the UL mod and daaaaamn i love it.

 

So i decided to play it with my friends on our dedicated server.

Uploaded everything via filezilla and it runs.... but there is 1 big problem.

No matter what i select on our server hoster, the map will be the standard Navezgane map. No matter if i choise random gen and 8k or 10k... its everytime Navezgane with 6k.

my head is hurting cuz i tried everything i could. every combination will lead to Navezgane 6k (in the configs on the website its shown as what i selected, but ingame not.

 

someone an idea what it could be? (the server is from 4players and in the faq Undead Legacy is supported on the servers).

 

could i creatve local a 10k random map and just upload it to the server? someone know if that would work?

Link to comment
Share on other sites

45 minutes ago, non53r10us said:

Hi there guys,

i got a little problem, maybe u can help me.

I tried the UL mod and daaaaamn i love it.

 

So i decided to play it with my friends on our dedicated server.

Uploaded everything via filezilla and it runs.... but there is 1 big problem.

No matter what i select on our server hoster, the map will be the standard Navezgane map. No matter if i choise random gen and 8k or 10k... its everytime Navezgane with 6k.

my head is hurting cuz i tried everything i could. every combination will lead to Navezgane 6k (in the configs on the website its shown as what i selected, but ingame not.

 

someone an idea what it could be? (the server is from 4players and in the faq Undead Legacy is supported on the servers).

 

could i creatve local a 10k random map and just upload it to the server? someone know if that would work?

You'll have to ask that question to the host of the server. You most definitely can have different map to be played on the server by changing GameWorld property to RWG in serverconfig.xml

Link to comment
Share on other sites

1 minute ago, Subquake said:

You'll have to ask that question to the host of the server. You most definitely can have different map to be played on the server by changing GameWorld property to RWG in serverconfig.xml

the problem is, that server doesnt even got a serverconfig.xml .... drives me crazy.

could i just download one from the internet and upload it?

 

I know where i could upload my own map and saw what code i need to change the serverconfig.xml but like i said...there isnt even a file with that name.

searched on the full server

Link to comment
Share on other sites

2 hours ago, non53r10us said:

the problem is, that server doesnt even got a serverconfig.xml .... drives me crazy.

could i just download one from the internet and upload it?

 

I know where i could upload my own map and saw what code i need to change the serverconfig.xml but like i said...there isnt even a file with that name.

searched on the full server

Then it's a crappy host ¯\_(ツ)_/¯

Link to comment
Share on other sites

10 hours ago, non53r10us said:

the problem is, that server doesnt even got a serverconfig.xml .... drives me crazy.

could i just download one from the internet and upload it?

 

I know where i could upload my own map and saw what code i need to change the serverconfig.xml but like i said...there isnt even a file with that name.

searched on the full server

 

11 hours ago, non53r10us said:

No matter if i choise random gen and 8k or 10k... its everytime Navezgane

How did you change it when there is no serverconfig.xml, that is the place you change it.

Anything you change on your client don't affect the server.

Maybe you should take a look at

http://ul.subquake.com/dedicated-servers

that could help to configure your server better.

Or ask the support of your hosting server.

 

 

Link to comment
Share on other sites

2 hours ago, Canute said:

 

How did you change it when there is no serverconfig.xml, that is the place you change it.

Anything you change on your client don't affect the server.

Maybe you should take a look at

http://ul.subquake.com/dedicated-servers

that could help to configure your server better.

Or ask the support of your hosting server.

 

 

I called the support today.

On 4netplayers you can set up some options with the webinterface.

There was a Basic mode where u can select some options, where u normaly need to go into the serverconfig.xml(now i know that)

and theres a advanced mode. There u get the serverconfig.xml listed on the webinterface (theres still no xml file if u check the server via filezilla).

there i could manually change all the configs. now the server is running fine.

 

there is just 1 problem left.
we played a vanilla standard game first (over 190 days) there we had selected (over the basic mode) that if u die u just get the xp penalty. and spawn with full hp/food/water (like u can select it if u play solo local).

Now while we selected the advanced mode i need to change all singlehandly.

On the serverconfig.xml u can only set up what u loose on death (nothing,toolbar,all)

 

After a reasearch i found out i need to change some stuff on the buff.xml.

There are 3 buff.xml on the UndeadLegacy folders.

All 3 got different informations.

In 1 of these i found "deathpenalty" but im not sure with line of code i need to change.

Someone got an idea?

 

 

 

Link to comment
Share on other sites

How big is this overhaul mod? I use a jet pack for internet and need to know if I have enough high speed data to download it or if I need to go to a friend's house and use their internet.

Link to comment
Share on other sites

1 hour ago, SPerry85 said:

How big is this overhaul mod? I use a jet pack for internet and need to know if I have enough high speed data to download it or if I need to go to a friend's house and use their internet.

it's about 3.4GB at the moment for 2.6.17 :)

Link to comment
Share on other sites

spacer.png
 

https://ibb.co/Y3DcrK8


 

Hi Guys,

I have the problem, that many objects appear matte black.
I created a copy of 7Days, downloaded and installed the latest (2.6.17 Stable) Undead Legacy.

I have seen, that a few pages back, someone had the same problem and that he uses a mac.

I do use Windows 11 and I have the same problem. I tried changing all of the graphics settings, but nothing helped.
My RTX 2080 runs on the latest drivers. I just did update the drivers yesterday.

Does anyone have an idea how to fix that?

 

 

 

Edited by LCsTarBuZz
added image (see edit history)
Link to comment
Share on other sites

9 hours ago, LCsTarBuZz said:

I have seen, that a few pages back, someone had the same problem and that he uses a mac.

I do use Windows 11 and I have the same problem. I tried changing all of the graphics settings, but nothing helped.
My RTX 2080 runs on the latest drivers. I just did update the drivers yesterday.

Does anyone have an idea how to fix that?

You can't do much about this situation, because Mac uses Metal rendering and not OpenGL/DirectX. My options are limited here as well, because I don't have a mac to test on and I can't package the assets in a way, that would work on all platforms equally. I would have to create a mac specific version of Undead Legacy, but without a way to test if it actually works, it's a bit of an issue.

Link to comment
Share on other sites

12 hours ago, Subquake said:

You can't do much about this situation, because Mac uses Metal rendering and not OpenGL/DirectX. My options are limited here as well, because I don't have a mac to test on and I can't package the assets in a way, that would work on all platforms equally. I would have to create a mac specific version of Undead Legacy, but without a way to test if it actually works, it's a bit of an issue.


yeah but I'm on Windows and it happens to me too.
I'll try getting a new, fresh copy of the game via Steam and then install UL manually because I get those "texture has not yet finished downloading" exceptions using the Mod Launcher. I hope that this fixes the errors for me. Because UL is a damn good overhaul.

EDIT:
I got it working fine now, using the manual install method. No missing textures anymore and no more black objects.
I renamed my current 7 Days To Die folder, redownloaded the game via steam, and added UL to the new clean 7 Days manually.       

Edited by LCsTarBuZz (see edit history)
Link to comment
Share on other sites

2 hours ago, LCsTarBuZz said:


yeah but I'm on Windows and it happens to me too.
I'll try getting a new, fresh copy of the game via Steam and then install UL manually because I get those "texture has not yet finished downloading" exceptions using the Mod Launcher. I hope that this fixes the errors for me. Because UL is a damn good overhaul.

EDIT:
I got it working fine now, using the manual install method. No missing textures anymore and no more black objects.
I renamed my current 7 Days To Die folder, redownloaded the game via steam, and added UL to the new clean 7 Days manually.       

You probably were using an outdated Mod Launcher then, the latest one is version 4: https://github.com/SphereII/7D2DModLauncher/releases/latest

Link to comment
Share on other sites

For some reason, when i press for ex. M to open the map, if i press M again to close it, it doesn't work.

The same applies to the other shortcuts, like skills, objectives etc.

The only way to close the thing is pressing ESC.

Is this behaviour intended ?

Link to comment
Share on other sites

5 hours ago, fullbanner said:

For some reason, when i press for ex. M to open the map, if i press M again to close it, it doesn't work.

The same applies to the other shortcuts, like skills, objectives etc.

The only way to close the thing is pressing ESC.

Is this behaviour intended ?

It's a known issue due to how I changed how the interface works. Not intentional but I also can't promise when it will be fixed.

Link to comment
Share on other sites

I want to start off by saying I love this mod so much, and am having so much fun playing it the past few days.

 

I've had a couple issues with noise and trying to stay stealthy in the game, especially at my base. The many storage options you've added are so cool, and I love that you can pick up everything and design the base of your dreams. My issue is that it seems counterproductive to upgrade beyond cardboard boxes, because they are so much quieter than all the other options. Even containers that seem like they should be quiet, like a leather trunk make so much noise that it immediately alerts nearby zombies, even though I'm sneaking and have points in the noise reduction perk. Would love to see some kind of padded wood or iron crates to improve storage capacity without sacrificing stealth. Or some kind of sound proof padding to add to base walls, though that seems more difficult. It would at least be nice to see how much noise the different containers make when you select them in the inventory.

 

These are just a few thoughts I had, I'm sure you already have plenty of your own and I look forward to whatever updates you bring. Thank you for this amazing mod.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...