Jump to content
sphereii

The 7D2D Mod Launcher - A Mod Launcher for 7 Days to Die

Recommended Posts

OK, I unticked 'Disable SSL' waited for it to respond and it is now showing all the mods. Wierd. All good, sorry to bother you.

 

Some ISPs change their policy on whether to allow SSL or not. It's no bother; enjoy the mods :)

Share this post


Link to post
Share on other sites

this.png.d8469bb63c48dc1da163645fd52dc26a.png

HELP Please....

 

 

I can't launch the mod launcher I keep getting this, and even when I follow this link and download the file, it says I have 4.7.1 already installed...

Share this post


Link to post
Share on other sites
[ATTACH=CONFIG]25090[/ATTACH]

HELP Please....

 

 

I can't launch the mod launcher I keep getting this, and even when I follow this link and download the file, it says I have 4.7.1 already installed...

 

Sorry for the trouble. Have you tried to reboot? Sometimes that helps with this error

Share this post


Link to post
Share on other sites

Hi please help me with this issue. Iv just DL SDX and unity and followed the tutorial to add the cube and katakana in to my 7dtd game. Game is 100% vanilla. But on starting up the game I get the command box saying something to do with easy anti cheat and won’t load up. Iv tried loading the game normally through steam and it works fine. Iv tried turning off easy anti cheat in steam and loading it up through SDX but still get that error. Please any help ?

Share this post


Link to post
Share on other sites
Hi please help me with this issue. Iv just DL SDX and unity and followed the tutorial to add the cube and katakana in to my 7dtd game. Game is 100% vanilla. But on starting up the game I get the command box saying something to do with easy anti cheat and won’t load up. Iv tried loading the game normally through steam and it works fine. Iv tried turning off easy anti cheat in steam and loading it up through SDX but still get that error. Please any help ?

 

Hi Kevin1000

 

Seems like EAC is still being loaded. Can you go to your 7 days to die folder, and run the 7Dlauncher.exe directly, unchecking Use EAC?

Share this post


Link to post
Share on other sites

This message also comes up when there is a version mismatch on one or more of the game DLLs. For example, if you previously played true survival which is 16.2, or Starvation that uses modified DLLs. Make sure you have a clean install of the game files before copying those files to the SDX directory.

Share this post


Link to post
Share on other sites

So. Not sure if you can help. My one year old hit my keyboard and some how deleted a bunch of my files. I was able to recover them. but now when I try to open the mod launcher, a message pops up saying "cannot start application" I tried uninstalling and reinstalling, but it still does it.

Share this post


Link to post
Share on other sites
So. Not sure if you can help. My one year old hit my keyboard and some how deleted a bunch of my files. I was able to recover them. but now when I try to open the mod launcher, a message pops up saying "cannot start application" I tried uninstalling and reinstalling, but it still does it.

 

Oh dear. Sorry for the trouble. Try this:

 

https://support.microsoft.com/en-ca/help/2713442/clickonce-application-fails-to-update

 

o delete the ClickOnce file cache delete the contents of this folder based on the operating system.

Windows XP and Server 2003 - %userprofile%\Local Settings\Apps\2.0\*.*
Windows Vista and Server 2008 and later - %userprofile%\AppData\Local\Apps\2.0\*.*

Deleting these files will clear the information for all installed ClickOnce applications. They will re-install the next time their shortcut or URLs are used.

Share this post


Link to post
Share on other sites

"If you still get a message about Required .NET Framework upgrade, and it does not install it automatically, download it here:..."

 

The Launcher say on start (zip Version) install network bla. but the version who is linked, this version are not kompatible with Windows 8. Only want report this.

Maybe a little write at first post, thats for Windows 8, the 4.6.1 NET. Framework are the newest worked version is.

Better write a message at the launcher start, if he miss NET Framework

 

(i hope the launcher can handle the older version)

 

 

EDIT:

OK. The Launcher didnt work on 4.6.1 and windows 8 can only install the 4.6.1 (as newest)

 

https://docs.microsoft.com/de-de/dotnet/framework/install/on-windows-8?utm_source=getdotnet&utm_medium=referral

"The .NET Framework 4.7.2 is supported on Windows Server 2012. It is not supported on Windows 8."

 

And now?

 

No way für Win8 or what?

Edited by FritzHugo3 (see edit history)

Share this post


Link to post
Share on other sites

This probably has been asked already, but with the launcher, does it always download the mod every time you pre-sync? I'm wondering for data usage amount. I'd hate to be downloading say Ravenhearst (because I know it is so large) every time I hit play and it syncs up to make sure the most up to date is on it.

Share this post


Link to post
Share on other sites
"If you still get a message about Required .NET Framework upgrade, and it does not install it automatically, download it here:..."

 

The Launcher say on start (zip Version) install network bla. but the version who is linked, this version are not kompatible with Windows 8. Only want report this.

Maybe a little write at first post, thats for Windows 8, the 4.6.1 NET. Framework are the newest worked version is.

Better write a message at the launcher start, if he miss NET Framework

 

(i hope the launcher can handle the older version)

 

 

EDIT:

OK. The Launcher didnt work on 4.6.1 and windows 8 can only install the 4.6.1 (as newest)

 

https://docs.microsoft.com/de-de/dotnet/framework/install/on-windows-8?utm_source=getdotnet&utm_medium=referral

"The .NET Framework 4.7.2 is supported on Windows Server 2012. It is not supported on Windows 8."

 

And now?

 

No way für Win8 or what?

 

I am sorry that I did not see this earlier. Are you using Windows 8.1? I thought the .1 was a free update.

 

- - - Updated - - -

 

This probably has been asked already, but with the launcher, does it always download the mod every time you pre-sync? I'm wondering for data usage amount. I'd hate to be downloading say Ravenhearst (because I know it is so large) every time I hit play and it syncs up to make sure the most up to date is on it.

 

It uses Github, so it should only download what has changed each time; often times that would be nothing. Is it taking awhile to download each time?

 

If you have Direct Download checked, it'd by-pass the shortcut, and do a full download each time. Uncheck that to make it work as expected.

 

You could also uncheck Refresh mods Automatically.

Share this post


Link to post
Share on other sites

It uses Github, so it should only download what has changed each time; often times that would be nothing. Is it taking awhile to download each time?

 

If you have Direct Download checked, it'd by-pass the shortcut, and do a full download each time. Uncheck that to make it work as expected.

 

You could also uncheck Refresh mods Automatically.

 

I don't have the Direct Download, but I do have the Refresh Mods Automatically, so I'll just also uncheck that. And it's not taking too long, I just was curious because how does it know if changes had been made without downloading the file unless it also checks either a changelog, file name, etc. that's on the site and not needed to be downloaded. I just didn't know. Also, since every time I hit play, it goes through the copying of files, so that threw me off too. But thank you for the info, I can keep using it without worries. Once I see a modder had put out a big update or something that affects my actual gameplay, then I'll have tell it to update.

Share this post


Link to post
Share on other sites
I don't have the Direct Download, but I do have the Refresh Mods Automatically, so I'll just also uncheck that. And it's not taking too long, I just was curious because how does it know if changes had been made without downloading the file unless it also checks either a changelog, file name, etc. that's on the site and not needed to be downloaded. I just didn't know. Also, since every time I hit play, it goes through the copying of files, so that threw me off too. But thank you for the info, I can keep using it without worries. Once I see a modder had put out a big update or something that affects my actual gameplay, then I'll have tell it to update.

 

No problem.

 

With Refresh Mods Automatically, it talks to github to check to see if there's any updates. This will only take a few seconds.

 

Each time you play, it does copy the files over. This is a 'safety' feature in case someone makes a mistake if they are editing the mod. We try to avoid needless support request to the modders for changes that the user makes. Its more noticeable if you are using a regular hard drive, rather than a solid state.

Share this post


Link to post
Share on other sites

Quick question.

 

I love using the mod launcher, and noticed that you are also able to download vanilla TFP versions with it.

 

Any chance you will be adding Alpha 16.4 in the near future?

 

I would like to download it so I can still play my current game saves when Alpha 17e comes out.

Share this post


Link to post
Share on other sites
Quick question.

 

I love using the mod launcher, and noticed that you are also able to download vanilla TFP versions with it.

 

Any chance you will be adding Alpha 16.4 in the near future?

 

I would like to download it so I can still play my current game saves when Alpha 17e comes out.

 

Yes, when it shows up in the list to download, I'll add it to the list :)

Share this post


Link to post
Share on other sites
Yes, when it shows up in the list to download, I'll add it to the list :)

 

Good news, thanks!

 

(Pity it's not available right now - it would help to develop mods for current versions. Well, c'est la vie.)

Share this post


Link to post
Share on other sites
Good news, thanks!

 

(Pity it's not available right now - it would help to develop mods for current versions. Well, c'est la vie.)

 

I added it. Restart your Mod Launcher and it should be available :)

Share this post


Link to post
Share on other sites
I added it. Restart your Mod Launcher and it should be available :)

 

This is great, especially with A17e coming so soon. Thanks!

Share this post


Link to post
Share on other sites

Sphereii, you ever think on how many hours you have saved some players being frustrated by trying to add mods to their game?

Bet it is a very high number.

Keep up the great work man.

 

I'd hug you but you are so far away.............and not for the launcher but because it's cold as balls here today and I could siphon off some of your body heat.

Share this post


Link to post
Share on other sites
Sphereii, you ever think on how many hours you have saved some players being frustrated by trying to add mods to their game?

Bet it is a very high number.

Keep up the great work man.

 

I'd hug you but you are so far away.............and not for the launcher but because it's cold as balls here today and I could siphon off some of your body heat.

 

Thank you.

 

It's chilly here too, with a winter storm rolling in tomorrow morning. If you are coming, I'd plan on arriving tonight. We have tostitos.

Share this post


Link to post
Share on other sites

@ sphereii .. Good day and hope you are doing well.

 

Question about A17 .. Will you be Updating your files to A17 in your Fun Pimps folder or do I have to run the Steam updater ..

Why I ask is because of the A16.4 versions in my game folder .. the mods that are already installed ..

I know it will be a couple of months for them to get around to updating their Mods to A17

 

Hope that all makes since … BE Safe and enjoy the week … the Old Gamer .. :02.47-tranquillity:

 

PS: I checked the launcher and didn't see A17 .. I did look

Edited by gpcstargate (see edit history)

Share this post


Link to post
Share on other sites
@ sphereii .. Good day and hope you are doing well.

 

Question about A17 .. Will you be Updating your files to A17 in your Fun Pimps folder or do I have to run the Steam updater ..

Why I ask is because of the A16.4 versions in my game folder .. the mods that are already installed ..

I know it will be a couple of months for them to get around to updating their Mods to A17

 

Hope that all makes since … BE Safe and enjoy the week … the Old Gamer .. :02.47-tranquillity:

 

PS: I checked the launcher and didn't see A17 .. I did look

 

Nice to see you again.

 

"A17" doesn't so much exist yet. However, it's available under the latest_experimental build under The Fun Pimp category. That will grab A17e.

 

None of the other mods listed will change until A17 goes stable :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...