Jump to content

The 7D2D Mod Launcher - A Mod Launcher for 7 Days to Die


sphereii

Recommended Posts

....hmmm....ummm....

I can't upload my mod to github.com because there's a 100mB limit....

 

do I have any options ?

 

Yes. As Guppycur already replied, for larger mods, we recommend using Gitlab.com. It has a much higher limit, at the expense that it's a bit slower.

 

You can use Github Desktop still with it, and it acts and behaves the same way.

Link to comment
Share on other sites

You can use Github Desktop still with it, and it acts and behaves the same way.

What's the meaning? It's only intended for gitHub....

How can i logIn through him to gitLab?

 

...guys, you too, messed with that SSH-key to send the first repository....ohhh...

Edited by n2n1 (see edit history)
Link to comment
Share on other sites

What's the meaning? It's only intended for gitHub....

How can i logIn through him to gitLab?

 

...guys, you too, messed with that SSH-key to send the first repository....ohhh...

 

GitHub Desktop is a tool that can connect to either github.com or gitlab.com.

 

In order to use gitlab.com, you will need to make a new account there. It's a different company.

 

Once logged into gitlab.com, you can create a new empty repository.

 

Then, in GitHub Desktop, go to Clone, and select URL

 

6LJWtaQ.png

 

mzBLRTU.png

 

You won't need to use GitHub.com at all.

  • Like 1
Link to comment
Share on other sites

Having security issues with win10. Can't install launcher getting "you admin has blocked this app" even though I was opening as the admin and was on my admin user. Could someone point me to work around post? Thanks in advance for your help

Link to comment
Share on other sites

Thank You sphereii !

 

I was able to unload on gitlab.com with the help of a GitHub Desktop!

You forgot to write that i need to change the address where the mod will be unloaded, but i guessed it :)

 

Now, i'm asking You to check the file topology to see if i made the folders right to be compatible with the launcher.

If everything is o'K - then add to the Launcher! :)

 

https://gitlab.com/n2n1/Classic-Style-Hardcore-MOD.git

Edited by n2n1 (see edit history)
Link to comment
Share on other sites

Having security issues with win10. Can't install launcher getting "you admin has blocked this app" even though I was opening as the admin and was on my admin user. Could someone point me to work around post? Thanks in advance for your help

 

Sorry for the trouble. See if this helps you out: https://superuser.com/questions/1252575/unable-to-install-clickonce-application-due-to-security-settings-windows-10

Link to comment
Share on other sites

Thank You sphereii !

 

I was able to unload on gitlab.com with the help of a GitHub Desktop!

You forgot to write that i need to change the address where the mod will be unloaded, but i guessed it :)

 

Now, i'm asking You to check the file topology to see if i made the folders right to be compatible with the launcher.

If everything is o'K - then add to the Launcher! :)

 

https://gitlab.com/n2n1/Classic-Style-Hardcore-MOD.git

 

Looks good! I'll give it a test tomorrow and we'll get it loaded up ASAP!

Link to comment
Share on other sites

after last update the launcher won't load the default mods. it says it timed out during the operation. i uninstalled and reinstalled and still won't read them.

 

i got it to work. just left it for a few and it read them finally.

Link to comment
Share on other sites

Once again I wanted to thank you for so much work, SphereII. With the latest update everything works perfectly (no longer manual updates). Excellent is the word that best defines it. My sincere thanks. Greetings.

Link to comment
Share on other sites

Question: If you are using advanced mode already, then what will it mean for mod users when Alpha 17 is released? Will our A16.4 mods still work using the launcher since it created a copy of the game? Or is there a tie in to Steam that, when it updates to A17, we will not be able to launch our A16 copies?

Link to comment
Share on other sites

I'm having an issue after I restarted my pc where the launcher is stuck at loading splash screen. No mods are listed and my installed mod (starvation) doesn't show. I reinstalled and get the same. Any suggestions?

Link to comment
Share on other sites

I'm having an issue after I restarted my pc where the launcher is stuck at loading splash screen. No mods are listed and my installed mod (starvation) doesn't show. I reinstalled and get the same. Any suggestions?

 

Sorry for the trouble. Can you check the "Disable SSL" checkmark, and try again? Usually, it's an issue with something blocking the launcher, like a firewall.

Link to comment
Share on other sites

Hello,

 

I think the application is great! Makes modding so much easier... But, I am having an issue with any mod I setup. I select the mod I want (currently any of the Valmod ones), select to copy my 7DTD install, and it appears to copy OK. I then pre-sync, and it appears to go OK as well.

 

When I launch the game, I keep getting an error about access to path/file items.xml is denied. I tried adding "Everyone" to Full Control on the folders/files, but I still get another error relating to access.

 

Any ideas? Thanks in advance for the help!

 

-MandalorePatriot

Link to comment
Share on other sites

Yes, what sphereii said or...

 

This could be an issue with the properties of that file. Albeit it should be fine but and shouldn't do this but maybe just maybe according to MS the file attribute "Read Only" is set. In the Launcher it tells you where that folder is for that mod. Get to that folder then get to the ..\7DaysToDie\Data\Config <- in that config folder is the items.xml file. Right click - select properties and then at the bottom make sure 'read only' is unchecked.

Link to comment
Share on other sites

Yes, what sphereii said or...

 

This could be an issue with the properties of that file. Albeit it should be fine but and shouldn't do this but maybe just maybe according to MS the file attribute "Read Only" is set. In the Launcher it tells you where that folder is for that mod. Get to that folder then get to the ..\7DaysToDie\Data\Config <- in that config folder is the items.xml file. Right click - select properties and then at the bottom make sure 'read only' is unchecked.

 

That was it! The issue is the copied items.xml file was set to read only, once I removed that everything launched without issues! Thanks!!!!!

 

-MandalorePatriot

Link to comment
Share on other sites

Ravenhearst loading issues

 

Having trouble getting the game to load. I have downloaded the mod launcher. It loads up fine. I got the Ravenhearst mod to download through the launcher. When I try to play, i get to the "loading main menu...." screen and then the freeze happens.

 

I am running on windows 7. I have down loaded the required .Net fix per the forums.

I did the complete restart per the forums.

 

But the game still freezes every time i try to play Ravenhearst.

 

I am at a complete loss and would love to give it a try. If there is something i missed of did wrong, I'm open to do it or try something else. If anyone can please help.

 

Thank you

Link to comment
Share on other sites

Having trouble getting the game to load. I have downloaded the mod launcher. It loads up fine. I got the Ravenhearst mod to download through the launcher. When I try to play, i get to the "loading main menu...." screen and then the freeze happens.

 

I am running on windows 7. I have down loaded the required .Net fix per the forums.

I did the complete restart per the forums.

 

But the game still freezes every time i try to play Ravenhearst.

 

I am at a complete loss and would love to give it a try. If there is something i missed of did wrong, I'm open to do it or try something else. If anyone can please help.

 

Thank you

 

Ravenhearst includes a lot of extra assets that load on start up. A longer boot up time is expected for that. For some people, it may take up to 20 minutes to load.

 

However, if you feel it's taking much longer than expect, you could post your log file.

 

1) start up ravenhearst again, through the mod launcher. Wait for it to crash.

2) In the Mod Launcher, click on the View Menu, then Log Files.

3) In the combo box, select the game's output_log.txt ( by default, the launcher log is displayed )

4) Click on Upload Log file, and post your pastebin.com link here.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...