Jump to content
sphereii

The 7D2D Mod Launcher - A Mod Launcher for 7 Days to Die

Recommended Posts

@ sphereii...I am having the exact same issues as Amanitasec...Same errors on trying to launch. I also have validated my files on the vanilla game and even tried the Win 7 tool just for giggles...(It would not run as I am using Win 8). I D/L'd the mod file and installed manually and it works fine, but I'd really like to get this resolved so I can switch between a couple of mods.

 

The mods I have tried (Ravenhearst & WOTW's) both show as installed on the splash page, but when I try to launch either, I just get vanilla.

 

Any ideas?

 

Sorry for the trouble. Let's get you sorted out.

 

Go back to Ravenhearst, and click on the Pre-Sync button. Then, go to the View Menu, then Log Files. Click on Upload log file, and send me the pastebin.com link.

Share this post


Link to post
Share on other sites

@sphereii--Thanks for leading me by the hand ;-). Here is the link you requested.

 

https://pastebin.com/cpZQSJ5d

 

I suspect that we are in different countries, given the amount of time between our postings, so I suspect this will take a couple of days of back and forth.

 

Thanks again for taking the time.

Share this post


Link to post
Share on other sites
@sphereii--Thanks for leading me by the hand ;-). Here is the link you requested.

 

https://pastebin.com/cpZQSJ5d

 

I suspect that we are in different countries, given the amount of time between our postings, so I suspect this will take a couple of days of back and forth.

 

Thanks again for taking the time.

 

Okay, so it's a problem between hosting and your PC. You are running Windows 8? Any anti-virus or firewall?

 

You could also try:

 

1) Click on Disable SSL, restart the Mod Launcher, and do another Pre-Sync

 

or

 

2) Click on Check here to download from a mirror, below the Pre-Sync, and then press Pre-Sync

Share this post


Link to post
Share on other sites
Okay, so it's a problem between hosting and your PC. You are running Windows 8? Any anti-virus or firewall?

 

You could also try:

 

1) Click on Disable SSL, restart the Mod Launcher, and do another Pre-Sync

 

or

 

2) Click on Check here to download from a mirror, below the Pre-Sync, and then press Pre-Sync

---------------------------------------------------------------------------------------------------------

 

ok...I checked Disable SSL, then restarted the launcher. The presync still gave the same error messages.

 

With SSL still disabled I checked the D/L from a mirror box and then tried the Pre-Sync, same error messages.

 

And just because I wasn't sure, I unchecked Disable SSL and then, with the D/L from a mirror box still checked I tried the Pre-Sync again, no joy. :-/

 

Just to let you know, I have the "Run game as admin" box checked as well.

 

As far as my computer...Win 8 x64, windows firewall, Malwarebytes 3.4.5 free for my antivirus.

Edited by sandpaper600 (see edit history)

Share this post


Link to post
Share on other sites
---------------------------------------------------------------------------------------------------------

 

ok...I checked Disable SSL, then restarted the launcher. The presync still gave the same error messages.

 

With SSL still disabled I checked the D/L from a mirror box and then tried the Pre-Sync, same error messages.

 

And just because I wasn't sure, I unchecked Disable SSL and then, with the D/L from a mirror box still checked I tried the Pre-Sync again, no joy. :-/

 

Just to let you know, I have the "Run game as admin" box checked as well.

 

As far as my computer...Win 8 x64, windows firewall, Malwarebytes 3.4.5 free for my antivirus.

 

Which version of .NET do you have installed?

Share this post


Link to post
Share on other sites
Which version of .NET do you have installed?

 

I recall a player with Malware bytes installed having issues with the game / installer but I can’t find the post. If I recall it was causing the same issues but not sure if it was here or on the steam forum.

Share this post


Link to post
Share on other sites

I have Microsoft .NET version 4.0.0.0.

 

I disabled Malwarebytes and tried to Pre-sync the mod again, but still same errors.

 

I decided to try D/Ling another mod using the launcher, with MB disabled. I decided to leave SSL disabled and told it to D/L a fresh copy from Steam. I'm in the process now and will let you know the outcome.

Share this post


Link to post
Share on other sites
I have Microsoft .NET version 4.0.0.0.

 

I disabled Malwarebytes and tried to Pre-sync the mod again, but still same errors.

 

I decided to try D/Ling another mod using the launcher, with MB disabled. I decided to leave SSL disabled and told it to D/L a fresh copy from Steam. I'm in the process now and will let you know the outcome.

 

It could be the version of .NET that you have installed. TLS support came into its own in later versions.

 

https://www.microsoft.com/en-ca/download/details.aspx?id=49981

Share this post


Link to post
Share on other sites
It could be the version of .NET that you have installed. TLS support came into its own in later versions.

 

https://www.microsoft.com/en-ca/download/details.aspx?id=49981

 

OK, it was a late night last night, so I didn't come back to reply, but I think I've got it hammered out. Turns out BB_Drifter had the key. It was Malwarebytes blocking the github connection? Not sure what it was actually doing, but when I turned MB off, it worked fine to D/L Clockwork Orange and launched fine.

 

I do have a couple of questions about using the launcher. The user blurbs made it look like there was a way to kinda mix and match mods using the launcher. Like if I wanted to play CW Orange, but wanted to use the BBM from WOTW's.

 

I see that there is SMX Big Back Pack listed under "UI's", so I would D/L this and.....what?

 

sphereii--Thanks again for your time and patience in helping me through getting the launcher issue straightened out.

 

Big Thank You and a tip 'o the hat to BB_Drifter for the clue about MB!!

Share this post


Link to post
Share on other sites
OK, it was a late night last night, so I didn't come back to reply, but I think I've got it hammered out. Turns out BB_Drifter had the key. It was Malwarebytes blocking the github connection? Not sure what it was actually doing, but when I turned MB off, it worked fine to D/L Clockwork Orange and launched fine.

 

I do have a couple of questions about using the launcher. The user blurbs made it look like there was a way to kinda mix and match mods using the launcher. Like if I wanted to play CW Orange, but wanted to use the BBM from WOTW's.

 

I see that there is SMX Big Back Pack listed under "UI's", so I would D/L this and.....what?

 

sphereii--Thanks again for your time and patience in helping me through getting the launcher issue straightened out.

 

Big Thank You and a tip 'o the hat to BB_Drifter for the clue about MB!!

 

I'm glad you were able to get it work, and thank you, BB_Drifter, for giving the key advice.

 

The mix and matching of mods is usually something I do, and is possible for the user as well. However, it's not 100% straightforward about what mods are available to combine.

 

The problem with the bigger back pack mod is that the UI needs adjustment to accommodate it. Clockwork Project has its own custom UI, so you'd have to manually adjust the values for it to work.

 

The mix and match is more for: vanilla game + SMX Bigger back pack + compo pack, and that type.

Share this post


Link to post
Share on other sites

Howdy Sphereii.

 

Firstly,

I have to respect your commitment to the consumer support you have displayed in this thread.

 

Secondly,

I wanted to start using mods on this game for the first time and therefore your mod launcher too. However, if I have slowly made my own xml edits to the base game over time and installed a custom UI (SMX) directly to the vanilla games folders.

Will using this launcher cause issues / reset my edits already made?

 

I saw it had an advanced option for "seperating mods and making fresh copies of the game" but I was wondering if this pulled a new copy from steam or simply did a copy/paste of the existing "vanilla files" edits and all that are already on my pc?

Share this post


Link to post
Share on other sites
Howdy Sphereii.

 

Firstly,

I have to respect your commitment to the consumer support you have displayed in this thread.

 

Secondly,

I wanted to start using mods on this game for the first time and therefore your mod launcher too. However, if I have slowly made my own xml edits to the base game over time and installed a custom UI (SMX) directly to the vanilla games folders.

Will using this launcher cause issues / reset my edits already made?

 

I saw it had an advanced option for "seperating mods and making fresh copies of the game" but I was wondering if this pulled a new copy from steam or simply did a copy/paste of the existing "vanilla files" edits and all that are already on my pc?

 

Thank you kindly for the kind words.

 

The Mod Launcher will make a copy of your steam folder, then install any mods in the copy. If you have XML changes in your steam folder, these will be copied too, and will be over-written by the new mod, if they have changed the same files. You can also choose an option to download from steam completely.

 

If you have made XML changes in your steam folder, you may want to make a copy of the game to keep your changes. If the Pimps push out an update, steam will likely auto-update and remove all your changes.

 

Let me know if that answers your questions.

Share this post


Link to post
Share on other sites

Answers my questions brilliantly, also thanks for the reminder on the backups.

 

I just assumed I could postpone or rollback but hadn't considered it wouldn't rollback to my changes in the event of an update. I'll get right on that.

Share this post


Link to post
Share on other sites
Answers my questions brilliantly, also thanks for the reminder on the backups.

 

I just assumed I could postpone or rollback but hadn't considered it wouldn't rollback to my changes in the event of an update. I'll get right on that.

 

Many a tear has been shed in the past by an auto-update from Steam :)

Share this post


Link to post
Share on other sites

Simple mode greyed out

 

Hi I've not had any problems with your launcher until now. But it seems that the simple option is greyed out. I've white listed the launcher.exe which lol was a pain to find. I've tried running it as admin also. but nothing seems to allow me to use simple mode.1276399959_7daystoDieLauncherscreenshot.jpg.60da28bd6402b1e78015d18f90503041.jpg

Share this post


Link to post
Share on other sites
Hi I've not had any problems with your launcher until now. But it seems that the simple option is greyed out. I've white listed the launcher.exe which lol was a pain to find. I've tried running it as admin also. but nothing seems to allow me to use simple mode.[ATTACH=CONFIG]24407[/ATTACH]

 

Sorry for the confusion. In the early releases, Simple had a place. However, with the current status of mods, there was little way to make sure they were cleanly installed. It's highly recommended to use Advanced mod to install, which will make a complete copy of the game to install the mods too.

Share this post


Link to post
Share on other sites

you: "In the early releases, Simple had a place."

 

me: "It's kinda useless anyway."

 

...you're such a wordsmith. :)

Share this post


Link to post
Share on other sites

Advanced mode

 

Sorry for the confusion. In the early releases, Simple had a place. However, with the current status of mods, there was little way to make sure they were cleanly installed. It's highly recommended to use Advanced mod to install, which will make a complete copy of the game to install the mods too.

 

Ok so I tried using the advanced mode. Tried loading starvation mod. On loading I got TONS of failed to load assets errors. Not sure if this is the Mod launcher or the mod itself.

As a side question I was wondering if you can only install one mod at a time with the advanced mode?

Share this post


Link to post
Share on other sites

every time i try and launch a mod i either get told that im 'missing easyanticheat launcher .dlls' or when i get into game i have many error codes saying something about the easy anti cheat servers. ive deleted and reinstalled the easyanticheat, ive fixed the easyanticheat and nothing ive done has fixed this issue. any idea what im doing wrong?

Share this post


Link to post
Share on other sites
every time i try and launch a mod i either get told that im 'missing easyanticheat launcher .dlls' or when i get into game i have many error codes saying something about the easy anti cheat servers. ive deleted and reinstalled the easyanticheat, ive fixed the easyanticheat and nothing ive done has fixed this issue. any idea what im doing wrong?

 

Some of the mods need EAC disabled.

Share this post


Link to post
Share on other sites
Ok so I tried using the advanced mode. Tried loading starvation mod. On loading I got TONS of failed to load assets errors. Not sure if this is the Mod launcher or the mod itself.

As a side question I was wondering if you can only install one mod at a time with the advanced mode?

 

Sorry for the delay. Could you try to load the mod again, and if it fails, can you do the following for me?

 

1) Go to the Mod Launcher

2) Click on the View Menu

3) Click on Log Files

4) Click on Upload Log File, and give me the pastebin.com link.

5) In the same screen, change the 7d2dlauncher.txt drop down to output_log.txt

6) Click on Upload Log file, and give me the pastebin.cm link.

 

As for your other question, the Advanced mode lets you make multiple copies of the game, with a mod installed in each copy. So you will be able to manage multiple mods, in different game folders. Is that what you were asking?

Share this post


Link to post
Share on other sites

Pastebin

 

Sorry for the delay. Could you try to load the mod again, and if it fails, can you do the following for me?

 

1) Go to the Mod Launcher

2) Click on the View Menu

3) Click on Log Files

4) Click on Upload Log File, and give me the pastebin.com link.

5) In the same screen, change the 7d2dlauncher.txt drop down to output_log.txt

6) Click on Upload Log file, and give me the pastebin.cm link.

 

As for your other question, the Advanced mode lets you make multiple copies of the game, with a mod installed in each copy. So you will be able to manage multiple mods, in different game folders. Is that what you were asking?

 

https://pastebin.com/FFqGaZ6c

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...