Jump to content

The 7D2D Mod Launcher - A Mod Launcher for 7 Days to Die


Recommended Posts

7DTDlauncher.txt

https://pastebin.com/t05XLFrs

 

output_log.txt

https://pastebin.com/0fhAyuxV

 

I hate to bother you seeing how busy you are. When I select play mod It is now stopping at the command line

Copying is Done.

Launching \7DaysToDie.exe

 

Never be shy reaching out for help. It's never a bother.

 

It looks like the copy of the game failed, even before applying the mod. Are you running and anti virus programs?

Link to post
Share on other sites
One users reported they installed 4.6.2, and it didn't seem to work for them. Once they installed 4.6.1, it started working. I'm not sure why that is, since the mod launcher doesn't really use anything special about those different versions. If you can confirm that 4.6.1 is installed, re-send your log files please, and I'l be happy to look.

 

I had actually installed the newest version, 4.7.1. So I downgraded net framework to 4.6.1 to try this out too, but no dice. I had gotten the exact same "error downloading...cleaning corrupted data" message already a few days *before* the whole Github-updating, so it's likely unrelated.

Here's the log again, today I tried with CBmod: https://pastebin.com/GmJGhL8U

Link to post
Share on other sites
I had actually installed the newest version, 4.7.1. So I downgraded net framework to 4.6.1 to try this out too, but no dice. I had gotten the exact same "error downloading...cleaning corrupted data" message already a few days *before* the whole Github-updating, so it's likely unrelated.

Here's the log again, today I tried with CBmod: https://pastebin.com/GmJGhL8U

 

This is a weird one. You are getting errors like it's still the SSL connection. Do you have any anti-virus or firewalls, other than default windows? maybe it's interfering and rejecting the change?

 

- - - Updated - - -

 

Can anyone tell me how to add the 120 increased inventory size mod to other mods like WOTW, if it's even possible, through the mod launcher?

 

Is there a mod that currently has the 120 slot backpack?

Link to post
Share on other sites
This is a weird one. You are getting errors like it's still the SSL connection. Do you have any anti-virus or firewalls, other than default windows? maybe it's interfering and rejecting the change?

 

- - - Updated - - -

 

 

 

Is there a mod that currently has the 120 slot backpack?

 

In the mod launcher, you can install the simple UIs with the 120 inventory backpack size. I tried copying the URL link provided to add to WOTW, but nothing seemed to have changed. And Undead Legacy has a pretty huge backpack size. I don't know if it's 120, but it's a lot bigger than the big backpack size inventory you can get in WOTW.

Link to post
Share on other sites
This is a weird one. You are getting errors like it's still the SSL connection. Do you have any anti-virus or firewalls, other than default windows? maybe it's interfering and rejecting the change?

 

- - - Updated - - -

 

No extra firewall, only Avast, but disabling that makes no difference, I tried that a few times now.

Link to post
Share on other sites
In the mod launcher, you can install the simple UIs with the 120 inventory backpack size. I tried copying the URL link provided to add to WOTW, but nothing seemed to have changed. And Undead Legacy has a pretty huge backpack size. I don't know if it's 120, but it's a lot bigger than the big backpack size inventory you can get in WOTW.

 

Each UI needs to know a fair amount about the base mod; Simple UI would have to be ported to work with WotW. I'd ask in the Simple UI thread to see if it's possible.

Link to post
Share on other sites
No extra firewall, only Avast, but disabling that makes no difference, I tried that a few times now.

 

Can you try Ravenhearst 7 Days Horde Edition? When you install the game for it, check the mark that says "Check here to download from mirror" and see if that lets you play that mod. It'll download from GitLab instead of Github, which is another hosting site.

Link to post
Share on other sites

I have another question, how do I play the early builds of 7d2d? I installed stable_u52, the latest experimental u52 and alpha 10.4 through the launcher, but when I load the game, it's still the latest update. And I do make new worlds each time I try it out.

Link to post
Share on other sites
I have another question, how do I play the early builds of 7d2d? I installed stable_u52, the latest experimental u52 and alpha 10.4 through the launcher, but when I load the game, it's still the latest update. And I do make new worlds each time I try it out.

 

In order to download the older versions, you would have to use the Download From Steam option. This will sync up the older alphas.

Link to post
Share on other sites
Never be shy reaching out for help. It's never a bother.

 

It looks like the copy of the game failed, even before applying the mod. Are you running and anti virus programs?

 

I use Advanced System Care and I checked my firewall setting and all of the 7dtd versions including the mod launcher mods I have tried to play are allowed. I have GNAMod working. If I minimize the screen as soon as it starts loading a window was popping up from system care asking whether to allow it or not. I couldn't see it with the game loading screen.

 

I am not seeing that same window for War of the walkers though so it seems to be my computer settings somewhere. I'm not much of a software user unfortunately.

Link to post
Share on other sites
I use Advanced System Care and I checked my firewall setting and all of the 7dtd versions including the mod launcher mods I have tried to play are allowed. I have GNAMod working. If I minimize the screen as soon as it starts loading a window was popping up from system care asking whether to allow it or not. I couldn't see it with the game loading screen.

 

I am not seeing that same window for War of the walkers though so it seems to be my computer settings somewhere. I'm not much of a software user unfortunately.

 

Gotcha. It's probably ASC that is causing the issue. These anti-virus tools prevent other programs from downloading and copying files on your computer, which is usually a good thing. However, that's kind of the purpose of the Mod Launcher.

 

Take a look at this site, https://www.iobit.com/product-manuals/asc-ultimate-help/, which shows you the Whitelist screen. Maybe you can white list the mod launcher, and the folder it'll copy the mods too (c:\7d2d)?

Link to post
Share on other sites
Can you try Ravenhearst 7 Days Horde Edition? When you install the game for it, check the mark that says "Check here to download from mirror" and see if that lets you play that mod. It'll download from GitLab instead of Github, which is another hosting site.

 

Yes, downloading from GitLab works.

Link to post
Share on other sites
Yes, downloading from GitLab works.

 

Okay, I can set up mirroring for most of the mods that'll automatically update matching gitlab links. Since this is an initially a manual step for me, which mods were you most interested in, and I'll get started hooking them in.

Link to post
Share on other sites
Okay, I can set up mirroring for most of the mods that'll automatically update matching gitlab links. Since this is an initially a manual step for me, which mods were you most interested in, and I'll get started hooking them in.

 

Thank you for the support and the workaround! If you just could host Starvation on the mirror please, that'd be great. It's the one mod where I get the most use out of the launcher's incremental updates, since my files are almost all customized.

Link to post
Share on other sites
I use Advanced System Care and I checked my firewall setting and all of the 7dtd versions including the mod launcher mods I have tried to play are allowed. I have GNAMod working. If I minimize the screen as soon as it starts loading a window was popping up from system care asking whether to allow it or not. I couldn't see it with the game loading screen.

 

I am not seeing that same window for War of the walkers though so it seems to be my computer settings somewhere. I'm not much of a software user unfortunately.

 

I USED ASC for years ... But about 6-7 months ago something happened with the way it works and Started causing all kinds of issues and Game problems .. Took into a computer shop and had it removed and all it's mighty threads (The way it installs into your system .. it isn't an easy uninstall like they tell you it is .. it will leave things in the computer if you are not careful ) ... NOW I have no problems with any games ....

Just a Thought you might want to think about.

Link to post
Share on other sites

Has anyone else had issues with this mod launcher not quite doing what it should be since the recent update?

 

I'm fairly new to using mods on 7dtd and quickly found this mod launcher. Worked great, letting me download, install, play, and switch between different mods quick and easy. But since the update on 2-24, it's a huge pain to actually get a mod I didn't already have installed to run. It will download the mod, creating the new folder and everything. But it launches the base game instead of the mod. Clicking pre-sync mod button no longer does anything either.

 

Update... I thought I had updated the mod launcher, but it seems that I was still using the prior version 1.0.4.6. Now that I have the updated version... hoping all goes well. =D

Edited by Slowpokie (see edit history)
Link to post
Share on other sites

Having a small issue could use some help.

 

so what I did was start with a clean copy of 7 days to die 16.4

modded in a simple ui

tested worked fine

installed sdx compliled it on modded copy no sdx mods installed (just first build)

tested worked fine

installed katana mod

tested worked fine

used Beyond Compare 4 to find all changed files ---> copied to folder

uploaded the files to my github used 7 days to Die mod launcher to download install and launch and get

 

 

Uerror.png.3c26ac7da665f6bac940e2a57cc2e45c.png

 

any ideas? if there is any log files that would help let me know and I will post them kinda new to the launcher

Edited by MadMan2415
clicked the wrong button wasn't done writing yet (see edit history)
Link to post
Share on other sites

and now it gets weirder if I go to the folder where the launcher installed the working copy of the mod the 7days2die.exe file's icon is the weird icon (the one that shows up like when a shortcut points to a file that no longer exists). so just for science I copied the file from my clean copy over to the folder for the modded version and left the folder open to watch what happens and hit play mod and boom icon changes back and error again. did the copy thing again and this time just ran the install from the folder itself (so used the launcher to install and sync but launched from the exe in the folder) and 7 days started fine, new game created fine, mods working in the game itself. so it only seems to do if if I try to launch the mod by hitting play inside the Mod Launcher.

Edited by MadMan2415
can't spell (see edit history)
Link to post
Share on other sites
Has anyone else had issues with this mod launcher not quite doing what it should be since the recent update?

 

I'm fairly new to using mods on 7dtd and quickly found this mod launcher. Worked great, letting me download, install, play, and switch between different mods quick and easy. But since the update on 2-24, it's a huge pain to actually get a mod I didn't already have installed to run. It will download the mod, creating the new folder and everything. But it launches the base game instead of the mod. Clicking pre-sync mod button no longer does anything either.

 

Update... I thought I had updated the mod launcher, but it seems that I was still using the prior version 1.0.4.6. Now that I have the updated version... hoping all goes well. =D

 

Are things working better for you now?

 

- - - Updated - - -

 

and now it gets weirder if I go to the folder where the launcher installed the working copy of the mod the 7days2die.exe file's icon is the weird icon (the one that shows up like when a shortcut points to a file that no longer exists). so just for science I copied the file from my clean copy over to the folder for the modded version and left the folder open to watch what happens and hit play mod and boom icon changes back and error again. did the copy thing again and this time just ran the install from the folder itself (so used the launcher to install and sync but launched from the exe in the folder) and 7 days started fine, new game created fine, mods working in the game itself. so it only seems to do if if I try to launch the mod by hitting play inside the Mod Launcher.

 

That is strange indeed. The mod launcher makes a copy of your 7 days to die files, including the 7daystodie.exe. There's no mod that affects that file either.

 

What kind of anti-virus / anti-spyware / firewall software are you running? Sometimes that interferes with mods and the mod launcher. They detect that a program is downloading and copying files, and in the case of SDX, modifying DLL files.

 

This triggers quite a few of these programs (rightfullly so! We don't want programs to do this for us, typically). But in this case, that's the purpose of SDX and the Mod Launcher, so I usually suggest white listing the mod launcher and the install folder (C:\7D2D, for example).

Link to post
Share on other sites

Using Malwarebytes, Rouge Killer, Malwarebytes Anti-Root kit, MSE, and Zone Alarm Firewall. Launcher and C:\7D2D are set to allowed and ignored in all of them. was thinking that it is something in my mod because I can download and run any of the default mods such as WOTW without any issue.

Edited by MadMan2415
Still can't spell Need Coffee (see edit history)
Link to post
Share on other sites
Using Malwarebytes, Rouge Killer, Malwarebytes Anti-Root kit, MSE, and Zone Alarm Firewall. Launcher and C:\7D2D are set to allowed and ignored in all of them. was thinking that it is something in my mod because I can download and run any of the default mods such as WOTW without any issue.

 

Would you be open to private messaging me a link for me to review your mod? It may be a few hours before I can get around to it however. It's a very unusual issue.

Link to post
Share on other sites
Are things working better for you now?

 

Yes Sphereii. Thank you. I was a dumbass. I thought I had updated. However, I proved that I didn't. Even worse, it was only after I posted that I realized that there were clearly printed notes as to when the last post was. After then going back and reading the stuff from the past few days, I found out my error.

Link to post
Share on other sites
Are things working better for you now?

 

Yes Sphereii. Thank you. I was a dumbass. I thought I had updated. However, I proved that I didn't. Even worse, it was only after I posted that I realized that there were clearly printed notes as to when the last post was. After then going back and reading the stuff from the past few days, I found out my error.

 

No worries. It was a very awkward problem to have, and it is challenging getting the word out, even under the best of conditions. I posted the note in the Mod Launcher in hopes that people would be able to see it, but in hindsight, I realized if the launcher wasn't reading the mod list, it was unlikely reading that note as well :)

Link to post
Share on other sites

It appears that the problem was inexperiance with Beyond 4 compare on my end.I was choosing Move to Folder instead of copy to folder.So the first changes worked but after i compared, uploaded and tested when I went back to my working folder and made any new edits when I compared, uploaded and tested I was missing files from the first set. Starting fresh to Check (not a big deal at this point just getting my base starting point started to use for a backup) will post back the results.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...