Jump to content
sphereii

The 7D2D Mod Launcher - A Mod Launcher for 7 Days to Die

Recommended Posts

My Launcher has stopped working properly all of a sudden.

 

http://i.imgur.com/U9vHsm0l.jpg

 

I could not find anyone else having this problem can you help me getting it to show all the Modpacks in the list again?

 

Have you tried to click on File -> Load Defaults?

 

- - - Updated - - -

 

GitHub's included in the massive DDoS attacks today, which is likely the cause of the problem.

 

That may explain it. JaxTeller718's configuration is not stored in Github, which may explain why it's the only one showing up.

Share this post


Link to post
Share on other sites

Updated the Config files a bit; added StompyNZ's BadCompany mod, and removed some older mods not compatible with A15.

Share this post


Link to post
Share on other sites

Can I put a link to a patch like herrpohl's tonemap into my server config to have it installed along with other mods for the server? Does it need to be denoted differently in the config file?

 

Thanks for your fantastic tool and the support you provide for it.

Share this post


Link to post
Share on other sites
Can I put a link to a patch like herrpohl's tonemap into my server config to have it installed along with other mods for the server? Does it need to be denoted differently in the config file?

 

Thanks for your fantastic tool and the support you provide for it.

 

Actually, you can download his patch, extract the zip file, and place his patch files as part of your normal zip file. The launcher will find them, and install them automatically.

Share this post


Link to post
Share on other sites

Sphereii, I've stopped updating Lathmod, and have instead created a new mod called Craftworx that's an overhaul of the old LathMod, but better. ;) Can you replace LathMod in the ModLauncher with Craftworx?

Share this post


Link to post
Share on other sites

hi there,

 

Mac users experience serious difficulties to add modes to their vanilla games. Appreciate if Mod Launcher supports Mac and eases the woes of my Mac players who are unable to upgrade to Valmar's mod.

Share this post


Link to post
Share on other sites
Sphereii, I've stopped updating Lathmod, and have instead created a new mod called Craftworx that's an overhaul of the old LathMod, but better. ;) Can you replace LathMod in the ModLauncher with Craftworx?

 

Sure Latheos. Is the Link changed?

 

- - - Updated - - -

 

hi there,

 

Mac users experience serious difficulties to add modes to their vanilla games. Appreciate if Mod Launcher supports Mac and eases the woes of my Mac players who are unable to upgrade to Valmar's mod.

 

The struggle with supporting Mac is that I do not have any experience with that platform, nor a machine to test.

Share this post


Link to post
Share on other sites
Yes. The new mod is located here.

 

The mod in the forum is located here.

 

Much obliged, SphereII. :)

 

All done. Craftworx should now appear in the Launcher.

Share this post


Link to post
Share on other sites

Question.. if I use this to add a few mods, is it easy to go back to vannilla? We have a vanilla server game we are running for my wife and myself, and I know she'll be ticked if we can't continue it.

 

I probably want to add the bad co. and the compopack. Would that create any incompatibilities bad adding both?

 

(I've used mod adding tools to skyrim, but that was the last one I really dug into a few years ago.)

 

Eager to add a bunch of new stuff to 7 Day! Thanks for the hard work creating this!

Edited by Gareee (see edit history)

Share this post


Link to post
Share on other sites
Question.. if I use this to add a few mods, is it easy to go back to vannilla? We have a vanilla server game we are running for my wife and myself, and I know she'll be ticked if we can't continue it.

 

I probably want to add the bad co. and the compopack. Would that create any incompatibilities bad adding both?

 

(I've used mod adding tools to skyrim, but that was the last one I really dug into a few years ago.)

 

Eager to add a bunch of new stuff to 7 Day! Thanks for the hard work creating this!

 

If you used the Advanced mode, it creates a copy of 7 Days to Die, so you can run multiple mods, without them conflicting. I usually leave my Steam copy as vanilla, so it can automatically update when updates are pushed, but keep all my mods in a separate folder.

Share this post


Link to post
Share on other sites

Ok, so I just install this and use advanced mode on all three systems, correct? The server system will use the server launch tool someone has posted here in the forums. How do I make the server launch tool launch using the mods selected from this? (Or once I set the mods, will it just automagically see them?)

 

We got really spoiled during the a15 testing, and we are jonesing for new content...lol!

Share this post


Link to post
Share on other sites
Ok, so I just install this and use advanced mode on all three systems, correct? The server system will use the server launch tool someone has posted here in the forums. How do I make the server launch tool launch using the mods selected from this? (Or once I set the mods, will it just automagically see them?)

 

We got really spoiled during the a15 testing, and we are jonesing for new content...lol!

 

The Launcher will help your clients' get the latest version of the mods installed, and will launch 7DaysToDie.exe with those mods loaded.

 

You would have to install the mods manually on the dedicated server. Sometimes its just a copy the mods download pack, while other mods may require additional changes. Usually the mods would have descriptions on how to install them on a server.

Share this post


Link to post
Share on other sites

I might try the poi addition one first, just to see if I have it set up properly. I've been running our local co op play server of my wifi surface, but I'm restoring an old hard wired pc first to see if I can get that to run the server.

Share this post


Link to post
Share on other sites
I might try the poi addition one first, just to see if I have it set up properly. I've been running our local co op play server of my wifi surface, but I'm restoring an old hard wired pc first to see if I can get that to run the server.

 

In the current A15.0 release, prefabs folders will need to be part of the client-side mod, as well as the server-side. But I do not believe the rwgmixer.xml needs to be included in the client-side package; That's the file that lists all the prefabs and where they are allowed to spawn.

 

A nice starting combination may be Valmod's Expansion, under the 7Days2Mod CompoPack heading. This will give you Valmar's mods, in addition to Magoli's prefabs. It's a popular combination that works well.

Share this post


Link to post
Share on other sites

Hi, thanks for this launcher, its great to be able to play modded and previous alphas easily.

I tried a13 again and it was fun...

 

But I installed alpha 12.5 , each time I hit play for some reason alpha 15 opens..

Ive deleted a12 and reinsalled but having no joy, any idea's ?

 

When I first played 7dtd it was on a12 and thought I'd try a playthrough again..

 

Any help is appreciated to help to get the launcher and a12 working.

 

I could just use the steam beta tab but I'd rather just install through the launcher and have it on my system.

I have both versions of valmod mods and the launcher has no problem with those...

 

Thanks.

Share this post


Link to post
Share on other sites

Is the mod to eliminate the bloom and sky fog listed anywhere? Or was that for <a15 only?

 

EDIT: found his thread and trying that as my first mod.

Edited by Gareee (see edit history)

Share this post


Link to post
Share on other sites

First try went badly. I tried megacity with valmod expansion.. the rgw took forever to genrate, and after 4 minutes the screen went black, and I couldn't pull up anything with cntrl alt delete or alt tab. trying something different to see if it'll work.. compo pack and valmod overhaul

Share this post


Link to post
Share on other sites
Hi, thanks for this launcher, its great to be able to play modded and previous alphas easily.

I tried a13 again and it was fun...

 

But I installed alpha 12.5 , each time I hit play for some reason alpha 15 opens..

Ive deleted a12 and reinsalled but having no joy, any idea's ?

 

When I first played 7dtd it was on a12 and thought I'd try a playthrough again..

 

Any help is appreciated to help to get the launcher and a12 working.

 

I could just use the steam beta tab but I'd rather just install through the launcher and have it on my system.

I have both versions of valmod mods and the launcher has no problem with those...

 

Thanks.

 

Hey TempusFugit

 

Are you using Advanced or Simple mode?

 

If you are using Advanced, then the Mod Launcher will try to log into steam, and sync up the correct beta version. The option would be "Download From Steam", instead of copying from your local Steam folder.

 

- - - Updated - - -

 

Is the mod to eliminate the bloom and sky fog listed anywhere? Or was that for <a15 only?

 

EDIT: found his thread and trying that as my first mod.

 

The Bloom and Skyfog were removed in A15, I think. I think he has added some Tone mapping adjustments, and then there's the 1-block crouch patch available too.

Share this post


Link to post
Share on other sites
BIGGER BACKPACKS http://steamcommunity.com/groups/valmod#announcements/detail/630897111563622681 I tried dl manually then dragging and dropping over created copy of V42 but the backpack doesn't change. Any ideas? Is there another way to do this with your mod?

 

Hey vudugan

 

I'll take a look at how Valmar has it set up, and see if we can make it easier for you.

Share this post


Link to post
Share on other sites
Hey TempusFugit

 

Are you using Advanced or Simple mode?

 

If you are using Advanced, then the Mod Launcher will try to log into steam, and sync up the correct beta version. The option would be "Download From Steam", instead of copying from your local Steam folder.

 

Hi I eventually got a12 installed, sort of anyway, using your advice..

 

I start the game and pick a seed name and change some settings, as the world is about to load I get null reference from the console and have to alt del to end 7dtd..

 

Ive tried using vac and without eac.. Also tried a random gen world and nav.. but the null appears and halts the world from loading.

 

Any ideas how to fix it ? Thanks.

 

EDIT: Im using advanced.

Edited by TempusFugit (see edit history)

Share this post


Link to post
Share on other sites

second try with compo and valmod worked great! The trick now will be to see if I can go back to vanilla to continue an older game.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...