Jump to content
sphereii

The 7D2D Mod Launcher - A Mod Launcher for 7 Days to Die

Recommended Posts

Hi, it turns out I hadn't fully deactivated norton. It works fine now, thanks. Was there an update to the mod launcher today?

 

Norton is aggressive.

 

A small update to allow a future mirroring effort, and allow local saves.

Share this post


Link to post
Share on other sites

I've been using the mod launcher for some great mods for a while now but suddenly today when I try to run it, it fails, Norton says I'm not allowed to use it and removes it, when I try to reinstall it, it goes all the way to 100% then this pops up;

 

"Windows can not access the specified device, path or file. You may not have the appropriate permissions to access the item."

 

How do I fix this?

Share this post


Link to post
Share on other sites
I've been using the mod launcher for some great mods for a while now but suddenly today when I try to run it, it fails, Norton says I'm not allowed to use it and removes it, when I try to reinstall it, it goes all the way to 100% then this pops up;

 

"Windows can not access the specified device, path or file. You may not have the appropriate permissions to access the item."

 

How do I fix this?

 

Ahh Norton, our old friend.

 

Can you run the mod launcher as admin? Can you set up an exclusion in Norton on the folder where the launcher is trying to install mods too?

Share this post


Link to post
Share on other sites

I can't even install the launcher... I tried excluding from Norton but still get the same message. I'm about to attempt the release.zip file way

 

**EDIT**

 

It failed as well...2058550270_MLError.jpg.6feb782f0fc8db73e60b2171e21d5d26.jpg

Edited by ElegantKa0s (see edit history)

Share this post


Link to post
Share on other sites
Done, attempting the install again now.

 

**EDIT**

 

Still getting same error...

 

Hmm I don't use Norton so I am not that familiar with it. I don't want to tell you to turn it off either. We just need a way to get Norton to ignore it

Share this post


Link to post
Share on other sites

It worked fine before today, that's whats confusing me... Then against I haven't shutdown/restarted in a while, I normally just put my pc in sleep mode. could it maybe just need a restart?

Share this post


Link to post
Share on other sites
It worked fine before today, that's whats confusing me... Then against I haven't shutdown/restarted in a while, I normally just put my pc in sleep mode. could it maybe just need a restart?

 

Hard to tell. Maybe Norton needs to be temporary disabled to installed? I do t have any experience in it.

Share this post


Link to post
Share on other sites

Norton was bought out by cubeii, sphereii's mortal enemy. This is his revenge...

 

...kidding aside, yeh a restart may help.

Share this post


Link to post
Share on other sites
Norton was bought out by cubeii, sphereii's mortal enemy. This is his revenge...

 

...kidding aside, yeh a restart may help.

 

cubeii? you misspelled sphereiv

Share this post


Link to post
Share on other sites
It worked fine before today, that's whats confusing me... Then against I haven't shutdown/restarted in a while, I normally just put my pc in sleep mode. could it maybe just need a restart?

 

Just an update. We continued this discussion on discord. The end result was temporarily disabling Norton, then installing the Mod Client. After that, it worked as expected.

Share this post


Link to post
Share on other sites
Just an update. We continued this discussion on discord. The end result was temporarily disabling Norton, then installing the Mod Client. After that, it worked as expected.

 

Yes it did. Thank you for all your assistance. I was losing my mind. Now I'm having a great time with the Settler's Mod. Now to hopefully get an updated True Survival ;)

Share this post


Link to post
Share on other sites

just wanted to chime in and say great work on the launcher, it works great and gets better each release.

 

Also, The "Refresh Mods Automatically" check box is now remembering its setting. I am not sure it is working as intended, but it is a little confusing how it is currently working since it looks like those check boxes would be tied to the individual mods based on how the UI is displayed, but it looks like the check boxes are really global settings that apply to all since checking or unchecking on one affects all installed.

 

if they are global, maybe they need to move to the settings menu/screen (or at least a separate outline box), but if they are not, it might be another bug.

 

Also a separate issue...on mods with a box for Server Information (like True Survival A16.2, Ravenhearst Test Server,etc.), the server Info box is being displayed in the upper right before the mod is installed and covering up part of the dialog saying it is not installed and the Download from Steam radio button text.

Share this post


Link to post
Share on other sites
just wanted to chime in and say great work on the launcher, it works great and gets better each release.

 

Also, The "Refresh Mods Automatically" check box is now remembering its setting. I am not sure it is working as intended, but it is a little confusing how it is currently working since it looks like those check boxes would be tied to the individual mods based on how the UI is displayed, but it looks like the check boxes are really global settings that apply to all since checking or unchecking on one affects all installed.

 

if they are global, maybe they need to move to the settings menu/screen (or at least a separate outline box), but if they are not, it might be another bug.

 

Also a separate issue...on mods with a box for Server Information (like True Survival A16.2, Ravenhearst Test Server,etc.), the server Info box is being displayed in the upper right before the mod is installed and covering up part of the dialog saying it is not installed and the Download from Steam radio button text.

 

The UI does need some more refinements. I made the options accessible for each mod, even though they are global. This is so that they are easily visible for the user, and they are typically focused just on one particular mod. There are a lot of casual users of the Mod Launcher that may not even be aware of the menu, let along where to look for options that may help get them started :)

 

I'll look and move the server info box around next update. Thanks for the feed back!

Share this post


Link to post
Share on other sites

Issue with Install

 

Due to some weird Windows install paranoia, I have to use the .zip files. The latest version of the .zip now produces a new issue on startup. An error making reference to "The application won't start because...side by side configuraiton is incorrect." I have had this issue with other programs because of mising runtimes, but I have all C++ runtimes (up to 2017) and .NET 4.7.1 framework installed. What did I screw up and how do I fix it?

Share this post


Link to post
Share on other sites
Due to some weird Windows install paranoia, I have to use the .zip files. The latest version of the .zip now produces a new issue on startup. An error making reference to "The application won't start because...side by side configuraiton is incorrect." I have had this issue with other programs because of mising runtimes, but I have all C++ runtimes (up to 2017) and .NET 4.7.1 framework installed. What did I screw up and how do I fix it?

 

Sorry for the delay. You can try making sure that you have .NET framework installed 4.5

Share this post


Link to post
Share on other sites
Sorry for the delay. You can try making sure that you have .NET framework installed 4.5

 

4.5 won't install since I have 4.7.1 already there. Is there any other runtime needed?

Share this post


Link to post
Share on other sites
4.5 won't install since I have 4.7.1 already there. Is there any other runtime needed?

 

No, it just uses .NET 4.5. No other framework should be needed.

Share this post


Link to post
Share on other sites
4.5 won't install since I have 4.7.1 already there. Is there any other runtime needed?

 

Okay, the application error log shows this:

 

Activation context generation failed for "D:\Games\Release\7D2DLauncher.exe.Manifest".Error in manifest or policy file "D:\Games\Release\7D2DLauncher.exe.Manifest" on line 2. Invalid Xml syntax.

 

Any help?

Share this post


Link to post
Share on other sites
Okay, the application error log shows this:

 

Activation context generation failed for "D:\Games\Release\7D2DLauncher.exe.Manifest".Error in manifest or policy file "D:\Games\Release\7D2DLauncher.exe.Manifest" on line 2. Invalid Xml syntax.

 

Any help?

 

Are you using the Release.zip package? I've never seen that error before.

Share this post


Link to post
Share on other sites
Are you using the Release.zip package? I've never seen that error before.

 

The one off the main post. The installer keeps getting blocked by my paranoid machine (saying the Admin is blocking it, in other words me). Downloaeded the archive again today and tried with a fresh extract just to be sure. So, yes I am using the Release.zip version.

Edited by PAKoffee (see edit history)

Share this post


Link to post
Share on other sites
The one off the main post. The installer keeps getting blocked by my paranoid machine (saying the Admin is blocking it, in other words me). Downloaeded the archive again today and tried with a fresh extract just to be sure. So, yes I am using the Release.zip version.

 

which anti-virus or security package are you using?

Share this post


Link to post
Share on other sites

error i cant lauch the mod laucher

 

PLATFORM VERSION INFO

Windows : 6.1.7601.65536 (Win32NT)

Common Language Runtime : 4.0.30319.34209

System.Deployment.dll : 4.0.30319.34280 built by: FX452RTMGDR

clr.dll : 4.0.30319.34209 built by: FX452RTMGDR

dfdll.dll : 4.0.30319.34280 built by: FX452RTMGDR

dfshim.dll : 4.0.41209.0 (Main.041209-0000)

 

SOURCES

Deployment url : https://7d2dlauncher.blob.core.windows.net/installer/7D2DLauncher.application

Server : Windows-Azure-Blob/1.0 Microsoft-HTTPAPI/2.0

 

IDENTITIES

Deployment Identity : 7D2DLauncher.application, Version=1.0.3.19, Culture=neutral, PublicKeyToken=7648fef8e97e2d05, processorArchitecture=msil

 

APPLICATION SUMMARY

* Installable application.

 

ERROR SUMMARY

Below is a summary of the errors, details of these errors are listed later in the log.

* Activation of https://7d2dlauncher.blob.core.windows.net/installer/7D2DLauncher.application resulted in exception. Following failure messages were detected:

+ Value does not fall within the expected range.

 

COMPONENT STORE TRANSACTION FAILURE SUMMARY

No transaction error was detected.

 

WARNINGS

There were no warnings during this operation.

 

OPERATION PROGRESS STATUS

* [12/1/2017 10:39:20 AM] : Activation of https://7d2dlauncher.blob.core.windows.net/installer/7D2DLauncher.application has started.

* [12/1/2017 10:39:30 AM] : Processing of deployment manifest has successfully completed.

 

ERROR DETAILS

Following errors were detected during this operation.

* [12/1/2017 10:39:30 AM] System.ArgumentException

- Value does not fall within the expected range.

- Source: System.Deployment

- Stack trace:

at System.Deployment.Application.NativeMethods.CorLaunchApplication(UInt32 hostType, String applicationFullName, Int32 manifestPathsCount, String[] manifestPaths, Int32 activationDataCount, String[] activationData, PROCESS_INFORMATION processInformation)

at System.Deployment.Application.ComponentStore.ActivateApplication(DefinitionAppId appId, String activationParameter, Boolean useActivationParameter)

at System.Deployment.Application.SubscriptionStore.ActivateApplication(DefinitionAppId appId, String activationParameter, Boolean useActivationParameter)

at System.Deployment.Application.ApplicationActivator.Activate(DefinitionAppId appId, AssemblyManifest appManifest, String activationParameter, Boolean useActivationParameter)

at System.Deployment.Application.ApplicationActivator.PerformDeploymentActivation(Uri activationUri, Boolean isShortcut, String textualSubId, String deploymentProviderUrlFromExtension, BrowserSettings browserSettings, String& errorPageUrl)

at System.Deployment.Application.ApplicationActivator.ActivateDeploymentWorker(Object state)

 

COMPONENT STORE TRANSACTION DETAILS

* Transaction at [12/1/2017 10:39:30 AM]

+ System.Deployment.Internal.Isolation.StoreOperationSetDeploymentMetadata

- Status: Set

- HRESULT: 0x0

+ System.Deployment.Internal.Isolation.StoreTransactionOperationType (27)

- HRESULT: 0x0

Edited by icedrone24 (see edit history)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...