Jump to content
sphereii

The 7D2D Mod Launcher - A Mod Launcher for 7 Days to Die

Recommended Posts

out of a sudden launcher refuse to download a mod(WoW in this case) it stuck on "Refreshing Mods for WoW"

 

I've restart the program and also my pc, nothing works. I can download directly from github tho so the problem is with the program

 

The Launcher has two ways to download:

 

1) Through the GitHub API

2) Direct Download

 

It appears that more ISPs are starting to block GitHub's API calls. If you check on the Direct Download, does it work better for you?

Share this post


Link to post
Share on other sites

Wanted to try dawn of the apocalypse and had a problem.

 

Then i wanted to uninstall it but i wrongly deleted it from the launcher. (the mod don't show up in the list anymore). How can i get it back ?

 

EDIT : Ok load default from one of the menus ;)

Edited by FFW_Rude (see edit history)

Share this post


Link to post
Share on other sites
Wanted to try dawn of the apocalypse and had a problem.

 

Then i wanted to uninstall it but i wrongly deleted it from the launcher. (the mod don't show up in the list anymore). How can i get it back ?

 

EDIT : Ok load default from one of the menus ;)

 

Glad it is working for you :)

Share this post


Link to post
Share on other sites

I've tried creating a mod, but without success. I'm mixing two separate mods, so I created a directory for the mod and extracted the stuff there. One's a UI, the other is an item, so there's no file conflicts. I then made a copy of Steam's install dir for 7D2D, and copied the mod directories over them, and tested it. Everything worked fine. I then created a zip file out of the directories, and extracted the zip file over the game copy, and everything still worked fine. Finally, I put the zip on dropbox, created a download link, and created a mod with that.

 

That's when things stopped working. It acts like everything is fine, but the game won't start, and I can see in the disk that at least the server data file is missing. It's there in the zip, but not it's not installed in the My Mods corresponding directory.

 

The log is here, and I exited the app, deleted all directories, and started everything from scratch to produce this log, so it should be clean. One file that is missing shows up as "copying directory", which I found suspicious. The link for the zip is in the log.

 

What am I doing wrong? It ought to work, because I can manually extract it to a pristine 7D2D directory and everything works. I've tried out a bunch of other mods, and they all work. So what's going wrong here?

Share this post


Link to post
Share on other sites

is there an option to turn off the check box for "Refresh Mods Automatically"? or a way to add additional download locations or file locations to a listed mod?

 

The problem i am having is that i am running StarvationMod16 from the mod launcher, but i am also applying Sirillions patched dll/xml files from https://7daystodie.com/forums/showthread.php?76756-SMX-Starvation-Mod-BigBag-Patch via a nexusmod rar file download that overwrites some of the files in the tempmods folder. But every time i open the launcher, it defaults back to Refresh Mods Automatically and if i/one of my players forget to uncheck that box, it redownloads the mod but not the patched files from the other location resulting in lost inventory items.

 

Thoughts?

Share this post


Link to post
Share on other sites
is there an option to turn off the check box for "Refresh Mods Automatically"? or a way to add additional download locations or file locations to a listed mod?

 

The problem i am having is that i am running StarvationMod16 from the mod launcher, but i am also applying Sirillions patched dll/xml files from https://7daystodie.com/forums/showthread.php?76756-SMX-Starvation-Mod-BigBag-Patch via a nexusmod rar file download that overwrites some of the files in the tempmods folder. But every time i open the launcher, it defaults back to Refresh Mods Automatically and if i/one of my players forget to uncheck that box, it redownloads the mod but not the patched files from the other location resulting in lost inventory items.

 

Thoughts?

 

Two ways:

 

Disable the Refresh Mods Automatically, then copy the new DLL and files directly into TempMods. Then use the Mod Launcher as normal.

 

or

 

Copy the files into the environment, after running Starvation Mod once through the Launcher, then manually copy the files in as you've been doing. From then on, just launch 7daystodie.exe directly, without using the Mod Launcher.

 

- - - Updated - - -

 

Is this only client side or can a server be use this?

 

It's client-side only, however, some Mods do package in their server files, which can be found under the TempMods folder, if they do.

 

- - - Updated - - -

 

I've tried creating a mod, but without success. I'm mixing two separate mods, so I created a directory for the mod and extracted the stuff there. One's a UI, the other is an item, so there's no file conflicts. I then made a copy of Steam's install dir for 7D2D, and copied the mod directories over them, and tested it. Everything worked fine. I then created a zip file out of the directories, and extracted the zip file over the game copy, and everything still worked fine. Finally, I put the zip on dropbox, created a download link, and created a mod with that.

 

That's when things stopped working. It acts like everything is fine, but the game won't start, and I can see in the disk that at least the server data file is missing. It's there in the zip, but not it's not installed in the My Mods corresponding directory.

 

The log is here, and I exited the app, deleted all directories, and started everything from scratch to produce this log, so it should be clean. One file that is missing shows up as "copying directory", which I found suspicious. The link for the zip is in the log.

 

What am I doing wrong? It ought to work, because I can manually extract it to a pristine 7D2D directory and everything works. I've tried out a bunch of other mods, and they all work. So what's going wrong here?

 

INFO 1 _7D2DLauncher.frmMain - Copying D:\Games\7D2D\My_Mods\SMX_BigBag_plus_Lawnmower\TempMods\7DaysToDieServer_Data\Managed\Assembly-CSharp.dll to D:\Games\7D2D\My_Mods\SMX_BigBag_plus_Lawnmower\7DaysToDie_Data\Managed\Assembly-CSharp.dll

 

Looks like things were working, but then copied over the Server's DLL into your game folder. Try to exclude it from your zip file, and see if it works better for you.

Share this post


Link to post
Share on other sites
Two ways:

 

Disable the Refresh Mods Automatically, then copy the new DLL and files directly into TempMods. Then use the Mod Launcher as normal.

 

or

 

Copy the files into the environment, after running Starvation Mod once through the Launcher, then manually copy the files in as you've been doing. From then on, just launch 7daystodie.exe directly, without using the Mod Launcher.

 

looks like i will have to use the 2nd option. Unless i am missing something, the launcher doesnt seem to be remembering that i turn off the refresh mods automatically check box for this one...every time i close and open the launcher, it is back to checked. is that Working as Intended or a bug?

Share this post


Link to post
Share on other sites
looks like i will have to use the 2nd option. Unless i am missing something, the launcher doesnt seem to be remembering that i turn off the refresh mods automatically check box for this one...every time i close and open the launcher, it is back to checked. is that Working as Intended or a bug?

 

Sounds like a bug. I'll take a look at it and see if I can get it fixed.

  • Like 1

Share this post


Link to post
Share on other sites

I just wanted to take the time to thank you for all the hard work you have done on your launcher; you took time out of your busy schedule to develop this thing, to support modding, and to create a standard so that the "m" word wouldn't be so scary for a lot of folks... then you did the same thing for Starvation, and SDX in general, all the while having never actually modded yourself.

 

Now that you HAVE a mod, I hope the bug has bitten hard and we see a lot more coming from you.

 

You are much appreciated.

 

-Gup

Share this post


Link to post
Share on other sites
I just wanted to take the time to thank you for all the hard work you have done on your launcher; you took time out of your busy schedule to develop this thing, to support modding, and to create a standard so that the "m" word wouldn't be so scary for a lot of folks... then you did the same thing for Starvation, and SDX in general, all the while having never actually modded yourself.

 

Now that you HAVE a mod, I hope the bug has bitten hard and we see a lot more coming from you.

 

You are much appreciated.

 

-Gup

 

Thank you for your kind words. Here's to a positive modding future :)

Share this post


Link to post
Share on other sites
Two ways:

 

Disable the Refresh Mods Automatically, then copy the new DLL and files directly into TempMods. Then use the Mod Launcher as normal.

 

or

 

Copy the files into the environment, after running Starvation Mod once through the Launcher, then manually copy the files in as you've been doing. From then on, just launch 7daystodie.exe directly, without using the Mod Launcher.

 

- - - Updated - - -

 

 

 

It's client-side only, however, some Mods do package in their server files, which can be found under the TempMods folder, if they do.

 

- - - Updated - - -

 

 

 

INFO 1 _7D2DLauncher.frmMain - Copying D:\Games\7D2D\My_Mods\SMX_BigBag_plus_Lawnmower\TempMods\7DaysToDieServer_Data\Managed\Assembly-CSharp.dll to D:\Games\7D2D\My_Mods\SMX_BigBag_plus_Lawnmower\7DaysToDie_Data\Managed\Assembly-CSharp.dll

 

Looks like things were working, but then copied over the Server's DLL into your game folder. Try to exclude it from your zip file, and see if it works better for you.

 

That worked, thanks.

Share this post


Link to post
Share on other sites
That worked, thanks.

 

A full Launcher Config has the option to Exclude files and folders, but My Mods doesn't yet.

Share this post


Link to post
Share on other sites

Is there a way to configure the launcher to keep the tick box for "refresh mods automatically" unchecked by default? I always have to worry about forgetting to uncheck it and having my config changes wiped.

Share this post


Link to post
Share on other sites
Is there a way to configure the launcher to keep the tick box for "refresh mods automatically" unchecked by default? I always have to worry about forgetting to uncheck it and having my config changes wiped.

 

Yes, we discovered this bug a few hours ago. Will release a patch in a day or so.

Share this post


Link to post
Share on other sites

May i respectfully put a second request in for a download counter of some sort. It REALLY would be nice to know how many people have downloaded a mod. I know, and yes it IS an ego driven thing. Maybe a super secret website for mod authors to go to check stats?

Share this post


Link to post
Share on other sites
May i respectfully put a second request in for a download counter of some sort. It REALLY would be nice to know how many people have downloaded a mod. I know, and yes it IS an ego driven thing. Maybe a super secret website for mod authors to go to check stats?

 

Aren't you able to pull that data from github? In your repo there is a tab called Insight and then a menu called Traffic. There you will see a count for the number of clones made for the repo... I think.

Share this post


Link to post
Share on other sites
Aren't you able to pull that data from github? In your repo there is a tab called Insight and then a menu called Traffic. There you will see a count for the number of clones made for the repo... I think.

 

Valoween, according to the Insight Graphs:

 

5DNds7hl.png

 

This method would likely only work if the DownloadMode was set to Clone. Currently, XML mods are usually direct downloads from the master.zip, and aren't counted. Larger mods, like SDX-based ones, are usually set to be Clone.

 

Looks like a monthly view? That may work with some :)

Share this post


Link to post
Share on other sites
Aren't you able to pull that data from github? In your repo there is a tab called Insight and then a menu called Traffic. There you will see a count for the number of clones made for the repo... I think.

 

Hot damn i did NOT know this.

Share this post


Link to post
Share on other sites
What's the advantage to using master.zip?

 

Original design was to download direct zip files. Master.zip is generated on the fly per request. It was always considered 'latest'.

 

All github mods could be switched to DownloadMode enabled, but would require testing so that current users wouldn't be negatively impacted.

 

Some people's ISPs are filtering GitHub API requests, but not the master.zip download. It's weird, but it's the cards that we were dealt.

Share this post


Link to post
Share on other sites

I was wondering if perhaps anyone could help me figure out an issue I'm currently having with the mod launcher. My issue is this: I can download the mod launcher just fine but whenever I try to open it nothing happens, the strange part is I had it working earlier this same day when I first downloaded it but now it won't work. I didn't do anything that would mess it up or at least I don't think so, all I did was open it to make sure it worked then, closed it since I had other stuff to do and now it won't work. Any help would be greatly appreciated. Thanks in advance.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...