Jump to content
sphereii

The 7D2D Mod Launcher - A Mod Launcher for 7 Days to Die

Recommended Posts

So everythime I have tried to run the ValMod Overhaul pack it stick on "loading ui" ... Is this normal? I have tried installing it from regular file to using this launcher and it does it the same in both ways. Any suggestions?

Share this post


Link to post
Share on other sites
So everythime I have tried to run the ValMod Overhaul pack it stick on "loading ui" ... Is this normal? I have tried installing it from regular file to using this launcher and it does it the same in both ways. Any suggestions?

 

Sorry for the trouble. I think A16.2 broke Valmod's UI, and it hasn't been officially fixed yet. I'll post a reply when its working again.

Share this post


Link to post
Share on other sites

Morning sphereii

 

Yes I can confirm A16.2 (b7) Will not run with Valmod Overhaul ..

 

When you load the game you will get a couple " nullreferance .. Error " messages and it hangs at the Loading UI.

 

I just checked it after see message from EvalleEez

 

Both Run just fine for A16.1 " Valmod Overhaul and Overhaul Bigger Backpack " I Combo is still good also, but haven't checked because of the empty housing issues.

 

Just thought I would let you know. Have a good weekend.

Share this post


Link to post
Share on other sites
Morning sphereii

 

Yes I can confirm A16.2 (b7) Will not run with Valmod Overhaul ..

 

When you load the game you will get a couple " nullreferance .. Error " messages and it hangs at the Loading UI.

 

I just checked it after see message from EvalleEez

 

Both Run just fine for A16.1 " Valmod Overhaul and Overhaul Bigger Backpack " I Combo is still good also, but haven't checked because of the empty housing issues.

 

Just thought I would let you know. Have a good weekend.

 

Thanks for the heads up. I'm working on a way to better detect these incompatibilities.

Share this post


Link to post
Share on other sites

Hi,

 

I read the help file that comes with this for mod authors and I think I get it, the reservations I have are that my tool (BARC) doesn't really belong mixed with game files. So the zip structure wouldn't relate to game file structures. Further complicating it would be that it wouldn't need an entire new copy of the game's files to keep my .exe separate so it'd be wasting space for your advanced users.

 

Maybe tools like mine just aren't a good fit for this? It'd be pretty cool, I think, if within the xml I could specify that it's a tool and therefore bypasses some of these normal mod behaviors but still give it a unique location to do its own business.

 

 

No problem if not though :)

 

Thx

Edited by Sophung (see edit history)

Share this post


Link to post
Share on other sites
Hi,

 

I read the help file that comes with this for mod authors and I think I get it, the reservations I have are that my tool (BARC) doesn't really belong mixed with game files. So the zip structure wouldn't relate to game file structures. Further complicating it would be that it wouldn't need an entire new copy of the game's files to keep my .exe separate so it'd be wasting space for your advanced users.

 

Maybe tools like mine just aren't a good fit for this? It'd be pretty cool, I think, if within the xml I could specify that it's a tool and therefore bypasses some of these normal mod behaviors but still give it a unique location to do its own business.

 

 

No problem if not though :)

 

Thx

 

Hey Sophung

 

BARC looks really cool, and obvious you have put a lot of effort in it. It's a great tool.

 

You are, sadly, correct that the Mod Launcher isn't the right place to install BARC. It'll always copy the game files over, and assume it's installing some kind of mod, rather than a Utility itself. It can enable certain in-game tools, like applying herrophl's mods to open up the in-game prefab, for example.

 

I would love to have the ability to back up game files, and allow folder-specific saves, so that the players don't load up a Valmod save with something like True Survival SDX.

 

Thank you for your suggestion about having a tool section, but I'm not sure if it'll be the right place for it. I'll think about it though.

Share this post


Link to post
Share on other sites

I kinda figured and it's okay :) nice mod launcher btw! It's a lot smoother than I expected, even for mod authors. And I might have to steal your idea about the help file, it would clean up the static notes covering my gui.

 

What are you looking to backup exactly? My source code is open and I don't mind helping you navigate the mess if you want to backup active things or something.

 

Thanks for considering

Edited by Sophung (see edit history)

Share this post


Link to post
Share on other sites
Morning sphereii

 

Yes I can confirm A16.2 (b7) Will not run with Valmod Overhaul ..

 

When you load the game you will get a couple " nullreferance .. Error " messages and it hangs at the Loading UI.

 

I just checked it after see message from EvalleEez

 

Both Run just fine for A16.1 " Valmod Overhaul and Overhaul Bigger Backpack " I Combo is still good also, but haven't checked because of the empty housing issues.

 

Just thought I would let you know. Have a good weekend.

 

The UI needs significant changes to run under 16.2. SMX for 16.2 needs to be added to the package, as well as the modified 16.2 DLLs for the backpack.

Share this post


Link to post
Share on other sites
The UI needs significant changes to run under 16.2. SMX for 16.2 needs to be added to the package, as well as the modified 16.2 DLLs for the backpack.

 

Valmar actually updated his repos, and I believe it's all current for 16.2. I've removed all the cross-links to patch in the hot fixes.

 

Sirillion added SMX to github, and now the launcher points to his repo now :)

Share this post


Link to post
Share on other sites

Hey Guys,

 

Everytime I load up the mod launcher when it gets to the game main menu it says 'steam client is not running or no connection possible ". Any idea why this might be happening? I've even gone as far as reinstalling steam itself and it hasn't fixed the problem.

 

Any suggestions?

Share this post


Link to post
Share on other sites
Hey Guys,

 

Everytime I load up the mod launcher when it gets to the game main menu it says 'steam client is not running or no connection possible ". Any idea why this might be happening? I've even gone as far as reinstalling steam itself and it hasn't fixed the problem.

 

Any suggestions?

 

Sorry for the trouble.

 

Have you tried restarting your Steam client? Logging out and back in?

 

Some Firewall software may be blocking it as well.

Share this post


Link to post
Share on other sites
Sorry for the trouble.

 

Have you tried restarting your Steam client? Logging out and back in?

 

Some Firewall software may be blocking it as well.

 

I have restarted steam, reinstalled steam and all games. Really annoying. It works on my laptop fine which has all the same software installed. Weird... I'm gunna reinstall the mod launcher

Share this post


Link to post
Share on other sites
Hey Guys,

 

Everytime I load up the mod launcher when it gets to the game main menu it says 'steam client is not running or no connection possible ". Any idea why this might be happening? I've even gone as far as reinstalling steam itself and it hasn't fixed the problem.

 

Any suggestions?

 

The mod launcher doesn't automatically start steam. If you don't have steam set to automatically start when your computer starts then the game has no way of verifying the game. Just make sure steam is running in the background before you run your game from the modlauncher and you should be ok.

Share this post


Link to post
Share on other sites
The mod launcher doesn't automatically start steam. If you don't have steam set to automatically start when your computer starts then the game has no way of verifying the game. Just make sure steam is running in the background before you run your game from the modlauncher and you should be ok.

 

Steam is running dude! I'm staring at the friends list when i launch the game waiting for it to change my status to "is playing 7 days to die" but it never changes to that status, just boots the game and then gives me the error message when the main menu for the game has loaded.

Share this post


Link to post
Share on other sites
Steam is running dude! I'm staring at the friends list when i launch the game waiting for it to change my status to "is playing 7 days to die" but it never changes to that status, just boots the game and then gives me the error message when the main menu for the game has loaded.

 

Any anti-spyware or anti-virus running? It could be that an anti-virus program flagged the Launcher, and is not letting its process see that Steam is running.

 

The Launcher executes the 7daystodie.exe once the mod is installed. If you go to the directory itself, can you start the game successfully by double clicking on the exe?

Share this post


Link to post
Share on other sites
Any anti-spyware or anti-virus running? It could be that an anti-virus program flagged the Launcher, and is not letting its process see that Steam is running.

 

The Launcher executes the 7daystodie.exe once the mod is installed. If you go to the directory itself, can you start the game successfully by double clicking on the exe?

 

Loading it from the mods folder directly from the 7daystodie.exe still gives me the same 'steam is not running' error message.

 

- - - Updated - - -

 

Loading it from the mods folder directly from the 7daystodie.exe still gives me the same 'steam is not running' error message.

 

Fixed it!!! I right clicked and set to 'run as administrator' on the 7 days to die EXE. Thanks for your help guys.

Share this post


Link to post
Share on other sites
Loading it from the mods folder directly from the 7daystodie.exe still gives me the same 'steam is not running' error message.

 

- - - Updated - - -

 

 

 

Fixed it!!! I right clicked and set to 'run as administrator' on the 7 days to die EXE. Thanks for your help guys.

 

I was just coming back to ask you to do that :) If you right click and Run As Administrator for the Mod Launcher, it should work with all your mods :)

 

Great job

  • Like 1

Share this post


Link to post
Share on other sites

Hey sphereii,

 

Please help, i have downloaded and installed the launcher, i have tried installing mods, they download, but the files dont change, the xmls are still vanilla. I am new to this, so i might be doing something wrong.

 

Thanks in advance :)

Share this post


Link to post
Share on other sites
Hey sphereii,

 

Please help, i have downloaded and installed the launcher, i have tried installing mods, they download, but the files dont change, the xmls are still vanilla. I am new to this, so i might be doing something wrong.

 

Thanks in advance :)

 

Which Mod were you trying out?

Share this post


Link to post
Share on other sites

If anyone watches Archer I would like to take this chance to say Linux can eat a bag of D*KS. I can get a modded server up and running on a windows VM but not in Ubuntu. I figured out I had the UI directory setup wrong with global style key 'yellow' not found and fixed that got into the server and found it to be unmodded. I am using the 7dtd mod launcher, and LGSM and I am sure it is down to operator error or maybe a I-D-10_t error but either way calling it a night and will start fresh tomorrow.

Share this post


Link to post
Share on other sites
Which Mod were you trying out?

 

I first tried True Survival Mod. Then I tried Valmod Expansion. Both did the same thing.

Share this post


Link to post
Share on other sites
I first tried True Survival Mod. Then I tried Valmod Expansion. Both did the same thing.

 

Sorry for the trouble. Let's get you sorted out.

 

Let's start off with True Survival Mod.

 

Click on the True Survival Mod, and click on the Play button

When you've confirmed that it's still vanilla, close the game, and go back to the Mod Launcher

Click on the View menu, then go to Log Files.

You'll see a screen with two drop down boxes.

Select one, and click on Upload Log file, and give me the pastebin.com link.

Select the other log from the drop down box, and click on the Upload Log file, and give me the pastebin link.

 

PEk6yJU.png

  • Like 1

Share this post


Link to post
Share on other sites
Sorry for the trouble. Let's get you sorted out.

 

Let's start off with True Survival Mod.

 

Click on the True Survival Mod, and click on the Play button

When you've confirmed that it's still vanilla, close the game, and go back to the Mod Launcher

Click on the View menu, then go to Log Files.

You'll see a screen with two drop down boxes.

Select one, and click on Upload Log file, and give me the pastebin.com link.

Select the other log from the drop down box, and click on the Upload Log file, and give me the pastebin link.

 

PEk6yJU.png

 

ok cool i did it, here the links,

 

https://pastebin.com/iTf072N5

 

https://pastebin.com/dELTP3h6

 

I got the Survival Mod Welcome message, but the items, XUI etc are all vanilla.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...