Jump to content
sphereii

The 7D2D Mod Launcher - A Mod Launcher for 7 Days to Die

Recommended Posts

New Update: 2.1.22
- Fixed issue with some modlets not being installed
- Fixed where Navezgane world files were being over-written
 

13 hours ago, Blackgryphon said:

Nope, but it would be easy enough to do it. :D  Once I do that, is it hard to get my server added?  Because there are a bunch of mods I'd like to use on my server, but helping everyone download and install everything one person at a time is a pain.

Not difficult at all.  Upload your mod with the correct folder structure. 

 

You can create an XML file to add your description and link. Here's an example of mine: https://github.com/SphereII/7D2DConfig/blob/master/Alpha19/sphereiimental.xml

 

Let me know the link to the xml when you are ready

  • Like 1

Share this post


Link to post
Share on other sites
5 hours ago, sphereii said:

New Update: 2.1.22
- Fixed issue with some modlets not being installed
- Fixed where Navezgane world files were being over-written
 

Not difficult at all.  Upload your mod with the correct folder structure. 

 

You can create an XML file to add your description and link. Here's an example of mine: https://github.com/SphereII/7D2DConfig/blob/master/Alpha19/sphereiimental.xml

 

Let me know the link to the xml when you are ready

Well, I want to have a bunch of mods from the community and a couple from myself.  So I guess I should have a mods folder on github with all the mods in?

Share this post


Link to post
Share on other sites
1 hour ago, Blackgryphon said:

Well, I want to have a bunch of mods from the community and a couple from myself.  So I guess I should have a mods folder on github with all the mods in?

Yup, Mods folder, plus all the mods you want to use. The github should reflect the install folder.

Share this post


Link to post
Share on other sites
6 minutes ago, sphereii said:

Yup, Mods folder, plus all the mods you want to use. The github should reflect the install folder.

Ok, thank you.  I'll do that as soon as I get and let you know

 

Share this post


Link to post
Share on other sites
1 hour ago, sphereii said:

Yup, Mods folder, plus all the mods you want to use. The github should reflect the install folder.

Well, apparently I am too stupid to figure out Github and Gitlab.. So..

Share this post


Link to post
Share on other sites
Posted (edited)
5 hours ago, Blackgryphon said:

Well, apparently I am too stupid to figure out Github and Gitlab.. So..

I don't think you are stupid :)

 

1) In your web browser, create a free account on GitHub.com

2) In your web browser, create a New Repository. Initialize with a ReadMe.md (it'll be an option).

3) Download and install GitHub Desktop

4) In your web browser, click on Clone... in your Repo.

5) Pick a folder where it'll download through Github Desktop. It should be an empty folder.

6) Copy your Mods folder into it the same folder.

7) In Github Desktop, click on Summary text, and enter in a description: "First upload"

😎 Submit.

9) In Github Desktop, click on "Push origin"

 

 

 

Edit: The smiley with the sun glasses is unintentional, but it is an exciting moment when you submit your changes.

Edited by sphereii (see edit history)
  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, sphereii said:

I don't think you are stupid :)

 

1) In your web browser, create a free account on GitHub.com

2) In your web browser, create a New Repository. Initialize with a ReadMe.md (it'll be an option).

3) Download and install GitHub Desktop

4) In your web browser, click on Clone... in your Repo.

5) Pick a folder where it'll download through Github Desktop. It should be an empty folder.

6) Copy your Mods folder into it the same folder.

7) In Github Desktop, click on Summary text, and enter in a description: "First upload"

😎 Submit.

9) In Github Desktop, click on "Push origin"

 

 

 

Edit: The smiley with the sun glasses is unintentional, but it is an exciting moment when you submit your changes.

Didn't even notice the Github desktop download. lol  I'll try that.  Thank you. :)

 

Share this post


Link to post
Share on other sites
2 hours ago, sphereii said:

I don't think you are stupid :)

 

1) In your web browser, create a free account on GitHub.com

2) In your web browser, create a New Repository. Initialize with a ReadMe.md (it'll be an option).

3) Download and install GitHub Desktop

4) In your web browser, click on Clone... in your Repo.

5) Pick a folder where it'll download through Github Desktop. It should be an empty folder.

6) Copy your Mods folder into it the same folder.

7) In Github Desktop, click on Summary text, and enter in a description: "First upload"

😎 Submit.

9) In Github Desktop, click on "Push origin"

 

 

 

Edit: The smiley with the sun glasses is unintentional, but it is an exciting moment when you submit your changes.

OK, here's my luck.  Neither the .exe or the .msi install files work on my computer..  the .exe gives me an error and doesn't install.  The .msi starts and then just disappears.

Share this post


Link to post
Share on other sites
8 hours ago, Blackgryphon said:

OK, here's my luck.  Neither the .exe or the .msi install files work on my computer..  the .exe gives me an error and doesn't install.  The .msi starts and then just disappears.

There seems to be something up with your PC then. Check your anti-virus and any security programs, make sure you have all your updates applied, and reboot your PC so its fresh.

  • Like 1

Share this post


Link to post
Share on other sites
3 hours ago, sphereii said:

There seems to be something up with your PC then. Check your anti-virus and any security programs, make sure you have all your updates applied, and reboot your PC so its fresh.

Updated windows just a few hours before download.  AV says it didn't block anything.

3 hours ago, sphereii said:

There seems to be something up with your PC then. Check your anti-virus and any security programs, make sure you have all your updates applied, and reboot your PC so its fresh.

lol  I literally did nothing differently right now compared to when I post that message and now it works.  Effing Windows. lol

Share this post


Link to post
Share on other sites
3 hours ago, sphereii said:

There seems to be something up with your PC then. Check your anti-virus and any security programs, make sure you have all your updates applied, and reboot your PC so its fresh.

Sent you a PM

Share this post


Link to post
Share on other sites
1 hour ago, LunariusH said:

Does anyone know what's causing this and how to fix it?  It only seems to use the unlocalized names for everything.   resourceScrapIron, for instance.
Image for Reference

Sounds like your Localization file is being messed up somehow. Without a log, I cannot say what the issue would be.

Share this post


Link to post
Share on other sites
Spoiler

Mono path[0] = 'C:/7D2D/Alpha19/My_Mods/Bear_Nation/7DaysToDie_Data/Managed'
Mono config path = 'C:/7D2D/Alpha19/My_Mods/Bear_Nation/MonoBleedingEdge/etc'
Initialize engine version: 2019.2.17f1 (8e603399ca02)
[XR] Discovering subsystems at path C:/7D2D/Alpha19/My_Mods/Bear_Nation/7DaysToDie_Data/UnitySubsystems
GfxDevice: creating device client; threaded=1
Direct3D:
    Version:  Direct3D 11.0 [level 11.0]
    Renderer: NVIDIA Quadro K620 (ID=0x13bb)
    Vendor:   
    VRAM:     2007 MB
    Driver:   23.21.13.9135
Begin MonoManager ReloadAssembly
- Completed reload, in  4.154 seconds
<RI> Initializing input. <RI> Input initialized. <RI> Initialized touch support. UnloadTime: 0.945300 ms
2020-09-12T15:49:51 0.119 INF [Steamworks.NET] SteamAPI_Init() ok
2020-09-12T15:49:51 0.450 WRN Localization: Duplicate key "mineBottlecapMine" found! Please check Localization file. Skipping entry...
2020-09-12T15:49:51 0.450 WRN Localization: Duplicate key "cntLunchbox" found! Please check Localization file. Skipping entry...
2020-09-12T15:49:51 0.450 WRN Localization: Duplicate key "cntLunchboxDesc" found! Please check Localization file. Skipping entry...
2020-09-12T15:49:51 0.468 INF Localization language: English
2020-09-12T15:49:51 0.503 INF Texture quality is set to 1
2020-09-12T15:49:51 0.504 INF Precaching...
2020-09-12T15:49:51 0.506 INF Precaching file: 7DaysToDie_Data/resources.assets
2020-09-12T15:49:52 0.944 INF [EAC] Not loading, not started from launcher
2020-09-12T15:50:04 13.395 INF Precaching file: 7DaysToDie_Data/sharedassets1.assets
2020-09-12T15:50:04 13.435 INF Precaching file: Data/Bundles/blocktextureatlases
2020-09-12T15:50:18 27.208 INF Precaching file: Data/Bundles/terraintextures
2020-09-12T15:50:32 41.441 INF Precaching done
2020-09-12T15:50:32 41.442 INF Loading main scene
Unloading 6 Unused Serialized files (Serialized files now loaded: 0)
UnloadTime: 4.819500 ms
2020-09-12T15:50:33 42.151 INF [GSM] Singleton Initialized...
2020-09-12T15:50:33 42.170 INF Awake IsFocused: True
2020-09-12T15:50:33 42.170 INF Awake
2020-09-12T15:50:33 42.259 INF Version: Alpha 19 (b180) Compatibility Version: Alpha 19, Build: Windows 64 Bit
2020-09-12T15:50:33 42.260 INF System information:
2020-09-12T15:50:33 42.260 INF    OS: Windows 10  (10.0.0) 64bit
2020-09-12T15:50:33 42.261 INF    CPU: AMD FX(tm)-6300 Six-Core Processor  (cores: 6)
2020-09-12T15:50:33 42.261 INF    RAM: 16360 MB
2020-09-12T15:50:33 42.261 INF    GPU: NVIDIA Quadro K620 (2007 MB)
2020-09-12T15:50:33 42.263 INF    Graphics API: Direct3D 11.0 [level 11.0] (shader level 5.0)
2020-09-12T15:50:33 42.264 INF Last played version: Alpha 19.1
2020-09-12T15:50:33 42.265 INF Local UTC offset: -5 hours
2020-09-12T15:50:33 42.276 INF Command line arguments: C:\7D2D\Alpha19\My_Mods\Bear_Nation\7DaysToDie.exe -logfile C:\7D2D\Alpha19\My_Mods\Bear_Nation\7DaysToDie_Data\output_log.txt -configfile=C:\7D2D\Alpha19\My_Mods\Bear_Nation\SaveConfig.xml
2020-09-12T15:50:33 42.316 INF Parsing server configfile: C:\7D2D\Alpha19\My_Mods\Bear_Nation\SaveConfig.xml
2020-09-12T15:50:33 42.471 INF Parsing server configfile successfully completed
2020-09-12T15:50:33 42.473 INF Not running in Big Picture Mode, no on-screen keyboard available
2020-09-12T15:50:33 42.474 INF Starting PlayerInputManager...
Fallback handler could not load library C:/7D2D/Alpha19/My_Mods/Bear_Nation/7DaysToDie_Data/Mono/XInputInterface32
Fallback handler could not load library C:/7D2D/Alpha19/My_Mods/Bear_Nation/7DaysToDie_Data/Mono/XInputInterface32.dll
Fallback handler could not load library C:/7D2D/Alpha19/My_Mods/Bear_Nation/7DaysToDie_Data/Mono/XInputInterface32
Fallback handler could not load library C:/7D2D/Alpha19/My_Mods/Bear_Nation/7DaysToDie_Data/Mono/libXInputInterface32
Fallback handler could not load library C:/7D2D/Alpha19/My_Mods/Bear_Nation/7DaysToDie_Data/Mono/libXInputInterface32.dll
Fallback handler could not load library C:/7D2D/Alpha19/My_Mods/Bear_Nation/7DaysToDie_Data/Mono/libXInputInterface32
2020-09-12T15:50:34 43.340 INF InControl (version 1.8.2 build 9357, native module = False, XInput = True)
2020-09-12T15:50:34 43.375 INF Starting UserProfileManager...
2020-09-12T15:50:34 43.566 INF Occlusion: Awake
2020-09-12T15:50:34 43.579 INF ApplyAllOptions streaming budget 1806.3 MB
2020-09-12T15:50:34 43.581 INF ApplyAllOptions current screen 1920 x 1080, 60hz, window 1920 x 1080, fullscreen True FullScreenWindow
2020-09-12T15:50:34 43.581 INF Texture quality is set to 1
2020-09-12T15:50:34 43.582 INF ApplyTextureFilter 0, AF Disable
2020-09-12T15:50:34 43.585 INF ApplyTerrainOptions 2
2020-09-12T15:50:36 45.322 INF [MODS] Start loading
2020-09-12T15:50:36 45.334 INF [MODS] Trying to load from folder: The Wasteland
2020-09-12T15:50:36 45.410 INF [MODS] Loaded Mod: The Wasteland (1.3)
2020-09-12T15:50:36 45.411 INF [MODS] Initializing mod code
2020-09-12T15:50:36 45.411 INF [MODS] Loading done
2020-09-12T15:50:38 47.536 INF Pack 159877 us
2020-09-12T15:50:38 47.579 INF Pack 4056 us
2020-09-12T15:50:38 47.622 INF Permissions file 'serveradmin.xml' not found, creating.
2020-09-12T15:50:38 47.658 INF Command "chunkcache" has no explicit permission level, but a default permission of 1000, adding to permission list
2020-09-12T15:50:38 47.661 INF Command "debugshot" has no explicit permission level, but a default permission of 1000, adding to permission list
2020-09-12T15:50:38 47.661 INF Command "debugweather" has no explicit permission level, but a default permission of 1000, adding to permission list
2020-09-12T15:50:38 47.664 INF Command "getgamepref" has no explicit permission level, but a default permission of 1000, adding to permission list
2020-09-12T15:50:38 47.665 INF Command "getgamestat" has no explicit permission level, but a default permission of 1000, adding to permission list
2020-09-12T15:50:38 47.665 INF Command "getoptions" has no explicit permission level, but a default permission of 1000, adding to permission list
2020-09-12T15:50:38 47.666 INF Command "gettime" has no explicit permission level, but a default permission of 1000, adding to permission list
2020-09-12T15:50:38 47.666 INF Command "gfx" has no explicit permission level, but a default permission of 1000, adding to permission list
2020-09-12T15:50:38 47.667 INF Command "help" has no explicit permission level, but a default permission of 1000, adding to permission list
2020-09-12T15:50:38 47.668 INF Command "listplayerids" has no explicit permission level, but a default permission of 1000, adding to permission list
2020-09-12T15:50:38 47.669 INF Command "listthreads" has no explicit permission level, but a default permission of 1000, adding to permission list
2020-09-12T15:50:38 47.670 INF Command "memcl" has no explicit permission level, but a default permission of 1000, adding to permission list
2020-09-12T15:50:38 47.678 INF Command "settempunit" has no explicit permission level, but a default permission of 1000, adding to permission list
2020-09-12T15:50:39 47.814 INF Awake done in 5644 ms
Fallback handler could not load library C:/7D2D/Alpha19/My_Mods/Bear_Nation/7DaysToDie_Data/Mono/libc
Fallback handler could not load library C:/7D2D/Alpha19/My_Mods/Bear_Nation/7DaysToDie_Data/Mono/libc.dll
Fallback handler could not load library C:/7D2D/Alpha19/My_Mods/Bear_Nation/7DaysToDie_Data/Mono/libc

Unloading 112 unused Assets to reduce memory usage. Loaded Objects now: 4201.
Total: 32.384600 ms (FindLiveObjects: 0.574000 ms CreateObjectMapping: 0.136800 ms MarkObjects: 31.390200 ms  DeleteObjects: 0.282700 ms)

2020-09-12T15:50:39 48.376 INF Reloading serveradmin.xml
2020-09-12T15:50:39 48.376 INF Loading permissions file at 'C:\7D2D\Saves\My Mods\Bear Nation/serveradmin.xml'
2020-09-12T15:50:39 48.551 INF Loading permissions file done.
2020-09-12T15:50:39 48.604 INF User joined: Captain McLir
2020-09-12T15:50:40 49.384 WRN No culture info found for given name: cultureInfoName
2020-09-12T15:50:42 51.251 INF [GSM] GameSparks Connected
2020-09-12T15:50:52 61.510 INF UMA Overlay loading took 10255 ms
2020-09-12T15:50:52 61.513 INF UMA Slot loading took 3 ms
2020-09-12T15:51:01 70.150 INF LoadTextureArraysForQuality quality -1 to 1, reload False
2020-09-12T15:51:02 71.000 INF [GSM] Skipping me
2020-09-12T15:51:05 74.189 INF WorldStaticData.Init() needed 12.408s
2020-09-12T15:51:06 75.429 INF [Steamworks.NET] Login ok.
2020-09-12T15:51:06 75.694 INF AchievementManager.UserStatsStored_Callback, result=k_EResultOK
2020-09-12T15:51:06 75.695 INF AchievementManager: Received stats and achievements from Steam
 

I was attempting to use the upload button to no results.  Here's the latest launch results.
Thank you for your prompt response.

Edited by LunariusH (see edit history)

Share this post


Link to post
Share on other sites
1 hour ago, LunariusH said:
  Hide contents

Mono path[0] = 'C:/7D2D/Alpha19/My_Mods/Bear_Nation/7DaysToDie_Data/Managed'
Mono config path = 'C:/7D2D/Alpha19/My_Mods/Bear_Nation/MonoBleedingEdge/etc'
Initialize engine version: 2019.2.17f1 (8e603399ca02)
[XR] Discovering subsystems at path C:/7D2D/Alpha19/My_Mods/Bear_Nation/7DaysToDie_Data/UnitySubsystems
GfxDevice: creating device client; threaded=1
Direct3D:
    Version:  Direct3D 11.0 [level 11.0]
    Renderer: NVIDIA Quadro K620 (ID=0x13bb)
    Vendor:   
    VRAM:     2007 MB
    Driver:   23.21.13.9135
Begin MonoManager ReloadAssembly
- Completed reload, in  4.154 seconds
<RI> Initializing input. <RI> Input initialized. <RI> Initialized touch support. UnloadTime: 0.945300 ms
2020-09-12T15:49:51 0.119 INF [Steamworks.NET] SteamAPI_Init() ok
2020-09-12T15:49:51 0.450 WRN Localization: Duplicate key "mineBottlecapMine" found! Please check Localization file. Skipping entry...
2020-09-12T15:49:51 0.450 WRN Localization: Duplicate key "cntLunchbox" found! Please check Localization file. Skipping entry...
2020-09-12T15:49:51 0.450 WRN Localization: Duplicate key "cntLunchboxDesc" found! Please check Localization file. Skipping entry...
2020-09-12T15:49:51 0.468 INF Localization language: English
2020-09-12T15:49:51 0.503 INF Texture quality is set to 1
2020-09-12T15:49:51 0.504 INF Precaching...
2020-09-12T15:49:51 0.506 INF Precaching file: 7DaysToDie_Data/resources.assets
2020-09-12T15:49:52 0.944 INF [EAC] Not loading, not started from launcher
2020-09-12T15:50:04 13.395 INF Precaching file: 7DaysToDie_Data/sharedassets1.assets
2020-09-12T15:50:04 13.435 INF Precaching file: Data/Bundles/blocktextureatlases
2020-09-12T15:50:18 27.208 INF Precaching file: Data/Bundles/terraintextures
2020-09-12T15:50:32 41.441 INF Precaching done
2020-09-12T15:50:32 41.442 INF Loading main scene
Unloading 6 Unused Serialized files (Serialized files now loaded: 0)
UnloadTime: 4.819500 ms
2020-09-12T15:50:33 42.151 INF [GSM] Singleton Initialized...
2020-09-12T15:50:33 42.170 INF Awake IsFocused: True
2020-09-12T15:50:33 42.170 INF Awake
2020-09-12T15:50:33 42.259 INF Version: Alpha 19 (b180) Compatibility Version: Alpha 19, Build: Windows 64 Bit
2020-09-12T15:50:33 42.260 INF System information:
2020-09-12T15:50:33 42.260 INF    OS: Windows 10  (10.0.0) 64bit
2020-09-12T15:50:33 42.261 INF    CPU: AMD FX(tm)-6300 Six-Core Processor  (cores: 6)
2020-09-12T15:50:33 42.261 INF    RAM: 16360 MB
2020-09-12T15:50:33 42.261 INF    GPU: NVIDIA Quadro K620 (2007 MB)
2020-09-12T15:50:33 42.263 INF    Graphics API: Direct3D 11.0 [level 11.0] (shader level 5.0)
2020-09-12T15:50:33 42.264 INF Last played version: Alpha 19.1
2020-09-12T15:50:33 42.265 INF Local UTC offset: -5 hours
2020-09-12T15:50:33 42.276 INF Command line arguments: C:\7D2D\Alpha19\My_Mods\Bear_Nation\7DaysToDie.exe -logfile C:\7D2D\Alpha19\My_Mods\Bear_Nation\7DaysToDie_Data\output_log.txt -configfile=C:\7D2D\Alpha19\My_Mods\Bear_Nation\SaveConfig.xml
2020-09-12T15:50:33 42.316 INF Parsing server configfile: C:\7D2D\Alpha19\My_Mods\Bear_Nation\SaveConfig.xml
2020-09-12T15:50:33 42.471 INF Parsing server configfile successfully completed
2020-09-12T15:50:33 42.473 INF Not running in Big Picture Mode, no on-screen keyboard available
2020-09-12T15:50:33 42.474 INF Starting PlayerInputManager...
Fallback handler could not load library C:/7D2D/Alpha19/My_Mods/Bear_Nation/7DaysToDie_Data/Mono/XInputInterface32
Fallback handler could not load library C:/7D2D/Alpha19/My_Mods/Bear_Nation/7DaysToDie_Data/Mono/XInputInterface32.dll
Fallback handler could not load library C:/7D2D/Alpha19/My_Mods/Bear_Nation/7DaysToDie_Data/Mono/XInputInterface32
Fallback handler could not load library C:/7D2D/Alpha19/My_Mods/Bear_Nation/7DaysToDie_Data/Mono/libXInputInterface32
Fallback handler could not load library C:/7D2D/Alpha19/My_Mods/Bear_Nation/7DaysToDie_Data/Mono/libXInputInterface32.dll
Fallback handler could not load library C:/7D2D/Alpha19/My_Mods/Bear_Nation/7DaysToDie_Data/Mono/libXInputInterface32
2020-09-12T15:50:34 43.340 INF InControl (version 1.8.2 build 9357, native module = False, XInput = True)
2020-09-12T15:50:34 43.375 INF Starting UserProfileManager...
2020-09-12T15:50:34 43.566 INF Occlusion: Awake
2020-09-12T15:50:34 43.579 INF ApplyAllOptions streaming budget 1806.3 MB
2020-09-12T15:50:34 43.581 INF ApplyAllOptions current screen 1920 x 1080, 60hz, window 1920 x 1080, fullscreen True FullScreenWindow
2020-09-12T15:50:34 43.581 INF Texture quality is set to 1
2020-09-12T15:50:34 43.582 INF ApplyTextureFilter 0, AF Disable
2020-09-12T15:50:34 43.585 INF ApplyTerrainOptions 2
2020-09-12T15:50:36 45.322 INF [MODS] Start loading
2020-09-12T15:50:36 45.334 INF [MODS] Trying to load from folder: The Wasteland
2020-09-12T15:50:36 45.410 INF [MODS] Loaded Mod: The Wasteland (1.3)
2020-09-12T15:50:36 45.411 INF [MODS] Initializing mod code
2020-09-12T15:50:36 45.411 INF [MODS] Loading done
2020-09-12T15:50:38 47.536 INF Pack 159877 us
2020-09-12T15:50:38 47.579 INF Pack 4056 us
2020-09-12T15:50:38 47.622 INF Permissions file 'serveradmin.xml' not found, creating.
2020-09-12T15:50:38 47.658 INF Command "chunkcache" has no explicit permission level, but a default permission of 1000, adding to permission list
2020-09-12T15:50:38 47.661 INF Command "debugshot" has no explicit permission level, but a default permission of 1000, adding to permission list
2020-09-12T15:50:38 47.661 INF Command "debugweather" has no explicit permission level, but a default permission of 1000, adding to permission list
2020-09-12T15:50:38 47.664 INF Command "getgamepref" has no explicit permission level, but a default permission of 1000, adding to permission list
2020-09-12T15:50:38 47.665 INF Command "getgamestat" has no explicit permission level, but a default permission of 1000, adding to permission list
2020-09-12T15:50:38 47.665 INF Command "getoptions" has no explicit permission level, but a default permission of 1000, adding to permission list
2020-09-12T15:50:38 47.666 INF Command "gettime" has no explicit permission level, but a default permission of 1000, adding to permission list
2020-09-12T15:50:38 47.666 INF Command "gfx" has no explicit permission level, but a default permission of 1000, adding to permission list
2020-09-12T15:50:38 47.667 INF Command "help" has no explicit permission level, but a default permission of 1000, adding to permission list
2020-09-12T15:50:38 47.668 INF Command "listplayerids" has no explicit permission level, but a default permission of 1000, adding to permission list
2020-09-12T15:50:38 47.669 INF Command "listthreads" has no explicit permission level, but a default permission of 1000, adding to permission list
2020-09-12T15:50:38 47.670 INF Command "memcl" has no explicit permission level, but a default permission of 1000, adding to permission list
2020-09-12T15:50:38 47.678 INF Command "settempunit" has no explicit permission level, but a default permission of 1000, adding to permission list
2020-09-12T15:50:39 47.814 INF Awake done in 5644 ms
Fallback handler could not load library C:/7D2D/Alpha19/My_Mods/Bear_Nation/7DaysToDie_Data/Mono/libc
Fallback handler could not load library C:/7D2D/Alpha19/My_Mods/Bear_Nation/7DaysToDie_Data/Mono/libc.dll
Fallback handler could not load library C:/7D2D/Alpha19/My_Mods/Bear_Nation/7DaysToDie_Data/Mono/libc

Unloading 112 unused Assets to reduce memory usage. Loaded Objects now: 4201.
Total: 32.384600 ms (FindLiveObjects: 0.574000 ms CreateObjectMapping: 0.136800 ms MarkObjects: 31.390200 ms  DeleteObjects: 0.282700 ms)

2020-09-12T15:50:39 48.376 INF Reloading serveradmin.xml
2020-09-12T15:50:39 48.376 INF Loading permissions file at 'C:\7D2D\Saves\My Mods\Bear Nation/serveradmin.xml'
2020-09-12T15:50:39 48.551 INF Loading permissions file done.
2020-09-12T15:50:39 48.604 INF User joined: Captain McLir
2020-09-12T15:50:40 49.384 WRN No culture info found for given name: cultureInfoName
2020-09-12T15:50:42 51.251 INF [GSM] GameSparks Connected
2020-09-12T15:50:52 61.510 INF UMA Overlay loading took 10255 ms
2020-09-12T15:50:52 61.513 INF UMA Slot loading took 3 ms
2020-09-12T15:51:01 70.150 INF LoadTextureArraysForQuality quality -1 to 1, reload False
2020-09-12T15:51:02 71.000 INF [GSM] Skipping me
2020-09-12T15:51:05 74.189 INF WorldStaticData.Init() needed 12.408s
2020-09-12T15:51:06 75.429 INF [Steamworks.NET] Login ok.
2020-09-12T15:51:06 75.694 INF AchievementManager.UserStatsStored_Callback, result=k_EResultOK
2020-09-12T15:51:06 75.695 INF AchievementManager: Received stats and achievements from Steam
 

I was attempting to use the upload button to no results.  Here's the latest launch results.
Thank you for your prompt response.

Does the wasteland mod contain a Localization.txt? I don't see in the log where it's loading anything from it, so maybe the copy is bad? 

Share this post


Link to post
Share on other sites
1 hour ago, sphereii said:

Does the wasteland mod contain a Localization.txt? I don't see in the log where it's loading anything from it, so maybe the copy is bad? 

I would imagine so. It's the same version that's running on my private shared server, and that everyone is using.

Share this post


Link to post
Share on other sites

Hi sphereii. I've been using your fantastic launcher for quite a while but just recently I cannot get it to run. I'm one of Devrix's Sorcery patreons. When A19 came out and Sorcery came back I had to load a new version of the Launcher. I'm on windows 10 and Windows Defender blocked the install file. The online help I found suggested switching off smartscreen and then trying again. That worked but during the install I got a "cannot access SQL file" error. It still installed but when I try to run Sorcery via the Launcher I get a "Fatal error - Failed to load mono". I've uninstalled and reinstalled a few times but the same problem occurs. I'm guessing that something has not worked correctly in the install. Love any suggestions

Share this post


Link to post
Share on other sites
8 hours ago, captainforesight said:

Hi sphereii. I've been using your fantastic launcher for quite a while but just recently I cannot get it to run. I'm one of Devrix's Sorcery patreons. When A19 came out and Sorcery came back I had to load a new version of the Launcher. I'm on windows 10 and Windows Defender blocked the install file. The online help I found suggested switching off smartscreen and then trying again. That worked but during the install I got a "cannot access SQL file" error. It still installed but when I try to run Sorcery via the Launcher I get a "Fatal error - Failed to load mono". I've uninstalled and reinstalled a few times but the same problem occurs. I'm guessing that something has not worked correctly in the install. Love any suggestions

Hi Captainforesight.  I had the same problem and found that it didn't install the game properly into the Sorcery folder..  it fixed itself when i selected the "download from steam" option in the launcher. Hope this helps.

Share this post


Link to post
Share on other sites
1 hour ago, Thebigmerv said:

Hi Captainforesight.  I had the same problem and found that it didn't install the game properly into the Sorcery folder..  it fixed itself when i selected the "download from steam" option in the launcher. Hope this helps.

Thanks Thebigmerv  That seems to have done the trick😀

Share this post


Link to post
Share on other sites

I am new to 7d2d on PC and new to modding. I downloaded this mod launcher to do the Dishong Tower Challenge and it seemed to work fine. Today I opted in for the 19.2 experimental, opened the game through Steam not the mod launcher and started a new random world seed. When the map loaded it had the Dishong Tower Challenge dialogue, gave me the stone axe, mining helmet etc, and the entire map is bare of grass fibers, bird nests etc.  Its very strange, like a combination of the Dishong challenge quests and the normal 7d2d quests.

 

As I said I'm new to this sort of thing and would appreciate some guidance on how to avoid this in the future.

Share this post


Link to post
Share on other sites
7 hours ago, Marculus said:

I am h aving some truble every time i load up the mod launcher i keep getting an error

7D2DLauncher.txt 33.3 kB · 0 downloads

I see two potential issues. Here's the first fix:

 

1) Close the Mod Launcher, if it's open

2) Click on your Start menu, then copy and paste this:     %APPDATA%\7D2DModLauncher\ModLauncher.txt

3) Look for RemoteServers=, and remove   D:\7D2D Mod\System.Data.SQLite.xml   and <SubscriptionLink>https://raw.githubusercontent.com/7D2DMods/Profiles/master/MyTestProfile.txt</SubscriptionLink>

4) Save the file

5) Re-open the mod launcher.

 

 

The other error you are getting is Could not create SSL/TLS Secure channel. What version of windows are you running? 

Share this post


Link to post
Share on other sites
4 minutes ago, minersdreams said:

I am getting the SQL database error when I launch the launcher and there is no option to go to alpha 19 mods only alpha16-18.

This means it had trouble downloading the database.

 

A few things to check:

 

1) Any anti-virus or firewall software that may be blocking it?

2) Have you tried rebooting? (helps if the lock on the database isn't released properly)

 

Share this post


Link to post
Share on other sites
Just now, sphereii said:

This means it had trouble downloading the database.

 

A few things to check:

 

1) Any anti-virus or firewall software that may be blocking it?

2) Have you tried rebooting? (helps if the lock on the database isn't released properly)

 

I have avast that could be blocking it, and I have tried rebooting and reinstalling the launcher completley and still get the error.

Also when I go to install and run the launchersetup installer Microsoft defender smartscreen tries and prevents it but i run it anyway.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...