Jump to content

True Survival


Recommended Posts

I hope this is that part of the log:

 

(Filename: <567df3e0919241ba98db88bec4c6696f> Line: 0)

ArgumentNullException: Value cannot be null.
Parameter name: key
  at System.Collections.Generic.Dictionary`2[TKey,TValue].FindEntry (TKey key) [0x00008] in <567df3e0919241ba98db88bec4c6696f>:0 
  at System.Collections.Generic.Dictionary`2[TKey,TValue].ContainsKey (TKey key) [0x00000] in <567df3e0919241ba98db88bec4c6696f>:0 
  at EntityBuffs.GetCustomVar (System.String _name) [0x00000] in <d7c95f421d354b5e851d6f3126817769>:0 
  at MinEventActionModifyCVar.Execute (MinEventParams _params) [0x000e8] in <d7c95f421d354b5e851d6f3126817769>:0 
  at MinEffectGroup.FireEvent (MinEventTypes _eventType, MinEventParams _eventParms) [0x0002e] in <d7c95f421d354b5e851d6f3126817769>:0 
  at MinEffectController.FireEvent (MinEventTypes _eventType, MinEventParams _eventParms) [0x00019] in <d7c95f421d354b5e851d6f3126817769>:0 
  at BuffClass.FireEvent (MinEventTypes _eventType, MinEventParams _params) [0x00013] in <d7c95f421d354b5e851d6f3126817769>:0 
  at EntityBuffs.FireEvent (MinEventTypes _eventType, BuffClass _buffClass, MinEventParams _params) [0x00003] in <d7c95f421d354b5e851d6f3126817769>:0 
  at EntityBuffs.Update (System.Single _deltaTime) [0x00128] in <d7c95f421d354b5e851d6f3126817769>:0 
  at EntityAlive.OnUpdateEntity () [0x00019] in <d7c95f421d354b5e851d6f3126817769>:0 
  at EntityPlayer.OnUpdateEntity () [0x00000] in <d7c95f421d354b5e851d6f3126817769>:0 
  at EntityPlayerLocal.OnUpdateEntity () [0x00127] in <d7c95f421d354b5e851d6f3126817769>:0 
  at World.TickEntity (Entity e, System.Single _partialTicks) [0x0015d] in <d7c95f421d354b5e851d6f3126817769>:0 
  at World.TickEntities (System.Single _partialTicks) [0x000ab] in <d7c95f421d354b5e851d6f3126817769>:0 
  at GameManager.UpdateTick () [0x00093] in <d7c95f421d354b5e851d6f3126817769>:0 
  at GameManager.gmUpdate () [0x0029b] in <d7c95f421d354b5e851d6f3126817769>:0 
  at GameManager.Update () [0x00000] in <d7c95f421d354b5e851d6f3126817769>:0 

Link to post
Share on other sites
  • 2 weeks later...

Just wanted to say thank you to everyone that has been on the server testing. With everyone's help I have gotten the early game of the mod just about finished and polished. Now that the Mods foundation it nice and stable I'll start working on polishing up mid game and importing new my new entity's. Testing server is still up and open to anyone that wants a good ass kicking.

Link to post
Share on other sites

-----------------------------------------------------Update------------------------------------------------------------------
-Server Wiped map re rolled
-Decreased loot respawn to 15 days
-Turned Cheat off
-New Feature - Automatic Player Reset, when your player dies and your wellness reaches 0 you will respawn as a brand new player and start over from scratch (with help from Khaine)
-New Item - "Dead is Dead Reset Item" crafted from broken grass. This item will reset your player to new. This can not be undone!
-Updated Orange tree to need watering and it's able to be Fertilized

Link to post
Share on other sites

Hallo Spider,

i have trouble downloading the mod. It fails always after 1 GB.

I saw others having the problem too (for github)

Idk how to fix it, can you try if it works for you ?

Thanks upfront for any help.

 

i found this thread: https://github.com/nextcloud/server/issues/5390

Edited by Bloodshot
bad english xD (see edit history)
Link to post
Share on other sites

-----------------------------------------------------Update--------------------------------------------------
-Fixed crop Trampling
-Fixed Eggplant crop 
-Fixed Wheat crop
-Fixed Severe Wound description
-Made Storage Sack retrievable when destroyed
-Add ammo to "Old" gun descriptions
-Fixed Orange Tree Crop
-Added missing Desert Vulture Gun crafting skill and recipe
-Fixed Wounds not issuing relief when properly tending to 
-Fixed wounds not resetting on Dead is Dead Reset

Link to post
Share on other sites

i cant seem to craft natural antibiotics, though i have the recipy and ingredients.
its white when im in inventory crafting mode, but grey in the campfire mode, and says im missing mortar and pestle.
i also tried the mortar and pestle in the campfires tool slots.
is there anything else i am missing for tools, or im doing wrong?
also, i placed the mortar and pestle on the ground to see if i can craft it there.
is there any way to pick it up again?

Link to post
Share on other sites

I have download the mod through the 7DTD Mod Launcher. However when I launch it appears to not contain any mod features. On starting a new game I do not start with the starting item and looking through the recipes and skills appear to all be vanilla items. Any ideas? The strange thing is while loading, the tips do appear to be true survival tips.

Link to post
Share on other sites

----------------------------------------------Update------------------------------------------------------------
-Fixed Mushrooms to require soil like other crops, still grows in dark
-Starting Knowledge Points Spoil 
-Removed ability to repair placed Wooden Logs
-Added Dirt to Soil recipes
-Added Mechanical Part to Watering Can recipe
-Added recipe for Iron Sheet Metal in Forge
-Added recipe for Steel Sheet Metal in Steel Forge and Anvil
-Fixed Vitamin description
-Fixed refrigerator dropping more than one with Crowbar
-Fixed Stats resetting after Dead is Dead reset
-Added 30min delay before you can use Dead is Dead item again
-Moved Machete recipe to the Anvil
-Added a reward of 1 Skill Point for each Storyline Quest finished
-Added recipe for Walkie Talkie incase you lose it
-Fixed Veggie and Fruit Juice recipe
-Fixed fertilized growth stages of crops
-Fixed Mason Hammer Degradation and to break at 0
-Fixed Flagstone Blocks not giving Cobblestones with Mason Hammer
-Fixed Concussions description  
-Increased Trader restock time from 3 days to 7
-Snow Balls melt into water
-Fixed Painkillers description
-Fixed all Wound descriptions
-Added Wheat to Desert biome
-Crowbar can pick up POI Spotlights
-Chance to get gas from road trash gas can
-Added different colors for the different spoil timers
-Added Testosterone to Mountain Lion, Dire Wolf and Baer harvest at max Hunting level
-Changed it so you can not have more than one Sleeping effect at a time
-Fixed Fat Lady Zombies explosion animation

@muaddib912-

Its only a client pack you have to join my server to test the mod.

 

@jihizuu-

Its done on the Chemistry Station.

Edited by Spider (see edit history)
Link to post
Share on other sites

------------------------------------------------------------------------------Update----------------------------------------------------------------------------------
-Figured out the schematics not showing learned when known(if you see other please let me know)
-Fixed Brass Knuckle Mold error
-Added Key Locks (door knob) to File cabinet, Tool Boxes and Wooden Chest normal harvest
-Added Auto Shotgun recipe and Crafting Skill/Quest
-Added Fan Belts to last car stage normal harvest
-Fixed Starting Weapon/Tool text
-Fixed Spiked Branch stats showing
-Fixed Bandage stat display
-Fixed reported names
-Fix(I think) Trader inventory when at max Rep
-Fix Meads stats
-Added Carrot and Wheat Seed icons
-Fixed Description on Anvil
 

Link to post
Share on other sites

Dont know if its mod related or its a general game bug, but some quest POIs dont seem to reset correctly.
The location is then totally destroyed with most of the location missing and ground merged into it where it shouldnt be.
I had this on "house old bungalow 11" lvl 4 waterworks quest poi and saw the same on a "coalmine" POI.
What the locations all have in common is that there is a underground complex.
After i shot i zombie in such a bugged location also a collapse of multiple blocks which werent visibly there happend, but it looked like a massive part of a structure collapsed.

Edited by jihizuu
forgot word (see edit history)
Link to post
Share on other sites

So, first thing-

Amazing mod, I remembered playing it for a while 2 years ago and decided to jump back in and that's amazing that you are still updating.

 

Now a note before my problem- This discord link that was above isn't available- https://discord.gg/QdvGXv.

Now, I tried using the mod launcher( http://7d2dmodlauncher.org/ )  to launch it cause that's how I launched it last time I played you modpack,

but I can only see the latest version there to download, and from my understanding that version will only work properly on the test server..?

I tried running it anyways and I get the normal starter items excluding the "start here" item that should let me choose perks.

 

Would love to know if there is any older version I'm supposed to play if I want to play solo, or if I can play the latest one solo and I'm just doing something wrong!

Link to post
Share on other sites

----------------------------------------------------------------------------- Update 19.1 ------------------------------------------------------------------------------

-Updated Mod to 19.1

-Fixed Steel Forge smelting

-Added recipe and crafting skill for Marksman Rifle

-Added recipe and crafting skill for Tactical AR

-Added Action Skill - Farming Skill, levels by harvesting player planted crops. 1 XP per harvest, 25XP per level, 100 levels, x2 harvest amount at lv50, x3 harvest amount at lv100

-Changed Crafting Skills to all require 5,10,15,20,25 items crafted per level except Armor which requires 3,3,3,3,3 items crafted per level

-Added unlocked recipe for Military Gun Parts

-Fixed Grain Alcohol Schematic recipe

-Added recipe for Battery Bank using Broken Battery Bank

-Client Updated

-Server Wiped

Link to post
Share on other sites
11 hours ago, Thanimal said:

@Bluish69, right now it is only a client and SP is essentially disabled until mod is out of testing. join the testing server and help us all help Spider finish this thing up :D

Oh I see!
So no older versions available 😕
Either way can I have a discord invite so I stay up to date on what's going on with the mod?
Will consider joining the test server!

Link to post
Share on other sites

I was able to fix my two previous questions. Thank you for the help! We are now trying to get this mod onto a server. Both the server owner and I are getting the same two Error's on loading and we get stuck on creating character. One is "end of stream exception" an done is hard to read but it looks like "NCSimple deserializer" I have never seen either of those error's before. I am guessing that since we both got the error it has to be an issue on the server not on our end.

Link to post
Share on other sites
On 8/21/2020 at 8:36 PM, Spider said:

A19 Test Server is up

 

Front page is unfinished but the information there is current

 

Manual Install - https://github.com/SpiderJZMOD/TrueSurvivalA19TestClient.git

Also on Mod Launcher

Test Server - IP - 172.96.166.50

                     Port. - 18733

                     PW - In DL ReadMe

 

Discord -https://discord.gg/9bdJhk

 

 

 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...