Jump to content

True Survival


Recommended Posts

Is anyone else having issues downloading ? I tried 5 times now, and every time between 1gb and 1.1gb the connection is closed, and stupid gtihub does not support resume downloading. I tried 3 times through the launcher, another time directly through the browser, and once again directly using download manager. Every time get disconnected in around same place.

Edited by Marinxar (see edit history)
Link to comment
Share on other sites

10 hours ago, Spider said:

I have a fix to try on for the mp stutter if a few can help me test it. please let me know.




I just downloaded a zipfile of the mod off GitHub just fine. Took 2 min maybe. Pleases let me know if your still having the problem


Lucky... with our slow internet its over a hour for each attempt. Will let it run again tonight.

EDIT : Worked first time now, thanks man.

Edited by Marinxar (see edit history)
Link to comment
Share on other sites

-This update will break all saves, please start new games
-99% Sure the MP stutter on hand actions is fixed. If you experienced it in the past please let me know if this fixes it.
-Changed all Perk/Skill points earned to be permanent(gray) not temp(green). Should help performance
-Removed the ability for clothing to be inspected("used") to learn recipe. (MP stutter culprit)
-I will add recipes on the Armor Table to make the patterns for these clothes with the item+Paper+pen as the recipe for the schematic
-Now that that is hopefully fixed I can get back to finishing the mod before A19 comes out


Not sure what you have going on there. Did you get it fixed?

Link to comment
Share on other sites

So - the first non-vanilla thing i tried to assemble was the Research  Desk - it completed, but i can't find it anywhere in my inventory or on my hot bar to place it into the world.


Anybody else have this issue creating a bench?

Link to comment
Share on other sites

Nother simple question/bug that i can't figure out. 


jz_preptable.  I have all the components needed to make it, i found a working work bench, and i have the handsaw (looks like a power saw) as a tool in the tool area of the workbench.  But - it still won't allow me to make the prep table. (it's grey'd out).  I'm wondering if there is a skill impacting the requirements - other mods have this issue that i've seen - where the list amount needed is actually less then the true amount needed because of some skill or other thing behind the scenes.

Anyway - wanted to give the heads up.

Link to comment
Share on other sites

Hi spider (Rickachae), Good to have TS mod back, is the mod intended for any premade maps? at this stage as im getting a ton o prefab errors on loading in the in the console [ about 50 or more... I usualy fix by using a ramdom map gen when i come across it]

mods= True Survival and Sphereii core only... clean install all round... A18.4-steam...

(also getting rendering shaders not found and reverts back to original)

Link to comment
Share on other sites

-Turned back off the XP notification in the bottom right corner
-Increased the crafting ingredient list from 5 to 7 (fixes a few items that did not show all their ingredients)
-Fixed some incorrect growth stages on farmable plants
-Fixed 2 errors in Drying Rack causing errors when recipes was clicked on
-Fixed Flagstone to upgrade to bricks with Bricks
-Removed Apache Sound that was used for testing some buffs
-Added missing recipe for Gun Oil and Weapon Repair Kits
-Added chance to loot placeable vehicles from vehicles
-Fixed Mason Hammer not showing in player hand in first person



Might want to check your install, There is a Prefabs folder with POI's in it that's needs installing too. No set map you can use RWG, That shader thing has been happening since A17 I have no idea what it is but it doesn't seem to effect anything, I get it playing vanilla


Edited by Spider (see edit history)
Link to comment
Share on other sites

-Added recipes on the Research Desk to learn new Professions
-Added Recipes to learn Clothing recipes that are not already in books. These can only be learned by collecting the clothing and crafting the recipe.
-Increased Biome Spawning a little
-Locked Painkiller recipe
-Added Dirt Fragment to soil drops
-Fixed Buckets description
-Fixed Wooden Spikes to repair with Sticks
-Changed First Aid Kit recipe so they could be made with either medical creams
-Updated Wound descriptions to list wellness loss

Link to comment
Share on other sites

-Added chance for Bike and Vehicle Wheels to drop from tires
-Fixed Prep Table and Steel Forge crafting
-Added Recipe for Splash of water
-When used Splash of Water will give 10 Heat Resist for 3min, more uses can extend time
-Added ability for Cowboy hats to take other mods
-Add recipe for Grubs frim Dirt Fragment only Soldier knows
-Soldier does not have chance for Food Pensioning on Grubs
-Fixed Sanitized Bandages use sound
-Fixed Watches to scrap with just one
-Added Mushrooms loot chance on Dead Tree Stumps
-Fixed Archery Level not leveling
-Added Gun Tools To weapon loot
-Removed First Aid Bandage Schematic from loot
-Changed animal respawn delay from 22 to 10 days
-Lowered speed on Wooden Spikes slightly
-Unlocked Cornmeal
-Fixed filling Old Milk Jugs

Link to comment
Share on other sites

Story quest, step 4?

Walkie Communication - this quest wants the player to retrieve the jz_QISateliteRadio object. 

The text of the quest suggests you find it at a radio station in a forest - how would/does this work on a random gen map?  is it ANY satellite dish can drop the object? 

Link to comment
Share on other sites

-Decreased the speed that the Players Hunger and 4 Vitamins Stats decay at by 10%
-Changed Farm Plot recipe
-Removed extra Grub recipe
-Changed First Aid Kit recipe to take one of each type bandage


@McKeighan-It's a custom block inside the radio tower poi's, the ones with the big radio antennas. Harvest it with a wrench or screwdriver. The quest are worded for A19 but in 18 the poi can be in any biome so you might find one not in the forest biome but in 19 it will only be in the forest. It will make more since next month.  And no there is no magics map markers, you just have to explore and find the poi's. I am designing the Storyline Quest to last your whole play through, as the over all goal of game play so some parts may take longer than others. Game weeks even.

Edited by Spider (see edit history)
Link to comment
Share on other sites

-Farming Update
-Updated all player planted crops to the True Survival Farming System
-All player cultivated crops must be planted in Farm Plots and have a chance to require insecticide and/or watering with a Watering Can between growth stages
-Watering Cans use Dirty Ounces of Water and Insecticide on player planted crops
-Added Watering Can and Insecticide recipes to Farmer Profession
-Added Recipes for Watering Can and Insecticide
-Added recipes for crafting the recipes for Watering Can and Insecticide
-Added Insecticide and Watering Cans and Schematics to loot table 
-Increased Biomass amount harvested from rotten items
-Balanced some loot tables
-Did more Localization on items and blocks


@user2010- Im not sure what any of that means but I'm going to take it as a complement. Thank you. :)

Link to comment
Share on other sites

-Fixed Firewood Stack Blocks to drop Fire Wood
-Fixed Anvil to scrap
-Fixes custom melee weapons to scrap
-Added crafting skills for Handcrafted Revolver and Handcrafted Rifle
-Lowered the needed amount of crafting for Firearms(greatly) and some Melee weapons(little) Crafting Skills
-Unlocked Crowbar recipe
-Added Crowbar Mold and Crowbar to loot tables
-Localization work
-Added Glazed Meats to Prep Table
-Fixed Poncho scraping
-Fixed POI torches not to give light
-Fixed Player placed Torches to require fuel to burn for light
-Added Sewing Kit to Storage Sack recipe

-Turned on Crop Trampling(by Sphereii) Player planted crops can be destroyed if non player entitys touch them.
-SERVER SETTING CHANGE- Increased to 90min days and increased safe zone on beds to 35

Edited by Spider (see edit history)
Link to comment
Share on other sites

Hi Spider


Me and my partner downloaded the True survival mod as we wanted something more challenging and we love this mod. However we have come across a number of issues which I’ve been fixing manually in the coding to get working but I’ll list the issues we currently have with parts of the mod


icons missing....

cucumber seed , egg plant seed , carrot seed , leek seed and chilli seed all are black in the UI. On inspecting code the icon is linked to jz_sheetstealmetal.


Sheet Iron, sheet steel and scavenged parts all have icons missing


gun receivers for Ak47, AR15, M60, double barrel shotgun are blank on the UI. Also all steel variable blocks are blank on UI


there were more but I haven’t got round to noting them all. 

there are a number of workstations that aren’t craftable or obtainable like the Prep Table, Steel Forge.


the only crafting stations I can access are Forge, Workbench, Tablesaw, chemistry station, oil refinery, research desk and dry rack.


also there are a lot of recipes that are locked and on the description it doesn’t say how to unlock. Example Nails, Forged Iron, Forged steel we’re all locked. I thought it might be due to profession but I learnt the metal work profession and they were still locked. Looked in creative to see if there were schematics to learn to craft them but none existed. Also another example Wood Frame blocks I unlocked the wood frame blocks but the Variable wood frame blocks stayed locked.


im currently on Alpha 18.4 and using the 7D2D mod Launcher so any help would be great



Link to comment
Share on other sites

Icons are being added as Spider has time (when he's not squashing major bugs). 


Prep Table can be constructed on the Workbench and needs no schematic/unlock.


Wood frame block variants should unlock after the 1st level of the 'Wood Building' quest is done (miscellaneous tab of skill screen).


The other stuff is missing (mostly schematics or other paths to enable players to acquire tools/tables).  



Link to comment
Share on other sites

Here's an odd one - Can't craft a stone sledgehammer, although it shows that it's not blocked. I go looking in the xml, and the items exists in both the main a18.4, and also  the truesurvival version of the XML.   In your version, it's got a tag of learnable, but in the root version, anyone can make them at level 1 (i.e., no tag).   If the goal is to have it a learnable only item, then i think you're going to have to kill it from the vanilla xml.  I can only imagine that's why most of the other mods out there just merge the xml files.

I also noticed that I took some perminent damage to my stamina. It was 100, now it's a max of 97. (Yes, i've even rested on a bedroll and healed up to full).  I can only assume this is some issue with it replacing the value of the variable for max health while trying to adjust for the different effects from damage / wounds / injuries.  Might want to build in a function that works like " IF negativebuffcount = 0 then set maxhp = 100 + any positive trait - any negative trait" .... I.E. recalculate it again after all the negative buffs wear off. Maybe have it only calculate as well if you're fully rested.

Link to comment
Share on other sites

Having a ball struggling to survive, glad you updated.  had a weird glitch after my 2nd bloodmoon I emerged from hiding to find Parasites spawned all around my base just idling.  wouldn't react to me.   creepy as hell.   when I logged and reloaded they were gone.  Starved to death while walking around looking at them, so I guess they did their job!




Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...