Jump to content

True Survival


Recommended Posts

It seems i can only start the mod as dedicated server now, or am i doing something wrong ?, using mod launcher

 

It complained to not be able to open

\Alpha18\Spider\True_Survival_18.4\Data\Bundles\blocktextureatlasesD

i had no such file, added D to my blocktextureatlases and it worked, though only as Dedicated Server

Edited by Shaidar (see edit history)
Link to post
Share on other sites

That's my bad. I forgot about ya'll using the Mod Launcher to play and shouldn't of put the server files in that DL. I have removed it so the Mod  Launcher should work again and I am setting up a separate DL for the Server Files. Post in a min with the Server DL link

Link to post
Share on other sites

When I try to start the dedicated server with the Server Files posted above I am getting the following error on startup:

 

2020-05-31T22:59:58 1976.128 ERR Loading prefab "oldwest_business_01" failed: Block 2298 used in prefab at 1 / 5 / 4 has no mapping.
2020-05-31T22:59:58 1976.129 WRN Could not load prefab 'oldwest_business_01'. Skipping it
2020-05-31T22:59:59 1977.103 ERR Loading prefab "oldwest_business_01" failed: Block 2298 used in prefab at 1 / 5 / 4 has no mapping.
2020-05-31T22:59:59 1977.103 WRN Could not load prefab 'oldwest_business_01'. Skipping it
2020-05-31T22:59:59 1977.326 INF Started thread GenerateChunks
2020-05-31T22:59:59 1977.424 INF Processing world files
IndexOutOfRangeException: Index was outside the bounds of the array.
  at GameUtils.WaterFloodFill (System.Byte[] _cols, System.Byte[] _waterChunks16x16Height, System.Int32 _width, HeightMap _heightMap, System.Int32 _posX, System.Int32 _maxY, System.Int32 _posZ, System.Byte _colWater, System.Byte _colBorder, System.Int32 _minX, System.Int32 _maxX, System.Int32 _minZ, System.Int32 _maxZ, System.Int32 _worldScale, System.Collections.Generic.List`1[T] _listPosX, System.Collections.Generic.List`1[T] _listPosZ) [0x00053] in <f9ab98ad7e8240f9bef6c6434814ba69>:0
  at WorldDecoratorPOIFromImage+<InitData>d__14.MoveNext () [0x001d1] in <f9ab98ad7e8240f9bef6c6434814ba69>:0
  at UnityEngine.SetupCoroutine.InvokeMoveNext (System.Collections.IEnumerator enumerator, System.IntPtr returnValueAddress) [0x00027] in <ca1d1fd848884ed5a84a515243f09e15>:0
 
(Filename: <f9ab98ad7e8240f9bef6c6434814ba69> Line: 0)

 

Link to post
Share on other sites

I managed to get it to start after wiping the entire directory, then recopying everything.

 

I still get a the following error:

Loading prefab "oldwest_business_01" failed: Block 2298 used in prefab at 1 / 5 / 4 has no mapping.
WRN Could not load prefab 'oldwest_business_01'. Skipping it

 

but the server at least started up.

Link to post
Share on other sites

We have been doing some testing and I have seen the bug where the server drops to under 10fps in the console.

 

While this is happening the server CPU spikes to 40% (across 4 cores) and I see a bunch of these in the server logs:

 

(Filename: <29fadc7ec52648d5b7f9da9b8521c520> Line: 0)

MissingMethodException: bool EntityUtilities.CheckAIRange(int,int)
  at SphereII_EAIApproachAndAttackTarget+SphereII_EAIApproachAndAttackTarget_CanExecute.Postfix (System.Boolean __result, EAIApproachAndAttackTarget __instance, System.Boolean& ___isTargetToEat) [0x00009] in <29fadc7ec52648d5b7f9da9b8521c520>:0
  at (wrapper dynamic-method) EAIApproachAndAttackTarget.CanExecute_Patch1(object)
  at EAITaskList.OnUpdateTasks () [0x000ce] in <f9ab98ad7e8240f9bef6c6434814ba69>:0
  at (wrapper dynamic-method) EAIManager.Update_Patch1(object)
  at EntityAlive.updateTasks () [0x00063] in <f9ab98ad7e8240f9bef6c6434814ba69>:0
  at EntityAlive.OnUpdateLive () [0x00154] in <f9ab98ad7e8240f9bef6c6434814ba69>:0
  at EntityEnemy.OnUpdateLive () [0x00000] in <f9ab98ad7e8240f9bef6c6434814ba69>:0
  at EntityZombie.OnUpdateLive () [0x00000] in <f9ab98ad7e8240f9bef6c6434814ba69>:0
  at EntityAlive.OnUpdateEntity () [0x0001e] in <f9ab98ad7e8240f9bef6c6434814ba69>:0
  at World.TickEntity (Entity e, System.Single _partialTicks) [0x0015d] in <f9ab98ad7e8240f9bef6c6434814ba69>:0
  at World.TickEntitiesSlice (System.Int32 count) [0x00037] in <f9ab98ad7e8240f9bef6c6434814ba69>:0
  at World.TickEntitiesFlush () [0x0000c] in <f9ab98ad7e8240f9bef6c6434814ba69>:0
  at GameManager.UpdateTick () [0x00033] in <f9ab98ad7e8240f9bef6c6434814ba69>:0
  at GameManager.gmUpdate () [0x00261] in <f9ab98ad7e8240f9bef6c6434814ba69>:0
  at GameManager.Update () [0x00000] in <f9ab98ad7e8240f9bef6c6434814ba69>:0

This error runs the entire time a zombie is trying to attack us until it dies.
 

I'll add more info as we troubleshoot.

Link to post
Share on other sites

Here is what we noticed.

 

Dedicated Server running on its own hardware (i5 4690k w/32GB ram).  2 Players connected during tests.

 

System #1 - Intel i7 8700k w/32gb ram 1080Ti - VLAN Connection - When problem started I would see System #2 lag-gliding around with some sound effects delayed up to 20 seconds.  Zombies would move erratically away from players or not move at all while being killed.

System #2 - AMD Ryzen w/32gb ram 2070Ti - Connected over the Internet - Once the server process spiked to 40%, any action on System #1 would cause System #2 to drop to 10fps with lag (ping would jump from 24ms to 48ms).  Lag and fps would return to normal the moment system #1 stopped performing actions other than moving.  Completely exiting the game did not fix the issue but restarting the server would.

 

For testing we had matching graphical settings to ensure it was not particle/texture related.

 

In all cases we did not see the lag spike until we had already generated a large amount of the errors in my previous post.  In a 2 hour playtest the server generated 54meg of log files due to the CheckAIRange errors.

Link to post
Share on other sites

----------------------------------Update-------------------------------------

-Fixed resource drops from blocks(it was not working right you were not getting what you should have)*80%complete
-Fixed Crowbar to function correctly, When used on a non player craftable world blocks the Crowbar will pick up the block in one hit and not give any resources
-I think the Server Bug is fixed. I did not test Coop but the server runs smooth now. Please let me know if it fixes the issues.

Edited by Spider (see edit history)
Link to post
Share on other sites

---------------------------------------Update------------------------------------
-I think I fixed the Co op/MP stutter. 
-If you had the issue please let me know if this fixes it.

Link to post
Share on other sites

We still had the same issue.

 

Total time before bug occurred 25 minutes from start - 2 players, 6 Zombies, 8 Entities - CPU Usage on Server 5-7%. average.

 

Player #1 using Spear, Player #2 using Club - Killed a ZombieUtilityworker and had an armless/legless Darlene to fight.  Right after Darlene died, Server CPU spiked to 37% anytime the spear/club was used.  Cpu usage would drop back to 5-7% when the players stood still or only walked but spiked right back to 40% the moment the club or spear was used.  When the CPU spiked Player #2 (playing over the net) would experience the extreme lag.

 

No errors in the logs. 

 

Here is the INF line from the initial log in:

2020-06-04T00:14:10 2351.334 INF Time: 38.18m FPS: 39.04 Heap: 2718.5MB Max: 2718.5MB Chunks: 293 CGO: 54 Ply: 1 Zom: 8 Ent: 10 (19) Items: 4 CO: 1 RSS: 6221.4MB

 

Here is the logs where the lag started.
2020-06-04T00:37:29 3750.090 INF Entity zombieFootballPlayer 929 killed by Shanky McStabber 555
2020-06-04T00:37:38 3758.729 INF VehicleManager saving 0 (0 / 0)
2020-06-04T00:37:42 3763.238 INF Time: 61.70m FPS: 36.52 Heap: 2842.7MB Max: 2997.1MB Chunks: 531 CGO: 53 Ply: 2 Zom: 9 Ent: 12 (45) Items: 0 CO: 2 RSS: 6657.1MB
2020-06-04T00:37:59 3779.971 INF Entity zombieUtilityWorker 921 killed by Shanky McStabber 555
2020-06-04T00:38:12 3793.387 INF [DECO] written 167/22
2020-06-04T00:38:13 3793.768 INF Time: 62.20m FPS: 32.46 Heap: 2931.1MB Max: 2997.1MB Chunks: 531 CGO: 54 Ply: 2 Zom: 7 Ent: 11 (45) Items: 0 CO: 2 RSS: 6937.1MB
2020-06-04T00:38:24 3804.814 INF Entity zombieDarlene 923 killed by Shanky McStabber 555
2020-06-04T00:38:43 3823.969 INF Time: 62.70m FPS: 30.45 Heap: 2980.4MB Max: 2997.1MB Chunks: 531 CGO: 59 Ply: 2 Zom: 7 Ent: 9 (46) Items: 1 CO: 2 RSS: 6696.5MB
2020-06-04T00:39:13 3853.975 INF Time: 63.20m FPS: 37.98 Heap: 2773.8MB Max: 2997.1MB Chunks: 531 CGO: 48 Ply: 2 Zom: 6 Ent: 8 (45) Items: 0 CO: 2 RSS: 6700.2MB

Link to post
Share on other sites

Looking for some people to help me test fixes for the Co op stutter problem. I have a server all you would have to do is join and run back and forth while I do test and tell me if you get a stutter. Biggest problem solving this is I need other players to test fixes. Here's my Steam Profile if you would like to help but we are not friends send me an invite.

https://steamcommunity.com/profiles/76561198071700260

 

Edited by Spider (see edit history)
Link to post
Share on other sites

-------------------------Update--------------------------
-Fixed error in Mechanic Profession
-Added more missing icons
-Adjusted some monsters speed
-Miscellaneous fixes and tweaks

Link to post
Share on other sites

---------------------------Update--------------------------------
-Lowered Painkillers in loot
-Fixed more icons
-Fixed Screwdriver scraping
-Removed unneeded medical schematics in loot
-Fixed Vitamin Buff Description
-Added all missing Apparel recipes
-Added all Apparel to the Schematic Tab in the Perk menu so that it can be tracked
-Fixed all clothes to have a "Use". Doing so will destroy the item and learn the recipe
-Updated the Wound system to continue to lower wellness until you treat it. 
-Small Wound 1 wellness every 2.5min
-Wound 1 wellness every 2min
-Sever Wound 1 wellness every 1.5min
-Infected Wound 1 wellness every 1 min

Link to post
Share on other sites

We did a test on the files you released 7 hours ago and are still seeing the lag start up while using any kind of hand item (or even punching open air).

 

You can see the CPU spike from 2-4% average to 40% usage whenever something hand related is being swung.  Could it be something related to the damage/hit calculations?  Maybe too many modifiers?

Link to post
Share on other sites

I honestly don't know. I am only one person and to even reproduce the bug it takes several people, making trying to test fixes take hours instead of min. I will keep working on it and figure it out eventually. For now if its to unplayable for you I would suggest just playing SP until I can figure it out.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...