Jump to content
Sign in to follow this  
Valmar

A16 Valmod Pack

Recommended Posts

This is a known issue with the stable build that occurs from time to time, logs posted here are identical from null reference onwards but devs (vanilla only, mods are supported by mod authors only) can't narrow down exactly what causes it but it suggests an issue with polygon count hard limit as it tries to hit 65k.

 

Sometimes with null reference on servers restarting the game fixes itself but read on these forums many times this issue is caused by wood frames, upgrading them past woodframes resolves the error. If you can stick to cobblestone, metal or concrete and paint it wood sparingly. If you can't do that demolish a building or two around you.

 

Am I running into some kind of a memory issue with the host? I was laying out wood frames (granted I have a ♥♥♥♥ ton already) plus Red Mesa, Plus the void that appeared, and when I lay an individual wood frame, I get a error that sends me to console that I have to click on "Close". Once i do I can move around, but when I lay an additional wood frame, the error occurs again. Do we need to increase the memory allocated to our virtual server in order to get around this issue, or is something else causing the error? See below:

 

2017-12-03T22:46:58 1937.951 INF Time: 31.97m FPS: 57.78 Heap: 960.8MB Max: 960.8MB Chunks: 367 CGO: 318 Ply: 1 Zom: 0 Ent: 5 (8) Items: 1 CO: 1 RSS: 7733.7MB

2017-12-03T22:47:03 1943.292 ERR ERROR: Vertices.Count (64964) != tangents.Count (0), MeshIdx=0 TriIdx=65984

NullReferenceException: Object reference not set to an instance of an object

at MeshUnsafeCopyHelper.CopyTangents (.ArrayListMP`1 _source, UnityEngine.Mesh _mesh) [0x00000] in <filename unknown>:0

at VoxelMesh.YZ (UnityEngine.Mesh , .ArrayListMP`1 , .ArrayListMP`1 , .ArrayListMP`1 , .ArrayListMP`1 , .ArrayListMP`1 , .ArrayListMP`1 , .ArrayListMP`1 ) [0x00000] in <filename unknown>:0

at VoxelMesh.CopyToMesh (UnityEngine.MeshFilter[] _mf, UnityEngine.MeshRenderer[] _mr, Int32 _lodLevel) [0x00000] in <filename unknown>:0

at ChunkGameObject.RZ (Int32 ) [0x00000] in <filename unknown>:0

at ChunkGameObject.CreateFromChunkAll (System.Int32& triangles, System.Int32& colliderTriangles) [0x00000] in <filename unknown>:0

at ChunkManager.WQ () [0x00000] in <filename unknown>:0

at ChunkManager.CopyChunksToUnity () [0x00000] in <filename unknown>:0

at GameManager.JQ () [0x00000] in <filename unknown>:0

at GameManager.Update () [0x00000] in <filename unknown>:0

 

(Filename: Line: -1)

Share this post


Link to post
Share on other sites
You can not use some tools to upgrade certain blocks in the mod. Carpenter blocks for instance can not be used with a wrench as an example (I had the same problem). I have not tried it with the nailgun but I can confirm it works just fine with a claw hammer, which does make sense from a "realism" point of view I suppose. The fire spikes/traps are the same way, but I believe you must be using a nailgun to fix them. Hope that helps.

 

Ty for that response,

would of thought the admin wrench works on everything but I will try with the claw hammer.

Share this post


Link to post
Share on other sites

Hello Valmod,

 

I tried a couple of mods for 7 days to die and I must say, Valmod is my favourite mod so far. I have a question about POI's.

 

Does Valmod offer new POI's? I'm not sure if it does or not. If not, is there a 'lore friendly' POI pack for Valmod? I don't want POI's with 10 bookcases (for example) which ruin the loot runs to my opinion.

 

Thank you for your time mr.Valmod creating this awesome mod. I like how it takes time and efford to reach something.

 

Carda

Share this post


Link to post
Share on other sites

Hello!

 

I have a problem with mod. I uploaded mod in my server, copy folders data and mods, and I don't have interface pictures, modded icons and descripsions.

 

How I can fix it?

 

s3c6p8fz4c6f_t.jpg

Share this post


Link to post
Share on other sites
Hello!

 

I have a problem with mod. I uploaded mod in my server, copy folders data and mods, and I don't have interface pictures, modded icons and descripsions.

 

How I can fix it?

 

Did you install the mod locally as well?

Share this post


Link to post
Share on other sites
Did you install the mod locally as well?

 

Haha, ok, that was a problem. I thought my client can download mod from server. With some mods, on some servers it's works like that. Thanks for help!

Share this post


Link to post
Share on other sites

curious question on wandering hordes.....now that I think about it, running valmod on our server and I have yet to see any wandering hordes, tis only day 6, however premod they seem to never end?

Share this post


Link to post
Share on other sites
curious question on wandering hordes.....now that I think about it, running valmod on our server and I have yet to see any wandering hordes, tis only day 6, however premod they seem to never end?

 

Trust me they are there... We are on level "3" I think on the server and now about day 42 ish I think. We run into plenty around where we travel and have a few wander by our "base" often through the day.

Share this post


Link to post
Share on other sites
Hello Valmod,

 

I tried a couple of mods for 7 days to die and I must say, Valmod is my favourite mod so far. I have a question about POI's.

 

Does Valmod offer new POI's? I'm not sure if it does or not. If not, is there a 'lore friendly' POI pack for Valmod? I don't want POI's with 10 bookcases (for example) which ruin the loot runs to my opinion.

 

Thank you for your time mr.Valmod creating this awesome mod. I like how it takes time and efford to reach something.

 

Carda

 

Valmod only adds 3 new POI's/prefabs and they are all graveyards, largely to facilitate spawning of the Reaper zombie added by the mod.

Share this post


Link to post
Share on other sites

You want straight ground with minimal water>>>>..........<<<<<

 

https://7daystodie.com/forums/showthread.php?67996-A16-(stable)-rwgmixer-re-done-top-to-bottom!-(refined)

 

- - - Updated - - -

 

please any one help me how change amount biomes water and elevation biomes ????

 

You want straight ground with minimal water>>>>..........<<<<<

 

https://7daystodie.com/forums/showthread.php?67996-A16-(stable)-rwgmixer-re-done-top-to-bottom!-(refined)

Share this post


Link to post
Share on other sites

Hey dude, i've been loving the Overhaul mod so much that i'm trying to load it onto our server but every time i attempt to load up the level it keeps hanging after - INF creatWorld() done. Have you or anyone else experienced anything like this before? I've wiped the server and started fresh, so not entirely sure what the issue could be.

 

Apologies if this has already been explained.

 

Cheers

Share this post


Link to post
Share on other sites
hello why I have no admin tool in the overhaul version ?

 

They are there and enabled. You have to go to creative menu and grab them, they're right after the bullet casings.

Share this post


Link to post
Share on other sites

Quest issues?

 

Hello - I remember back in Alpha 15.2 Valmod had a series of quests for the builder, vet, etc. Playing the latest two Valmods - 5.4 & 5.5 I don't see them progress past the 'first one.' Is that intended?

Share this post


Link to post
Share on other sites
Hey dude, i've been loving the Overhaul mod so much that i'm trying to load it onto our server but every time i attempt to load up the level it keeps hanging after - INF creatWorld() done. Have you or anyone else experienced anything like this before? I've wiped the server and started fresh, so not entirely sure what the issue could be.

 

Apologies if this has already been explained.

 

Cheers

 

did u get it working

Share this post


Link to post
Share on other sites

New to the game but I just recently joined into a new server and died very soon before I was able to change class. I haven't able to retrieve the crafting component: Class Selection (the clipboard) yet. Does it disappear from the map or is there way craft another one?

Share this post


Link to post
Share on other sites
New to the game but I just recently joined into a new server and died very soon before I was able to change class. I haven't able to retrieve the crafting component: Class Selection (the clipboard) yet. Does it disappear from the map or is there way craft another one?

 

Apparently there's a glitch with 7DTD - a bunch of times me and my friends experienced this exact issue. Unless you're the Admin - the only way to get it is to ask the admin, or if you can get into the Creative Menu via the command console via F1. Then type in "CM" and hit enter; at this point it will tell you if it was accepted or denied. Then go to your inventory and click on the light bulb tab at the far right; then search for "Class" and find it or the one you want, then type in "Key" and grab the key for it, please note that there are locked and unlocked versions of the different classes.

 

Now - barring the ability to do either you'll have to suffer or try another server with Valmod installed; although there's something with the persistent profile settings that may let you try again; Start the game and change your profile settings and then try to get back on the server... That would depend upon the servers persistent profile settings too; if it will let you.

 

(EDIT: Long and tedious!) I seem to think that uninstalling the game on your end and reinstalling everything may let you get back on and try again... There's a profile file on the server that would also have to be 'deleted'/'changed' that would let you back in as 'a new player' that would help too.

Share this post


Link to post
Share on other sites

Hey Valmar, i love your mod. It's a simple but amazing mod. I want to change the ui using Simple UI Plus, but there are only for Overhaul version. So i must edit it for Expansion version. I want to ask, is there a different in the xui.xml and other xml file in xui folder between overhaul and expansion version.? Thanks Valmar.

 

Sorry for bad english.

Edited by Agpradipa
Wrong word (see edit history)

Share this post


Link to post
Share on other sites

been trying to research or look around on how to make the zombies harder to kill for our valmod server. We have the server setting "game difficulty" on 10, however does that actually work as intended or do I need to bring it down to 5 which shows being the highest on our actual game settings for being the hardest?

 

Basically be nice to make the zombies harder to kill if possible.

 

thanks

Share this post


Link to post
Share on other sites

I love your mod, but when I play it I have to ask myself: what the hell are the devs doing? there is so much stuff in your mod that the devs should have in the game but they don't. Alot of it is simple things like the iron shiv, or the hunting rifle having more than 1 round in the clip etc. The Machete being made with 10 forged iron and 10 wood is brilliant, I love how you also left the forged steel to repair it, so while you CAN make one, your going to need a workbench to combine to repair it at all unless you bought some steel that is for the early game anyway.

 

I have a question: Can you pick up workbenches in your mod? Like if I wrenched it or destroyed it? Also will you update this for A17 once its released, not for the experemental version of course as that has too many changes to fast, but for the stable?

 

Another question: Do I miss out anything on not using the Wildcards class skill book? other than the 50 skill points? I feel its cheating to just be instantly given like 10 levels worth of skill points. Same with depending on what random tool it gives me, I may not use it as I didn't "earn" it.

Edited by Scyris (see edit history)

Share this post


Link to post
Share on other sites
been trying to research or look around on how to make the zombies harder to kill for our valmod server. We have the server setting "game difficulty" on 10, however does that actually work as intended or do I need to bring it down to 5 which shows being the highest on our actual game settings for being the hardest?

 

Basically be nice to make the zombies harder to kill if possible.

 

thanks

 

There might be an option in one of the xmls, that controls stuff like damage taken/delt or something, you could maybe modify those values directly, in entityclasses.xml. Setting headshots only is a decent diffculty spike as some of them move pretty quick and get hard to land a headshot. Mind you I always aim for headshots if I can myself anyway as it takes way to many hits to kill with any other body area. Setting them to always run also ups diffculty quite a bit. Fire a non-silenced hunting rifle or something in this mod with that always run.. have fun your going to get swarmed XD.

 

You could also increase the spawn as well. Might even be able to set it so they spawn in large numbers in a city area or areas that are damaged like the wasteland.

Share this post


Link to post
Share on other sites
There might be an option in one of the xmls, that controls stuff like damage taken/delt or something, you could maybe modify those values directly, in entityclasses.xml. Setting headshots only is a decent diffculty spike as some of them move pretty quick and get hard to land a headshot. Mind you I always aim for headshots if I can myself anyway as it takes way to many hits to kill with any other body area. Setting them to always run also ups diffculty quite a bit. Fire a non-silenced hunting rifle or something in this mod with that always run.. have fun your going to get swarmed XD.

 

You could also increase the spawn as well. Might even be able to set it so they spawn in large numbers in a city area or areas that are damaged like the wasteland.

 

Looks like there are multiple values to consider... Zed's max health in entityclasses and then DamageEntity (which I presume to be the damage delt by noted zed against an entity) which is in items. Albeit I don't know if a player is considered a "block" or entity, I presume entity.

 

So... One quick way would be to up the zeds' health. Or increasing their DamageEntity value, or both... Just a quick look got those but there doesn't seem to be more you can do 'immediately' besides the server settings.

 

IE: Look up the zed in entityclasses. You can up their maxhealth directly there, this would make them harder to kill... And now you can see what their handitem is, this is presumably the damage they do per swing... Then go to the items xml and increase the 'handitem' value, which would increase the damage delt.

 

So its a few step process to increase their health and the damage they do. You could go into the items xml and lower the values for the armor and damage for the weapons and such, but now you're talking about a whole lot more.

 

OH! Don't increase the values too much, you can run into issues if you do... But considering what you're trying to attempt and what I've outlined - it shouldn't be a problem unless you change like DamageEntity to +500 or so... Just a guess...

Edited by Cadamier
refinement (see edit history)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...