Jump to content
Sign in to follow this  
Valmar

A16 Valmod Pack

Recommended Posts

Upgrading anything wood (blocks/doors/hatches) takes regular wood as opposed to requiring carpenter kits in order to upgrade with it seems.

 

Also not sure if this is by design or not but wooden doors are hand craftable instead of requiring the bench and bedrolls are still 20 plant fiber instead of the original 20 cloth like the 15.2 build had done. (Just little changes I was used to that added an interesting layer of difficulty.)

 

Hmm that's not the case with me as far as the updating wood goes. I have upgraded a whole house now and it required carpenter kits each time

Share this post


Link to post
Share on other sites

Played B129, decided to play valmod exp, problem with combine station, cant upgrade above quality level 500 on anything, altough i can do it in B129 vanilla.

 

If this is intended then how and where(what file) can i change it in, so i can combine stuff to reach max level 600?

Share this post


Link to post
Share on other sites

Hello, I'm new to PC but have played on Xbox. And thus new to Valmods. Love them so far. This is on a dedicated server with mods installed in their respective places client and server side.

 

I am having an issue that I'm unsure if are related to the mod or the A16, maybe others are having them too.

 

I notice when upgrading wooden structures, to a higher tier, and other structures say cement to Metal. the game says I do not have the resource martial available, even though its in my inventory, the work around is to put the resources needed in the hot bar. Also Upgrading concrete blocks to Re-enforced, does not always work, some times after it dries, its not upgraded, and i can "upgrade" it again, and it uses the resources. Its really random.

Share this post


Link to post
Share on other sites
Hmm that's not the case with me as far as the updating wood goes. I have upgraded a whole house now and it required carpenter kits each time

 

Yeahh I realized that it's the reinforcing stages that require carpenter kits now, was just used to in 15.2 even the first stage required carpenter kits in order to upgrade from frames to regular blocks... though I actually prefer this more anyway because it makes a little more sense.

 

That being said, reinforcing doors with wood I think should probably use carpenter kit since it's technically a second stage.

Share this post


Link to post
Share on other sites

I'm on a steady stream of RedBull and my eyes are getting itchy from staring at Kdiff for hours. Trying to merge changes between Valmod Expansion and the Experimantial build to make a playble Expansion mod for the current Exp Build. Valmar, if you're around and there's anything I should watch out for other than the config xmls let me know. I'm just winging it and mashing it all up as I go.

 

Wait, what files are different between the Expansion and the Conversion? If I just focus on those I should be able to hammer this out by tonight. As long as my eyeballs don't burst from staring at a white screen and lines and lines of xml code.

Share this post


Link to post
Share on other sites

hmm.jpg.36541d62b3aac2ad6d2aa25bd380de23.jpg

 

Sorry about the writing, I've had a lot of RedBull. As you can see there's a discrepancy in the spelling there. Which one is it? I'm going with the Vanilla spelling.

 

Augh... there's way more stuff in there than I remember. I got a bit done. All of the files ending with ".Vanilla" have a merged version except the items.xml. I'm going to go pour some eye drops on my eyes and take rest a bit.

 

https://drive.google.com/drive/folders/0BxXEAV27a2tpV3BYR1pPeHg2a1U?usp=sharing

 

I may or may not have broken many things, but all the same I made progress merging and checking .xml files against the latest experimental build. :distrust:

Edited by falloutgod13 (see edit history)

Share this post


Link to post
Share on other sites
Played B129, decided to play valmod exp, problem with combine station, cant upgrade above quality level 500 on anything, altough i can do it in B129 vanilla.

 

If this is intended then how and where(what file) can i change it in, so i can combine stuff to reach max level 600?

 

progression.xml

Share this post


Link to post
Share on other sites

Well, I spent way too much time looking over the files with little to show for it in terms of expansion. I think I actually deleted more stuff than I added by trying to get my progression edits to work. Well, I give up so here's what I managed to do so far. It works if you just overwrite the overhaul files. I used a progression mod from nexus to make it work. My edits were somehow breaking the game and it kept saying skill null refrence and I can't figure it out, can it not be more specific? The logs are useless if I don't know where the problem origniates in a file with 15k lines. -_- If anyone wants to take a look at my progression.old I'd appreciate some help. I have no clue what's wrong with my changes. I was just trying to add Valmar recpies and things to unlock by level to certain things but it didn't want to work.

 

https://drive.google.com/drive/folders/0BxXEAV27a2tpTmFsLTFFYTBjeGc?usp=sharing

Share this post


Link to post
Share on other sites

weapon repairs seem odd.. level 8 weaponsmith 54 pistols and i repaired a 500+ pistol to 103. i think RepairQualityLoss is being taken from weaponsmith and weapon perk causing double loss

Share this post


Link to post
Share on other sites

noticed the trussing spikes are gone anyway to get them back? i tried it myself but it seems the shape property "cone" has been removed and not sure where to go from there.

Share this post


Link to post
Share on other sites

Solution for language Bug in Alpha 16 Experimental

 

I know how you can make your Mod for other languages with the version "Alpha 16 Experimental" compatible.

I play in German and before it the descriptions of your Items were always indicated with "SomethingDesc". Here the solution with which you can indicate your English description also into other languages: You write in the file "Localization. txt" at the end of every line one of yours items 4 commas instead of only 2. Simply add to two commas another two.

If you already knew this, I apologise for this. :)

 

Edit: No notion why, however, it functions only partially. Only some descriptions are indicated into other languages. :(

Edited by Lenoiel (see edit history)

Share this post


Link to post
Share on other sites
B129

First good news. Without modification Valmod is running on OSX, also the bigger backpack.

 

- no icon for macdyvers book

- no sell price for tool and die set

 

How are you getting the UI to work? I am getting all question marks here and following the old post instructions for UI creates null error.

Share this post


Link to post
Share on other sites

Val Mod A16

 

How are you getting the UI to work? I am getting all question marks here and following the old post instructions for UI creates null error.

 

 

I had the same issue, overlay had question marks and lots of items in the creative menu were messed up.. but what do you expect.. it's experimental... so just gonna have to wait for Stable .........

Share this post


Link to post
Share on other sites

I have a problem with Jason.

If we shot him we have this error message NullReferenceException: Object reference not set to an instance of an object

Zombies seem to be able to hit him but he doesn't take damage, if we go beside him, he does nothing to use like he didn't see us but he will attack zombies. He took good care of my red moon.

 

Yesterday, major problem husband and I were not able to get in the game with our actual character, if I create a new one its fine problem is, where my base is and so Jason the world doesn't load anymore. I had to find the map grid to delete that part which of course removed my base and other that was around. GRRRR. The error we had is

ERR Buff burning could not find transform child path Graphics/Model/npc_male/UMA_Female_RigGlobal/Position/Hips in entity (type=EntityNPC name=ZombieJason id=13440)

 

So I'm guessing that Jason when on the burning spikes and burned to death maybe?

 

After removing the grid I was able to get in the game without problem with my character that I saved and where my base was the world loaded normally.

 

I comment out the Jason part in the entitygroups, something is not working with him so.

 

We built again our base and the ♥♥♥♥er was still there EVEN IF I COMMENT OUT JASON and also the bandit. I don't know what to do with that, for now we built stainless wall around him so he doesn't get out and walk to ♥♥♥♥ed up my game again (hope gonna work).

 

What is the problem with Jason in the file? with that message NullReferenceException: Object reference not set to an instance of an object there is something missing to make him working.

Share this post


Link to post
Share on other sites
I have a problem with Jason.

If we shot him we have this error message NullReferenceException: Object reference not set to an instance of an object

Zombies seem to be able to hit him but he doesn't take damage, if we go beside him, he does nothing to use like he didn't see us but he will attack zombies. He took good care of my red moon.

 

Yesterday, major problem husband and I were not able to get in the game with our actual character, if I create a new one its fine problem is, where my base is and so Jason the world doesn't load anymore. I had to find the map grid to delete that part which of course removed my base and other that was around. GRRRR. The error we had is

ERR Buff burning could not find transform child path Graphics/Model/npc_male/UMA_Female_RigGlobal/Position/Hips in entity (type=EntityNPC name=ZombieJason id=13440)

 

So I'm guessing that Jason when on the burning spikes and burned to death maybe?

 

After removing the grid I was able to get in the game without problem with my character that I saved and where my base was the world loaded normally.

 

I comment out the Jason part in the entitygroups, something is not working with him so.

 

We built again our base and the ♥♥♥♥er was still there EVEN IF I COMMENT OUT JASON and also the bandit. I don't know what to do with that, for now we built stainless wall around him so he doesn't get out and walk to ♥♥♥♥ed up my game again (hope gonna work).

 

What is the problem with Jason in the file? with that message NullReferenceException: Object reference not set to an instance of an object there is something missing to make him working.

 

Similar issue, I dumped Valmars changes all together for entity .xmls and dropped in the vanilla ones. I think the reason he's back is the same reason I'm seeing that ugly crazy lady in the snow biome which has no collision detection. It must be that once the world is generated with those enemies they are presistent and hardcoded to spawn there. Which sadly means you have to restart the game.

Edited by falloutgod13 (see edit history)

Share this post


Link to post
Share on other sites

Also, if anyone wants to try out the my "expansion like" edits you can hit up my server. Since I started it back up again a few days ago I'll once again be hosting, now with a DDNS service so won't have to worry about my ip changing on people and having to tell them the new one.

 

Welcome to Earth

IP: FG13.DDNS.NET

Port: 26900

Description: Experimental build, running a poorly edited Valmod overhaul in an attempt to build an expansion version(It works, kind of...)

Based in the U.S.A., Texas

Share this post


Link to post
Share on other sites

I'm not sure whether it's valmod or vanilla that does this, but.... the entity damage on the blunderbuss seems amazingly high. For a 150 quality blunderbuss it's pushing 222 entity damage with level 1 shotgun skill lol.. it gets even more ridiculous at 342 entity damage with the shredder ammo. :rapture:

 

With those stats, is there any reason not to use a blunderbuss over anything else? Lol

Edited by KinaUndead (see edit history)

Share this post


Link to post
Share on other sites

So I have been playing the experimental version of Valmod on B129, and its running great, but everytime I try to use a station like a campfire or a forge, as long as I am in the window of the station, the game lags horribly. As soon as I back out of the station everything is fine.

Share this post


Link to post
Share on other sites
So I have been playing the experimental version of Valmod on B129, and its running great, but everytime I try to use a station like a campfire or a forge, as long as I am in the window of the station, the game lags horribly. As soon as I back out of the station everything is fine.

 

I have the same problem, in A15.

Share this post


Link to post
Share on other sites
So I have been playing the experimental version of Valmod on B129, and its running great, but everytime I try to use a station like a campfire or a forge, as long as I am in the window of the station, the game lags horribly. As soon as I back out of the station everything is fine.

 

This is due to the amount of recipes.

 

basically every time the inventory is updated (items added/removed) the game rechecks EVERY recipe in the game causing this lag.

 

This is especially worse in the forge when you are melting items down or making items that get crafted quickly (such as bullets) as the quantities are changing constantly thus call for a recipe refresh constantly.

 

You can reduce this effect to an extent by switching to your "favorites" menu as that will usually have no, or very few recipes in it and will reduce the number of 'refreshes' that are done at each inventory update.

 

Personally I would like too see TFP address this directly by having a simple 'refresh' button that will update the recipe list rather than it doing it at every inventory update.

Edited by CyrusBlaze (see edit history)

Share this post


Link to post
Share on other sites

Hello! Made an account to ask a question! I really like the Overhaul edition of Valmod Pack and I would like to know if the download link works on the stable edition of A16 of the game!

 

Thank you in advance!

Share this post


Link to post
Share on other sites

Trying to find an answer to this - to level up blacksmithing and cooking (and other crafting with stations), do you have to have the UI open to gain skill points?

Share this post


Link to post
Share on other sites
Hello! Made an account to ask a question! I really like the Overhaul edition of Valmod Pack and I would like to know if the download link works on the stable edition of A16 of the game!

 

Thank you in advance!

 

Trying to find an answer to this - to level up blacksmithing and cooking (and other crafting with stations), do you have to have the UI open to gain skill points?

 

It will not work currently from what I have read. This update will require some tweaks I am sure. Val will get to it soon enough and then we can test it.

Share this post


Link to post
Share on other sites

so far as i know it has been running all day on my server and no complaints. blacksmithing does require forge window to be open to get skills, same as before.

 

all im waiting for is back pack mod part to be updated

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...